19:01:33 <hogepodge> #startmeeting refstack
19:01:34 <openstack> Meeting started Mon Jun 22 19:01:33 2015 UTC and is due to finish in 60 minutes.  The chair is hogepodge. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:37 <openstack> The meeting name has been set to 'refstack'
19:01:59 <catherineD|2> o/
19:02:02 <sslypushenko__> o/
19:02:04 <hogepodge> Hello again everyone. catherineD|2 has asked me to help out again with the meeting this week.
19:02:24 <catherineD|2> hogepodge: thx
19:02:26 <sslypushenko__> catherineD|2 Welcome back)
19:02:29 <pvaneck> o/
19:02:30 <hogepodge> #chair catherineD|2
19:02:31 <openstack> Current chairs: catherineD|2 hogepodge
19:02:39 <davidlenwell> o/
19:02:45 <Rockyg> o/
19:03:06 <catherineD|2> sslypushenko__: thx .. lots to catch up ...
19:03:18 <hogepodge> agenda #link https://etherpad.openstack.org/p/refstack-meeting-15-06-22
19:03:59 <hogepodge> Let's start with administrative items.
19:04:13 <hogepodge> #topic New Core Election
19:04:34 <davidlenwell> sounds good!  you've seen my nomination on the agenda.
19:04:39 <hogepodge> Currently we don't have enough core members to be as productive as we'd like, especially during vacations.
19:04:55 <hogepodge> davidlenwell: has nominated paul
19:05:00 * hogepodge seconds nomination
19:05:04 <davidlenwell> pvaneck: ^^
19:05:33 * Rockyg agrees but has no vite
19:05:39 <davidlenwell> vite?
19:05:48 <davidlenwell> oh .. vote..
19:05:52 * Rockyg ^vite^vote
19:06:13 <davidlenwell> catherineD|2: sslypushenko__ thoughts?
19:06:29 <catherineD|2> do we vote now or next week?
19:06:38 <davidlenwell> I think we can be less formal
19:06:45 <davidlenwell> if nobody objects
19:06:53 <sslypushenko__> pvaneck has made a huge contribution in Refstack code
19:06:59 <catherineD|2> +1
19:07:02 <Rockyg> works forme
19:07:05 <davidlenwell> I think he's in
19:07:10 <sslypushenko__> So +1 for Paul
19:07:29 <davidlenwell> I can do the add to the core group if nobody objects
19:07:30 <pvaneck> haha thanks guys
19:07:40 <hogepodge> I'll open a formal vote. You can vote yes or no using #vote yes|no
19:07:52 <sslypushenko__> Also I have any objection about Chris nomination
19:08:10 <hogepodge> sslypushenko__: I would have to decline any nomination
19:08:28 <hogepodge> sslypushenko__: I have not contributed enough code directly
19:08:31 <catherineD|2> hogepodge: too busy?
19:08:41 <davidlenwell> get some code in there hogepodge ;)
19:08:55 <hogepodge> :-)
19:09:24 <hogepodge> #startvote Elect pvaneck as refstack core
19:09:25 <openstack> Unable to parse vote topic and options.
19:09:33 <catherineD|2> hogepodge: you have done an amzing job running the porject in the past few weeks ...
19:09:59 <hogepodge> #startvote Elect pvaneck as refstack core? yes, no, abstain
19:10:00 <openstack> Begin voting on: Elect pvaneck as refstack core? Valid vote options are yes, no, abstain.
19:10:01 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:10:05 <hogepodge> #vote yes
19:10:07 <sslypushenko__> #vote yes
19:10:07 <catherineD|2> #vote YES
19:10:07 <davidlenwell> #vote yes
19:10:41 <sslypushenko__> unanimously)
19:11:12 <pvaneck> #vote yes
19:12:01 <hogepodge> #endvote
19:12:02 <openstack> Voted on "Elect pvaneck as refstack core?" Results are
19:12:03 <openstack> yes (5): sslypushenko__, hogepodge, davidlenwell, pvaneck, catherineD|2
19:12:11 <hogepodge> Congratulations!
19:12:31 <pvaneck> :) Will use the +A responsibly
19:12:42 <hogepodge> Action item is for core member to update the gerrit acl
19:12:46 <Rockyg> I didn't vote because I'm not a core, but I'm +100
19:13:06 <davidlenwell> I'm already doing that
19:13:11 <hogepodge> Excellent
19:13:12 <davidlenwell> however its getting an error ..
19:13:19 <davidlenwell> will ping infra to see why
19:13:52 <davidlenwell> done
19:13:55 <davidlenwell> I figured it out
19:14:07 <hogepodge> #topic Relocate RefStack Project
19:14:26 <hogepodge> We had deferred this topic until catherineD|2 had returned
19:14:47 <hogepodge> Discussing applying as either a big tent OpenStack project, or an infra project.
19:14:57 <davidlenwell> so the options at the time are .. 1. stay put .. 2. move to infra name space.. or 3. move to openstack namespace
19:15:23 <davidlenwell> there are good arguments for both openstsack and infra
19:15:29 <hogepodge> I believe the discussion was more in favor of infra, as it's providing a service to the community rather than being a project others are expected to deploy and host themselves.
19:15:34 <hogepodge> But I could see either way.
19:15:41 <hogepodge> Or just stay in refstack.
19:15:48 <davidlenwell> *stackforge
19:15:54 <catherineD|2> definitely not staying ...
19:16:00 <hogepodge> stackforge
19:16:07 <hogepodge> thankd davidlenwell :-D
19:16:12 <davidlenwell> I think infra is a good fit..
19:16:13 <Rockyg> infra
19:16:20 <sslypushenko__> If refstack can be used as local service I would prefer openstack  namespace
19:16:21 <davidlenwell> since refstack isn't part of the integrated release
19:16:26 * hogepodge is way too eager to hit return without proofreading
19:16:36 <sslypushenko__> otherwise infra will be fine
19:16:41 <davidlenwell> happens to the best of us hogepodge
19:17:23 <catherineD|2> refstack is very unique ... on one hand it is a service on the other hand vendor can also stand-up a refstack server on premise ... I know IBM does
19:17:45 <davidlenwell> openstack might help with that adoption
19:17:57 <hogepodge> Same goes for CI too. It's meant to deployed by third parties, but is an infra project.
19:18:18 <davidlenwell> yea.. okay.. I have changed my mind.. it belongs in openstack
19:18:42 <catherineD|2> which way is easier to get approval ?
19:18:49 <davidlenwell> they're both pretty easy now
19:19:01 <davidlenwell> with big tent they are letting everyone in
19:19:13 <davidlenwell> with some restrictions.. but im sure we qualify
19:19:22 <catherineD|2> do we get any special treatment from infra if it is in infra?
19:19:27 <davidlenwell> no
19:19:57 <davidlenwell> from their perspective its just a namespace.. doesn't actually mean anything
19:20:13 <catherineD|2> hogepodge: how about we vote?
19:20:22 <hogepodge> catherineD|2: ok
19:21:08 <hogepodge> #startvote What namespace should RefStack be moved to? OpenStack, Infra, Stackforge
19:21:09 <openstack> Begin voting on: What namespace should RefStack be moved to? Valid vote options are OpenStack, Infra, Stackforge.
19:21:10 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:21:17 <hogepodge> #vote Infra
19:21:19 <davidlenwell> #vote OpenStack
19:21:28 <catherineD|2> #vote OpenStack
19:21:31 <pvaneck> #vote Infra
19:21:33 <sslypushenko__> #vote OpenStack
19:21:56 <Rockyg> #vote infra
19:22:13 <davidlenwell> in a tie catherine has to decide
19:22:44 <Rockyg> Yeah, I'm torn on the location
19:22:53 <pvaneck> I feel that the primary use case of this project is the infra-hosted refstack.org site
19:23:05 <catherineD|2> anyone else on this meeting .. krofscheck?
19:23:15 <hogepodge> I'll close the voting in two minutes (12:25)
19:23:21 <davidlenwell> we can defer till next week if you want more parties present for the vote
19:23:44 <pvaneck> krotscheck*
19:23:52 <Rockyg> Would be good to get zehicle input
19:24:08 <krotscheck> eh?
19:24:21 <catherineD|2> let's defer to next week .. with zehicle: and krotscheck:
19:24:22 <davidlenwell> krotscheck: we're voting on what namespace to move the project to
19:24:30 <krotscheck> Ahhh
19:24:33 <krotscheck> #abstain
19:24:35 <davidlenwell> so far we are tied infra/openstack
19:24:59 <Rockyg> Kewl!
19:25:01 * krotscheck is not strongly enough invested in the project to feel entitled to influence policy
19:25:03 <hogepodge> #endvote
19:25:04 <openstack> Voted on "What namespace should RefStack be moved to?" Results are
19:25:05 <openstack> OpenStack (3): sslypushenko__, catherineD|2, davidlenwell
19:25:06 <openstack> Infra (3): hogepodge, pvaneck, Rockyg
19:25:35 <davidlenwell> technically ptl vote is the tie breaker
19:25:41 <hogepodge> krotscheck: you've done a lot with the infra deploy puppet modules
19:25:56 <davidlenwell> but I also won't object to defering the vote till next week
19:27:18 <hogepodge> catherineD|2: ?
19:27:20 <catherineD|2> davidlenwell: let's give Rob a vote next week ....
19:27:28 <sslypushenko__> davidlenwell +1
19:27:51 <davidlenwell> someone should talk to him before then and make sure he can attend
19:28:32 <hogepodge> We have a defcore meeting on Wednesdays. We can chat with him then
19:28:40 <davidlenwell> sounds like a plan
19:28:47 <hogepodge> On to the next topic?
19:28:47 <catherineD|2> +1
19:28:58 <sslypushenko__> +1
19:29:04 <hogepodge> #topic Infra Hosting
19:29:12 <hogepodge> #link https://review.openstack.org/#/c/188207/
19:29:32 <davidlenwell> jeblair: fungi can ya'll review this again please ^^^
19:29:32 <hogepodge> I added the spec review to the next infra meeting agenda
19:29:53 <davidlenwell> good thinking
19:30:01 <hogepodge> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:30:02 <fungi> hogepodge: yep, we'll bring it up tomorrow as being ready for council voting
19:30:06 <fungi> davidlenwell: ^
19:30:14 <davidlenwell> thanks fungi
19:30:30 <fungi> i likely won't have time to go back through it before then anyway
19:31:02 <catherineD|2> have we decided on 1 vs 2 domains or are we waiting for infra's inputs?
19:31:17 <davidlenwell> I don't think we decided
19:31:26 <davidlenwell> the discussion last week was fairly circular
19:31:35 <hogepodge> In the meantime, can the rest of the team review and post comments, and +1 if they're ok with it? We can iterate a few times before the meeting if we need to.
19:31:38 <davidlenwell> we could vote on it
19:31:52 <davidlenwell> right now the spec says 2 domains
19:32:04 <hogepodge> Ok, start a new vote on that.
19:32:46 <fungi> yeah, i _think_ 2 domains is probably going to mean two servers unless we can either get rackspace to bind multiple ip addresses to a server or wrangle a multi-subdomain cert for it
19:32:47 <davidlenwell> if we are going to change the spec we need to do it today
19:33:15 <hogepodge> #startvote Host refstack ui and api on one domain? yes, no
19:33:16 <openstack> Begin voting on: Host refstack ui and api on one domain? Valid vote options are yes, no.
19:33:17 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:33:26 <hogepodge> #vote no
19:33:28 <davidlenwell> #vote no
19:33:41 <hogepodge> #vote yes
19:33:47 <hogepodge> (based on fungi information)
19:33:57 <catherineD|2> #vote yes
19:34:02 <Rockyg> #vote yes
19:34:08 <fungi> well, if you're in favor of having the site and the api on multiple servers, there's no reason we can't have two
19:34:09 <hogepodge> to clarify, yes means one domain, no means two
19:34:09 <sslypushenko__> #vote yes
19:34:52 <davidlenwell> fungi: thats actually why I want them seperate .. one scales differntly than the other
19:35:09 <catherineD|2> based on an error that I see with one particular proxy server ... I sometimes lost the CORS header  ... with one domain maybe we can defer this issue to be solved later ..
19:35:17 <hogepodge> fungi can't we use vhosts and dns entries with one ip? It's what I do on my own servers.
19:35:29 <fungi> hogepodge: for separate https sites?
19:35:34 <davidlenwell> thats how the site is hosted now
19:35:40 <davidlenwell> but you need a wild card cert
19:35:51 <davidlenwell> which doesn't really cost much more
19:35:55 <hogepodge> fungi yes
19:36:03 <fungi> we're not going to use a wildcard cert, though you can do subjectaltname you just need a non-discount ca to sell you one
19:36:30 <davidlenwell> I see
19:36:46 <fungi> a *.openstack.org wildcard cert is a security risk, since you could host your own review.openstack.org or something if you got your hands on it
19:37:22 <hogepodge> closing vote at 12:39
19:37:24 <fungi> and in theory we want to get rid of the refstack.org domain as early as possible in the lifecycle of this app and onto an official openstack.org subdomain name
19:37:30 <pvaneck> #vote yes
19:37:41 <davidlenwell> avast gives a two sub domain cert for free
19:38:35 <fungi> i thought avast was windows spyware/adware pretending to be a free virus scanner
19:38:45 <davidlenwell> no
19:38:50 <davidlenwell> I think thats another group
19:38:52 <fungi> didn't know they branched out into the certificate authority racket
19:39:39 <hogepodge> #endvote
19:39:40 <openstack> Voted on "Host refstack ui and api on one domain?" Results are
19:39:41 <openstack> yes (5): Rockyg, hogepodge, sslypushenko__, pvaneck, catherineD|2
19:39:42 <openstack> no (1): davidlenwell
19:39:59 <Rockyg> Hmmm
19:40:19 <fungi> well, anyway i can try to get the current ca i've been buying our certs from to do additional subdomains on one if it's needed, or look at switching to a different ca
19:40:19 <Rockyg> Might need more discussion after gathering more info
19:41:03 <davidlenwell> looks like we just voted to make it one domain the /api
19:41:06 <hogepodge> We can revisit again, but if infra wants to relocate refstack to refstack.openstack.org that feels like the most compelling argument (although it doesn't preclude a second like refstackapi.openstack.org)
19:41:16 <fungi> or i can put the site on one vm and the api on a separat vm and use one cert for each
19:41:41 <Rockyg> fungi: I like that
19:41:43 <davidlenwell> So hogepodge do you want to change the spec or do you want me to do it ?
19:41:54 <davidlenwell> should be changed before tomorrows infra meeting
19:42:08 <hogepodge> davidlenwell: do you have time to? I have a huge todo list this afternoon.
19:42:15 <davidlenwell> hogepodge: I can handle it
19:42:20 <hogepodge> davidlenwell: thanks
19:42:22 <davidlenwell> I'm also busy .. but its a fast change
19:42:23 <catherineD|2> davidlenwell: thx
19:42:58 <hogepodge> Any more discussion on this?
19:43:12 <davidlenwell> I'm good with the vote
19:43:27 <hogepodge> #topic OpenStack ID Auth
19:43:34 <hogepodge> sslypushenko__: this is yours
19:43:45 <hogepodge> #link https://review.openstack.org/#/c/176335/
19:44:40 <pvaneck> looks like it just needs reviews. I'll review it today
19:44:56 <hogepodge> afaik, it just needs review. Everything should be in place
19:45:07 <davidlenwell> I've reviewed in a few times .. but then he patches it again
19:45:12 <davidlenwell> will review again today
19:45:16 <sslypushenko__> I think this patch is ready
19:45:24 <davidlenwell> okay.. will review then
19:45:28 <catherineD|2> will review
19:45:30 <sslypushenko__> Sure after some reviews
19:45:44 <davidlenwell> I think it got patched again because of the js linting tests right ?
19:45:51 <sslypushenko__> Now, with docker scripts it is easy)
19:45:55 <davidlenwell> ahh
19:46:15 <sslypushenko__> davidlenwell yeap, linting and unittests
19:46:27 <davidlenwell> makes sense
19:46:30 <davidlenwell> will review again today
19:46:46 <sslypushenko__> You can tested it with openstackid.org
19:47:09 <sslypushenko__> or with local openstackid
19:47:41 <hogepodge> I'm going to consolidate the rest of the open reviews in to the same topic for the last few minutes of the meeting.
19:47:48 <hogepodge> #topic Open Reviews
19:48:04 <hogepodge> Schema Version Handling #link https://review.openstack.org/#/c/191610/
19:48:29 <hogepodge> Is this ready for review pvaneck?
19:48:42 <pvaneck> yep, just waiting on reviews
19:48:45 <sslypushenko__> I will review all UI patches
19:49:17 <hogepodge> Insecure SSL Endpoint Flag for Client https://review.openstack.org/#/c/191129/
19:49:29 <catherineD|2> will review
19:49:29 <hogepodge> that one is for running against self-signed certs, etc
19:49:50 <hogepodge> I like that it defaults to secure but allows insecure in a standard way.
19:50:15 <catherineD|2> hogepodge: +1
19:50:27 <sslypushenko__> yes. It is necessary, because docker scripts deploy refstack under ssl
19:50:28 <catherineD|2> I will test that feature ...
19:50:40 <hogepodge> Test Auto Watch Target https://review.openstack.org/#/c/188835/
19:50:59 <hogepodge> I think this one is just waiting on more core reviews
19:51:04 <catherineD|2> I think davidlenwell: or I should +2 and merge this one
19:51:11 <catherineD|2> hogepodge: :-)
19:51:41 <hogepodge> UI Update for Capability Versions #link https://review.openstack.org/#/c/183397/
19:51:46 <davidlenwell> I just merged it catherineD|2
19:51:47 <hogepodge> another UI patch
19:52:01 <catherineD|2> davidlenwell: thx
19:52:20 <hogepodge> needs reviews
19:52:24 <catherineD|2> will review
19:52:26 <davidlenwell> I'm taking off now .. my son needs lunch
19:52:28 <hogepodge> It's been around since June 5
19:52:50 <hogepodge> davidlenwell: thanks! Enjoy!
19:53:05 <hogepodge> #topic open discussion
19:53:45 <catherineD|2> Eavesdrop in Refstack channel discussion last week ...
19:54:33 <hogepodge> Thanks catherineD|2, I missed that topic.
19:54:42 <hogepodge> #topic Eavesdrop in Refstack channel
19:55:34 <catherineD|2> what would be the next step?
19:55:52 <hogepodge> Submit a review to infra that adds the bot to the channel.
19:55:53 <sslypushenko__> It will be helpful
19:56:41 <Rockyg> It also comes with the big tent, but we'd need to rename to openstack-refstack
19:57:09 <Rockyg> which makes sense
19:57:17 <catherineD|2> ++
19:57:18 <sslypushenko__> +1
19:57:39 <hogepodge> It's my action item. I'l lcarry it forward.
19:57:51 <hogepodge> #action hogepodge set up eavesdrop for refstack channel
19:57:58 <catherineD|2> hogepodge: thank you!  that would be very helpful with vacation ....
19:58:11 <hogepodge> Any other items?
19:58:21 <catherineD|2> I am good ..
19:58:24 <hogepodge> Thanks for another great week everybody.
19:58:31 <Rockyg> Thanks!
19:58:55 <hogepodge> as usual, more discussion can be had in #refstack channel
19:59:00 <catherineD|2> thank you so much hogepodge: for running very effective meetings .... we got a lot done ...
19:59:03 <sslypushenko__> Thx!
19:59:09 <hogepodge> #endmeeting