19:01:48 <hogepodge> #startmeeting refstack
19:01:49 <openstack> Meeting started Mon Jun  8 19:01:48 2015 UTC and is due to finish in 60 minutes.  The chair is hogepodge. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:53 <openstack> The meeting name has been set to 'refstack'
19:01:56 <davidlenwell> o/
19:02:01 <pvaneck> o/
19:02:07 <hogepodge> #link https://etherpad.openstack.org/p/refstack-meeting-15-06-08 agenda
19:02:09 <hogepodge> o/
19:02:21 <bethelwell> o/
19:02:48 <davidlenwell> Hi Everyone!
19:02:58 <hogepodge> Hello!
19:03:02 <bethelwell> Hi all!
19:03:10 <hogepodge> #topic Infra Deployment
19:03:13 <hogepodge> #link https://review.openstack.org/#/c/188207/
19:03:26 <davidlenwell> sslypushenko:  glad you are back.. it was kinda stressful being the only core not on vacation last week ;)
19:03:39 <hogepodge> The first patch for the infra deployment went under review last week. Lots of good comments.
19:04:02 <hogepodge> davidlenwell: is working on the next revision of it, since he has much more expertise in the deployment.
19:04:06 <davidlenwell> I have a new patch almost ready.. will push it up and poke people to review it by it by the end of the day
19:04:52 <hogepodge> Any comments or ideas regarding it?
19:04:58 <davidlenwell> trying to go into as much detail as possible about what we expect for HA and database backups
19:05:15 <Rockyg> o/
19:05:24 <davidlenwell> I'd suggest if anyone does to leave them as comments in the review.. because that is what I am using to shape the next patch
19:05:26 <hogepodge> Based on interactions with infra, it's going to take a few weeks to land and be implemented.
19:05:50 <davidlenwell> I think we decided over the week to leave the hosting as is until that happens.
19:05:51 <hogepodge> Does infra automate back ups of their dbaas?
19:06:02 <davidlenwell> fungi: ^^ ?
19:07:27 <hogepodge> We can get more info on that in the reviews.
19:07:31 <davidlenwell> sure
19:07:42 <hogepodge> #action davidlenwell submit revision to refsstack infra deployment
19:08:00 <hogepodge> #topic Puppet Module
19:08:18 <hogepodge> Quick update on this, from krotsck_at_con work
19:08:24 <davidlenwell> So hp has been doing a lot of maintance on its system in the last few weeks... however even with that refstack.net has only had minimal downtime.. So I think leaving it as is would be recomended.
19:09:05 <fungi> hogepodge: davidlenwell: we do
19:09:09 <davidlenwell> krotsck_at_con pinged me last week to review a chain of patches
19:09:20 <davidlenwell> thanks fungi.. So we shouldn't have to call it out in the spec?
19:09:22 <fungi> hogepodge: davidlenwell: it's a puppet manifest that adds a cron job to perform a mysqldump into /var/baskup
19:09:32 <fungi> er, into /var/backup
19:09:53 <fungi> it's helpful to call it out in the spec since it needs to be explicitly added to the puppet module
19:09:56 <hogepodge> #topic Infra Deployment
19:10:02 <fungi> it's easy to add, but it's a necessary step
19:10:06 <davidlenwell> okay.. I will call it out
19:10:36 <hogepodge> thanks fungi
19:10:40 <fungi> yw
19:10:56 <hogepodge> The puppet module is related to the deployment.
19:11:20 <hogepodge> It's going to follow the model of the rest of the infra-hosted projects and be its own project.
19:12:01 <hogepodge> krotsck_at_con: is away at a conference this week, so we should hear more next week.
19:12:10 <hogepodge> Any other items related to this topic?
19:12:11 <krotsck_at_con> eh?
19:12:12 <krotsck_at_con> wha?
19:12:23 <krotsck_at_con> The puppet module is waiting on the spec to be approved.
19:12:50 <hogepodge> krotsck_at_con: any other updates regarding it?
19:13:04 <krotsck_at_con> We have a +2 from jeblair on the puppet module project.
19:13:15 <krotsck_at_con> The patch currently depends-on https://review.openstack.org/#/c/188207/
19:13:16 <davidlenwell> sslypushenko: should review the patches that krotsck_at_con has on the refstack ui
19:13:27 <krotsck_at_con> And that one has a lot of comments and discussion
19:13:37 <sslypushenko> davidlenwell: I have very unstabl iternet connection is very unstable, so I almost in readonly mode)
19:13:55 <krotsck_at_con> So, no updates on the puppet module until the spec lands.
19:14:02 <jeblair> oh hi
19:14:06 <davidlenwell> starting here .. https://review.openstack.org/#/c/185723/5
19:14:15 <hogepodge> sslypushenko: good to know, we will use that knowledge to assign a lot of action items to you. ;-)
19:14:22 <davidlenwell> :)
19:14:22 <sslypushenko> I will back to worn only day after tomorow
19:14:32 <davidlenwell> sslypushenko:  good to know
19:14:39 <jeblair> yeah, my feeling is that the spec is generally good and we have a few things to clarify/address in a new revision
19:14:57 <davidlenwell> jeblair: I will address all the comments in the new revision later today
19:15:06 <jeblair> woot
19:15:56 <hogepodge> Ok, sounds like we have really great progress and action planned. Thanks to everyone in both the refstack and infra team for working on this. Going to be really cool.
19:16:03 <jeblair> ++
19:16:06 <davidlenwell> krotsck_at_con: are you cool with waiting for sslypushenko to get back to merge that patch chain or should we talk about merging it before he returns in a few days?
19:16:08 <Rockyg> ++
19:16:41 <davidlenwell> ie starting here: https://review.openstack.org/#/c/185723/5
19:18:03 <hogepodge> davidlenwell: krotsck_at_con: sslypushenko: since Sergei is just a few days away from being back, I'd advocate for waiting for his review.
19:18:16 <davidlenwell> okay.. I have no problem with that
19:18:20 <krotsck_at_con> davidlenwell: I'm patient. Horizon is less so.
19:18:27 <davidlenwell> sure
19:18:28 <krotsck_at_con> But they can wait.
19:18:31 <hogepodge> Look for final reviews on Wednesday.
19:18:34 <krotsck_at_con> They have to go argue about other thigns.
19:18:37 <sslypushenko> I will try to do that tomorow
19:18:38 <krotsck_at_con> anyway, have to take notes.
19:18:43 * krotsck_at_con goes AFK
19:18:53 <hogepodge> thanks krotsck_at_con
19:18:56 <davidlenwell> when catherine is back we need to have a discussion about electing another core
19:18:58 <hogepodge> and sslypushenko
19:19:15 <Rockyg> ++
19:19:22 <davidlenwell> so we have decent vacation coverage
19:19:29 <hogepodge> That has bearing on the next topic, which I think will be brief because of vacation coverage
19:19:49 <hogepodge> #topic future location of Refstack
19:20:03 <hogepodge> With the project maturing, it's time to start thinking about graduating it out of refstack.
19:20:23 <davidlenwell> ahh.. you mean should we move to the openstack namespace or to the infra namespace?
19:20:27 <hogepodge> Options would be to look at making it a big tent project, or bring it under the umbrella if infra since it's providing a community service.
19:20:53 <hogepodge> Yes, I wanted to make it an agenda item, but it probably needs to be deferred until the full set of core members are here.
19:20:55 <Rockyg> Yeah.  Tough call.
19:20:59 <davidlenwell> my perspective has always been that it belongs under infra.. however arguments could be had both ways
19:21:21 <pvaneck> I think infra makes more sense
19:21:25 <hogepodge> I'm in favor of it being an infra project too.
19:21:29 <davidlenwell> I'd say lets put it on the agenda for two or three weeks from now and we can discuss and vote
19:21:34 <Rockyg> But, it should be a separate repository in the OpenStack repository namespace.  Just whether on its own or under infra....
19:21:40 <davidlenwell> but we shouldn't make the call without all the cores present
19:21:56 <hogepodge> absolutely. Putting the seed there.
19:22:07 <davidlenwell> Rockyg:  the questions is stackforge, openstack or openstack-infra
19:22:11 <Rockyg> I think we should also invite some infra and DefCore folks.
19:22:32 <hogepodge> #agreed defer discussion and decision to when all refstack cores are present.
19:22:36 <davidlenwell> I wouldn't mind some TC input either
19:22:40 <sslypushenko> What argument do we have to be infra project?
19:22:54 <Rockyg> How about a "spec" that sets out the alternatives, so infra, reftstack and defcore can review, then discuss in a couple of weeks here?
19:23:02 <hogepodge> sslypushenko: refstack provides a service to the community
19:23:05 <davidlenwell> interop and services that support it technically fall under infra's perview
19:23:58 <sslypushenko> Rockyg: +1
19:24:12 <hogepodge> who would want to grab that action item?
19:24:15 <davidlenwell> since its largly a foundation and board supporting set of tools.. I'll defer to their judgment
19:24:31 <Rockyg> Right.  It's tecnically not an integrated project, so makes OpenStack a little iffy, but it's still part of what defines OpenStack
19:24:43 <davidlenwell> Rockyg:  +1
19:24:55 <davidlenwell> it better fits into infra
19:25:18 <Rockyg> I'm willing to give it a shot, but I may need some poking to keep it on schedule :P
19:25:40 <davidlenwell> I think we should let catherine drive this .. we shouldn't be in a hurry to move it
19:25:45 <Rockyg> I just got back today and have too many projects, plus company politics on my plate.
19:25:52 <davidlenwell> no reason the spec can't wait till she is back
19:26:06 <hogepodge> Yes, let's defer any strong actions until catherine is back.
19:26:09 <Rockyg> Maybe Catherine and I can put a spec together in a F2F when she's back.
19:26:23 <davidlenwell> Rockyg: make sure you invite me to that ;)
19:26:41 <Rockyg> davidlenwell: will do!
19:26:55 <hogepodge> Ok, lots to move through. Ready for the next topic?
19:27:05 <Rockyg> ++
19:27:14 <davidlenwell> yes
19:27:16 <sslypushenko> +
19:27:17 <hogepodge> #topic OpenStackID
19:27:32 <hogepodge> #link https://review.openstack.org/#/c/176335/
19:27:57 <davidlenwell> last we heard sslypushenko was going to work on this when he returns.. sounds like that won't be for a few days
19:28:37 <davidlenwell> needs to be rebased and to have some tests reworked before it can land.. I believe he raised his hand last week and said he was planning to take that on as soon as he is back at work.
19:28:49 <sslypushenko> yep nothing new here)
19:28:53 <hogepodge> I've been speaking with the team working on OpenStack ID. They're looking in to expanding it to cover Open ID Connect (on top of the existing OAuth 2.0 functionality)
19:28:54 <davidlenwell> okay..
19:29:09 <hogepodge> great
19:29:41 <hogepodge> If there isn't aything else, moving on.
19:29:50 <sslypushenko> +
19:29:56 <davidlenwell> +1
19:30:01 <hogepodge> #topic DefCore Capabilities Schema Update
19:30:14 <Rockyg> The openid stuff for infra would likely be a separate project that would then make it easy for them to use on other websites they might support
19:30:39 <hogepodge> DefCore has approved a new version of the capabilities schema (I'm being a bit loose with the word schema, since we have no official schema to validate against)
19:31:01 <hogepodge> It's captured here:
19:31:03 <hogepodge> #link https://github.com/openstack/defcore/blob/master/2015.next.json
19:31:46 <hogepodge> Most notably, tests are no longer a list, but now a dictionary
19:32:03 <hogepodge> Flags moved into the tests themselves.
19:32:27 <hogepodge> This will have an impact on the rendering of the refstack pages. We tried to mimimize the disruption, but it will be felt.
19:32:42 <hogepodge> pvaneck: and anyone else working on the UI, wanted to make you aware of it.
19:32:45 <davidlenwell> hogepodge:  we won't be deleteing the old one right?
19:32:58 <pvaneck> seems to be a missing quote on line 45
19:33:00 <davidlenwell> we'll have some overlap ?
19:33:05 <hogepodge> No, but the 1.3 version will be what's going forward.
19:33:30 <pvaneck> but yea, i'll see how this affects the UI
19:33:36 <Rockyg> for at least another few month ;-)
19:33:42 <hogepodge> pvaneck: I'll run it through the validator and make patches
19:34:13 <hogepodge> davidlenwell: for the old approved lists, they'll keep the version. New approved files will use the 1.3, so we'll have overlap.
19:34:34 <davidlenwell> so we'll need to make the js able to parse either format
19:34:55 <davidlenwell> so if someone selects the old version from the drop down it will still pull the old format
19:35:00 <hogepodge> This review captures lots of information about the changes.
19:35:03 <hogepodge> #link https://review.openstack.org/#/c/185158/
19:35:21 <hogepodge> davidlenwell: we embed version information into the file to help with that
19:35:28 <davidlenwell> cool..
19:35:55 <Rockyg> davidlenwell: Yeah, we were forward thinkers on that one;-)
19:36:15 <Rockyg> We being you, too, if you remember....
19:36:43 <davidlenwell> yes.. I did say that we needed to maintain versioning while we were on the hallway track at the summit
19:36:58 <davidlenwell> but I wasn't in the next set of meetings .. so its good to know
19:38:05 <hogepodge> Any other comments or questions about the change?
19:38:14 <davidlenwell> pvaneck: feel free to ask bethelwell for js cycles when you are working on this
19:39:08 <pvaneck> davidlenwell: sure. just looking at what's different in this new version first
19:39:09 <bethelwell> am more than happy to contribute. Following the conversation and have a long way to go to fully understand context but always up for contributing to the codebase and helping out.
19:39:31 <pvaneck> seems to be mainly the test array to hash, and how tests are flagged
19:39:41 <davidlenwell> pvaneck:  how goes the adding of jsdoc comments to the javascirpt?
19:39:49 <davidlenwell> (sorry off topic)
19:39:59 <pvaneck> was doing it now, but i'll have it up today
19:40:01 <hogepodge> davidlenwell: we can move to the next topic, which is JS related.
19:40:08 <hogepodge> #topic JS Integration
19:40:10 <davidlenwell> sweet
19:40:23 <davidlenwell> so the first step in my mind was better docs around our js code
19:40:34 <hogepodge> prompted from this review, but general to JS dev in general
19:40:34 <bethelwell> documentation is always good
19:40:35 <hogepodge> #link https://review.openstack.org/#/c/187278/
19:40:42 <davidlenwell> I don't want new contributers to have to divine from context how things are supposed to work
19:41:01 <davidlenwell> and I want to encourage new front end devs to get involved.. as you can see with my pushing bethelwell into helping us
19:41:03 <bethelwell> that would be really useful. from a newcomers perspective it would help to then become productive faster
19:41:34 <bethelwell> would it be useful for me to be involved in this to document from a newcomers persective?
19:41:49 <davidlenwell> front end tests are useful .. I think what krotsck_at_con has added here are the stubs for future tests..
19:42:41 <hogepodge> I think its always helpful. The perspective of the learning and integration process helps. Also having a test framework is nice, and a great place to start.
19:42:53 <davidlenwell> I am going to be a lot more strict about js that I review and if its got tests and comments/docs .. its a bad habbit of a lot of openstack projects to sorta not really test or read javascirpt and I don't want us to fall into that category
19:43:16 <hogepodge> davidlenwell: I think that's a great idea.
19:43:35 <pvaneck> well, soon we should have the js linting and testing gates added to the project
19:44:06 <davidlenwell> refstack is 1/3 a front end website.. the other two parts being the api and the client.. success is going to pin on all three being well documented and designed
19:44:32 <hogepodge> pvaneck: what's the work that's needed for that? Is this in flight, or dependent on existing reviews?
19:44:36 <davidlenwell> pvaneck:  as soon as sslypushenko is back form vacay he will review those and we should be good to go
19:44:50 <davidlenwell> hogepodge:  existing reviews I called out earlier
19:45:00 <hogepodge> davidlenwell: ok, thanks
19:45:24 <pvaneck> this patch which adds the jobs has been merged: #link https://review.openstack.org/#/c/185731/
19:45:50 <Rockyg> bethelwell: you can certainly add documentation that's missing when you figure out what the code is doing ;-)  Or file a bug that the code isn't very readable without comments in specific places
19:45:52 <hogepodge> pvaneck: nice, thank you
19:45:53 <pvaneck> then there is this: #link https://review.openstack.org/#/c/188133/
19:46:33 <davidlenwell> hogepodge:  ^^ that and the patches that depend on it
19:46:44 <hogepodge> yup
19:46:53 <Rockyg> davidlenwell: would it make sense to do a *short* reviewer checklist for what RefStack reviewers will ding folks for?  Like docs and tests?
19:46:58 <bethelwell> Rockyg: thank you! I will do as I start to navigate it more. Appreciate it :)
19:47:08 <hogepodge> dependent patch #link https://review.openstack.org/#/c/188834/
19:47:34 <davidlenwell> Rockyg:  I think those things are common knowledge but folks get lazy .. the review process will fix that
19:47:49 <davidlenwell> if the cores can agree to be more strict that all should fall in line fast enough
19:48:33 <bethelwell> davidlenwell: it is probably good timing for a newcomer to submit comments though rather than attempting to troll through tons of code yourself when we are doing it anyway and can raise issues as necessary.
19:49:12 <bethelwell> as you say, moving forward easier to change by just being stricter in what gets through.
19:49:13 <davidlenwell> Rockyg:  I've been -2ing for lack of doc strings in python since the begining.. that has resulted in good documented python code.. we just need to follow the same practice in the front end code
19:49:28 <davidlenwell> bethelwell: +1
19:49:30 <Rockyg> bethelwell: ++ and if it's a review, you can always -1 with the comment that the code alone is not clear enough and more commenting is needed
19:49:55 <davidlenwell> awesome .. it sounds like we all agree.. pvaneck I look forward to your first jsdoc patch later
19:50:11 <Rockyg> +1000
19:50:19 <pvaneck> yep, will have it up soon
19:50:24 <davidlenwell> awesome!
19:51:11 <hogepodge> Ok, on to the next topic?
19:51:16 <davidlenwell> +
19:51:31 <hogepodge> #topic Code reviews
19:51:48 <davidlenwell> most of the pending reviews are related to the last topic
19:51:54 <hogepodge> Please post links to any outstanding reviews you'd like additional attention to here.
19:52:05 * Rockyg thinks that last exchange was a perfect lead in to the current topic
19:52:15 <hogepodge> There's one Docker patch that sslypushenko has been working on.
19:52:17 <hogepodge> #link https://review.openstack.org/#/c/182266/
19:53:15 <hogepodge> There's also a pip cleanup patch from Catherine
19:53:17 <hogepodge> #link https://review.openstack.org/#/c/186886/
19:54:58 <hogepodge> I'll also roll the patch review into the last open discussion topic and leave the meeting open until 12:59
19:55:07 <hogepodge> #topic Open Discussion
19:55:08 <davidlenwell> +1
19:56:00 <Rockyg> +1
19:56:22 <davidlenwell> I for one am super happy about all the progress in the last few months and our continued official adoption by defocre!
19:56:32 <hogepodge> +1
19:56:41 <sslypushenko> It will really helpfull to get dockerp get docker patch merged
19:57:00 <davidlenwell> thanks hogepodge for all your input and hard work in getting us here over the last cycle.. I know we had some rough patchs .but we are a stronger team for it in the end!
19:57:03 <Rockyg> +1  to what davidlenwell said
19:57:27 <davidlenwell> its nice to bring validation to all our hard work over the last 18 months..
19:57:36 <hogepodge> davidlenwell: thank you. I'm really happy with how the project is advancing. The ui and demos were really strong.
19:58:04 <hogepodge> davidlenwell: pvaneck: can you look at the docker patch and see what it needs to move forward for sslypushenko?
19:58:12 <davidlenwell> yes.. I have it open..
19:58:23 <Rockyg> I'd also like to point out that the collaboration has gotten much stronger, the conversations more positive, and, we still need to recruit a few more to the team....
19:58:25 <davidlenwell> I was going to ping eric.. he's been our unofficial docker reviewer
19:58:48 <Rockyg> davidlenwell: good thought.  Eric is the right person.
19:59:02 <davidlenwell> trying to remember his irc handle at the moment
19:59:11 <Rockyg> ewindisch?
19:59:16 <davidlenwell> yeah .. thats the one
19:59:16 <hogepodge> I'm going to wrap this up, but more discussion welcome over in the #refstack channel.
19:59:20 <davidlenwell> I'll ping him ..
19:59:33 <hogepodge> Thanks for another productive meeting everyone.
19:59:45 <hogepodge> #endmeeting