19:01:06 <hogepodge> #startmeeting refstack
19:01:07 <openstack> Meeting started Mon Jun  1 19:01:06 2015 UTC and is due to finish in 60 minutes.  The chair is hogepodge. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:10 <openstack> The meeting name has been set to 'refstack'
19:01:11 <krotscheck> o/
19:01:13 <hogepodge> o/
19:01:17 <pvaneck> o/
19:01:19 <sslypushenko__> o/
19:01:44 <hogepodge> Hello everybody! Hope you're all doing well after the summit.
19:01:48 <davidlenwell> o/
19:01:54 <davidlenwell> tired
19:02:09 <hogepodge> #link meeting agenda and notes, please feel free to add items https://etherpad.openstack.org/p/refstack-meeting-15-06-01
19:02:37 <hogepodge> #topic OpenStack ID Integration
19:02:43 <hogepodge> sslypushenko__: do you want to give us an update on that?
19:03:17 <davidlenwell> last I spoke with catherine last week she wanted to move to using launchpads openid in the short term.
19:03:32 <sslypushenko__> I am working on tests for that patch
19:04:02 <hogepodge> davidlenwell: what was the reason?
19:04:04 <sslypushenko__> I think it is almost ready to merge
19:04:36 <sslypushenko__> We can use openstackid right now
19:04:40 <davidlenwell> she was under the impression we needed approval to use openstack id .. I don't know that she was right
19:04:43 <davidlenwell> well then lets use it
19:04:57 <hogepodge> I think that infra is ready to give us access to it.
19:05:03 <pvaneck> yea, worked from what I can tell
19:05:26 <sslypushenko__> As far as I understand no approve is needed
19:05:55 <davidlenwell> it sounded odd to me that we'd need approval.. but I was sick when she talked to me about it so I didn't do much research
19:06:11 <hogepodge> sslypushenko__: so which are you working on merging now?
19:07:35 <sslypushenko__> Actually I am on vacation now. When I return, we can start merging process
19:08:01 <hogepodge> sslypushenko__: ok, but for which auth provider? Mostly just for info.
19:08:27 <sslypushenko__> openstackid of course)
19:08:52 <hogepodge> #info sslypushenko__ working on openstackid auth merging upon return from vacation
19:08:55 <hogepodge> thanks sslypushenko__
19:09:06 <hogepodge> Any other items related to this topic?
19:09:41 <pvaneck> all good
19:09:55 <hogepodge> #topic Infra deployment
19:10:01 <davidlenwell> I'm good on this .. the patch looks good .. so when they get it to pass tests im happy
19:10:11 <krotscheck> There's a comment on the puppet project patch asking for a spec : https://review.openstack.org/#/c/182437/
19:10:13 <hogepodge> krotscheck: you've been working on this, can you give us an update on this?
19:10:16 <krotscheck> Not certain who's responsible for that one.
19:10:41 <hogepodge> krotscheck: I can volunteer to work on the spec
19:11:01 <krotscheck> The github project, as it currently stands, is out of sync with the refstack tree, so the puppet module as it exists is broken.
19:11:19 <krotscheck> The relevant patches in refstack seem to be failing on python tests though, I'm not entirely certain why.
19:11:24 * krotscheck didn't change any python thigns.
19:11:33 <hogepodge> krotscheck: what would it take to bring them back into sync?
19:11:34 <pvaneck> regarding that, i just submitted a patch to fix the failing tests
19:11:42 <krotscheck> Oh good
19:11:44 <pvaneck> had to do with the new pecan release
19:11:58 <hogepodge> As a team, do we want to start hosting the puppet deployment code as part of the refstack server project?
19:12:16 <krotscheck> Synching them I believe will require this: https://review.openstack.org/#/c/185723/
19:12:41 <hogepodge> #link https://review.openstack.org/#/c/185723/
19:13:02 <krotscheck> pvaneck: What's the patch on that? I can rebase.
19:13:32 <pvaneck> krotscheck: https://review.openstack.org/#/c/187282/
19:13:45 <krotscheck> pvaneck: Thanks.
19:13:48 <davidlenwell> hogepodge: that does seem like the logical place to host the puppet code
19:13:53 <hogepodge> #link  https://review.openstack.org/#/c/187282/
19:14:39 <hogepodge> krotscheck: how do you feel about that? It's your work.
19:15:23 <davidlenwell> I like the idea of having standard ways of deploying the server.
19:15:26 <krotscheck> hogepodge: Pondering.
19:15:34 <davidlenwell> built into the repo
19:15:40 <krotscheck> hogepodge: It's odd, right? Because the module's there to support infra's efforts.
19:15:48 <hogepodge> krotscheck: we can defer to next week if you want more time to think
19:16:17 <hogepodge> krotscheck: I was thinking about that too. I like the deployment code being hosted as part of the project, though.
19:16:22 <krotscheck> I don't think I'm going to be the forcing function. I believe that's going to be infra's requirements.
19:16:24 <krotscheck> Where to host that code is definitely an #openstack-infra question.
19:16:33 <hogepodge> We can chat with infra about their preferences.
19:16:33 <krotscheck> I'm not a fan of mixing my languages.
19:16:37 <hogepodge> fungi: ? ^^
19:17:08 <fungi> can you tl;dr?
19:17:27 <davidlenwell> ruby and python in the same repo.. oh my!
19:17:29 <hogepodge> puppet code for deploying refstack hosted in the refstack project
19:17:33 <krotscheck> fungi: There's a puppet-refstack module. We're discussing whether it should live in its own repository or as a part of the refstack project.
19:17:39 <fungi> got it
19:17:58 <fungi> well, we've been trying to publish the infra puppet modules to the puppetforge
19:18:26 <fungi> so if the refstack puppet module is comingled with refstack's source code, then we'd end up publishing all of refstack to the forge i think?
19:18:39 <davidlenwell> oh that sounds better
19:18:44 <fungi> seems like that could get messy
19:18:52 * davidlenwell doesn't know how puppet people do it
19:18:57 <fungi> i'm not sure what the immediate problems with that might be
19:19:03 <davidlenwell> puppetiers?
19:19:21 <hogepodge> fungi: that's what would happen. afaik git doesn't really support deploying from subdirectories very well.
19:19:42 <fungi> so from an infra perspective, we've generally separated puppet modules out into their own git repos
19:19:46 <hogepodge> Like say, pointing to the repo as a subdirectory of a parent.
19:20:03 <hogepodge> fungi: are they hosted on refstack or elsewhere?
19:20:29 <fungi> hence an openstack-infra/puppet-refstack git repo for the puppet module that deploys the openstack-infra/refstack software
19:21:09 <fungi> for example, we have openstack-infra/puppet-zuul that deploys the openstack-infra/zuul software
19:21:09 <hogepodge> #info openstack-infra/puppet-refstack git repo for the puppet module that deploys the openstack-infra/refstack software
19:22:29 <hogepodge> That brings up the question about refstack hosting. Right now it's a stackforge project, but I think longer term it should be graduated to another repo. I always assumed to openstack as part of big tent, but would openstack-infra make more sense?
19:23:00 <hogepodge> Probably not the time to discuss it in depth, but we can add to a future meeting agenda.
19:23:16 <davidlenwell> wouldn't want to dive too deep into that with out catherine here
19:23:19 <hogepodge> davidlenwell: sslypushenko__: thoughts on that as core members
19:23:25 <hogepodge> davidlenwell: agree
19:23:34 <davidlenwell> I think .. punt to next week..
19:23:46 <davidlenwell> I've never personally cared which name space it was in
19:24:06 <davidlenwell> stackforge was just the right place for it at the time.
19:24:19 <davidlenwell> but technically we do fall under infras perview
19:24:25 <fungi> being an openstack or openstack-infra repo isn't a prerequisite for the infra team deploying and maintaining a service (we run a bunch of non-openstack-originated services), but it still sounds like a good idea
19:24:29 <sslypushenko__> I do not have no thoughts about it right now.
19:24:30 <hogepodge> #action namespace location for refstack in 1-2 weeks (after catherine has returned from leave)
19:24:43 <davidlenwell> +1
19:24:59 <sslypushenko__> +1
19:25:03 <hogepodge> krotscheck: are there other issues regarding the deployment that you'd like to address during this topic?
19:25:08 <hogepodge> Or anyone else?
19:25:10 <davidlenwell> I do
19:25:14 <krotscheck> Not that I can think of.
19:25:24 <davidlenwell> what is the time table for getting it online?
19:25:49 <davidlenwell> I was thinking of asking dreemhost to donate some instances in the interum .. that way im not still paying for hosting out of pocket..
19:26:09 <hogepodge> davidlenwell: that would be fantastic
19:26:24 <davidlenwell> so its not really worth the effort if they'll have it online in the next say 3 weeks
19:26:51 <davidlenwell> but if it will be a few months .. then I'll go ahead and do that
19:27:00 <hogepodge> I think that krotscheck and fungi might be able to give us the best estimates on how long it will take from a development and deployment side.
19:27:36 <hogepodge> I'll commit to writing the spec by Wednesday cob for infra
19:27:38 <krotscheck> hogepodge: What you need is someone who's sole job it is to drive this forward and pester the appropriate people. Else it'll just get buried under other priorities.
19:27:52 <hogepodge> #action hogepodge write spec for infra cloud deployment
19:27:56 <davidlenwell> krotscheck: who is the appropriate person to poke
19:28:14 <fungi> pretty much. i mean we're probably going to go from zero to infra on the apps.openstack.org site in a week or two time but it really depends on what else is going on and the relative priorities
19:28:27 <davidlenwell> since its on my private hosting account .. I can be the one to follow up
19:28:35 <krotscheck> davidlenwell: Everyone involved? If the puppet module's broken, it's me. If it's provisioning the instance, it'd be any of the infra-root people. If it's writing a spec, it's hogepodge
19:28:57 <hogepodge> Starting with the spec I can move this forward, and commit to having it ready for review as early as possible.
19:29:01 <fungi> and especially on whether someone is already writing the spec and puppet module for it
19:29:05 <davidlenwell> okay .. so lets fix everythign on our end and I'll follow up next week
19:29:28 <hogepodge> davidlenwell: So, I would expect if we move fast, three weeks fastest.
19:30:58 <hogepodge> Just throwing this out there, we need to think about TLS, database backups, and updates.
19:31:28 <hogepodge> Ok. I'll leave the topic open for a minute or so more, then we can move on.
19:31:39 <davidlenwell> hogepodge: okay .. I'll talk to some folks and then we can make a final decision about what to do about hosting while we wait next week
19:32:08 <hogepodge> #action davidlenwell to look at dreamhost hosting
19:32:44 <hogepodge> #topic reviews
19:33:34 <hogepodge> Almost all of the reviews are on refstack server.
19:34:02 <hogepodge> most from krotscheck. Are there any in particular you'd like us to call out during the meeting?
19:34:17 <krotscheck> hogepodge: Maybe?
19:34:43 <krotscheck> #link https://review.openstack.org/#/c/185723/
19:35:07 <krotscheck> So, this one moves the various js-based configuration files into the root directory, because that's where the infra jobs expect them to be.
19:35:22 <krotscheck> We could discuss whether that's clutter.
19:36:14 <hogepodge> I don't think so if it's the convention for infra.
19:36:47 <sslypushenko__> +1
19:36:51 <krotscheck> Well, in that case, the only thing the other patches do is add linting and increase the browsers used in testing.
19:36:51 <davidlenwell> I think its fine
19:37:12 <krotscheck> A random question: Should test be split apart by browser, or by test type?
19:37:23 <davidlenwell> type I'd assume
19:37:36 <sslypushenko__> +1
19:37:39 <hogepodge> I'd also guess type. Browser feels too brittle.
19:37:40 <krotscheck> davidlenwell: What if microsoft comes along and wants to run only IE tests?
19:37:54 <davidlenwell> do you really want me to answer that?
19:37:57 <krotscheck> :D
19:38:04 * davidlenwell bites his tongue
19:38:28 <krotscheck> I'm thinking usability. If someone puts up a UI change and it runs into an x-browser compatibility problem, it'd be easier to see from gerrit which one broke.
19:38:44 <krotscheck> But then again, someone can always click into the test output and see what broke there.
19:38:57 <krotscheck> It's really just semantics.
19:39:13 <davidlenwell> harder to orginize while writing tests though
19:39:32 <krotscheck> Oh, I'm not even going that far.
19:39:39 <davidlenwell> since I personally won't write any of these tests I withdraw my objection
19:39:49 <krotscheck> I'm proposing "npm-run-test-phantom", where it just runs all tests against phantom.
19:39:58 <davidlenwell> hm
19:40:00 <davidlenwell> okay
19:40:00 <krotscheck> Or maybe npm-run-test-unit-phantom
19:40:01 <krotscheck> Ehn
19:40:11 <davidlenwell> no objection there
19:40:14 <krotscheck> Now that I think about it, that's really going to clutter up the package.json file.
19:40:17 <krotscheck> I withdraw my topic
19:40:52 <davidlenwell> :)
19:41:17 <hogepodge> pvaneck: has a couple of review up. Gate fixing patch
19:41:32 <hogepodge> updated by davidlenwell
19:41:34 <hogepodge> #link https://review.openstack.org/#/c/187282/
19:41:40 <davidlenwell> I gave it a plus 2
19:42:00 <hogepodge> yes, me not reading properly. :-P
19:42:13 <pvaneck> would be good to get that one in asap
19:42:22 <davidlenwell> +2
19:42:29 <hogepodge> +1
19:42:30 <davidlenwell> sslypushenko__:  can you review
19:42:31 <davidlenwell> ?
19:42:35 <davidlenwell> I know you are on vacation
19:42:43 <hogepodge> sslypushenko__:  you would be the vote, but you're here. :-D
19:43:02 <davidlenwell> we need to add a 4th core this cycle
19:43:19 <davidlenwell> we should put that on the agenda for discussion next time we have catherine again
19:43:22 <sslypushenko__> I can not check this patch)
19:43:44 <davidlenwell> sslypushenko__: do you object to my merging it?
19:43:47 <sslypushenko__> But at first look it is ok
19:44:11 <sslypushenko__> No objections
19:44:12 <davidlenwell> with two cores on vacation that has been acceptable..
19:44:16 <davidlenwell> thanks.. I'll merge it
19:44:21 <hogepodge> thanks davidlenwell
19:44:48 <davidlenwell> done
19:44:53 <hogepodge> pvaneck has another patch which updates ui on capabilities files for releases covered
19:44:56 <hogepodge> #link https://review.openstack.org/#/c/183397/
19:45:22 <pvaneck> that is minor
19:46:10 <davidlenwell> I'll review toady
19:46:10 <pvaneck> would like to have the js linting patch in (#link https://review.openstack.org/#/c/185711/) first
19:46:31 <pvaneck> since that does a lot of style fixes
19:47:19 <hogepodge> pvaneck: don't want to create more work, but I think there's a way to make them a set of linked patches if you work them on the same branch.
19:47:43 <krotscheck> git review -d ### will pull down one patch, you can rebase on that
19:47:55 <pvaneck> yea, i can do that
19:47:57 <davidlenwell> ^^ krotscheck types faster than me ;)
19:48:07 <hogepodge> But can you add a review that you'd like the linting patch to land first so the other doesn't go in accidentaly?
19:48:36 <pvaneck> sure
19:49:08 <hogepodge> sslypushenko__: has one for dockerizing refstack. It's not passing gate. I'm assuming we'll defer on that until you're back from vacation?
19:49:26 <hogepodge> #link https://review.openstack.org/#/c/182266/
19:50:16 <sslypushenko__> sure
19:50:48 <hogepodge> Any other reviews we should be looking at? I'm skipping over ones that haven't verified of whose submitter isn't around.
19:51:01 <hogepodge> s/of/or
19:51:27 <davidlenwell> seems logical
19:51:55 <hogepodge> #topic open discussion
19:52:01 <davidlenwell> I'd like to introduce you guys to a possible new contributer.. bethelwell .. I'm trying to encourage her to help us out with some of our front end code..
19:52:26 <hogepodge> bethelwell: welcome!
19:52:41 <bethelwell> thank you
19:52:53 <pvaneck> hello!
19:53:14 <bethelwell> hope you don't mind me viewing from the sidelines! Really interesting to see how the meetings work
19:53:36 <davidlenwell> she is still lurking and learning how we do things.. I think refstack would be a good place to do some low hanging front end commits..
19:54:31 <pvaneck> we are now using launchpad right?
19:54:52 <davidlenwell> are we?
19:55:05 <hogepodge> bethelwell: I'm all for you jumping right in too. New contributors are always welcome. We're happy to answer any questions about refstack or openstack dev in general.
19:55:17 <davidlenwell> krotscheck: did they decide on a replacement
19:55:27 <hogepodge> I'm not 100% certain.
19:55:33 <krotscheck> davidlenwell: I'm not partial to taht discussion
19:55:37 <krotscheck> Sorry
19:55:39 <krotscheck> Part of that discussion
19:55:45 <davidlenwell> no worreis
19:56:06 <bethelwell> thanks hodgepodge.
19:56:11 <hogepodge> With four minutes left I also want to call out Vlad's contributions. He's moved on to another project within Mirantis.
19:56:29 <davidlenwell> +2 thanks Vlad!
19:56:56 <sslypushenko__> +100500)
19:57:20 <pvaneck> yep. thankful for vlad's contributions
19:58:29 <hogepodge> Hope everyone is recovering from the summit, and are excited for the upcoming cycle. We have some really great work backing us up.
19:59:09 <hogepodge> #endmeeting