22:00:33 <davidlenwell> #startmeeting refstack
22:00:34 <openstack> Meeting started Mon Jun 30 22:00:33 2014 UTC and is due to finish in 60 minutes.  The chair is davidlenwell. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:39 <openstack> The meeting name has been set to 'refstack'
22:02:04 <davidlenwell> roll call?
22:03:04 <fcarpent_> o/
22:04:29 <davidlenwell> First week of new meeting time .. we'll give everyone a few minutes before giving up on them all
22:07:32 <zehicle> o/
22:07:52 <davidlenwell> lets wait a few more minutes to see if catherine/rocky show
22:07:58 <zehicle> and there was a request to move the meeting back to 10 am already (keep on Monday
22:08:08 <davidlenwell> by whome?
22:08:24 <zehicle> the Mirantis contractors
22:08:44 <zehicle> this time is super bad for them
22:08:46 <davidlenwell> I feel like we are playing musical meetings
22:08:51 <zehicle> my mistake for miscaculating
22:08:54 <zehicle> yy
22:09:07 <zehicle> I can proxy for them
22:09:43 <davidlenwell> nobody is showing up for this meeting anyways.. I feel like if we change it again we'll have low attendance again
22:09:51 <davidlenwell> but I'm open to discussing it
22:10:15 <zehicle> agree
22:10:19 <davidlenwell> alright im going to start..
22:10:22 <zehicle> this time is ok but not great for me
22:10:24 <zehicle> +1
22:10:27 <zehicle> let;s roll
22:12:09 <davidlenwell> agenda: api status, schema migration, sqlite, graphs for defcore, dell contractors
22:12:21 <zehicle> +1
22:12:22 <davidlenwell> + meeting time
22:12:38 <davidlenwell> #topic api status
22:13:09 <davidlenwell> I'm very close to commiting a patch that will give us full api functionlity that meets the v1 api spec.
22:13:14 <zehicle> :)
22:13:29 <zehicle> the Mirantis guys say that they are looking at unit tests for it
22:13:32 <zehicle> I'll check w/ them tomorrow
22:13:37 <davidlenwell> I am still missing unit tests..
22:16:14 <davidlenwell> I'd preffer to just write the api unit tests myself and leave the schema and migration unit tests to the contractors .. but we'll get back to that in a bit when theya re the topic
22:16:36 <zehicle> ok, that would be better
22:16:37 <zehicle> agree
22:17:31 <davidlenwell> okay .. so we're on the same page here.. next topic
22:17:36 <davidlenwell> #topic schema change
22:18:12 <davidlenwell> with the exception of zehicle's -1 because of "the allowable types should be documented with a safe default given (0=unknown). Also, there should be a field test to limit the values to the know values."
22:18:13 <zehicle> kk
22:18:43 <davidlenwell> I think its in good shape to merge once the api stuff is finished.. I was hoping catherine would be around to give an opinion on that but she seems to be having connectivity issues.
22:18:48 <zehicle> +1 agree
22:19:16 <davidlenwell> (these meetings go a lot faster when nobody shows up ;) )
22:19:26 <davidlenwell> #topic sqlite
22:20:30 <davidlenwell> sqlite migration has been a bit painful... alembic doesn't deal well with its special edge cases. And I hate that someone on our team would need to write a bunch of extra code to make sqlite happy everytime we want to change the name of a feild.
22:20:58 <davidlenwell> I would like to continue to have an open discussion about why / if we should continue to support it at all.
22:21:20 <zehicle> I'm ok to NOT have sqlite
22:21:23 <davidlenwell> so far my pros are; easier to get a dev env going...
22:21:43 <davidlenwell> cons are: poor sql support, poor alembic support .. pain in the ass migrations
22:21:50 <davidlenwell> so you can see which way I am leaning
22:22:08 <davidlenwell> I can table this till next week when more folks show up at the meeting and can offer an opinion..
22:22:20 <davidlenwell> fcarpent_: Do you have any opinions on removing sqlite support?
22:22:49 <fcarpent_> not without better understanding the alternatives
22:23:11 <davidlenwell> fcarpenter: the alt is to only support mysql / postgres
22:23:24 <davidlenwell> because they can migrate cleaner
22:23:25 <fcarpenter> at first blush it doesn't sound like a "need to have" for v1
22:23:43 <davidlenwell> okay .. well lets agree to pick up this discussion in another week.
22:23:56 <davidlenwell> #agree we'll pick up the sqlite discussion in a week.
22:24:11 <davidlenwell> #topic graphs for defcore
22:24:27 <davidlenwell> So last week joshua and I did some brain storming.
22:24:49 <zehicle> graphs = the screen casts
22:24:52 <davidlenwell> We'd like to go a slightly diff direction on the graphs and reporting for defcore than the current proposed spec describes
22:25:29 <zehicle> ok, happy to see alternatives
22:25:34 <davidlenwell> I am going to sit down with joshua in the next couple of days to submit a review on an updated spec clearly describing the idea.. this way you can all have input
22:25:58 <davidlenwell> he's also volunteered to do the coding becuase he's excited about this type of graphing tool.
22:26:32 <zehicle> ok
22:26:46 <davidlenwell> I'd like more code out of him if we can get it
22:26:57 <catherine_d> HidHi
22:27:01 <zehicle> that's fine w/ me
22:27:10 <davidlenwell> cool .. spec to follow
22:27:11 <zehicle> just send me a picture of what he's thinking
22:27:44 <davidlenwell> zehicle: I want a spec because the visualizations them selves are a lot more flexible than the underlying data it self..
22:27:55 <zehicle> sure
22:28:03 <davidlenwell> So the spec will describe clearly how we are going to store stuff.. which we are currently missing
22:28:05 <zehicle> the data is the harder thing to get
22:28:12 <davidlenwell> its a giant hole in our architecture
22:28:15 <zehicle> we'll learn what we want to show as we have data
22:28:29 <davidlenwell> open .. moving right along ..
22:28:31 <zehicle> I owe everyone the spec on the JSON & flows
22:28:43 <zehicle> I've got drafts of them, just need to write the spec
22:28:53 <zehicle> the flow is being reviewed by defcore
22:28:53 <davidlenwell> very good
22:29:03 <davidlenwell> when is the next defcore meeting ?
22:29:08 <zehicle> not scheduled
22:29:28 <zehicle> there are community ones 7/9
22:29:40 <zehicle> and a TC interlock tomorrow
22:29:45 <zehicle> 1pm PT
22:29:54 <davidlenwell> good to know
22:29:59 <zehicle> I suggest bringing some popcorn to watch the fireworks
22:30:08 <davidlenwell> good advice
22:30:24 <davidlenwell> #topic dell contractors
22:30:30 <zehicle> I'm making sure my asbestos suit is back from the cleaners
22:30:44 <zehicle> +1 Dell Contractors
22:30:47 <davidlenwell> I know we need to do some work to plan things so that we can keep the contractors busy while they are engadged
22:31:02 <zehicle> they were able to get Refstack working and explored the code
22:31:03 <davidlenwell> we can start with having them tackle our test coverage
22:31:20 <zehicle> they are making plans about how to improve coverage
22:31:23 <davidlenwell> while they do that I'll review all the open stories
22:31:28 <zehicle> I asked them to focus on API & upload
22:31:42 <davidlenwell> hmm .. well since I am doing that you can refocus them
22:31:46 <zehicle> would be helpful if we had stories that I can point them to
22:31:48 <zehicle> +1
22:31:58 <davidlenwell> we have a ton of open stories
22:32:25 <davidlenwell> need to be tretriaged
22:33:06 <zehicle> I meet w/ the contractors tomorrow early
22:33:08 <davidlenwell> I'll make that a priority in the next couple of days
22:33:11 <zehicle> any direction is helpful
22:33:16 <davidlenwell> zehicle: define early
22:33:21 <zehicle> 7am central
22:33:27 <davidlenwell> wow thats early
22:33:31 <davidlenwell> I might still be awake then
22:33:36 <zehicle> last week it was 5:30
22:33:48 <zehicle> but that was just because I was at the airport anyway
22:34:01 <davidlenwell> Do you want me to try to make an apearance for that meeting?
22:34:13 <davidlenwell> managing developers by proxy is hard
22:34:25 <davidlenwell> I'd like to get an idea of strengths and stuff
22:34:53 <zehicle> I have their backgrounds - I'll forward 1x1
22:35:04 <davidlenwell> sounds good
22:35:09 <tedchang> Hi This is Catherine using Ted's machine ... Having problem with my IRC
22:35:10 <zehicle> that's why I was suggesting moving the meeting time back to 10 am
22:35:17 <zehicle> so you'd have direct contact
22:35:30 <davidlenwell> zehicle: alright .. that seems to be the next topic anyway
22:35:32 <zehicle> my goal is to have them operate in community, not act as puppets for me
22:35:36 <davidlenwell> #topic meeting time
22:36:05 <davidlenwell> zehicle has asked that we move the meeting to monday at 10am pdt .. any objections?
22:36:25 <zehicle> my apologies > I mis-spoke about the time zone needs for our EU people
22:36:32 <zehicle> this time is 2 am for them
22:36:55 <tedchang> 10 am on Monday works for me
22:37:00 <zehicle> entirely my fault when we were discussing before
22:37:15 * davidlenwell thanks zehicle for granade jumping
22:37:30 <fcarpenter> 10am is fine for me
22:37:44 <zehicle> better for me than 5 central
22:37:45 <davidlenwell> okay lets do 10am on mondays.. I'll update things again in the wiki
22:37:53 <zehicle> thanks
22:38:01 <zehicle> I'll let them know tomorrow AM
22:38:14 <davidlenwell> #agree meeting to change to 10am pdt mondays
22:38:34 <davidlenwell> #agreed meeting to change to 10am pdt mondays
22:39:19 <davidlenwell> #topic mid cycle meeting in Darmstadt germany
22:40:22 <davidlenwell> I will be attending the q/a, infra mid-cycle thing in germany in two weeks.. I will most likely still be available for the monday meetings .. but if I am absent zehicle will moderate the meetings in my place
22:40:41 <zehicle> +1 can do
22:40:58 <zehicle> I will have a conflict on the OSCON week
22:41:05 <davidlenwell> I'll be back for that
22:41:17 <davidlenwell> #topic open discussion
22:41:24 <davidlenwell> zehicle: are you going to oscon?
22:41:27 <zehicle> yy
22:41:35 <zehicle> boardmeeting and presenting DefCore at the cloud day
22:41:38 <davidlenwell> happy birthday openstack
22:41:44 <catherine_d> Could we talk about coding work ...
22:42:05 <davidlenwell> catherine_d: you missed half the meeting .. we talked about a lot of stuff..
22:42:22 <davidlenwell> we have 18 minutes for open discussion now.. we can talk about whatever you like.
22:42:36 <catherine_d> we need the code for https://review.openstack.org/#/c/98914/
22:42:52 <davidlenwell> yes we do
22:42:55 <catherine_d> to get us going with local refstack for Icehouse
22:43:49 <davidlenwell> yes ..
22:43:57 <davidlenwell> So is that code you want to tackle catherine_d?
22:44:02 <davidlenwell> I know we talked about that before
22:44:07 <catherine_d> yes we can
22:44:27 <davidlenwell> I'm good with that
22:44:48 <davidlenwell> catherine_d: I am not sure if we put the work items from that spec into story board yet.. I'll make sure they are in storyboard today
22:45:07 <davidlenwell> and as you make commits could you keep story board up to date ..that way I know the status of things
22:45:15 <catherine_d> great.. also once we have that code ... we will need some update the web.py ... do you want us to update the old code or should we only use the new V1 API?
22:45:36 <davidlenwell> catherine_d: that is going to require some discussion
22:46:17 <davidlenwell> we also have an issue with two different testers
22:46:43 <davidlenwell> catherine_d: Do you have time next week for a face to face?
22:46:45 <catherine_d> yes we do ...
22:47:12 <davidlenwell> it might be more productive to lock our selves in a room and work out how we are going to do this stuff
22:47:17 <davidlenwell> with whiteboards
22:47:25 <catherine_d> how about you pick one tester then we can use that tester and identify what else needed
22:47:38 <davidlenwell> the newer tester is prefered
22:47:41 <catherine_d> agree ..
22:47:57 <davidlenwell> but it kinda breaks the way you were driving tests/config from the web ui
22:48:05 <catherine_d> should we have a face-2-face ... I really want to get refstack local to work with Icehouse
22:48:29 <davidlenwell> I'm free next monday,tuesday,wednesday
22:48:52 <catherine_d> Let's be it ... refstack is not worlking with Icehoiuse any way .. and I am not sure we want to do much work on Havana
22:49:04 <davidlenwell> we don't
22:49:24 <davidlenwell> So lets talk offline about when we can have facetime
22:49:39 <catherine_d> great let's do that ...
22:49:57 <davidlenwell> does anyone have anything else to discuss?
22:50:53 <catherine_d> About pushing data ..
22:51:15 <catherine_d> right now we have an API to push with keystone UUID ...
22:51:41 <catherine_d> how about API with tester ID... we we plan to use the same API or update the current API?
22:52:12 <davidlenwell> same function for both
22:52:20 <davidlenwell> its all detailed int he spec
22:52:51 <davidlenwell> I'm also almost finished with the working api code.. trying to get it in today.. just working out a bug in the validation
22:53:19 <catherine_d> I did not see the test id option in https://review.openstack.org/#/c/99752/
22:55:01 <davidlenwell> its called job_id
22:55:31 <catherine_d> ic
22:55:34 <davidlenwell> {	119
22:55:34 <davidlenwell> 'cpid': '2fd4e1c67a2d28fced849ee1bb76e7391b93eb12',	120
22:55:34 <davidlenwell> 'duration_seconds': 23445234,	121
22:55:34 <davidlenwell> 'job_id': '3fd4e1c67a2d28fced849ee1bb76e7391b93eb13', /*optional*/	122
22:55:34 <davidlenwell> 'results': {} /* to be defined */	123
22:55:35 <davidlenwell> }
22:55:46 <catherine_d> great
22:56:38 <davidlenwell> So a few things have been renamed .. but that functionality was preserved
22:56:52 <davidlenwell> okay .. so thats all the time we have for today boys and girls.. until next week
22:57:05 <davidlenwell> #endmeeting