17:10:18 <davidlenwell> #startmeeting refstack
17:10:19 <openstack> Meeting started Thu Jun 19 17:10:18 2014 UTC and is due to finish in 60 minutes.  The chair is davidlenwell. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:10:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:10:23 <openstack> The meeting name has been set to 'refstack'
17:10:50 <zehicle_at_sbuck> o/
17:10:55 <fcarpenter> o/
17:11:07 <catherine_d> here
17:12:34 <zehicle_at_sbuck> suggsted topic: participating in the Tempest mid cycle meeting (if they are having one)
17:12:36 <davidlenwell> Sorry I was late popping in here.. I had a guy installing a new ineternet connection at my house
17:12:52 <zehicle_at_sbuck> yeah!  MORE INTERNETS
17:13:02 * zehicle_at_sbuck never has enough of them
17:13:19 * davidlenwell never can have enough internets
17:14:13 <zehicle_at_sbuck> I can give a DefCore update
17:14:27 <zehicle_at_sbuck> basically, came out like we were expecting with a minor change
17:14:52 <zehicle_at_sbuck> we're moving to using capabilities for the scoring and then tests are in managed in the capabilities.json
17:15:02 <zehicle_at_sbuck> I'll remove the tests.json
17:15:14 <davidlenwell> sounds good to me
17:15:24 <davidlenwell> was waiting for that after the defcore meeting the other day
17:15:28 <zehicle_at_sbuck> the bigger change is that we're going to have capabilities include ALL TESTS that the PTLs think should be included
17:15:42 <zehicle_at_sbuck> and DefCore will flag tests that can be omitted
17:15:47 <davidlenwell> that should be interesting ..b ut they would know best
17:15:48 <zehicle_at_sbuck> it's a little more complex to model
17:16:02 <davidlenwell> is it written down in detail some place?
17:16:14 <davidlenwell> #topic defcore update
17:16:15 <zehicle_at_sbuck> the assumption is that if the technical teams think these tests make up a capability then they are likely right
17:16:25 <zehicle_at_sbuck> it was in the minutes of DefCore.
17:16:27 <davidlenwell> they would know best
17:16:39 <catherine_d> So PTLs will give a list o tests
17:16:40 <zehicle_at_sbuck> #question should we make a spec for the change or just patch the existing files
17:16:57 <zehicle_at_sbuck> I'm in favor of just patching, but could do it either way
17:16:59 <davidlenwell> we should write a spec about how we are supposed to interpret that data and include instructions for ptls
17:17:07 <davidlenwell> we can change the existing spec
17:17:18 <zehicle_at_sbuck> ok, that makes sense
17:17:21 <davidlenwell> but as far as I know that hasnt merged into the approved folder anyways
17:17:22 <zehicle_at_sbuck> better documentation
17:17:35 <zehicle_at_sbuck> so, I'll need a story for that.  I can get that done for tomorrow
17:17:56 <zehicle_at_sbuck> was that Catherine's spec?
17:18:32 <davidlenwell> she started it .. but I don't think it ever merged
17:18:49 <catherine_d> My spec only specify the testid format
17:19:04 <catherine_d> we should merge mine and start a new spec for the JSON
17:19:10 <davidlenwell> zehicle_at_sbuck: so hers might make a good reference .. but maybe start from scratch
17:19:12 <zehicle_at_sbuck> let's keep them separate.  I can xref
17:19:17 <zehicle_at_sbuck> +1
17:19:34 <zehicle_at_sbuck> agreed, we have a plan on that
17:19:52 <catherine_d> +1 to keep them separate... I think there would be more change to the JSON format down the road
17:20:14 <catherine_d> but the test id format should be mor stable ..
17:20:17 <davidlenwell> #agreed zehicle_at_sbuck will write the defcore spec defining how the data is to be used and how ptls can add the lists of tests they want for each projects
17:20:51 <zehicle_at_sbuck> sounds like I'll need a flow chart too (something I promised to DefCore anyway)
17:20:56 <zehicle_at_sbuck> may take longer than Friday
17:21:06 <catherine_d> so davidlenwell:  if you can merge https://review.openstack.org/#/c/98907/ then zehicle_at_sbuck: can refer to that spec for test id
17:21:12 <davidlenwell> #topic sprint planning
17:21:36 <davidlenwell> Now that we have a ton of work items .. we can actually plan work sprints
17:21:53 <davidlenwell> Since most things depend on the api.. that will be the first item tackled.
17:22:12 <rockyg> o/
17:22:29 <davidlenwell> hi rocky .. you can read the minutes later and get the back log
17:22:35 <rockyg> kk
17:22:51 <zehicle_at_sbuck> ok if I can find someone to turn the mocks into HTML/CSS templates?
17:23:01 <davidlenwell> I can do that
17:23:11 <davidlenwell> unless you can find someone who's good at it
17:23:20 <davidlenwell> but lets start with the mocks
17:23:32 <zehicle_at_sbuck> davidlenwell, if you have someone, then let's use them
17:23:40 <zehicle_at_sbuck> +1
17:23:54 <zehicle_at_sbuck> they can work w/ me 1x1 if needed
17:24:25 <davidlenwell> in this early stage I want to be very anal about the front end code .. it will set a precident for the rest of the work done on the front end
17:24:34 <zehicle_at_sbuck> +1
17:24:41 <rockyg> +1
17:24:42 <davidlenwell> which means if I have to forgo sleep for a weekend to make sure its right.. that is what I will do
17:24:53 <zehicle_at_sbuck> you may want a story for a design template
17:25:12 <davidlenwell> yeah .. sounds like a plan
17:26:04 <davidlenwell> we should probably have a ui planning meeting in general
17:26:18 <zehicle_at_sbuck> if there was a template in place, I'd could help populate the data flows inside the template
17:26:20 <davidlenwell> I don't want to take a lot of time here .. but some face time and a white board will probably go a long way
17:26:52 <rockyg> +1
17:26:58 <zehicle_at_sbuck> it looks like I'm in SJC next week.  Not sure if I have time to swing to SF but can try
17:27:05 <davidlenwell> by our next meeting lets have a ui f2f planned
17:27:15 <zehicle_at_sbuck> +1
17:27:30 <davidlenwell> #agreed by our next meeting lets have a ui f2f planned
17:27:32 <zehicle_at_sbuck> we should shortlist people who want to be involved
17:27:42 <zehicle_at_sbuck> and try go keep it short
17:27:51 <zehicle_at_sbuck> to make scheduling easier
17:27:58 <davidlenwell> I can probably steel one of pistons ux people for an afternoon to help
17:28:15 <davidlenwell> but I'll find out
17:28:53 <davidlenwell> if nothing else they can help in the review process .. they've already offered this much
17:29:16 <catherine_d> so there are 2 things that I think are priority to work on 1) UI 2) data model ... seems like we have a plan for UI ... How about data model
17:29:50 <davidlenwell> catherine_d: are you reffering to the data model in general or the data models needed for the defcore reports?
17:30:11 <catherine_d> data model in general ..
17:30:26 <catherine_d> I think we talked about that in the last f2f
17:30:30 <davidlenwell> So we did make a better plan for the data model in general durring the api redesign
17:30:46 <catherine_d> too many changes and we would like to take a over look at the model
17:30:49 <davidlenwell> if you look at the spec that landed in approved this week .. it clearly lists a lot of changes to the models
17:31:31 <davidlenwell> part of integrating the new api will be patching the old code to use the new model structure
17:31:35 <davidlenwell> and a migration path
17:31:43 <catherine_d> so are we set in the current data model with the changes?
17:31:58 <davidlenwell> yes I think so
17:32:10 <davidlenwell> https://storyboard.openstack.org/#!/story/132
17:32:14 <catherine_d> for example .. at the f2f we discussed that the endpoint UUID should be in test object ..
17:32:27 <davidlenwell> #link https://github.com/stackforge/refstack/blob/master/specs/approved/api-v1.md
17:32:53 <davidlenwell> cpid is being added to the test model
17:32:54 * krotscheck peers at that story - it doesn’t load instantly, he should file a story for that.
17:32:58 <catherine_d> in the spec that zehicle_at_sbuck: wrote this UUID will be in the cloud object (which I aree) .. so where should it be?
17:33:35 <davidlenwell> krotscheck: that has been happening a lot
17:33:46 <krotscheck> davidlenwell: Got it
17:33:48 <catherine_d> but that is not state in https://review.openstack.org/#/c/99500/
17:34:03 <davidlenwell> that is not a merged spec
17:34:47 <catherine_d> I know but both zehicle_at_sbuck: and I think it should be in cloud model so should we have some discussion?
17:34:57 <catherine_d> to get the final agreement?
17:35:09 <davidlenwell> if we dissagree .. yes
17:35:34 <catherine_d> I think that is the case here ..
17:35:40 <davidlenwell> I will review his spec today and if I dissagree will comment as such .. then we can have further discussion
17:36:06 <catherine_d> ok
17:36:28 <zehicle_at_sbuck> back - catching up in thread
17:37:09 <zehicle_at_sbuck> My assumption was that there's a model above cloud ("vendor / company"?)
17:37:30 <davidlenwell> I will make a diagram of the database so that we can stop making asumptions
17:37:34 <catherine_d> the model aboive cloud is user then vendor
17:37:54 <zehicle_at_sbuck> ok
17:37:55 <catherine_d> test is below cloud
17:38:07 <rockyg> I <3 diagrams
17:38:10 <catherine_d> test result is inside test
17:38:19 <zehicle_at_sbuck> +1 on a diagram
17:38:41 <davidlenwell> its like russian nesting dolls .. I'll make some pictures and then we can debate where things belong
17:38:52 <zehicle_at_sbuck> I'm happy to adjust the spec
17:38:53 <davidlenwell> no point in going into it here
17:39:22 <zehicle_at_sbuck> +1, issue flagged, let;s keep moving
17:39:39 <catherine_d> +1
17:40:03 <catherine_d> are we moving to review next?
17:40:07 * zehicle_at_sbuck thinks lunch time meetings are hard on the schedule
17:40:08 <davidlenwell> no
17:40:27 <davidlenwell> zehicle_at_sbuck: agreed .. my last agenda item of the day is adjusting this meeting time
17:40:36 <davidlenwell> but I digress
17:40:52 <zehicle_at_sbuck> davidlenwell, +1 - esp w/ people joining from Ukrain
17:41:24 <davidlenwell> #topic unit tests
17:41:58 <davidlenwell> so I'd like to make it someones job to think through some basic starting point unit tests for our code..
17:42:19 <davidlenwell> rockyg: what do you have alex doing?
17:43:00 <rockyg> Docker stuff.  He's creating a container for provisioning data centers
17:43:09 <davidlenwell> So not refstack things
17:43:35 <rockyg> Not at the moment.  But the docker stuff is very useful for our TCUP stuff.
17:43:45 <rockyg> He's learning tons.
17:43:52 <davidlenwell> thats good for him..
17:44:21 <davidlenwell> I'd personally volunteer to write and design the unit tests.. but so far every single work item in the refstack storyboard stories are assigned to me
17:44:56 <rockyg> Might be abel to carve some time out, but I don't want to break his rythm, and he's so accomodating that I need to make sure he can do multiple things without losing focus.
17:45:14 <davidlenwell> catherine_d: Do you think this is something you or someone at ibm can help with?
17:46:05 <rockyg> davidlenwell: if you can write one good example that tests ean existing chunk of code, that could help
17:46:24 <rockyg> We could point almost anyone at it then.
17:46:27 <catherine_d> I am not sure that is our forte .. I was about to take and implement  the spec about tempest file
17:46:47 <davidlenwell> what spec is that?
17:47:44 <davidlenwell> I will create unit tests for the api that I am working on now.
17:47:48 <catherine_d> https://review.openstack.org/#/c/98914/
17:47:50 <davidlenwell> it is one of the work items
17:47:50 <rockyg> I can get someone on it in China once the repository is in openstack/infra.  Right now, the CN management is only counting integrated contributions to OS
17:48:14 <catherine_d> for https://review.openstack.org/#/c/98914/ we can work on most of the stuff except UI ..
17:48:27 <davidlenwell> oh .. catherine_d I had assumed I would have to do that
17:48:34 <catherine_d> or UI will be mockup until a official UI is desinged
17:48:38 <davidlenwell> but if you can handle it .. by all means .. lets assign it to you
17:48:39 <zehicle_at_dell> I've asked our new people to help w/ tests but it will be a while before they are up to speed
17:48:43 <catherine_d> ok np
17:49:01 <catherine_d> we have not started ...
17:49:10 <davidlenwell> well I suppose my api tests will have to suffice as a starting point
17:49:16 <davidlenwell> okay final topic ..
17:49:21 <davidlenwell> #topic meeting times
17:49:40 <davidlenwell> I'd like to make sure I can start attending all of the q/a meetings
17:49:46 <zehicle_at_dell> +1
17:49:50 <davidlenwell> rob has a hard time meeting at lunch
17:49:55 <catherine_d> so would you like us to take https://review.openstack.org/#/c/98914/ while you work on API?
17:50:01 <rockyg> Fortunately for me, davidlenwell dislikes early mornings even more than I do.
17:50:01 <catherine_d> or we can work on the API spec
17:50:02 <zehicle_at_dell> any chance we could move it earlier in the day?
17:50:13 <zehicle_at_dell> sigh
17:50:18 <davidlenwell> and we have a few new team members from ukrain
17:50:27 <davidlenwell> I'm not a morning person
17:50:39 <zehicle_at_dell> so, likely the best time will be afternoon
17:50:47 <zehicle_at_dell> back to 3 pm?
17:50:48 <davidlenwell> yes ..
17:50:49 <rockyg> what is Ukrain utc offset?
17:51:00 <davidlenwell> 3pm pacific ?
17:51:04 <zehicle_at_dell> I think it's -10
17:51:05 <rockyg> No.  3pm is the alternate time of QA
17:51:14 <zehicle_at_dell> we could alternate w/ QA
17:51:19 <zehicle_at_dell> take the opposite slots
17:51:24 <davidlenwell> are we married to thursday ?
17:51:28 <zehicle_at_dell> no
17:51:28 <rockyg> Unless you want to do 10 and 3 altenating opposite of QA
17:51:39 <davidlenwell> I actually find that thursday isn't the best day
17:51:45 <davidlenwell> I'd preffer early in the week
17:51:52 <davidlenwell> makes planning for the week easier
17:51:54 <rockyg> Anything but Tuesday
17:52:05 <davidlenwell> now we have a planning meeting and then the weekend before anyone actually works
17:52:14 <davidlenwell> I move for monday in the mid afternoon
17:52:16 <zehicle_at_dell> Monday?
17:52:19 <zehicle_at_dell> +1
17:52:24 <rockyg> Works for me.
17:52:25 <zehicle_at_dell> let's give that a try
17:52:26 <davidlenwell> 2pm
17:52:40 <zehicle_at_dell> 3 would be better for the Ukrain people
17:52:41 <davidlenwell> zehicle_at_dell: do you want to do the change in the wiki's or should I do it?
17:52:47 <davidlenwell> 3 is fine
17:52:50 <zehicle_at_dell> davidlenwell, could you do it
17:52:58 <davidlenwell> yes .. I'll try to remember
17:53:01 <zehicle_at_dell> I'm not crazy about the 5 pm time, but I can make it work
17:53:15 <zehicle_at_dell> not good for east, but that's not an issue right now
17:53:38 <rockyg> Puts Praveen around 10pm
17:53:43 <davidlenwell> thats why I said 2 pm
17:53:48 <zehicle_at_dell> Praveen does not have much time for this
17:53:53 <rockyg> Ah.
17:54:32 <davidlenwell> #agreed new meeting time will be monday at 3pm pacific .. channel tbd
17:54:57 <davidlenwell> I wil get it in the wiki and scheduled and then I will email fits
17:55:13 <davidlenwell> catherine_d: lets talk later today offline about what you guys can work on
17:55:15 <rockyg> Checking tz of Ukraine
17:55:32 <catherine_d> ok
17:55:49 <catherine_d> can we talk on #refstack?
17:55:52 <davidlenwell> the ukraine folks are contractos and likely won't be perminate additions to the team .. we aren't going to be able to make everyone happy with the meeting time
17:56:08 <davidlenwell> catherine_d: yes .. but in an hour or so .. im commutng to the office after this meeting
17:56:23 <catherine_d> ok
17:56:29 <davidlenwell> anything else?
17:56:41 <catherine_d> review but we do not have time
17:56:49 <rockyg> 9pm Ukraine tinme =11am PDT
17:57:02 <davidlenwell> how is that relevant ?
17:57:11 <rockyg> ifno
17:57:13 <rockyg> ionfo
17:57:18 <rockyg> info
17:57:53 <davidlenwell> like I said .. we can't make everyone happy on a global team with meeting times .. its just not possible
17:57:53 <catherine_d> I -1 https://review.openstack.org/#/c/99500/ because I would like to see whether we still support push with credential ..
17:58:14 <davidlenwell> catherine_d: I'll review all pending code reviews today
17:58:23 <davidlenwell> we can discuss them in #refstack
17:58:41 <catherine_d> ok
17:59:01 <davidlenwell> #endmeeting