17:07:23 <rockyg> #startmeeting Refstack
17:07:24 <openstack> Meeting started Thu Apr 10 17:07:23 2014 UTC and is due to finish in 60 minutes.  The chair is rockyg. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:07:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:07:27 <openstack> The meeting name has been set to 'refstack'
17:07:41 <rockyg> roll call
17:08:10 <rockyg> #topic progress updates
17:09:08 <troytoman> here but probably not of much use!
17:09:52 <rockyg> :-)  catherineD, tedchang?
17:09:56 <tedchang> here
17:09:58 <catherine|2> Here
17:10:27 <rockyg> fcarpenter waiman
17:11:09 <catherine|2> pinging waiman
17:12:05 <rockyg> I guess I'll start.  Been looking at sphinx and trying to get it to document the code.  It finds the modules and sets up the docs partially, but won't do things like classes and stuff.
17:12:46 <rockyg> Plus, it won't capture comments, only stuff in the source files that have doubledouble-quotes.
17:13:20 <rockyg> And I expect I'll need to migrate to oslosphinx once I do get it working properly.
17:14:16 <rockyg> So, so far I have docs with headings but no content within the headings
17:15:06 <rockyg> That's it for me.  catherine|2 and team?
17:15:23 <catherine|2> ic Our practice is using  doubledouble-quites for headers and # for in-line
17:15:42 <catherine|2> We have been working closely with David ..
17:16:20 <catherine|2> mostly updating to get ready for gearman
17:16:30 <rockyg> Yeah.  I'd like to get at least some of the # stuff to be incorporated, but I don't see a way with the sphinx maekup
17:16:35 <catherine|2> Raymond is stuck in traffic
17:17:01 <rockyg> Great.  Gearman is going to be key, I think, for demos and discussion.
17:17:52 <rockyg> Do we have a working tcup implementation my colleagues can try?  I thought we were there from what I've seen go by in reviews.
17:17:53 <catherine|2> Raymond also working on enabling backend for report .. right now he is writing some very simple front-end
17:18:46 <rockyg> front-end for report?
17:19:20 <catherine|2> yes but that is just sample code ... our focus is the back-end methods ..
17:20:14 <rockyg> Good.  The back-end *is* the important part.  Just need the simple to show human parsable results right now.
17:20:25 <catherine|2> Lot's of coding discussionamong Ted, Raymond and David in the past few days ..
17:20:43 <catherine|2> rockyg:  exactly
17:20:54 <rockyg> Good.
17:21:26 <tedchang> btw, rocky the current implementation is using tcpu.
17:21:59 <rockyg> I've tried to extract the flows from the urls tedchang provided last week.  Especially the man page.  All I can get are images, though.
17:22:12 <rockyg> tedchang tcup ;-)
17:22:40 <rockyg> tcpu used to be a vms command to show realtime cpu usage
17:23:36 <rockyg> I'm putting the flow images into the architecture section of the wiki.  Either links or images.  I've done both for the moment.
17:23:50 <praveen_dell> hello guys
17:23:52 <catherine|2> rockyg: Thx
17:24:06 <rockyg> Hey, Praveen!  any staus updates?
17:24:08 <praveen_dell> i have tested the latest code,it just builts the docker container
17:24:09 <catherine|2> praveen_dell: Hello
17:24:30 <praveen_dell> i am updating tcp.md  file,will submit as a patch
17:24:43 <rockyg> excellent.
17:25:44 <rockyg> praveen_dell, read the roll-up.  If you have any questions, ask as we move along.
17:25:59 <praveen_dell> sure
17:26:43 <rockyg> I think we've got the progress doc'ed here.  What should the next topic be?
17:28:04 <rockyg> #topic Summit
17:28:32 <catherine|2> wha is plan to collect data from various clouds?
17:28:49 <rockyg> We've got the proposal fleshed out.  Thanks, guys.
17:29:09 <catherine|2> rockyg: see the update .THANK YOU!
17:29:37 <rockyg> catherine|2:  I thought DB.  I think the the DB needs more thought and design discussion.
17:30:05 <rockyg> before we go to db, quick question: who will be at the summit?
17:30:19 <catherine|2> yes that is one of the topic we have been discussing with David ..
17:30:54 <catherine|2> We can only go after our session is approved
17:31:23 <rockyg> I am expecting to be there, bu my boss is travelling at the moment.
17:31:36 <praveen_dell> where is the summit?
17:31:46 <rockyg> Session aproval is still at least a week awy, I think.
17:31:57 <rockyg> Atlanta.
17:32:08 <rockyg> Georgia, USA
17:32:18 <praveen_dell> umm,no chance for me to attend
17:32:20 <praveen_dell> so far
17:32:27 <rockyg> Dang.
17:32:29 <catherine|2> Refstack session link http://summit.openstack.org/cfp/details/197
17:33:16 <praveen_dell> are you guys planning to demo Tcup project?
17:34:03 <rockyg> I'm wondering if we should propose any others.  Like some open discussions around refstack and defcore selesctions
17:34:45 <rockyg> We need a demo for the summit.  Even if it's very choriographed.
17:34:55 <catherine|2> rockyg: make sense ..
17:35:04 <praveen_dell> 1+
17:35:21 <catherine|2> where would we demo?  During the session?
17:35:30 <rockyg> Yes.
17:35:45 <davidlenwell> Hi
17:35:48 <catherine|2> Maybe that should be a topic for next week ... when everyone is here
17:35:51 <praveen_dell> I can't open summit link
17:35:58 <rockyg> Hey davidlenwell!
17:36:14 <davidlenwell> I'm about to shut off my phone
17:36:28 <davidlenwell> Flight about to depart
17:37:03 <rockyg> you can read after.  mostly status and there will be some action items
17:37:10 <catherine|2> davidlenwell: Hello , so not much time?
17:37:48 <rockyg> davidlenwell: anything you want to say before you sign off?
17:38:06 <davidlenwell> Review my code ;)
17:38:17 <rockyg> Will do;-)
17:38:36 <rockyg> Although the others will be better for it;-)
17:38:46 <catherine|2> davidlenwell: Raymond did ... and we also need to make some update ..
17:39:14 <rockyg> I'll take an action to put together a strawman for demo we can modify.
17:39:26 <rockyg> let's move to db topic
17:39:31 <catherine|2> Ted also review
17:39:43 <rockyg> #topic Database discussions
17:40:35 <rockyg> I assume part of the discussions have been on the added complexity of private data vs public data?
17:42:59 <praveen_dell> is that mean user who are  pushing tempest results to refstack UI can only compare with their previous set of results?
17:43:52 <rockyg> people need to be able to say whether data is "publishable" or not
17:44:13 <praveen_dell> okay
17:44:34 <rockyg> And prople can submit unofficial data tha could be used for aggregation, but can't be individually visible
17:44:43 <rockyg> ^people
17:46:13 <rockyg> And I would expect that people could elect to thow out the data from a specific run.  Obviously right after the run completes, but what about some time after more runs have occurred?
17:47:02 <rockyg> catherine|2: are the discussions with davidlenwell on IRC, skype or phone conference?
17:47:47 <catherine|2> mostly on IRC #refstack or in the review comments
17:49:05 <rockyg> Thanks.  Maybe we should schedule a meeting so Praveen and others could join the discussion?  Maybe once the design is closer or do you think more heads could help move it along?
17:50:02 <rockyg> II'm sure zehicle_at_dell would also like to contribute.
17:50:44 <catherine|2> rockyg: +1 also for next week we should discuss about the summit session ...so we can prepare ..
17:51:00 <rockyg> Yes.
17:51:25 <catherine|2> Thank you!
17:51:59 <rockyg> #action schedule meeting to discuss DB design based on privacy/security/use cases requirements
17:52:47 <rockyg> #action agenda for next week to include topic on summit session - topics, demo, etc
17:53:05 <praveen_dell> 1+
17:54:42 <rockyg> praveen_dell: what are you utc hours of availability?  I think we at least need audio and either screen share or an etherpad
17:55:55 <praveen_dell> up to 6pm utc should be fine for me
17:56:52 <rockyg> So, 1800utc, which is 11am pdt
17:57:43 <praveen_dell> correct
17:58:26 <rockyg> I'm thinking 1700 utc to start, again.  I'll get davidlenwell's availability and zehicle_at_dell and I think we might want joshuamckenty
17:59:24 <praveen_dell> 1+
17:59:34 <praveen_dell> when are you planning the meeting?
17:59:52 <rockyg> I think part of the key here is this needs to be more of a traditonal database than most of the ops dbs in OpenStack. So design is much more critical.
18:00:08 <rockyg> Not before Wednesday.
18:00:13 <praveen_dell> ok
18:01:21 <praveen_dell> is there anything to discuss now?
18:01:28 <rockyg> zehicle_at_dell has some schedule complexities next week, as does davidlenwell (still in Canada), so maybe mailing list to work out meeting times.  Is the list even working?
18:02:19 <rockyg> Nope.  Wrapping up.  Last call for getting things on agenda. any more discussion should move to #refstack.
18:03:56 <rockyg> Hearing none, #endmeeting
18:04:06 <praveen_dell> yeah
18:04:16 <rockyg> #endmeeting