17:03:10 <davidlenwell> #startmeeting Refstack
17:03:11 <openstack> Meeting started Thu Apr  3 17:03:10 2014 UTC and is due to finish in 60 minutes.  The chair is davidlenwell. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:15 <openstack> The meeting name has been set to 'refstack'
17:03:25 <davidlenwell> roll call?
17:05:47 <zehicle_at_dell> o/
17:06:08 <boris-42> hi all
17:06:11 <davidlenwell> HI boris-42
17:06:18 <fcarpenter> Morning, all.
17:06:22 <praveen-dell> Hello all
17:06:28 <davidlenwell> So we have some late arrivals this morning .. this is the first week at this time..
17:07:03 <davidlenwell> we'll get started and hopedully they show up
17:07:08 <zehicle_at_dell> +1
17:07:13 <davidlenwell> #topic Introductions and team identification
17:08:18 <davidlenwell> wanted to introduce everyone to boris-42.. he's ptl of rally.. we're going to be keeping them in our loop for the time being .. the hope is that our projects can find a way to colaborate on some of our shared requirments
17:08:43 <boris-42> davidlenwell sure
17:09:06 <davidlenwell> usually I'd have several more people to introduce to you right now .. but alas I think we'll loop back around to that when they show up .
17:09:06 * zehicle_at_dell welcome boris-42
17:09:26 <boris-42> zehicle_at_dell hi there
17:09:44 <davidlenwell> So I'll just move right into the next topic
17:09:47 <davidlenwell> #topic Rally > Refstack Collaboration
17:10:20 <davidlenwell> for those of your who haven't .. take some time later and review the readme on the rally repo . its well done! .. https://github.com/stackforge/rally
17:10:45 <davidlenwell> you will notice right away their process has a "validation" step that uses tempest tests.. which should seem very familure
17:10:45 <boris-42> davidlenwell wiki one is better=)
17:10:54 <davidlenwell> good to know
17:11:08 <boris-42> davidlenwell yep we are trying to bind all existing tools
17:11:22 <boris-42> davidlenwell to make live of devops/devs/qa simpler
17:11:36 <davidlenwell> next wednesday boris-42 and I have a google hangout call for some show and tell of each of our projects.. after which we'll have some discussions on how we might work together
17:12:46 <zehicle_at_dell> cool!
17:12:58 <zehicle_at_dell> will you send out a general invite?
17:13:19 <boris-42> zehicle_at_dell pls share email
17:13:23 <boris-42> zehicle_at_dell so I'll send
17:13:39 <boris-42> zehicle_at_dell davidlenwell  yep I think that it's good for first step
17:13:52 <davidlenwell> boris-42: maybe we can chat the day before and work out a loose agenda
17:13:53 <boris-42> zehicle_at_dell davidlenwell  to understand what we are doing and how to colobarate
17:14:21 <davidlenwell> zehicle_at_dell: do you have rockyg's phone number .. maybe we can text her .. I wanted her to pay attention to the next part of this meeting
17:14:55 <zehicle_at_dell> davidlenwell, working on it
17:15:09 <boris-42> zehicle_at_dell davidlenwell so guys
17:15:15 <boris-42> btw here is a high level roadmap
17:15:16 <boris-42> https://docs.google.com/document/d/1cAgyueiQ__tZ_MG5oOxe4q49tyPQcm-Y1469lmeERq8/edit?usp=sharing
17:15:18 <boris-42> for Juno
17:15:28 <boris-42> I am writing with community now
17:15:32 <boris-42> so only topics are ready
17:15:59 <davidlenwell> it is interesting that you shared that now .. my next meeting topic is "Specs"
17:16:12 <davidlenwell> #Specs
17:16:22 <davidlenwell> #topic Specs
17:16:43 <davidlenwell> In an effort to reign things in. I am implementing something that a lot of the community(nova and others) are doing and use more defined specs when designing features and assigning work. They are doing it with a separate repos like nova-specs (https://github.com/openstack/nova-specs). We're going to keep things in a single repo for now. I don’t want to create extra places for things.
17:17:01 <zehicle_at_dell> +1
17:17:09 <davidlenwell> The idea is to allow you and others to submit features as detailed specs that go through normal code review process so that all future work is thought out on a higher level and can be approved by proper channels before being implemented.
17:17:24 <davidlenwell> I’ve committed a readme, template and the first proposed spec here;
17:17:36 <davidlenwell> folder with template and read me.. https://github.com/stackforge/refstack/tree/master/specs
17:17:45 <davidlenwell> #link https://github.com/stackforge/refstack/tree/master/specs
17:18:05 <davidlenwell> first spec for the gearman workflow.. #link https://github.com/stackforge/refstack/blob/master/specs/proposed/refstack-org-gearman-tester.rst
17:18:24 <davidlenwell> I also thought it would be useful for members of the defcore committee to get credit in stackalytics for designing features and defining use cases.
17:19:12 <zehicle_at_dell> +1
17:20:06 <davidlenwell> any questions?  I'm sure later when ibm people and rockyg show up they will have a million questions .. I'll be available in #refstack all day and am happy to talk about it.
17:20:14 <boris-42> davidlenwell zehicle_at_dell  guys I am bit busy in moment (so see you later)
17:20:26 <davidlenwell> boris-42: thanks for stopping by .. will catch you later
17:20:49 <boris-42> davidlenwell anyway I'll read meeting logs
17:20:50 <zehicle_at_dell> boris-42, looking forward to future collaboration!
17:21:23 <zehicle_at_dell> davidlenwell, I think you're on the right track.  we need more of a quorum for finalize process
17:21:34 <davidlenwell> exactly
17:21:40 <zehicle_at_dell> I think we should move foward since this conforms to community best practice
17:21:55 <davidlenwell> #agreed moving forward with specs
17:22:18 <davidlenwell> #topic Refstack design session in Atlanta.
17:22:53 <praveen-dell> interesting topic
17:23:02 <davidlenwell> if rocky were here .. she's share this #link http://summit.openstack.org/cfp/details/197
17:23:58 <davidlenwell> catherine at ibm has emailed around some additions for it .. we'll need rockyg to update that with the details asap.. I'll email around today with some more notes on the subbject ..
17:24:08 <davidlenwell> since nobody is here to talk about it .. we'll move on..
17:24:19 <davidlenwell> #topic Pending Code Reviews:
17:24:41 <davidlenwell> zehicle_at_dell: https://review.openstack.org/#/c/84337 I'm reviewing this now
17:24:47 * zehicle_at_dell added comment to Rocky's post
17:25:12 <davidlenwell> thank you rob
17:25:13 <zehicle_at_dell> cool - I'm about to work on changes to execute_test that allow it to pick up the environement variables
17:25:52 <davidlenwell> okay .. zehicle_at_dell lets make sure your code gets reviewed by waiman and ted to make sure we arne't breaking anything
17:26:01 <zehicle_at_dell> +1
17:26:21 <zehicle_at_dell> I'm planning for it to be it's own patch, not added to the existing TCUP one
17:26:28 <davidlenwell> waiman: wanna take a minute and read the scroll back.. we'll loop around to open discussion in a few
17:26:41 <davidlenwell> zehicle_at_dell: good thinking ..
17:26:48 <waiman> so far, davidlenwell:  code is in a different folder, so won't break any existing code.
17:27:11 <davidlenwell> waiman: maybe you missed the part where he said he was going to edit execute_test.py
17:27:14 <waiman> i mean zehicle_at_dell:  tcup code is in a separate folder.
17:27:23 <waiman> oh.. i don't see that.
17:27:37 <davidlenwell> its going to be in a different review
17:27:54 <waiman> ok. will watch out for that...
17:28:18 <davidlenwell> after this topic I'll go back to specs..
17:28:30 <davidlenwell> waiman: are other members of ibm joining us?
17:28:54 <waiman> i don't see them online... Catherine has a doctor appointment
17:29:04 <davidlenwell> ah .. okay .. we'll just catch her up later on
17:29:11 <davidlenwell> So lets talk about https://review.openstack.org/#/c/84320/
17:29:30 <davidlenwell> waiman and ted took the time yesterday to make us some flow charts detailing how things work here..
17:29:43 <davidlenwell> I haven't had a chance to read them yet but I'll take a look
17:30:03 <davidlenwell> rockyg: read the scroll back .. and we'll loop around to specs and open discussion shorttly
17:30:19 <waiman> #link https://www.lucidchart.com/documents/view/efd2ff41-8269-45e1-8950-30ce09bd2061
17:30:31 <rockyg> Don't have the scroll back because was disconnected fro net.
17:30:39 <waiman> #link https://www.lucidchart.com/documents/view/ed40cb3e-18a6-4121-a990-6d87a7310378
17:30:50 <davidlenwell> rockyg: sorry .. (not everyone has persistant irc.. I must remember this)
17:30:50 <waiman> i don't have the scroll back neither.
17:30:56 <davidlenwell> okay..
17:31:07 <davidlenwell> lets finish this topic and I'll just loop around
17:31:29 <rockyg> cool
17:31:41 <davidlenwell> waiman: I'm going to reivew your drawings and will leave some feed back in your code review ..
17:31:49 <waiman> good.
17:32:06 <waiman> has anyone had a chance to run it?
17:32:19 <davidlenwell> rockyg waiman.. I'll let you read the meeting log to  catch the introduction and rally part of the discussion ..
17:32:22 <zehicle_at_dell> I tied but ran into python dependencies
17:32:32 <davidlenwell> we'll now go back to Specs..
17:32:40 <davidlenwell> #topic Specs .. again
17:32:52 <davidlenwell> In an effort to reign things in. I am implementing something that a lot of the community(nova and others) are doing and use more defined specs when designing features and assigning work. They are doing it with a separate repos like nova-specs (https://github.com/openstack/nova-specs). We're going to keep things in a single repo for now. I don’t want to create extra places for things.
17:32:57 <davidlenwell> The idea is to allow you and others to submit features as detailed specs that go through normal code review process so that all future work is thought out on a higher level and can be approved by proper channels before being implemented.
17:33:04 <davidlenwell> I’ve committed a readme, template and the first proposed spec here;
17:33:04 <davidlenwell> folder with template and read me.. https://github.com/stackforge/refstack/tree/master/specs
17:33:04 <davidlenwell> first spec for the gearman workflow.. https://github.com/stackforge/refstack/blob/master/specs/proposed/refstack-org-gearman-tester.rst
17:34:00 <davidlenwell> rockyg: this should lead to good raw material for documentation
17:34:26 <davidlenwell> #topic specs q and a
17:34:41 <zehicle_at_dell> davidlenwell, do you expect to have more directories after proposed?  like "accepted" and "completed" ?
17:34:49 <davidlenwell> yes .
17:35:01 <davidlenwell> when something is final and we've agreed on it .. it will move to accepted
17:35:03 <waiman> so, we should have the specs approved, before coding (or at least checking in, right?)
17:35:07 <davidlenwell> when its dinished comleted
17:35:23 <davidlenwell> waiman: idealy we'd have specs approved before writing any code ..
17:35:39 <waiman> +1
17:35:42 <davidlenwell> it will save us a lot of wasted efforts and re-writes if the group decideds to go another way
17:35:43 <zehicle_at_dell> +1
17:36:05 <zehicle_at_dell> I'm assuming we'd use this time to approve/discuss specs?
17:36:20 <davidlenwell> yes
17:36:29 <davidlenwell> it will be a regular meeting topic
17:36:32 <rockyg> And, we can enforce updating the specs before moving to completed.
17:36:34 <zehicle_at_dell> +1
17:36:45 <davidlenwell> as well as using the code review process to refine the specs
17:37:01 <davidlenwell> waiman: I also can't see the comments you tried to make on my proposed spec ..
17:37:17 <davidlenwell> so we can discuss that offline if you like
17:37:33 <waiman> https://review.openstack.org/#/c/84957/
17:37:49 <waiman> i added 4 inline comment in patch set 2
17:37:56 <davidlenwell> oh I see it .. thanks
17:38:22 <davidlenwell> good call on the using the test status message
17:38:28 <davidlenwell> I'll add that to the spec
17:38:54 <davidlenwell> are there any other questions about specs ?
17:39:15 <waiman> are you going to use the execute_test.py on the gearman worker?
17:39:21 <davidlenwell> yes
17:39:23 <zehicle_at_dell> are you going to have a list of items that need specs?
17:39:37 <davidlenwell> zehicle_at_dell: right now that is all of our open blue prints
17:39:53 <davidlenwell> and I will likely create blueprints and empty specs and assign them to people to flush out
17:39:58 <zehicle_at_dell> so, I'm infering, we need one for TCUP
17:40:05 <davidlenwell> zehicle_at_dell: absolutely
17:40:06 <zehicle_at_dell> +1
17:40:12 <rockyg> +10
17:40:32 <davidlenwell> anyone wanna take the first pass at the tcup spec ?
17:40:41 <davidlenwell> the template is pretty easy to follow
17:40:43 <zehicle_at_dell> I'm willing to do it
17:40:49 <davidlenwell> okay.. excelent
17:40:50 <rockyg> Thanks!
17:41:01 <zehicle_at_dell> we should possibily agree that there are mutiple TCUPs right now
17:41:09 <davidlenwell> #agreed zehicle_at_dell will take the first pass at the tcup spec
17:41:09 <zehicle_at_dell> and break it into the different cases
17:41:18 <rockyg> Agreed.
17:41:27 <davidlenwell> rob .. I believe my drawing gave us a good seperation between the use cases
17:41:35 <zehicle_at_dell> yes
17:41:36 <davidlenwell> feel free to use it in your spec
17:41:39 <zehicle_at_dell> thanks
17:41:54 <davidlenwell> try to cover one use case per spec
17:41:56 <waiman> where is the drawing?
17:42:18 <davidlenwell> #link https://www.dropbox.com/s/sfx7e8ehlogdpk1/refstack%20high%20level%20flow%20chart.png
17:42:38 <davidlenwell> waiman: its the one we were reviewing at the f2f
17:42:44 <zehicle_at_dell> is there a prefered way to create these drawings?  and, where do you want to keep their source/image output
17:42:54 <davidlenwell> we're using lucid chart
17:43:00 <waiman> good...we were looking for that everywhere in the wiki... :)
17:43:06 <davidlenwell> the free account is sufficient
17:43:15 <davidlenwell> and for my spec I uploaded the image to the wiki
17:43:23 <davidlenwell> and linked it in the rst
17:43:32 <rockyg> Request:  Can we put all the docs in one (or two) location?  DropBox is also a non-starter in corporate network here and I'm not sure how they'd take to having the client on this machine.
17:43:35 <davidlenwell> you can view the source of my rst to see that in action
17:43:48 <davidlenwell> rockyg: we'll use the openstack wiki
17:43:56 <davidlenwell> thats just were I had mine for now
17:44:01 <rockyg> I'll link to the stuff in the wiki.  I'll get that done today.
17:44:08 <davidlenwell> great
17:44:15 <davidlenwell> okay .. next topic ..
17:44:26 <davidlenwell> #topic Refstack design session in Atlanta.
17:44:29 <davidlenwell> again
17:44:40 <rockyg> Yes!
17:44:46 <davidlenwell> rockyg: you didn't see it .. but I linked your session thing
17:44:51 <davidlenwell> rob left a comment on it ..
17:45:05 <davidlenwell> if we can make that a priority to get populated with real info asap.. like today maybe
17:45:13 <davidlenwell> I would be a very happy camper
17:45:37 <rockyg> Can do.  Any comments on catherineD's verbage?
17:45:50 <davidlenwell> I will reply to that email with my comments
17:45:53 <davidlenwell> later today
17:46:02 <rockyg> Great.  I'll get that out today, too.
17:46:08 <davidlenwell> awesome!
17:46:30 <davidlenwell> #agreed rockyg will update the session details here .http://summit.openstack.org/cfp/details/197
17:46:34 <rockyg> It'll be nice not to be struggling with Sphinx for a bit ;-)
17:46:55 <davidlenwell> rockyg: I think this spec thing is a good thing for you to focus your energy on
17:47:04 <rockyg> Agreed.
17:47:33 <davidlenwell> #agreed david will email the group later with comments on catherines verbage for the design session
17:47:47 <davidlenwell> #topic Open Discussion
17:47:49 <rockyg> The cool thing is that we can use the spec docs as wiki sections.
17:48:05 <davidlenwell> absolutely
17:48:10 <davidlenwell> its the same format
17:49:08 <rockyg> Just an FYI.  I've been struggling with docs mostly because I've been on the corporate net, so no access to Architecture drawing, and realizing that the details of a lot of this from a user perspective are still extremely fluid.
17:49:41 <waiman> a question:  is the project name "Refstack" or "RefStack" ?
17:49:47 <davidlenwell> Refstack
17:49:59 <zehicle_at_dell> good to know!  I've been using S
17:50:16 <rockyg> So, off network today until I've collected all the stuff needed into the wiki.  davidlenwell:  Me, too.
17:50:59 <davidlenwell> http://refstack.org/ clearly isn't capitolized ;)
17:51:06 <davidlenwell> just look at the logo
17:51:28 <davidlenwell> thats another topic of discussion .. I'm goign to take a design pass before the summit..
17:51:41 <rockyg> Yeah, but look at the page title.
17:51:51 <davidlenwell> ha ha .. I see ..
17:51:58 <davidlenwell> we are anything but consistant here with refstack
17:52:05 <davidlenwell> see I just did it again
17:52:08 <davidlenwell> no caps
17:52:11 <waiman> and in #link https://wiki.openstack.org/wiki/RefStack
17:52:31 <zehicle_at_dell> I've been doing it RefStack - so that's me
17:52:31 <rockyg> That's my bad.  I'll fix it today.
17:52:42 <zehicle_at_dell> you may mess up the deep linking
17:52:50 <waiman> ok. so "Refstack" is official.
17:52:51 <zehicle_at_dell> I think the wiki is case sensitive
17:52:58 <davidlenwell> it is
17:53:01 <davidlenwell> you can leave it ..
17:53:11 <davidlenwell> I don't actually care if its capitolized at this point
17:53:12 <zehicle_at_dell> #agree Refstack is official
17:53:30 <davidlenwell> I'd rather focus on the work at hand
17:53:32 <zehicle_at_dell> can we agree to not try and fix retroactively?
17:53:33 <rockyg> Wiki is.  I might have to leave the link and link another page with the correct capitalization
17:53:51 <zehicle_at_dell> opportunistic fixes please
17:54:00 <rockyg> zehicle_at_dell:  Yup.
17:54:03 <davidlenwell> so back to our layout and ui for a moment
17:54:03 <waiman> +1
17:54:16 <zehicle_at_dell> davidlenwell, one of my kids is playing with it
17:54:44 <zehicle_at_dell> I can send you a draft tonight
17:54:44 <waiman> we need a better way to display clouds and tests...
17:54:47 <davidlenwell> So I'll publish a spec  with the ux requirment including some wireframes of layout changes and a flow chart showing how things will link together
17:55:08 <zehicle_at_dell> +1 (he's playing w/ CSS not flow)
17:55:20 <davidlenwell> waiman: we had talked in person that time about integrating the cloud / test lists in a colapsable menu
17:55:30 <waiman> right.
17:55:36 <rockyg> Great.  Can we ping the UX team to take a look (Jaromir and someone else?)
17:55:36 <davidlenwell> I think thats a good call ..
17:55:48 <zehicle_at_dell> I was talking w/ Boris R (board member) about the Driver Test work.
17:55:53 <waiman> and now we will have tests doesn't belong to any cloud, uploaded from TCUP.
17:55:57 <zehicle_at_dell> that should be a topic for next week
17:56:33 <rockyg> Oh, also.  Outside of functionality, does Refstack want to also run what security tests we have for the core?
17:56:39 <davidlenwell> waiman: do you mean test results that are anonymous ?
17:56:49 <waiman> davidlenwell: yes
17:57:06 <davidlenwell> waiman: for now we are not making those results public
17:57:12 <waiman> ok
17:57:13 <davidlenwell> they are for data collection for defcore only
17:57:27 <davidlenwell> we'll likely need to build some reporting tools into the sites admin
17:57:37 <waiman> +1
17:57:40 <davidlenwell> I'll put that on the agenda for next week
17:57:53 <davidlenwell> okay .. so I think we've covered all of it ..
17:58:07 <rockyg> Security testing -- next week?
17:58:12 <davidlenwell> rockyg waiman please read the meeting log when we're done .. catch anything we missed
17:58:14 <davidlenwell> yes rockyg
17:58:22 <rockyg> will do.
17:58:31 <catherineD> me too miss the new irc time
17:58:41 <davidlenwell> its okay ..
17:59:00 <catherineD> do we need to have a call to go over the lfow charts
17:59:11 <davidlenwell> I am going to commute into the office now.. then we have a scrum meeting and lunch.. but I'll be in irc all day and would love to talk about specs and flow charts ..
17:59:25 <rockyg> +1
17:59:32 <zehicle_at_dell> OpenStack board meeting today
17:59:35 <davidlenwell> catherineD: get caught up on what a spec is .. and we'll discuss your flow charts this afternoon
17:59:43 <zehicle_at_dell> I'll be online but trying to focus there
17:59:45 <catherineD> ok
17:59:48 <davidlenwell> #endmeeting