21:02:22 <rockyg> #startmeeting refstack
21:02:23 <openstack> Meeting started Thu Mar 27 21:02:22 2014 UTC and is due to finish in 60 minutes.  The chair is rockyg. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:28 <openstack> The meeting name has been set to 'refstack'
21:02:45 <rockyg> Who's here?
21:02:54 <davidlenwell> I'm here
21:03:04 <davidlenwell> agenda: code reviews, py26 gate, tomorrows f2f,  tcup methods
21:03:25 <rockyg> Open discussion....
21:03:37 <rockyg> CatherineD?
21:03:45 <rockyg> Waiman?
21:03:46 <davidlenwell> zehicle: ?
21:03:51 <waiman> o/
21:04:08 <catherineD> Hi Rocky,  I am here
21:04:29 * zehicle running late
21:05:02 <davidlenwell> also on the agenda but we can push it to tomorrows f2f .. docs
21:05:21 <rockyg> Okay, since zehicle is running late, let's talk #topic py26
21:05:40 <rockyg> #topic py26
21:05:51 <davidlenwell> okay .. so I'm planning to remove py26 from the gate all together
21:05:58 <rockyg> What do we need to do to get it working?
21:06:02 <davidlenwell> a lot
21:06:02 <ajo> project stats for lot, 90 days
21:06:52 <davidlenwell> rockyg: so far nobody has expressed interest in running our code in a py26 env .. and a lot of our code does things that didn't exist in py26
21:07:19 <davidlenwell> plus .. for those who want centos and rehl .. they can still run py27
21:07:26 <rockyg> But, tthe first pass is for Havana.  and I though RHEL was py2.6?
21:07:37 <rockyg> Ah.
21:07:49 <davidlenwell> rockyg: so it doesn't matter what env we are testing .. it matters what the test is running from
21:08:06 <rockyg> Maybe we get a redhat contributor to help/work on 2.6?
21:08:06 <davidlenwell> the thing running refstack.org right now needs to be py.27 or py3
21:08:26 <davidlenwell> rockyg: maybe .. but right now having py2.6 in the gate slows down our merges
21:08:45 <davidlenwell> py 26 is old .. we're hanging on to the past
21:08:45 <rockyg> True.
21:09:15 <rockyg> With time being precious, let's deal with 2.6 after we have working 2.7
21:09:16 <davidlenwell> So unless we have any objection I am going to remove py26 from the gate
21:09:27 <zehicle> o/
21:09:41 <davidlenwell> rockyg: im not sure I'll ever care about py26 . but we can bring it back into discussion at a later time
21:09:44 <rockyg> I don't think we want to gate on py3 yet, either.
21:10:03 <davidlenwell> rockyg: I don't agree with you there
21:10:12 <davidlenwell> esp since we pass py33 tests now
21:10:53 <rockyg> how about we vote to not bother with 2.6 until someone shows a need for it?
21:11:11 <davidlenwell> I vote we vote on it later
21:11:20 <davidlenwell> and put it out of our heads
21:11:44 <rockyg> #action table 2.6 discussion for sometime in the future, by request
21:11:54 <davidlenwell> thank you
21:11:59 <davidlenwell> next topic .. code reviews
21:12:14 <rockyg> Now that zehicle is here, let's go back to reviews
21:12:23 <rockyg> #topic code reviews
21:12:45 <davidlenwell> So several things got merged today including teds change for discovery of config options
21:12:54 <davidlenwell> I made some minor dock changes..
21:13:02 <davidlenwell> zehicle has a few reviews that need some work
21:13:24 <zehicle> I've got the pep8 fixes in
21:13:45 <davidlenwell> zehicle: I don't see the review yet
21:14:10 <zehicle> cannot upload from the office.... in a hour or so
21:14:15 <davidlenwell> it doesn't exist until there is a review ;)
21:14:42 <davidlenwell> I've been working on https://review.openstack.org/#/c/81402/ .. will push it later today
21:15:09 <rockyg> #link https://review.openstack.org/#/c/81402/
21:15:54 <davidlenwell> I think that covers the open reviews for now unless anyone else has anything?
21:15:55 <rockyg> I've got similar network issues... can be on corporate network and get emails, or on guest net and get work done.
21:16:15 <rockyg> Anything major besides zehicle's stuff still out there?
21:16:19 <zehicle> I will need some support on the last step of TCUP
21:16:25 <zehicle> because the execute test is not working for me yet
21:16:31 <davidlenwell> zehicle: I can make time for you this afternoon
21:16:33 <zehicle> thanks
21:16:58 <davidlenwell> rockyg: I merged all the other open reviews today .. I think we're abandoning joshua's reviews from last week in favor of zehicle
21:16:58 <rockyg> Do we want to do tcup next or f2f?
21:16:58 <zehicle> have you been able to try the stuff to prep the environment?
21:17:18 <davidlenwell> I was pushing tcup for last because it could drag on
21:17:28 <davidlenwell> zehicle: yes .. I have
21:17:43 <zehicle> +1
21:18:06 <rockyg> I passed CatherineD's instructions on to our infra guy.  Haven't heard back from him yet weher he could make it work.
21:18:25 <davidlenwell> rockyg: all of that will simplify
21:18:36 <davidlenwell> we'll work out the details tomorro w
21:18:46 <rockyg> Thought it would, but wanted to get him started.
21:18:55 <rockyg> So, on to f2f?
21:19:08 <davidlenwell> sure
21:19:18 <rockyg> #topic F2F
21:19:31 <davidlenwell> so I have the room booked from 1-3:30
21:20:01 <fcarpenter> (And that 3:30 is a hard stop)
21:20:20 <rockyg> I'm working on getting sphinx to generate docs.  Some of it is working.
21:21:05 <davidlenwell> the agenda for the f2f is mostly centered around our docs
21:21:30 <catherineD> Is the f2f strictly for doc? Have room for code discussion?
21:21:44 <rockyg> We'll do handoff of davidlenwell's verbiage and drawings tomorrow.  and yes, code is also happening tomorrow.
21:21:57 <davidlenwell> yeah.. we'll cover both ..
21:22:12 <davidlenwell> but my primary objective is to make sense of our docs .
21:22:19 <davidlenwell> we can have some stuff happening in parallel
21:22:37 <rockyg> Do you have a drwing/graphics package to recommend I have preloaded?
21:22:57 <davidlenwell> I use a cloud based one
21:23:09 <davidlenwell> gliffy
21:23:26 <rockyg> I've used that before, but it was part of Confluence.
21:23:47 <rockyg> I'll check it out after this meeting.
21:23:52 <davidlenwell> sure ..
21:24:01 <davidlenwell> okay.. so on to tcup..
21:24:06 <rockyg> So, code and docs tomorrow.  Plus the Defcore meeting.
21:24:19 <rockyg> #topic tcup
21:24:22 <davidlenwell> wait .. when is the defcore meeting ?
21:24:39 <rockyg> zehicle?
21:24:51 <rockyg> Maybe it's today?
21:24:57 * zehicle checking
21:25:38 <zehicle> #link https://etherpad.openstack.org/p/DefCoreElephant.7
21:25:45 <zehicle> It's on 4/1 at 2pm
21:26:04 <rockyg> Ah.  Not today *or* tomorrow.  Good.
21:26:13 <davidlenwell> this is good
21:26:16 <davidlenwell> its monday
21:26:18 <zehicle> oh, there is something tomorrow too
21:26:23 <zehicle> an Interlock w/ the TC
21:26:28 <fcarpenter> monday == tuesday
21:26:38 <rockyg> Oh, right.  I knew there was something.
21:26:42 <zehicle> #link https://etherpad.openstack.org/p/openstack-designated-sections
21:26:49 <zehicle> Friday 3/28 @ 8pm UTC
21:27:13 <rockyg> 'which is 1pm PDT
21:27:22 <zehicle> yes
21:27:32 <davidlenwell> so we'll be here at piston durring that
21:27:54 <rockyg> So, first hour tomorrow we'll be at least listening in while working
21:28:09 <zehicle> it's all about designated sections
21:28:23 <rockyg> OK, that' means we should be on time.
21:28:25 <davidlenwell> does that immidiately effect us .. because we do have limited time
21:28:30 <zehicle> so, it's not likely to hit RefStack stuff just yet
21:28:50 <davidlenwell> as fcarpenter said the 330 end is a hard stop
21:29:07 <davidlenwell> we'll be kicked out of that room and will have to go to the local bar to keep talking
21:29:34 * zehicle buying tx to join in RefStack happy hour
21:29:47 <rockyg> Which is your favorite work bar?
21:30:05 <rockyg> back to tcup.
21:30:06 <davidlenwell> rockyg: as I am new here I don't have one yet ..
21:30:24 <davidlenwell> yes .. so we've had some discussion in the past about what is the right way to run things in docker
21:30:28 <rockyg> Thirsty Bear is a bit far, but really good;-)
21:30:31 <davidlenwell> zehicle: do you want to state your position
21:31:19 <zehicle> so, I've been working to make TCUP into something that runs RefStack
21:31:32 <zehicle> basically, it puts all of into a container and then kicks off the test
21:31:47 <zehicle> so it should be the same to use it from the dev setup, production infratructure or TCUP
21:32:03 <zehicle> that makes it really really light for people to use
21:32:16 <zehicle> basicially, it's just run one py file
21:32:26 <zehicle> and it gets the container and runs the tests inside it
21:32:34 <davidlenwell> I also want to discuss the generating the docker file from a template vs env variables
21:33:02 <rockyg> I like the template idea.
21:33:07 <zehicle> the template approach is a non-starter for me
21:33:10 <davidlenwell> rockyg: there is a reason it won't work
21:33:13 <zehicle> I have some issues with it
21:33:25 <davidlenwell> zehicle: can you spell those out please
21:33:27 <zehicle> 1st, it makes the code more complex for generating it
21:33:42 <zehicle> 2nd, it means that the container is unique each time instead of standard
21:33:54 <davidlenwell> #2 is actually what I am hung up on
21:33:59 <zehicle> #2 is my biggest issue
21:34:08 <catherineD> No the container is not unique for each run
21:34:17 <zehicle> IMHO, the goal is that we have a standard environement that everyone uses
21:34:25 <zehicle> and we pass in the unique stuff as env variables
21:34:32 <zehicle> very easy to repeat and troubleshoot
21:34:44 <zehicle> if we have custom templates then it's hard to troubleshoot
21:35:01 <zehicle> and we can't upload the standard template for everyone to use in a single shot
21:35:27 <davidlenwell> so it sounds to me like maybe we have a slight communication problem about what the template is used for and wather or not it caches or makes every container unuiqe
21:35:49 <rockyg> Question:  lots of people are expressing a desire to "run [api|acceptance|custom|etc] tests against their cloud"  Mostly ops guys.  How does this play in the two options?
21:35:51 <catherineD> if you look at the way we build the container, we push the most stable variables up front.  This will allow docker to cache .. and at the same time will rebuild image when it detected  changes ..
21:36:25 <zehicle> the tcup script I've been working on does exactly that - you put in the differents as environement variables
21:36:37 <catherineD> I can send out the log files after the meeting you will see the evident of caching
21:37:00 <davidlenwell> catherineD: please do ..
21:37:11 <davidlenwell> that said ..
21:37:32 <catherineD> Evironment variables only work in the case of local docker container .... we plan for it to work with gearman remotely
21:37:45 <catherineD> will send dthe logs ...
21:37:49 <davidlenwell> catherineD: the gearman remote thing won't use docker at all
21:37:57 <davidlenwell> it will run the scripts that docker runs
21:38:02 <zehicle> +1
21:38:03 <davidlenwell> doesn't need docker
21:38:14 <zehicle> the scripts should work anywhere
21:38:23 <davidlenwell> and refstack.org CANNOT have docker as a dependancy
21:38:46 <zehicle> I'm trying to keep the docker stuff as a wrapper, not an internal dependency
21:38:51 <catherineD> The scripts will work anywhere but will paring with RefStack
21:38:53 <davidlenwell> +1
21:39:31 <davidlenwell> so for remote execution from the gui.. refstack should be able to be configured to use docker .. but in those instances I think that running them locally will be fine
21:40:00 <davidlenwell> env variables are a more secure way of passing in creds .. and also keeps the container more of a container and less of a one off gererated thing for this one test
21:40:24 <davidlenwell> then docker doesn't have to genreate anything at all and all of it is cached
21:40:34 <zehicle> +1
21:40:37 <catherineD> +1 for security ..
21:40:54 <davidlenwell> and rockyg as far as ops people using it to run there own tests .. nobody is stopping them from modifying things in the tcup thing for their own build
21:40:54 <zehicle> I've been pretty happy w/ using env variables for this
21:41:02 <zehicle> (it was not my original approach)
21:41:16 <catherineD> one of the improvement that we will be doing is to improve security now that the code are merged
21:41:19 <waiman> how about passing in as arg?  the current execute_test.py takes them as command line arg.
21:41:24 <davidlenwell> so catherineD I'd like to see us transition from the template generated docker into one that uses env variables
21:41:34 <zehicle> effectively, the env variables ARE passed as args
21:41:44 <davidlenwell> waiman: ^^ that
21:41:45 <zehicle> the code sets them when the container is started
21:41:58 <catherineD> we need to discuss  who will set the ENV
21:42:01 <davidlenwell> so the thing that calls the script from the command line can just pass them in
21:42:20 <davidlenwell> catherineD: we can whiteboard tomorrow if that will help
21:42:34 <catherineD> When you actually run the tests you will realized that some on need to pass in variables ...
21:42:34 <zehicle> my code (and Josh's code) both build a set of input parameters to the container that set the env variables needed to run thetests
21:42:43 <catherineD> yes let's discuss stomorrow
21:42:51 <rockyg> Whiteboard sounds good.
21:43:13 <davidlenwell> okay then .. I think we can move to open discussion
21:43:35 <rockyg> #topic Open Discussion
21:43:56 <zehicle> oh, one minor note: Docker 0.8 has a bug that makes the Dockerbuild files return EOF
21:44:06 <zehicle> I had to upgrade to 0.9.1
21:44:18 <davidlenwell> zehicle: thats one reason I was so hesitant to use docker at all
21:44:20 <zehicle> just so you don't have to repeat my learning exprience
21:44:25 <davidlenwell> its in a super early alpha stage
21:44:34 <davidlenwell> riddled with bugs and a moving target
21:44:34 <zehicle> I understand the concern
21:44:58 <davidlenwell> thats why I will continue to support the need for it .. but refstack.org won't be dependant on it
21:45:20 <davidlenwell> and in our docs we have to be clear that it is just one of many options
21:45:34 <rockyg> what would be an alternative for the remote runs?
21:45:58 <davidlenwell> a vm running the py scripts that run the tests and clean up afterwards .. probably triggered from gearman
21:46:19 <davidlenwell> rockyg:  its essentially the same thing .. just not in a throw away container
21:46:32 <davidlenwell> my goals are to make us hostable by infra long term
21:46:35 <rockyg> I figured everything but the gearman part.  Would gearman be a requirement, though?
21:46:37 <davidlenwell> they aren't going to play with docker
21:46:59 <davidlenwell> gearman would be a requirement if you chose that option .. just like docker would be if you wanted to use that
21:47:12 <davidlenwell> gearman is also a lot more mature and in heavy use by the infra team now
21:47:40 <rockyg> OK.  I'll need to document options for remote execution.  In case others don't want to use docker.
21:47:41 <zehicle> realistically, we should also be able to clone and run the code too!
21:47:43 <davidlenwell> so refstack.org will use gearman to queue tests
21:48:07 <davidlenwell> thats what local tests are for
21:48:24 <rockyg> Question on tests:  are we cloning them fro the Havana branch?
21:48:26 <davidlenwell> so far the three options for triggering tests are : local, tcup, and remote (gearman)
21:48:50 <davidlenwell> rockyg:  we abslutely should be
21:49:34 <davidlenwell> damnit my spelling .. absolutely
21:49:45 <waiman> davidlenwell: 3 options from refstack web ui, right?
21:49:51 <davidlenwell> waiman: yes
21:49:56 <rockyg> I think we need a way to advertise the branch the tests are cloned from in the test log and the UI.
21:50:00 <davidlenwell> 3 options for the refstack ui
21:50:19 <davidlenwell> rockyg: file a blueprint
21:50:27 <rockyg> Will do.
21:50:30 <zehicle> is the documentation for running the UI up to date?
21:50:33 <davidlenwell> we are selecting the version at the time of making the tests
21:50:34 <waiman> davidlenwell:  i have one related to that
21:51:04 <davidlenwell> thats right .. you ahve one for displaying the results
21:51:13 <waiman> we talk about allowing users to pick version. each version will be mapped to a tempest url.
21:51:20 <davidlenwell> it should say what version .. so rockyg just add to the whiteboard of the existing blueprint
21:51:43 <rockyg> OK.
21:51:47 <davidlenwell> we also talked about allowing them to specify a url of a specific tempest branch they want to run
21:52:04 <waiman> #link https://blueprints.launchpad.net/refstack/+spec/support-different-tempest-versions
21:52:33 <waiman> davidlenwell:  yes. i am working on this.
21:52:41 <davidlenwell> excelent
21:53:06 <davidlenwell> okay .. I think we all have lots of things to do .. lets all this meeting ajourned
21:53:06 <rockyg> I think my homework before tomorrow is to review all the BPs.
21:53:15 <Praveen-dell> Hi,this is praveen from Dell,Ireland,working for Rob on Refstack project
21:53:16 <davidlenwell> rockyg: good plan
21:53:21 <rockyg> Call to end...
21:53:22 <davidlenwell> hi Praveen-dell
21:53:31 <Praveen-dell> Hi David
21:53:37 <zehicle> Praveen-dell is from my team here
21:53:48 <zehicle> He's time zone disadvantaged (in the UK)
21:53:49 <rockyg> Are you in Ireland?
21:53:51 <davidlenwell> Praveen-dell: we're just wrapping up here .. wanna jump over to #refstack and introduce your self
21:54:04 <Praveen-dell> sure
21:54:05 <Praveen-dell> will do
21:54:06 <Praveen-dell> thanks
21:54:18 <rockyg> OK, then time to move back to our "home"
21:54:20 <zehicle> can we have a short topic about potentially changing time?
21:54:33 <rockyg> Here?  Now?
21:54:43 <rockyg> #topic meeting time
21:54:47 <davidlenwell> zehicle: what time did you want to change to  ?
21:54:49 <zehicle> if we're going to change it for next week
21:54:55 <davidlenwell> thursdays at 2 was your idea
21:55:08 <davidlenwell> I'm fine with keeping it how it is
21:55:10 <zehicle> true, did not have anyone from Europe at the time
21:55:15 <davidlenwell> ahh
21:55:26 <davidlenwell> how much time is Praveen-dell going to have for refstack ?
21:55:34 <rockyg> Yeah.  It's likely at least midnight start for Praveen
21:55:52 <Praveen-dell> GMT 5pm or 6pm should be fine for me
21:56:21 <rockyg> So, 11am or noon PDT
21:56:26 <davidlenwell> so I'd like to keep meetings as static as we can .. if we keep moving it we're just going to loose poeple .
21:57:00 <zehicle> +1
21:57:06 <rockyg> Sorry.  10am or 11am
21:57:16 <davidlenwell> 10am is fine for me
21:57:20 <davidlenwell> 11 is a nogo
21:57:43 <rockyg> 10am works for me.
21:57:50 <davidlenwell> any objections to changing the meeting time to 10am pst on thursdays?
21:58:02 <rockyg> that's pDt
21:58:13 <zehicle> I can make that work
21:58:27 <davidlenwell> whats the diff between pdt and pst ?
21:58:33 <catherineD> good for us
21:58:48 <rockyg> Standard vs Daylight savings
21:58:49 <zehicle> I'd like to agree that we'll follow daylight time
21:58:55 <zehicle> sorry, follow the changes
21:59:14 <davidlenwell> I'm good with it .. zehicle wanna change the meeting time on the wiki thing ?
21:59:19 <zehicle> +1 will do
21:59:20 <zehicle> thanks
21:59:29 <zehicle> Thursdays @ 10 am Pacific
21:59:29 <rockyg> yes, thanks.
21:59:37 <Praveen-dell> thanks for the time change
21:59:42 <zehicle> likely to stay on this channel
21:59:52 <davidlenwell> just update the email list
22:00:05 <rockyg> Yeah.  I know QA alternates between this time and the new time on the meeting channel.
22:00:42 <rockyg> Time!
22:00:46 <rockyg> last call.
22:01:05 <rockyg> #endmeeting