22:07:37 <davidlenwell> #startmeeting refstack
22:07:38 <openstack> Meeting started Thu Feb 20 22:07:37 2014 UTC and is due to finish in 60 minutes.  The chair is davidlenwell. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:07:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:07:42 <openstack> The meeting name has been set to 'refstack'
22:07:59 <fungi> i didn't restart the bot, seems to have rejoined from the split
22:08:03 <davidlenwell> yeah
22:08:11 <davidlenwell> like 60 people just jumped back in all at once
22:08:17 <davidlenwell> seems to be correcting it self
22:08:35 <davidlenwell> anyways meeting started
22:08:45 <zehicle_at_dell> thanks
22:08:47 <zehicle_at_dell> o/
22:08:49 <rockyg> rollcall again for minutes
22:09:23 <rockyg> o/
22:09:26 <tedchang> :)
22:09:37 <catherine|3> here
22:09:45 <davidlenwell> here
22:09:54 <tedchang> here
22:10:27 <davidlenwell> So I am going to kick off with a topic if nobody objects ?
22:10:46 <Alex-H> I am here
22:10:55 <zehicle_at_dell> +1
22:10:58 <davidlenwell> #topic stackforge
22:11:10 <rockyg> +1
22:11:53 <tedchang> +1
22:12:25 <davidlenwell> yesterday I had a five hour face to face meeting with catherine|3 and her crew.. They've been very busy.. but their lawyers won't allow them to share it unless its in stackforge first.. So.. I'm right in the middle of pushing the repo into stackforge.. I'm told by mordred (monty) that he'll review it when he gets a minute.. might be tomorrow ..
22:12:25 <zehicle_at_dell> timemachine: Agenda topics RefStack, TCUP, F2F Meetings, Rollout time/plan
22:13:52 <rockyg> Anything needed beyond the commits that you've gotta do?
22:14:17 <davidlenwell> rockyg: once its commited and accepted we'll be in stackforge and we'll actually need to do a lot
22:14:38 <davidlenwell> I'll work on a list of things and put blueprints and stuff in launch pad
22:15:03 <davidlenwell> the main thing I need right now is another core-reviewer since its not cool if I plus2 my own patches
22:15:13 <rockyg> BTW.  I hate launchpad.
22:15:19 <davidlenwell> rockyg:  you are not alone
22:15:24 <davidlenwell> but its how the community does things
22:15:25 <davidlenwell> for now
22:15:45 <rockyg> Catherine maybe?  You've worked with her.  Could we make her core?
22:15:56 <davidlenwell> possibly
22:16:14 <davidlenwell> altho we might want someone with more openstack expierance as the reviewer
22:16:36 <catherine|3> How do one become core?
22:16:38 <rockyg> Yeah, the review checklist is getting long;-)
22:17:15 <davidlenwell> for now Chris Mcgowan has agreed to be another core reviewer if we need him to .. but he won't make a lot of contributions
22:18:07 <davidlenwell> once catherine|3 has gone through gerrit / review a few tiems I'll be fine with giving her +2 .. but as those of us know who have gone through it .. sometiems it can be confusing at first
22:18:24 <rockyg> Review is the key.  Catherine|3: you become core by becoming known as a solid coder and reviewer.  Usually against some project.  Then you get nominated by the team, voted and you get the special +2 want.
22:18:28 <rockyg> wand
22:18:53 <davidlenwell> well put rockyg
22:19:54 <rockyg> We can get Catherene to start reviewing your patches. Coach, and voila!  Let's point her at the reviwer info...
22:20:16 <davidlenwell> so to fill that roll two things are really important .. one is that you are a solid revier and can clearly comment and judge others work in the scheme of the big picture of the project .. the second is availability .. reviews need to happen in a timely fashion
22:20:44 <zehicle_at_dell> do we need blueprints first for this?
22:20:48 <zehicle_at_dell> will that be a limit
22:21:11 <catherine|3> We had a blueprint right?
22:21:31 <davidlenwell> zehicle_at_dell: do you mean a lp blueprint ?
22:21:35 <zehicle_at_dell> yy
22:21:37 <rockyg> If anything, all we need are titles to start.  Roll out a bunch.
22:22:10 <rockyg> I can do it if there's a list to work from.  Even put in some words :-)
22:22:20 <davidlenwell> I like to keep blueprints downto features .. we do have a lot of incomplete features I'd love to use lp to coordinate the specifics on
22:22:40 <davidlenwell> assign to humans and track
22:37:32 <davidlenwell> so some of the things we covered.. config location/format, db changes, were to keep the list of "must pass" tests for each release
22:37:35 <davidlenwell> catherine|3: what else?
22:38:06 <catherine|3> going thru my list
22:38:09 <catherine|3> one sec
22:38:26 <davidlenwell> the bot is back
22:38:32 <davidlenwell> #topic f2f
22:39:02 <catherine|3> those are the majot one ... the rest is just programing style like JSON object vs text etc..
22:39:24 <davidlenwell> lets not dive too deep into that stuff here
22:39:51 <davidlenwell> catherine|3: has your team read into the pep8 standards we talked about?
22:40:29 <davidlenwell> before you can submit your patches you are going to want a clean flake8 test .. otherwise they'll get kicked out of the review before anyone can approve them
22:41:01 <catherine|3> yes we are in the process to do pep8 checking ..
22:41:45 <davidlenwell> great
22:42:59 <davidlenwell> So the next time we are all in the same city is the week of march 3rd .. zehicle_at_dell you still plan to be in the bay that week right?
22:43:22 <zehicle_at_dell> yes
22:43:27 <zehicle_at_dell> Alex cannot make it
22:43:40 <davidlenwell> lets plan at least a 2 hour session some place
22:43:53 <davidlenwell> I think most of us will be in the south bay .. so the piston office won't work well
22:44:13 <davidlenwell> I'll be at an ironic/tripleo sprint all week
22:44:24 <davidlenwell> zehicle_at_dell has board and defcore meetings
22:44:29 <rockyg> I can find a conference room here.  It's kinda wonky because of security, but if I find an external one, it will work fine.
22:44:52 <rockyg> We're in Santa Clara at Central Expressway and San Tomas
22:44:55 <davidlenwell> I think we can coordinate the deails on that next week
22:45:20 <rockyg> There's also a wine bar I know with wifi ;-)
22:45:33 <davidlenwell> #agree we will have a face to face meeting the week of march 3rd
22:45:53 <davidlenwell> we'll decide what and when and where next meeting
22:46:06 <davidlenwell> #topic Rollout time/plan
22:49:09 <rockyg> At this late date, we will only have a prototype/test pilot for Icehouse, since we won't have a definition of core for a while.  What can we have by icehouse-3?
22:49:21 <zehicle_at_dell> the deliverable is around Havana
22:50:06 <rockyg> Yes, but all the schedules revolve around the summit, which is tracked with the Icehouse timelines.
22:50:43 <zehicle_at_dell> let me clarify that
22:51:02 <zehicle_at_dell> the DefCore work for this cycle is to prove it for Havana not Icehouse or Juno
22:51:18 <zehicle_at_dell> that let's people make comments about stable stuff that's been in market
22:51:21 <davidlenwell> +1
22:51:37 <zehicle_at_dell> after we've reviewed & tested w/ Havana then we'll start to look at Icehouse
22:51:47 <zehicle_at_dell> ideally, that's targeted for +90 after the summit
22:51:58 <rockyg> I've got that, I'm just thinking schedules.  I would think the first milestone would be full ttcup with Havana Tempest tests on devtest?  We need to break that down into functionalities.
22:52:02 <zehicle_at_dell> but that can change based on feedback about the Havana work
22:52:14 <zehicle_at_dell> rockyg, +1
22:52:33 <zehicle_at_dell> I'd like to be able to demo it to the board on 3/4
22:52:47 <zehicle_at_dell> so that I can have them start trying it out on their own sites
22:53:06 <rockyg> Can we go back to trello and start mapping some of this stuff out?  Does RefStack have a Trello project?
22:53:10 <davidlenwell> zehicle_at_dell: by demo to the board do you mean tcup with raw output because we're still working out how to parse them
22:53:19 <zehicle_at_dell> yy
22:53:22 <davidlenwell> rockyg: no
22:53:32 <davidlenwell> I'd preffer to keep things in lp
22:54:01 <rockyg> 3/4 would likely mean:  hardcoded stuff from stackforge that gets a cleanup.  that should be pretty good, I would think.
22:54:02 <davidlenwell> which should be all onine later today.. I'll send a team email with the details as soon as its online
22:54:42 <davidlenwell> #agree zehicle_at_dell will demo tcup to the board on 4/3
22:54:57 <davidlenwell> rockyg: I think by then we won't have to hard code anything
22:55:04 <rockyg> Kewl!
22:55:11 <catherine|3> 4/3 = April 3
22:55:14 <davidlenwell> should just need creds and to know what arch the cloud is
22:55:21 <davidlenwell> shit
22:55:23 <davidlenwell> 3/4
22:55:35 <zehicle_at_dell> Here's what I'd like to demo - rob runs TCUP on a VM w/ Rackspace as the target.  Results upload to RefStack from TCUP.  I can show that the results are uploaded BUT NOTHING ELSE.
22:55:44 <davidlenwell> #agree davidlenwell can't type adn that should be 3/4 board meteting
22:55:47 <zehicle_at_dell> Repeat w/ Dreamhost as the target
22:56:08 <zehicle_at_dell> yikes,soory.  yes Mar 4
22:56:22 <davidlenwell> zehicle_at_dell:   might be a challenge   .. we haven't worked out how to run without admin creds
22:56:34 <zehicle_at_dell> that's not required for my demo
22:56:37 <catherine|3> so we have those Cloud (Rackspace and DreamHost) available for us to test first ?
22:56:44 <zehicle_at_dell> I can get accounts
22:56:55 <davidlenwell> zehicle_at_dell: sounds good to me
22:57:01 <rockyg> +1
22:57:03 <zehicle_at_dell> the results of the tests do not need to be shown
22:57:07 <zehicle_at_dell> just that we can post them
22:57:21 <davidlenwell> catherine|3: has almost got it to that point now
22:57:26 <zehicle_at_dell> processing and security of results can be added
22:57:31 <davidlenwell> zehicle_at_dell: just need to clean up the hard coded stuff
22:57:39 <catherine|3> I am more concern about the config parameters that Tempest needed
22:57:56 <zehicle_at_dell> davidlenwell, that's what I was hoping.  I am NOT trying to create a demo crisis
22:58:10 <davidlenwell> catherine|3: we'll know by next thursday if we need to hard code something or not
22:58:16 * zehicle_at_dell join to have to drop off in 120 seconds
22:58:18 <davidlenwell> worst case we can make the user enter more data
22:58:29 <davidlenwell> I'm good with ending now
22:58:33 <davidlenwell> I have a lot to do as well
22:58:34 <catherine|3> so a couple public clouds available as soon as possible will be very helpful
22:58:50 <davidlenwell> I'll put up a piston cloud we can test against as well
22:59:01 <catherine|3> great
22:59:16 <davidlenwell> #endmeeting