22:41:04 <joshuamckenty> #startmeeting refstack
22:41:05 <openstack> Meeting started Thu Jan 30 22:41:04 2014 UTC and is due to finish in 60 minutes.  The chair is joshuamckenty. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:41:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:41:08 <openstack> The meeting name has been set to 'refstack'
22:41:27 <fungi> awesome
22:41:28 * zehicle_ no meeting karma for me tonight
22:41:29 <joshuamckenty> #agreed Use Cases are as of in https://etherpad.openstack.org/p/DefCoreRefStackUseCases
22:41:37 <joshuamckenty> #topic database
22:41:38 <davidlenwell> Alex_H: was working on tempest in container .. and I still don't have a status of that
22:41:47 <zehicle_> #link https://etherpad.openstack.org/p/DefCoreRefStackUseCases
22:41:50 <joshuamckenty> #agreed Sprints will be two weeks
22:42:04 <joshuamckenty> #agreed meetings will continue to be weekly
22:42:14 <zehicle_> also updating the meeting page on wiki
22:42:25 <joshuamckenty> #agreed development will continue to be "informal" for a couple more months (no stackforge process)
22:42:37 <davidlenwell> I don't know if I agree with that one
22:42:41 <davidlenwell> but we can discuss it
22:42:50 <joshuamckenty> okay, let's finish db first
22:42:54 <davidlenwell> okay
22:43:00 <joshuamckenty> so we need to get off sqlite
22:43:06 <joshuamckenty> but we need to support running locally
22:43:13 <davidlenwell> database .. the local version needs no database.. it just uses the restful api on refstack ..
22:43:20 <davidlenwell> it can run locally all day long
22:43:26 <joshuamckenty> and streams the results while tempest is running?
22:43:31 <davidlenwell> tests are stored in a test-r repo
22:43:39 <davidlenwell> locally
22:43:41 <joshuamckenty> oh, right
22:43:46 <joshuamckenty> test-r is cray-cray
22:43:57 <davidlenwell> no .. when the test is done .. the results are pulled and uploaded throught he api
22:44:04 <joshuamckenty> ah, k
22:44:23 <davidlenwell> joshuamckenty: agreed .. test-r is cray cray .. but we have all the support we need on it .. robert colins wrote it and is very helpful when asked
22:44:30 <joshuamckenty> totally agree
22:44:52 <joshuamckenty> okay, so I can take switching prod refstack to mysql or postgres
22:44:52 <catherineD> So all local run will have data upload.  What if we are in private network and can not access RefStack.
22:44:55 <joshuamckenty> any preference?
22:45:05 <joshuamckenty> catherineD: you don't *have* to upload
22:45:17 <davidlenwell> ++ correct ..
22:45:19 <davidlenwell> but you should
22:45:21 <joshuamckenty> but it won't influence defcore or prove certification if you don't
22:45:36 <davidlenwell> .. yeah that
22:45:45 <davidlenwell> stop typing faster than me joshuamckenty.. ;)
22:45:49 <joshuamckenty> :)
22:45:54 <joshuamckenty> it's how I win arguments
22:46:00 <zehicle_> the upload process should be just a webpost
22:46:16 <davidlenwell> most networks can get out .. but you won't be able to get back in ..
22:46:20 <zehicle_> so, if you can access both your cloud and the refstack site then tcup can report for you
22:46:25 <davidlenwell> usually there is a proxy or something
22:46:33 <zehicle_> effectively, tcup is a bridge
22:46:34 <catherineD> I was thinking of in the case of private cloud.  We can run the test locally and then export the result and up load via a RefStack accesible network server
22:46:45 <davidlenwell> private clouds need internet access too
22:46:47 <zehicle_> catherineD, yes, that's the idea
22:47:05 <davidlenwell> usually they can call out .. but don't have routes back in unless specifically opened
22:47:07 <rocky2> Some private clouds don't need the internet
22:47:24 <rocky2> or rather don't want it
22:47:26 <zehicle_> rocky2, but the clients are not isolated
22:47:33 <davidlenwell> I would suggest using a proxy server while certifying and then shutting it off
22:47:35 <joshuamckenty> #action pull dlenwell's branch back into the openstack-ops branch
22:47:49 <davidlenwell> joshuamckenty: pull request ?
22:47:50 <catherineD> rocky2.  Yest, not all private cloud hav network
22:48:01 <joshuamckenty> yeah
22:48:13 <rocky2> proxy might work.  Need a "batch" or "ship when I say" capability for reporting
22:48:16 <zehicle_> let's slow down a little
22:48:25 <davidlenwell> catherineD: I don't know how we'll be able to solve that problem just yet ..
22:48:30 <joshuamckenty> did you have a preference on mysql vs. postgres, david?
22:48:48 <zehicle_> I'd prefer postgresql but can adapt
22:48:56 <davidlenwell> I defualt to mysql because I hate psql ..but I can also adapt
22:49:05 <zehicle_> rocky2 & catherineD - we've broken the problem into two parts
22:49:11 <davidlenwell> also .. infra has to run this
22:49:15 <joshuamckenty> well, I like running refstack on top of cloud foundry on top of AWS (because it's ironic)
22:49:16 <davidlenwell> they usually use mysql ..
22:49:25 <joshuamckenty> there's no evidence that infra has to run it
22:49:35 <joshuamckenty> although I don't object to them doing it
22:49:38 <davidlenwell> I don't want to long term
22:49:38 <zehicle_> I think that adds compelxity
22:49:45 <joshuamckenty> eventually
22:50:03 <zehicle_> we should focus on making it easy to run tempest against clouds where the user does not have other infrastructure
22:50:03 <davidlenwell> I'd rather not have to rebuilld it to pass it along
22:50:12 <rocky2> zehicle_  agreed on the complexity
22:50:23 <zehicle_> so, I should be able to run it from my laptop against my internal clouds
22:50:28 <joshuamckenty> zehicle_: we should focus on being able to gather and collate tempest runs from many clouds
22:50:28 <davidlenwell> joshuamckenty: I don't think we should base engineering decisions on how ironic they are .. but thats just me
22:50:38 <zehicle_> those clouds would have have external access, but I can reach them internally
22:50:44 <rocky2> zehicle_ +1
22:50:46 <joshuamckenty> davidlenwell: that's the entire history of OpenStack, though
22:50:50 <zehicle_> when I run the tests, I can tehn upload the results to refstack
22:51:04 <zehicle_> because my laptop is connected to the internet (even if the cloud I tested is now)
22:51:06 <zehicle_> not
22:51:08 <joshuamckenty> anyway, I'm going mysql
22:51:13 <zehicle_> +1 on mysql
22:51:19 <joshuamckenty> b/c it's supported by -infra and cloud foundry
22:51:23 <joshuamckenty> and farmboy
22:51:24 <zehicle_> #agree mysql
22:51:39 <zehicle_> already on the etherpad
22:51:41 <davidlenwell> yeah .. and termie already did a lot of the work for refstack to use mysql in farm boy
22:51:45 <joshuamckenty> yup
22:51:54 <davidlenwell> so done .. next topic
22:52:00 <joshuamckenty> okay - do you want to talk about stackforge process now?
22:52:05 <davidlenwell> yes
22:52:09 <joshuamckenty> my concern is just that it will slow us down in the short term
22:52:10 <zehicle_> for this sprint, I think willing participants need to get your refstack working on their local envuronements
22:52:15 <joshuamckenty> and we're under a lot of time pressure
22:52:25 <rocky2> How about changing the topic officially?
22:52:31 <joshuamckenty> #topic stackforge
22:52:31 <davidlenwell> yes ..
22:52:50 <davidlenwell> stackforge process I think is important for two reasons
22:53:18 <davidlenwell> 1. people contributing will be elegable for coupon codes to attend the summit in atlanta
22:53:25 <davidlenwell> right now they wouldn't be
22:53:32 <rocky2> Somebody reviews the code before checkin
22:53:49 <davidlenwell> it would require a plus two from a core dev
22:53:54 <joshuamckenty> rocky2: we do that now, it doesn't require stack forge. (Although it is a side effect)
22:54:02 <joshuamckenty> davidlenwell: is that a bonus?
22:54:16 <rocky2> Can we do it with a +1?  loosen the rules for the project?
22:54:19 <zehicle_> would make it easier to me to engage my team if they would show up as ATCs
22:54:20 <joshuamckenty> define refstack core right now: me, you, and termie?
22:54:37 <joshuamckenty> rocky2: +1
22:54:59 <zehicle_> would help attract people
22:55:01 <davidlenwell> I don't want to be all power hungry .. but I don't want 10 conflicting pull requests to deal with merging manually
22:55:07 <fungi> well, being a stackforge project contributor won't get anyone free summit passes. being an openstack{,-dev,-infra} contributor will. but by "stackforge" i assume you really mean "openstack"
22:55:45 <davidlenwell> zehicle_: thats my other point .. being in gerrit review process is a known thing in the comminity and a work flow these guys are used to
22:55:47 <fungi> just need to figure out what official program the project belongs within, in that case
22:55:54 <davidlenwell> I don't want to be seen as different or special
22:55:58 <joshuamckenty> I do
22:55:59 <zehicle_> I'm in favor
22:56:00 <joshuamckenty> :)
22:56:27 <zehicle_> I think that we're solving problems that we don't have - not that many contributors
22:56:33 <rocky2> joshuamckenty:  +1
22:56:42 <joshuamckenty> If you suggest making this an official openstack project, you'll immediately lose two of the three core devs
22:56:50 <davidlenwell> before atlanta I want to be in gerrit review
22:56:50 <joshuamckenty> because neither termie nor I will keep contributing
22:57:18 <joshuamckenty> but the ATC temptation may mitigate that
22:57:30 <joshuamckenty> e.g., you might get enough new devs to make it a good trade
22:57:48 <davidlenwell> termie would be a loss .. but you are too busy to be that active on this anyways
22:57:51 <davidlenwell> outside of planning
22:57:56 <zehicle_> lets plan a transition and move on.  really, I would not expect you to remain a maintainer
22:57:56 <joshuamckenty> also true
22:58:20 <joshuamckenty> so once we have PRs from two other devs, I think we should pull the trigger
22:58:25 <zehicle_> can we talk about work items for the sprint?
22:58:25 <davidlenwell> lets put planning the transition on the agenda for next week
22:58:26 <joshuamckenty> a reasonable compromise?
22:58:36 <zehicle_> +1
22:58:41 <davidlenwell> agreed
22:58:54 <rocky2> +0
22:58:58 <zehicle_> adding to the wiki page
22:59:02 <joshuamckenty> #topic sprint work items
22:59:11 <davidlenwell> item one .. t-cup
22:59:38 <davidlenwell> a few weeks ago .. Alex_H and I were planning to make tempest in a docker container
22:59:39 <zehicle_> # agenda: Transition of RefStack into OpenStack management
23:00:08 <davidlenwell> after much deliberation I decided that docker wasn't the right move .. docker is still very imature
23:00:26 <zehicle_> Alex_H had it working
23:00:43 <zehicle_> for what we're doing, it's a reasonable and fast way to get it distributed
23:00:48 <davidlenwell> I've been trying to sync with him for a few days .. we keep missing each other
23:00:58 <zehicle_> he's not available until after 2 your time
23:01:08 <davidlenwell> I'll try to chat with him today ..
23:01:16 <zehicle_> he's on the IRC
23:01:18 <joshuamckenty> let's focus on the upload API
23:01:21 <davidlenwell> So lets table the tcup talk for now
23:01:25 <davidlenwell> the api
23:01:30 <joshuamckenty> since that's agnostic to what was used to run the code
23:01:31 <davidlenwell> is dependant on the database
23:01:37 <zehicle_> #topic API
23:01:37 <joshuamckenty> I'll do the DB right away
23:01:46 <zehicle_> we do need a way for users to run the tests locally
23:01:50 <joshuamckenty> davidlenwell: we've been putting the work items into https://etherpad.openstack.org/p/DefCoreRefStackUseCases
23:01:55 <joshuamckenty> zehicle_: we have that
23:01:59 <joshuamckenty> there's a refstack CLI already
23:02:04 <davidlenwell> yes ..
23:02:06 <joshuamckenty> (which davidlenwell and termie want to rewrite)
23:02:08 <zehicle_> ok, let's get the documented
23:02:08 <joshuamckenty> :)
23:02:30 <joshuamckenty> https://github.com/dlenwell/refstack/tree/master/refstack/cli
23:02:40 <davidlenwell> well right now it lets you add clouds and generate configs adn then execute tests ..
23:03:00 <davidlenwell> tthe testing part I want to replace with tcup as what is there is a hack job
23:03:08 <davidlenwell> the config generation is pretty strong
23:03:49 <joshuamckenty> https://github.com/dlenwell/refstack/blob/master/refstack/cli/refstack#L114
23:04:14 <davidlenwell> the store the results thing doesn't work with sqlite
23:04:24 <davidlenwell> which this version of the cli is dependant on
23:04:24 <joshuamckenty> https://github.com/dlenwell/refstack/blob/master/refstack/common/tester.py#L95 ?
23:04:24 <catherineD> So have we decided to replace CLI with Restful API.  CLI is what we have been focused on for local test.
23:04:39 <joshuamckenty> no, there will still be a CLI
23:04:45 <davidlenwell> no .. let me clearify
23:04:52 <joshuamckenty> we're going to add an API for upload
23:04:56 <joshuamckenty> to refstack.org
23:04:56 <davidlenwell> there will be a cli .. it will just work a lot differently
23:05:11 <catherineD> That is great.
23:05:45 <davidlenwell> the cli .. will generate the config .. trigger tcup .. capture the results from tcup and upload them through the api to refstack
23:06:20 <rocky2> Wanna capture that in the etherpad?
23:06:40 <davidlenwell> I want to make a flow chart explaining the behavior
23:06:45 <rocky2> cool
23:06:59 <davidlenwell> one thing that is seriously lacking in this project is a propper high level design document
23:07:04 <davidlenwell> that takes the use cases into account
23:07:10 <joshuamckenty> #chair zehicle_
23:07:11 <openstack> Current chairs: joshuamckenty zehicle_
23:07:15 <joshuamckenty> #chair davidlenwell
23:07:16 <openstack> Current chairs: davidlenwell joshuamckenty zehicle_
23:07:20 <joshuamckenty> guys, I have to run, I'm sorry
23:07:25 <joshuamckenty> late for another meeting
23:07:28 <zehicle_> I'm pulled into my next thing too
23:07:36 <davidlenwell> so until next time ?
23:07:42 <joshuamckenty> davidlenwell: can you keep going with technical bits?
23:07:46 <davidlenwell> sure
23:07:47 <joshuamckenty> make sure every dev has work :)
23:07:52 <davidlenwell> :)
23:07:54 <joshuamckenty> and keep the etherpad updated
23:07:58 <rocky2> davidlenwell:  +1 for high level design doc.  I'll help anyway I can.
23:07:58 <joshuamckenty> thanks everyone!!!
23:08:13 <catherineD> David could we meet at #refStack?
23:08:25 <davidlenwell> sure .. lets move there and gree up this room
23:08:33 <catherineD> OK thanks a lot!
23:08:44 <davidlenwell> fungi: how do we end this thing ?
23:08:46 <fungi> davidlenwell: please #endmeeting
23:09:05 <davidlenwell> #endmeeting