#openstack-meeting Meeting

Meeting started by hub_cap at 22:02:56 UTC (full logs).

Meeting summary

    1. http://wiki.openstack.org/Meetings/RedDwarfMeeting (hub_cap, 22:04:21)

  1. Meet and greet (hub_cap, 22:05:46)
    1. michael basnight, lead of the opensource portion of the project from rackspace (hub_cap, 22:07:02)
    2. Josh Dorothy w/ HP (jdorothy, 22:07:32)
    3. Clare Springer w/ HP (yidclare, 22:07:41)
    4. Justin Hopper w/ HP (juice, 22:07:51)
    5. Vipul Sabhya @ hp (vipul, 22:07:53)
    6. Nikhil Manchanda, with HP. (SlickNik, 22:08:01)
    7. jim cooley, director of database/reddwarf @ HP (jcooley, 22:08:14)
    8. Saurabh, w/ HP (saurabhs, 22:08:21)
    9. Kevin Mansel @ HP (kmansel, 22:09:29)
    10. Nirmal Ranganathan @ Rackspace.. just eavesdropping (rnirmal, 22:10:02)
    11. grapex is tim simpson, sr dev on the project at rax, cp16net is craig vyvial sr dev at rax, rnirmal is nirmal ranganathan former reddwarfer (hub_cap, 22:10:07)

  2. Discuss launchpad participation (hub_cap, 22:10:29)
    1. https://launchpad.net/reddwarf (hub_cap, 22:10:54)
    2. Aaron Crickenberger w/ HP (spiffxp, 22:11:00)
    3. added the grizzly series to the page (hub_cap, 22:11:37)
    4. https://launchpad.net/reddwarf/grizzly (hub_cap, 22:15:38)
    5. ACTION: grapex to make a launchpad site for redstack (hub_cap, 22:16:59)
    6. we need a way to configure reddwarf easier within devstack (hub_cap, 22:20:52)

  3. devstack integration (hub_cap, 22:21:18)
    1. we need a way to configure reddwarf easier within devstack (hub_cap, 22:21:53)
    2. ACTION: hub_cap to discuss devstack integration (hub_cap, 22:22:35)
    3. consider using the libs in devstack (hub_cap, 22:22:55)
    4. ACTION: jcooley (not hub_cap) to discuss devstack integration (hub_cap, 22:23:22)
    5. non-incubated precendence already in devstack, see 'ryu' integration (vipul, 22:23:27)

  4. Discuss initial core team (hub_cap, 22:24:51)
    1. current reddwarf-core team: hub_cap, grapex, vipul (vipul, 22:25:21)
    2. ACTION: hub_cap to add spiffxp to core team (hub_cap, 22:27:44)
    3. https://launchpad.net/~reddwarf-core (hub_cap, 22:36:49)
    4. ACTION: Vipul to follow up on reddwarf-core with mordred (vipul, 22:37:30)
    5. ACTION: jcooley to follow up for Vipul on reddwarf-core with mordred :) (vipul, 22:38:01)
    6. make sure one of the other company (rax/hp) looks at each review (add a particular reviewer from core) (hub_cap, 22:38:34)

  5. Proper blueprinting/bug practices (hub_cap, 22:40:04)
    1. ACTION: everyone to make sure that reviews are linked with bugs or blueprints (hub_cap, 22:41:53)
    2. http://wiki.openstack.org/GerritWorkflow (vipul, 22:43:02)
    3. http://wiki.openstack.org/GerritWorkflow (rnirmal, 22:44:27)

  6. PTL? (hub_cap, 22:46:04)
    1. not now, wait for more participation and incubation (hub_cap, 22:47:49)
    2. vipul and hub_cap to keep communication open between hp/rax (hub_cap, 22:49:00)

  7. Open discussion (hub_cap, 22:49:28)
    1. there is likely a decent bit of work to make rdli (reddwarf-integration) work for the public project (hub_cap, 22:51:14)
    2. we _need_ _need_ _need_ some CI soon (hub_cap, 22:51:27)
    3. ACTION: grapex to own CI and make sure it gets accomplished (hub_cap, 22:51:39)
    4. we need to integrate the client in to stackforge as well (hub_cap, 22:54:03)
    5. hub_cap is a moron, its already there (hub_cap, 22:54:55)
    6. ACTION: hub_cap make sure the client launchpad page is up to date w/ the series like the reddwarf one (hub_cap, 22:55:36)
    7. ACTION: hub_cap talk to lifeless or devananda about the image creation (hub_cap, 22:57:36)
    8. hub_cap is on paternity leave for 2 more weeks and will be sparse (hub_cap, 22:58:13)


Meeting ended at 23:01:54 UTC (full logs).

Action items

  1. grapex to make a launchpad site for redstack
  2. hub_cap to discuss devstack integration
  3. jcooley (not hub_cap) to discuss devstack integration
  4. hub_cap to add spiffxp to core team
  5. Vipul to follow up on reddwarf-core with mordred
  6. jcooley to follow up for Vipul on reddwarf-core with mordred :)
  7. everyone to make sure that reviews are linked with bugs or blueprints
  8. grapex to own CI and make sure it gets accomplished
  9. hub_cap make sure the client launchpad page is up to date w/ the series like the reddwarf one
  10. hub_cap talk to lifeless or devananda about the image creation


Action items, by person

  1. grapex
    1. grapex to make a launchpad site for redstack
    2. grapex to own CI and make sure it gets accomplished
  2. hub_cap
    1. hub_cap to discuss devstack integration
    2. jcooley (not hub_cap) to discuss devstack integration
    3. hub_cap to add spiffxp to core team
    4. hub_cap make sure the client launchpad page is up to date w/ the series like the reddwarf one
    5. hub_cap talk to lifeless or devananda about the image creation
  3. jcooley
    1. jcooley (not hub_cap) to discuss devstack integration
    2. jcooley to follow up for Vipul on reddwarf-core with mordred :)
  4. lifeless
    1. hub_cap talk to lifeless or devananda about the image creation
  5. mordred
    1. Vipul to follow up on reddwarf-core with mordred
    2. jcooley to follow up for Vipul on reddwarf-core with mordred :)
  6. spiffxp
    1. hub_cap to add spiffxp to core team
  7. vipul
    1. Vipul to follow up on reddwarf-core with mordred
    2. jcooley to follow up for Vipul on reddwarf-core with mordred :)


People present (lines said)

  1. hub_cap (170)
  2. vipul (50)
  3. SlickNik (25)
  4. jcooley (25)
  5. spiffxp (18)
  6. rnirmal (16)
  7. grapex (12)
  8. juice (11)
  9. ThiagoCMC (5)
  10. mordred (4)
  11. yidclare (4)
  12. lifeless (3)
  13. openstack (3)
  14. jdorothy (2)
  15. clarkb (2)
  16. kmansel (2)
  17. ttx (1)
  18. uvirtbot` (1)
  19. saurabhs (1)
  20. esp2 (1)


Generated by MeetBot 0.1.4.