14:01:20 <amoralej> #startmeeting RDO meeting - 2020-06-17
14:01:20 <openstack> Meeting started Wed Jun 17 14:01:20 2020 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:23 <openstack> The meeting name has been set to 'rdo_meeting___2020_06_17'
14:01:38 <amoralej> #topic roll call
14:01:40 <rdogerrit> mathieu bultel proposed openstack/validations-common-distgit rpm-master: Add python3-prettytable as requirement for validations-common  https://review.rdoproject.org/r/28121
14:02:13 <amoralej> you still can add your topics to https://etherpad.opendev.org/p/RDO-Meeting
14:02:55 <ykarel> o/
14:03:41 <amoralej> #chair ykarel
14:03:42 <openstack> Current chairs: amoralej ykarel
14:03:44 <spotz> o/
14:03:46 <jcapitao> o/
14:03:50 <amoralej> #chair spotz jcapitao
14:03:52 <openstack> Current chairs: amoralej jcapitao spotz ykarel
14:05:37 <amoralej> ok, let's start with first topic
14:05:53 <amoralej> #topic FWaaS retirement in Victoria
14:06:03 <amoralej> #link https://review.opendev.org/#/c/735838/
14:06:26 <amoralej> #info fwaas is being retired upstream and will be removed from RDO
14:07:16 <amoralej> #action projects using FWaaS from RDO should stop using it
14:07:33 <amoralej> so, this seems to be a cleaning releases
14:07:51 <amoralej> some projects have been retired, congress, tricircle (not in RDO) and fwaas
14:08:00 <amoralej> also paunch was cleaned today
14:08:10 <amoralej> i think it's good maturity signal
14:08:34 <amoralej> that's it about this topic
14:09:19 <amoralej> #topic Install guide bugs for Ussuri - confirm and I'll put up ptaches
14:09:24 <amoralej> spotz, all yours
14:10:10 <spotz> So someone said there was no Octavia documentation for CentOS so I decided we couldn't have that so started buildiing out an USsuri cluster
14:10:34 <cgoncalves> spotz, cool!
14:10:58 <amoralej> spotz, you mean upstream install guide, right?
14:11:05 <spotz> Updating the latest for the individual projects not an issue but for the main install guide we do have the issue of differences between RHEL 7 and 8
14:11:31 <spotz> amoralej: Yeah and then we can downstream anything, I noticed there's supposed to be a Doc Days in Auguest?
14:11:47 <amoralej> yes, we do doc days from time to time
14:12:16 <spotz> I'll definitely have things in working order upstream by then then we can adapt for RDO
14:12:44 <amoralej> ok, note the policy is to have in rdo only very specifi info for RDO
14:12:52 <spotz> But here's the questions. On the install guide we only go so far as repos for Rocky
14:12:57 <amoralej> and point to upstream one when possible
14:13:13 <spotz> Ok well Upstream will be correct when I'm done:)
14:13:20 <amoralej> good
14:13:48 <amoralej> some time ago, there was someone reviewing the upstream doc on each release but i don't remember the nick, tbh
14:13:53 <amoralej> not sure about last releases
14:14:08 <spotz> DO we want to update the main install guide through adding repos for Ussuri? And point our for like the client different package name for RHEL 8/Ussuri?
14:15:08 <amoralej> I'd say so
14:15:25 <amoralej> I mean, install guide follows stable branches iiuc
14:15:28 <spotz> And I'll add the power tools repo for rabbitmq and note rhel 8
14:15:31 <amoralej> so current doc should point to ussuri
14:15:36 <amoralej> and reflect changes for centos8
14:15:44 <amoralej> as it's the supported release now
14:16:17 <amoralej> so, i'd say we should push all changes required to follow the doc properly
14:16:28 <spotz> It's not release related aka no latest, train, etc which is why I hesitate to take out RHEL 7 info especially as we say add the rocky, queens, etc, repos. If we do want it Ussuri only I can do that as well
14:16:50 <amoralej> spotz, https://docs.openstack.org/ussuri/
14:16:55 <amoralej> it points to ussuri iiuc
14:16:55 <spotz> Hence asking for lazy team consensus before making changes
14:17:05 <amoralej> you can select the release
14:17:17 <spotz> https://docs.openstack.org/install-guide/ - has no release:(
14:17:32 <spotz> After your basic setup then you go back to choosing
14:17:57 <spotz> https://docs.openstack.org/install-guide/openstack-services.html
14:18:09 <spotz> Hence I'm weary of ripping older stuff out
14:19:01 <amoralej> uh
14:19:07 <amoralej> i got it now
14:19:13 <spotz> :)
14:20:00 <amoralej> i hadn't check upstream doc in some time, sorry
14:20:02 <amoralej> so, yes
14:20:10 <spotz> I'm leaning towards updating the last few release repos and pointing out differences between 7 and 8 when needed
14:20:13 <amoralej> for the common part we need to keep centos7 and add centos8 sections
14:20:17 <spotz> I live in amixed world:)
14:20:56 <spotz> And I'm gonna say repos for stein, train, and ussuri if everyone is good with it?
14:21:04 <amoralej> +1
14:21:38 <ykarel> +1
14:21:39 <spotz> Once we're cleaned up then I'll get back to Octavia install:)
14:21:59 <amoralej> i'd like to add support for octavia to packstack too
14:22:06 <amoralej> it has been in my todo list for some time
14:22:22 <amoralej> specially now that has the ovn provider which should be easier to deploy
14:22:34 <amoralej> for PoC purposes
14:22:48 <spotz> +1
14:23:02 <spotz> And I'm done, so next:)
14:23:24 <amoralej> ok, thanks spotz
14:23:40 <spotz> Happy to help and it's boring in semi-lockdown:)
14:23:56 <amoralej> :)
14:24:02 <amoralej> i understand it
14:24:08 <amoralej> let's move to next topic
14:24:10 <amoralej> #topic CentOS 8.2 is published
14:24:31 <amoralej> so CentOS team pushed 8.2 to official mirrors a couple of days ago
14:24:50 <spotz> That's what I'm using FYI:)
14:25:08 <amoralej> #info openvswitch 2.12.0 is not compatible with dpdk in 8.2 so we removed dpdk support until we can rebuild it with it
14:25:21 <rdogerrit> Yatin Karel proposed rdo-infra/puppet-dlrn master: Drop ocata and pike DLRN builders  https://review.rdoproject.org/r/28119
14:25:52 <amoralej> #info proposal to move to FastDataPath rebuilds has been made https://lists.centos.org/pipermail/centos-devel/2020-June/036996.html
14:26:17 <amoralej> also libvirt has been updated to new major release what needed some changes in puppet-nova
14:26:37 <amoralej> #info New version of libvirt in Advanced Virtualization required changes in puppet-nova
14:26:56 <amoralej> #link https://review.opendev.org/#/c/730689
14:27:14 <amoralej> and also broke some tripleo ci jobs
14:27:40 <amoralej> #info CentOS 8.2 broke some TripleO-CI jobs
14:27:57 <amoralej> #link https://bugs.launchpad.net/tripleo/+bug/1883913
14:27:58 <openstack> Launchpad bug 1883913 in tripleo "Introspection fails in OVB, bmc error: openstackbmc: struct.error: unpack requires a string argument of length 2" [Critical,Triaged]
14:28:22 <amoralej> #link https://bugs.launchpad.net/tripleo/+bug/1883692
14:28:23 <openstack> Launchpad bug 1883692 in tripleo "Error: Execution of '/usr/sbin/named-checkconf /etc/named.conf20200616-19-u0cat6' returned 1: /etc/named.conf20200616-19-u0cat6:6: '192.168.24.1/24': address/prefix length mismatch '24'" [High,In progress]
14:28:43 <amoralej> and finally, good part of 8.2
14:29:15 <amoralej> #info CentOS 8.2 introduced support for aarch64, we'll work in the missing packages as rabbitmq-server
14:29:36 <amoralej> so i hope we have consistent dependencies for aarch64 on 8.2 soon
14:29:54 <jcapitao> aarch64 was not support at all before ?
14:29:59 <amoralej> not in 8
14:30:04 <amoralej> it worked in 7
14:30:07 <amoralej> but not in 8
14:30:11 <jcapitao> okk
14:30:17 <amoralej> tbh, i'm not sure if was tested with 7
14:30:30 <amoralej> but at least we have packages needed
14:30:45 <amoralej> and i'm aware of some tests using packstack, and probably kolla
14:31:02 <amoralej> but centos 8.0 and 8.1 missed some packages we need to build rabbitmq
14:31:09 <amoralej> 8.2 finally has everything
14:31:46 <ykarel> nice
14:32:17 <ykarel> we also waiting for centos-release-advanced-virtualization, right
14:32:32 <ykarel> to avoid carrying that repo in openstack release rpm
14:32:33 <amoralej> yep
14:32:41 <amoralej> no news from it afaik
14:32:54 <ykarel> hmm needs to follow up
14:34:11 <amoralej> builds are done by danilocesar in cbs https://cbs.centos.org/koji/buildinfo?buildID=29954
14:34:16 <amoralej> that's probably the contact to follow
14:34:37 <amoralej> let's move to next topic
14:34:54 <ykarel> or <sbonazzo>
14:34:57 <amoralej> #topic Ocata/Pike DLRN builders being cleaned
14:35:13 <amoralej> yep sbonazzo has been very responsive in the past for virt sig
14:35:18 <rdogerrit> Sorin Sbarnea (zbr) proposed rdo-infra/ci-config master: Enforce use of python3 for promoter  https://review.rdoproject.org/r/28038
14:35:26 <amoralej> but not sure he's dealing with advanced virtualization now
14:35:35 <amoralej> good to ask him anyway
14:35:46 <amoralej> ykarel,  this topic is yours
14:36:07 <ykarel> yes so we finally dropping ocata/pike trunk repos
14:36:17 <rdogerrit> Chandan Kumar created rdo-jobs master: [podman] Switch to build_rpm.sh script  https://review.rdoproject.org/r/28129
14:36:20 <ykarel> #link https://lists.rdoproject.org/pipermail/dev/2020-May/009380.html
14:36:29 <ykarel> #link https://review.rdoproject.org/r/#/c/28119/
14:37:01 <ykarel> that's for this topic
14:37:10 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: Promoter: implement qcow promotion in python  https://review.rdoproject.org/r/26002
14:37:11 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: Promoter: implement containers promotion in python  https://review.rdoproject.org/r/26010
14:38:45 <amoralej> ok, nice
14:39:03 <amoralej> so, we'll remove symlinks once we merge that
14:39:19 <amoralej> and after one or two weeks we can remove the actual content
14:40:53 <amoralej> next topic
14:40:56 <amoralej> #topic Next Week's Chair
14:41:05 <amoralej> any volunteer?
14:41:41 <spotz> let me check
14:41:57 <spotz> I should be able to:)
14:42:08 * spotz lives by calendar
14:42:17 <amoralej> #action spotz to chair next meeting
14:42:21 <amoralej> thanks spotz
14:42:36 <spotz> NO problem
14:42:40 <amoralej> #topic open floor
14:42:54 <amoralej> anything else you'd like to share in this meeting?
14:44:14 <spotz> I'm good
14:44:41 <ykarel> nothing from me too
14:44:46 <amoralej> if there are no more topics i will close the meeting and give you 15 minutes back
14:44:48 <amoralej> 3..
14:44:50 <amoralej> 2..
14:44:53 <amoralej> 1..
14:45:09 <amoralej> Thank you all for joining!
14:45:10 <amoralej> #endmeeting