15:02:11 <number80> #startmeeting RDO meeting - 2018-12-12
15:02:12 <openstack> Meeting started Wed Dec 12 15:02:11 2018 UTC and is due to finish in 60 minutes.  The chair is number80. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:15 <openstack> The meeting name has been set to 'rdo_meeting___2018_12_12'
15:02:43 <number80> #topic roll call
15:02:52 <number80> agenda: https://etherpad.openstack.org/p/RDO-Meeting
15:02:57 <dciabrin> o/
15:02:58 <Vorrtex> o/
15:03:06 <amoralej> o/
15:03:20 <bandini> o/
15:03:31 <number80> #chair dciabrin Vorrtex amoralej bandini
15:03:32 <openstack> Current chairs: Vorrtex amoralej bandini dciabrin number80
15:03:53 <jpena> o/
15:03:58 <rdogerrit> Gabriele Cerami proposed config master: [WIP] Add temporary task to deal with promotion on mixed pipeline  https://review.rdoproject.org/r/17744
15:03:58 <number80> #chair jpena
15:03:59 <openstack> Current chairs: Vorrtex amoralej bandini dciabrin jpena number80
15:04:13 <number80> Anyone has heard from leanderthal?
15:04:43 * number80 suggests to start with haproxy then
15:04:55 <number80> #topic haproxy 1.8 packaging
15:05:00 <number80> dciabrin, bandini ^
15:05:02 <dciabrin> so
15:05:23 <dciabrin> centos8 will ship with haproxy 1.8, which is not compatible with how we use it in tripleo-heat-templates
15:05:41 <dciabrin> the request is to prepare  haproxy rpm ahead of time for centos
15:05:56 <dciabrin> and as a first step, have a distgit in rdo-common
15:06:08 <number80> so you need a separate repo for this one, right?
15:06:25 <dciabrin> number80, correct
15:06:35 <amoralej> wdym by separate repo?
15:06:37 <rdogerrit> Merged rdo-infra/rdo-infra-playbooks master: afs hosts: add mirror.ca-ymq-1.vexxhost-rdo host  https://review.rdoproject.org/r/17627
15:06:57 <number80> amoralej: we're not tagging it into stein
15:07:08 <number80> but rather ship it somewhere on trunk.rdoproject.org
15:07:17 <moguimar> o/
15:07:22 <number80> #chair moguimar
15:07:23 <openstack> Current chairs: Vorrtex amoralej bandini dciabrin jpena moguimar number80
15:07:23 <amoralej> but then we will break stein users in centos7
15:07:38 <dciabrin> number80, amoralej ftr I'm tracking t-h-t work for haproxy 1.8 in https://review.openstack.org/#/c/607856/
15:07:52 <amoralej> remember that we will release stein on centos7
15:07:54 <dciabrin> amoralej, no the plan is to be backward compatible with current haproxy and nex haproxy 1.8 in stein
15:08:28 <number80> amoralej: since there's no CentOS 8 yet, we will build haproxy 1.8 in CBS but not shipping it in either master or stein repositories
15:08:32 <amoralej> dciabrin, so it will work with current haproxy and with new haproxy 1.8?
15:08:38 <rdogerrit> Alex Schultz proposed rdoinfo master: Add py3 networking-{baremetal,l2gw,odl} packages  https://review.rdoproject.org/r/17743
15:08:42 <ykarel> o/
15:08:44 <dciabrin> amoralej, correct, t-h-t will handle both.
15:08:47 <bandini> amoralej: yes
15:08:47 <number80> #chair ykarel
15:08:48 <openstack> Current chairs: Vorrtex amoralej bandini dciabrin jpena moguimar number80 ykarel
15:08:59 <amoralej> could it be tested with fedora job?
15:09:16 <amoralej> instead of centos7?
15:09:18 <number80> good question
15:09:33 <bandini> i guess we could
15:09:35 <dciabrin> amoralej, number80 probably yes, granted what the containers for fedora job already include haproxy 1.8
15:09:44 <dciabrin> amoralej, i'll double check that and confirm
15:10:09 <number80> dciabrin, bandini: if you can confirm it, will it be fine to rely only on the fedora job?
15:10:18 <amoralej> i think quiquell is doing good progress with standalone jobs on fedora
15:10:29 <bandini> number80: I think so, yes. dciabrin?
15:10:44 * quiquell appears from nowhere
15:10:46 <amoralej> but i'm nost sure about the status of containers
15:10:57 <ykarel> amoralej, but containers there are centos currently
15:11:03 <ykarel> in fedora job i mean
15:11:06 <mwhahaha> i've been working on the containers
15:11:09 <amoralej> yeah, that's also my understonding
15:11:12 <mwhahaha> we're missing neutron/ironic packages
15:11:23 <mwhahaha> please see my reviews/comments on the distgits
15:11:39 <mwhahaha> we're also missing skydive, collectd and sensu stuff
15:11:45 <dciabrin> I don't know if we have other CI jobs which exercise neutron HA routers, which is the other consumer of haproxy
15:11:54 <quiquell> mwhahaha: you mean with a fedora base image ?
15:11:59 <mwhahaha> yes
15:12:03 <bandini> nice
15:12:05 <dciabrin> but yeah basically I need a job with haproxy 1.8 in container
15:12:07 <quiquell> mwhahaha: ack, anything we can do to help there ?
15:12:48 <mwhahaha> other than helping get the py3 versions of some stuff not really
15:13:02 <mwhahaha> i will need help figuring out the solution for the missing collectd/sensu packages for fedora
15:13:10 <mwhahaha> right now i've just commented them out
15:13:11 <dciabrin> number80, amoralej also, until we land https://review.openstack.org/#/c/607856/ haproxy 1.8 in fedora job won't work
15:13:18 <number80> ok
15:13:20 <mwhahaha> i'm trying to get a list together of all the missing bits
15:13:30 <amoralej> mwhahaha, i understand the py3 reviews you have sent are related to containers?
15:13:32 <ykarel> that would be good
15:13:39 <mwhahaha> amoralej: yes
15:13:43 <amoralej> ack
15:14:05 <mwhahaha> ironic-staging-drivers is the missing piece for ironic
15:14:30 <mwhahaha> there's a bunch of neutron modules missing as well but some have already been converted so i have a review out to get them into the stable base
15:14:40 <ykarel> hmm review is up, but have some issue there, can't reproduce locally ironic-staging-dreiver
15:14:51 <mwhahaha> yea need to figure that one out
15:14:59 <amoralej> that's the one with the weird issue
15:15:03 <amoralej> yeap
15:15:04 <amoralej> ok
15:15:08 <quiquell> mwhahaha: btw about container prep at fedora28 we need it there to debug python3 issues they are legit not related to py3-py2
15:15:48 <mwhahaha> quiquell: we wont' be able to do container prep on f28 until we have fedora28 containers
15:15:50 <mwhahaha> but yes
15:15:55 <mwhahaha> we need to figure out that setup tools thing
15:16:29 <amoralej> mwhahaha, you are trying to build all containers in tripleo profile or a subset of them?
15:16:50 <mwhahaha> amoralej: i've built the subset that we have packages for or that i've worked around
15:16:57 <amoralej> ok
15:17:00 <number80> Proposal: review haproxy 1.8 next week, contigency plan will be haproxy 1.8 package for EL7 in a separate channel
15:17:18 <mwhahaha> amoralej: right nwo we can't build sensu-client, skidive-*, fluentd or crane
15:17:33 <amoralej> there are patches in kolla for fedora or you have some local patches?
15:17:34 <number80> Why contigency plan? a lot of people will be out of office in 2 weeks, so let's not block upstream by waiting on F28 container progress
15:17:47 <mwhahaha> amoralej: i have a working fork of kolla at the moment
15:17:57 <amoralej> nice
15:18:00 <rdogerrit> Ronelle Landy proposed rdo-infra/ci-config master: Separate the Centos-7 and Fedora-28 promotion ini files  https://review.rdoproject.org/r/17780
15:18:19 <mwhahaha> https://github.com/mwhahaha/kolla/tree/fedora
15:18:27 * ykarel looks
15:18:46 <amoralej> ok, i see the patches
15:18:54 <ykarel> and yes from the list UcsSdk doesn't have python3 support
15:19:01 <ykarel> i filed a bug for ironic to move from it
15:19:06 <mwhahaha> nor IcmSdk
15:19:08 <mwhahaha> or whatever
15:19:09 <amoralej> there is a new sdk
15:19:22 <amoralej> ucsmsdk or something like that
15:19:44 <mwhahaha> so i'm going to spend some time today to cleanup my fork and try and come up with an exact list of what packages we're missing
15:20:04 <mwhahaha> but as of yesterday i was able to build all the tripleo containers minus the previously mentioned ones
15:20:16 <amoralej> sounds good
15:20:19 <mwhahaha> of course for some of those it just doesn't include the code so it may not be completely functional :D
15:20:44 <amoralej> mwhahaha, do you know if upstream is adding python3 support to crane?
15:20:49 <mwhahaha> I'm also working on an improvement to the tripleo code to allow us to skip some containers w/o having to hack a bunch of things , https://review.openstack.org/#/c/624532/
15:20:56 <mwhahaha> amoralej: no and we're actually not going to use it
15:20:57 <amoralej> it didn't support it some weeks ago
15:21:04 <amoralej> ok
15:21:06 <amoralej> good to know
15:21:11 <mwhahaha> stevebaker has been working on an apache only thing
15:21:18 <amoralej> ack
15:21:33 <mwhahaha> we probably should pull crane out of the tripleo stuff
15:23:20 <ykarel> this is the story for ucssdk: https://storyboard.openstack.org/#!/story/1668909
15:24:35 <number80> Let's try to focus on actions and decisions here, we can hold discussions after the meeting or on the mailing lists :)
15:24:57 <amoralej> yeap
15:25:24 <dciabrin> so I guess the bottom line is "haproxy 1.8 is coming, and we have areview in the pipe to support both old and new haproxy"
15:25:38 <amoralej> wrt haproxy, it'd be nice if we could leave centos7 as-is and  use fedora to test 1.8
15:25:52 <amoralej> i'm not sure how fare we are of being able to use fedora for that
15:25:58 <amoralej> s/fare/far/
15:26:05 <number80> Yep, that's why I suggest to revisit the situation next week
15:26:18 <amoralej> yes, i think that's the best option
15:26:23 <dciabrin> as to how we should test it, if f28 job can provide a container with haproxy 1.8 that's fine with me
15:26:28 <number80> Nobody opposes?
15:26:31 <dciabrin> agreed
15:26:44 <amoralej> in case we rebuild 1.8 for ci only we should keep jobs with old and new ones
15:26:48 <number80> #agreed revisit haproxy 1.8 situation next week
15:27:14 <number80> I can also provide temporary //-installable haproxy if that helps
15:27:20 <rdogerrit> Merged rdoinfo master: Add py3 networking-{baremetal,l2gw,odl} packages  https://review.rdoproject.org/r/17743
15:27:41 <number80> but next week
15:28:02 <number80> #topic What to do with upcoming meetings
15:28:24 <number80> Next meetings are: december, 19 - december, 26 - January 2
15:28:41 <number80> My proposal will be to cancel december, 26 and January, 2
15:28:48 <amoralej> +1
15:29:11 <rdogerrit> Lee Yarwood proposed rdoinfo master: Add puppet-placement package  https://review.rdoproject.org/r/17206
15:29:28 <number80> Nobody against it?
15:29:57 <number80> #agree Cancelling december, 26 and January, 2 RDO meeting
15:30:04 <ykarel> i will be available those days, so for any issue, query ping me :)
15:30:05 <number80> #agreed Cancelling december, 26 and January, 2 RDO meetings
15:30:31 <jpena> +1 to cancelling both, I won't be around :)
15:30:38 <number80> ack
15:31:25 <number80> ykarel: just make sure that you get management approval (for non-redhatters, we have RH annual shutdown in this period)
15:31:26 <rdogerrit> Merged openstack/cloudkitty-distgit rpm-master: Add influxdb dependency  https://review.rdoproject.org/r/17762
15:31:47 <number80> Then, hop on the next topic
15:32:11 <number80> #action number80 Notify the list about meetings cancelled
15:32:17 <number80> #topic FOSDEM and DevConf.CZ booths and swag
15:32:52 <number80> leanderthal is not around, so in short: we need volunteers for FOSDEM and devconf.cz to hold the openstack/RDO booths there
15:33:18 <number80> So if you're around and willing, just sign up in the etherpad
15:33:31 <number80> Other very important topic, submit ideas for swags and goodies
15:34:03 <number80> (we'll likely have scarves already)
15:34:23 <number80> #info we need volunteers for openstack and RDO booths at FOSDEM/devconf.cz
15:34:32 <number80> #info submit ideas for RDO goodies to leanderthal
15:34:58 <number80> Anyway, I'll talk with Rain when I'm back from PTO, so I'll make sure she gets the message
15:35:02 <number80> Next then
15:35:14 <number80> #topic next meeting chair
15:35:22 <number80> who wants the iron chair?
15:36:39 <number80> No volunteers? I'll do it
15:36:52 <number80> #action number80 to chair next week
15:36:59 <number80> #topic open floor
15:37:07 <number80> You last chance to bring a new topic
15:37:21 <Vorrtex> Hey all!  Adam Kimball couldn't be here but he asked me to bring information to you guys and a request.
15:37:29 <number80> Sure
15:37:30 <Vorrtex> Tempest containers are breaking because python2-octavia-tests-tempest-golang is missing from the delorean repos, but was there before the 7.6 release.  Its a noarch package that already works with ppc64le, but needs to be put back.
15:38:10 <number80> I think someone is working on that
15:38:33 <number80> ykarel: do you remember who?
15:38:37 <amoralej> mmmm
15:38:52 <amoralej> we added it, but not sure why it was lost
15:38:57 <amoralej> let me remember
15:39:30 <number80> amoralej: you take that action?
15:39:38 <amoralej> ok
15:39:46 <number80> Thanks :)
15:39:47 <ykarel> from where it lost?
15:40:09 * number80 will be on PTO from tomorrow to monday
15:40:17 * ykarel noted
15:40:38 <Vorrtex> Thanks!  I'll let him know
15:40:54 <amoralej> Vorrtex, i see it in https://trunk.rdoproject.org/centos7-master/deps/latest/ppc64le/python-octavia-tests-golang-0.1.0-1.el7.ppc64le.rpm
15:41:21 <amoralej> where is it missing, sorry i'm lost
15:41:56 <Vorrtex> He said its missing from the delorean repos?  Sorry, I'm not all that familiar with all the process around packaging and such.
15:42:12 <amoralej> but for ppc64le?
15:42:19 <amoralej> or what's failing?
15:42:37 <ykarel> amoralej, it seems python2- vs python-
15:42:45 <ykarel> from Vorrtex original message
15:42:56 <amoralej> but i think nothing has changed on that
15:43:03 <amoralej> that's what i'm missing
15:43:07 <ykarel> in tempest we ported to python2 only for centos
15:43:13 <ykarel> so there it requires python2-
15:43:23 <ykarel> and pp6 is python- one
15:43:28 <amoralej> oook
15:43:38 <amoralej> so problem is that we changed the requires to python2-
15:43:46 <amoralej> so we broke it in ppc64le
15:43:52 <ykarel> yup
15:43:56 <Duck> quack
15:44:10 <amoralej> we should add a provides to python2 in the build for ppc
15:44:23 <ykarel> +1
15:45:03 <amoralej> spec is https://github.com/rdo-common/python-octavia-tests-golang/blob/master/python-octavia-tests-golang.spec
15:45:12 <amoralej> i'll rebuild and send a patch to push new build
15:45:15 <amoralej> Vorrtex, ^
15:45:25 <Vorrtex> Thanks amoralej !  I'm writing the email response right now, much appreciated!
15:45:32 <amoralej> but for the record, it's unrelated to 7.6 :)
15:45:52 <Vorrtex> I'll let him know!  Sorry about that, was basically copy-pasting from an email!
15:47:06 <Vorrtex> That's all I got, much appreciated guys.
15:49:37 <amoralej> jpena, ykarel please review https://github.com/rdo-common/python-octavia-tests-golang/commit/74581da216bbf19e9894341da8aafa97d23edcf8
15:49:40 <rdogerrit> Alex Schultz proposed openstack/networking-bgpvpn-distgit rpm-master: Create python2/python3 package depending on distro  https://review.rdoproject.org/r/17771
15:50:30 <ykarel> amoralej, Provides: python2-octavia-tests-golang = %{version}-%{release} also needed?
15:50:40 <amoralej> just in case
15:51:01 <ykarel> ack
15:51:25 <ykarel> +1
15:52:26 <number80> Ok, let's close the meeting then
15:52:31 <Duck> nooooooooo
15:52:49 <number80> next week :)
15:52:49 <Duck> I'm waiting for news about the ML migration, but I've got no reply
15:53:19 <amoralej> jpena, ykarel i've just rechecked all FTBFS in fedora
15:53:25 <ykarel> amoralej, ack
15:54:09 <Duck> it would be better to do it soon, because after X-mas & co there is not much time before FOSDEM & co
15:54:19 <Duck> and then it means not before March at best
15:55:22 <number80> OK
15:55:38 <number80> nothing else?
15:58:25 <Duck> no Sir
16:00:16 <number80> #endmeeting