15:01:56 <amoralej> #startmeeting RDO meeting - 2018-11-07
15:01:57 <openstack> Meeting started Wed Nov  7 15:01:56 2018 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:00 <openstack> The meeting name has been set to 'rdo_meeting___2018_11_07'
15:02:19 <amoralej> #topic roll call
15:02:46 <PagliaccisCloud> \o
15:03:11 <jpena> o/
15:03:52 <amoralej> #chair PagliaccisCloud jpena
15:03:53 <openstack> Current chairs: PagliaccisCloud amoralej jpena
15:03:58 <amoralej> gfidente are you around?
15:04:06 <amoralej> there is a topic for you
15:05:07 <gfidente> amoralej hey
15:05:28 <amoralej> #chair gfidente
15:05:29 <openstack> Current chairs: PagliaccisCloud amoralej gfidente jpena
15:05:36 <amoralej> let's wait a couple more minutes
15:07:42 <baha> o/
15:09:51 <amoralej> #chair baha
15:09:52 <openstack> Current chairs: PagliaccisCloud amoralej baha gfidente jpena
15:09:59 <amoralej> apevec, are you around?
15:10:45 <mjturek> o/
15:11:12 <amoralej> #chair mjturek
15:11:13 <openstack> Current chairs: PagliaccisCloud amoralej baha gfidente jpena mjturek
15:11:19 <amoralej> so let's start with first topic
15:11:49 <amoralej> #topic [CentOS-devel] SIGs: Possibility to drop EOL content at 7.6.1810 release time
15:12:00 <amoralej> #info ceph-jewel requires by Ocata and Pike, but Ceph Jewel is EOLed upstream
15:12:45 <amoralej> gfidente, so the point is what to do with ceph-jewel
15:13:23 <amoralej> iiuc, it's not supported upstream
15:13:29 <amoralej> but we need it for ocata and pike
15:13:36 <gfidente> amoralej and newton even
15:13:41 <amoralej> newton is eol
15:13:52 <amoralej> it's not longer available in RDO
15:14:33 <amoralej> so the options are move ocata and pike to luminous
15:14:41 <amoralej> or maintain jewel in RDO
15:15:00 <amoralej> the problem is what to do if there is any critical bug or security issue in jewel
15:16:00 <gfidente> and we can't really move ocata and pike to luminous because tripleo won't be able to deploy it, luminous introduced a new ceph-mgr
15:16:29 <gfidente> amoralej so if I understood correctly the options are
15:16:31 <amoralej> gfidente, jewel branch in ceph is closed?
15:18:25 <gfidente> amoralej jewel should remain supported by ceph until the next two LTS are published, which means Luminous and Nautilus
15:18:32 <gfidente> Nautilus is not out yet
15:19:20 <apevec> amoralej, I'm on a call
15:19:36 <amoralej> then, why apevec mentioned "ceph jewel is EOLed upstream"?
15:19:42 <apevec> gfidente, so jewel EOL mentioned on centos-devel is not correct?
15:19:55 <apevec> amoralej, I'm just a messanger...
15:20:13 <amoralej> yeah apevec, i was not finger pointing, :)
15:20:14 <gfidente> well it was supposedly after 18 months from release
15:20:20 <gfidente> hence june 2018
15:20:33 <gfidente> but nautilus is going out a bit later so jewel is still not EOL
15:20:49 <apevec> gfidente, ok, please clarify that on centos-devel list
15:20:52 <amoralej> what's expected GA for nautilus?
15:21:06 <gfidente> http://docs.ceph.com/docs/mimic/releases/schedule/
15:22:27 <gfidente> 9 months after mimic, which did go out on june
15:22:33 <amoralej> gfidente, "For example, Luminous (12.2.z) will reach end of life (EOL) shortly after Nautilus (14.2.0) is released"
15:22:43 <gfidente> amoralej exactly
15:22:58 <gfidente> and each release takes 9 months
15:23:04 <amoralej> that's luminous, not jewel
15:23:27 <amoralej> sorry, still reading
15:23:29 <amoralej> it's lts
15:23:34 <gfidente> so nautilus should be apr 2019
15:23:41 <gfidente> amoralej lts, exactly, so every two lts
15:23:52 <amoralej> but it says
15:23:53 <amoralej> Jewel will be maintained until Mimic is released in the spring of 2018.
15:23:56 <amoralej> it's confusing
15:24:04 <gfidente> amoralej because until jewel, lts was every 2 stable
15:24:21 <gfidente> amoralej from luminous this changes into no-lts, every stable only lasts 2 releases
15:24:36 <amoralej> ok, so if jewel is still supported, we are good
15:24:46 <amoralej> just, please clarify it in the mailing list
15:25:05 <amoralej> pike EOL is suposed to be in 2019-03-03
15:25:12 <gfidente> amoralej so until jewel, it would have lasted until next two lts were out (aka, 6*3 = 18 months)
15:25:19 <amoralej> which is not too far away
15:25:26 <gfidente> amoralej from luminous every stable is lts, but releae is 9 months
15:25:37 <amoralej> ok
15:25:40 <gfidente> amoralej so from luminous it is 2*9 = 18months
15:25:54 <gfidente> (still 18, but for a different reason, yes)
15:26:11 <amoralej> what is clear is that jewel has no "Actual retirement" date yet in http://docs.ceph.com/docs/mimic/releases/schedule/
15:26:20 <apevec> gfidente, amoralej - centos-devel thread https://lists.centos.org/pipermail/centos-devel/2018-November/017025.html
15:26:25 <amoralej> so as you said
15:26:29 <amoralej> seems supported
15:26:29 <gfidente> and no EOL tag
15:26:30 <apevec> (sorry I'm not following, will read minutes)
15:26:51 <amoralej> apevec, short version, jewel is still supported
15:27:13 <apevec> ok please clarify that in ^ thread
15:28:18 <amoralej> gfidente, for my education, where can i see EOL tags?
15:30:34 <gfidente> amoralej next to the release name, the table headings
15:30:50 <amoralej> ah, ok
15:30:50 <gfidente> and thanks a lot for helping !
15:31:00 <amoralej> i was looking for EOL git tags :)
15:31:26 <amoralej> #info jewel is not EOLed yet so it will be included in CentOS 7.6
15:31:54 <amoralej> #action gfidente to send a mail to centos-devel existing thread about the topic
15:32:03 <amoralej> #link http://docs.ceph.com/docs/mimic/releases/schedule/
15:32:09 <amoralej> gfidente, ^ are you ok with this?
15:32:12 <gfidente> amoralej yes!
15:32:16 <gfidente> thanks!
15:32:49 <amoralej> so, there are no more topics in the agenda
15:32:53 <amoralej> let's move to open floor
15:33:00 <amoralej> well, first
15:33:06 <amoralej> #topic chair next week
15:33:15 <amoralej> any volunteer?
15:33:23 <mjturek> I can handle
15:34:21 <amoralej> #action mjturek to chair next week
15:34:26 <amoralej> thanks mjturek
15:34:34 <amoralej> #topic open floor
15:34:38 <mjturek> np
15:35:01 <amoralej> does anyone have something to bring?
15:35:11 <baha> mjturek and I do!
15:35:31 <amoralej> ok
15:35:48 <PagliaccisCloud> i do: I haven't heard back from anyone about the contributor workshop for red hat summit 2019 :(
15:35:51 <mjturek> yeah we're not sure what could be done here, but we ran into a package in containers builds that won't hit centos ppc64le opstools for about a month
15:36:11 <baha> It's provided by epel, and works just fine there, but they're currently in repo freeze.
15:36:12 <mjturek> rubygem(ffi)
15:36:35 <amoralej> PagliaccisCloud, let's start with mjturek point if it's ok for you
15:36:48 <PagliaccisCloud> oh i'm sorry, ok
15:37:06 <amoralej> mrunge, ^ about rubygem package
15:37:13 <mjturek> he's aware
15:37:30 <baha> He's marked it already I believe, but the opstools repos are in freeze for a month or so.
15:37:48 <mjturek> would including it in delorean deps or something be out of line?
15:38:13 <amoralej> i see the package in https://cbs.centos.org/koji/buildinfo?buildID=18834
15:38:16 <amoralej> properly tagged
15:38:17 <amoralej> mmm
15:38:31 <mjturek> right but with the repo freeze baha mentioned
15:38:33 <amoralej> adding it to deps repo will fail
15:38:40 <amoralej> because of missing deps
15:38:49 <amoralej> it will not pass ci to add it formally
15:38:57 <mjturek> hmmm okay
15:38:57 <amoralej> that's just for master?
15:39:03 <amoralej> or rocky too?
15:39:22 <mjturek> I think all supported releases
15:39:41 <mjturek> as the sensu container is built for all of them if my understanding is right
15:39:45 <amoralej> blocks all jobs? or only certain Featuresets?
15:39:57 <amoralej> i mean, could you disable sensu container?
15:40:24 <mjturek> that I'm not sure about. Is there a way to blacklist containers in the build job
15:40:26 <mjturek> ?
15:40:49 <baha> That would be a valid workaround until opstools comes out of freeze, if it exists
15:41:02 <mjturek> +1
15:41:28 <amoralej> i think that'd be best option until then
15:41:52 <mjturek> we'll look into that
15:41:58 <mjturek> thanks!
15:41:58 <baha> Do you know if it's something the current build system actually supports, though?
15:42:13 <amoralej> i'm not sure
15:42:26 <amoralej> there is the concept of profiles, iirc
15:42:42 <amoralej> you could create a new profile with all the containers in the tripleo one but sensu
15:42:56 <mjturek> baha was working towards that awhile back
15:43:07 <mjturek> but stopped when it looked like  we were going to get all the builds working
15:43:42 <baha> That's true! And the workaround to replace the profile was somewhat hacked together. It's probably okay to do it while we waiting on the package to sync over though.
15:43:45 <amoralej> do you know why opstools repo is disabled?
15:43:51 <amoralej> frozen, i mean
15:44:02 <baha> I believe they're gearing up for a release cycle, and will unfreeze afterward
15:44:12 <mjturek> not sure there :-\
15:45:13 <amoralej> mjturek, baha other option would be to use https://buildlogs.centos.org/centos/7/opstools/ppc64le/common/
15:45:19 <amoralej> i see rubygem-ffi there
15:45:24 <amoralej> that's -testing repo
15:45:57 <amoralej> i'm not sure if you enable repos manually or tripleo does it
15:45:58 <mjturek> amoralej right, I guess we're just not sure how to enable a repo in all containers
15:46:02 <amoralej> but if you can add that
15:46:11 <baha> Would it be preferred that we use testing over using epel, if we start changing repository configurations?
15:46:17 <amoralej> yes
15:46:34 <amoralej> -testing should be better that -epel
15:47:20 <amoralej> so, i think you have two options to test :)
15:47:34 <mjturek> yeaaah we'll play around with those
15:47:39 <baha> thanks amoralej!
15:48:04 <amoralej> ok
15:48:29 <amoralej> PagliaccisCloud, wrt the contributor workshop
15:48:59 <amoralej> i think the action was to discuss with leanthertal?
15:49:24 <PagliaccisCloud> Yeah but she's OoO :/
15:49:26 <PagliaccisCloud> Rich, too
15:50:18 <PagliaccisCloud> Just in case I can't get ahold of them before CFP closes, would anyone else be willing to team up?
15:50:41 <PagliaccisCloud> email me - tribecca [at] tribecc [dot] us
15:50:49 <amoralej> i like the idea
15:50:54 <amoralej> a lot
15:51:02 <amoralej> not sure about my availability
15:51:11 <amoralej> i'll check and let you know
15:51:22 <PagliaccisCloud> ok, i appreciate it amoralej
15:53:08 <amoralej> anything else?
15:53:22 <amoralej> otherwise i'll close and give you some minutes back
15:54:47 <amoralej> #endmeeting