15:01:03 <amoralej> #startmeeting RDO meeting - 2018-07-04
15:01:04 <openstack> Meeting started Wed Jul  4 15:01:03 2018 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:07 <openstack> The meeting name has been set to 'rdo_meeting___2018_07_04'
15:01:17 <amoralej> #topic roll call
15:01:23 <leanderthal> o/
15:01:30 <leanderthal> PagliaccisCloud, are you here as well?
15:01:33 <number80> o/
15:02:24 <amoralej> #chair leanderthal number80
15:02:24 <openstack> Current chairs: amoralej leanderthal number80
15:02:41 <ykarel> o/
15:03:19 <amoralej> #chair ykarel
15:03:20 <openstack> Current chairs: amoralej leanderthal number80 ykarel
15:03:33 <jpena> o/
15:04:05 <amoralej> #chair jpena
15:04:07 <openstack> Current chairs: amoralej jpena leanderthal number80 ykarel
15:04:49 <amoralej> let's start with first topic
15:05:08 <amoralej> #topic proposal to move RDO distgit repos to openstack/rdo-*
15:05:20 <amoralej> #info https://lists.rdoproject.org/pipermail/dev/2018-July/008806.html
15:05:29 <amoralej> pabelanger, ^ i think this comes from you
15:06:23 <amoralej> we can change order if pabelanger is not around
15:06:41 <leanderthal> i'm fine with going now
15:06:45 <amoralej> #undo
15:06:46 <openstack> Removing item from minutes: #info https://lists.rdoproject.org/pipermail/dev/2018-July/008806.html
15:06:50 <amoralej> #undo
15:06:51 <openstack> Removing item from minutes: #topic proposal to move RDO distgit repos to openstack/rdo-*
15:07:02 <amoralej> #topic Happy Birthday, OpenStack! 17 July livestream with PagliaccisCloud
15:07:11 <amoralej> #info https://www.rdoproject.org/newsletter/2018/july/#events
15:07:20 <amoralej> #info     mini virtual birthday party planning seession TOMORROW 05 July at 1400 UTC https://bluejeans.com/6709832932/
15:07:26 <leanderthal> this month is openstack's 8th birthday and there are events all over the world.
15:07:27 <amoralej> all yours leanderthal
15:07:54 <leanderthal> i'm going to throw a mini birthday planning session to discuss things we could do remotely TOMORROW at 1400 UTC on my bluejeans channel
15:08:12 <pabelanger> amoralej: yes
15:08:16 <leanderthal> and then PagliaccisCloud is involved with a school that uses packstack and she'd love it if we joined their celebration on the 17th
15:08:21 <leanderthal> it's a streaming thing.
15:09:04 <leanderthal> really, every month is openstack month in our world, so this is actually just an excuse to eat cake.
15:09:15 <misc> cake as a service
15:09:16 <amoralej> :)
15:09:25 <amoralej> sounds cool leanderthal
15:09:26 <leanderthal> and to take a pause to realize how freaking long / short of a time it's been. EIGHT
15:09:48 <leanderthal> if you're keen, email / message me or just join the bjn session tomorrow
15:10:31 <leanderthal> any questions?
15:10:37 <leanderthal> CaaS sounds AWESOME misc
15:10:52 <leanderthal> i hope so, amoralej - i just want icing^Wcake
15:11:48 <jpena> as long as there's chocolate, you can count on me
15:11:58 <ykarel> hmm it conflicts with Container as a Service :)
15:12:03 <leanderthal> damnit
15:12:10 <leanderthal> chocolate is always a plus plus jpena
15:12:33 <sfbender> Jakub Ružička created distroinfo master: WIP: core: packages and releases inheritance  https://softwarefactory-project.io/r/12882
15:12:38 <leanderthal> Cake as a Service is infinitely cooler.... we'll have to find a compromise.
15:12:52 <amoralej> we'll ask containers guys to change it, cakes are more important that containers
15:12:59 <ykarel> :)
15:12:59 <leanderthal> EXACTLY
15:13:19 <amoralej> ask kids, they are always right
15:13:24 <leanderthal> true story.
15:13:41 <amoralej> ok, let's move to next topic
15:13:42 <leanderthal> but that's about it for that; i'm going to write up a blog post tomorrow after the 1400 meeting with more details
15:14:12 <amoralej> ok
15:14:29 <amoralej> #topic zuulv3 migration update
15:14:34 <amoralej> pabelanger, stage is yours
15:15:00 <pabelanger> yes
15:15:13 <pabelanger> so we are really close to being done with the migration to zuulv3
15:15:37 <pabelanger> I'd like to land https://review.rdoproject.org/r/14612/ this morning and monitor
15:15:51 <pabelanger> but once working, we'll move the last jobs (promotion) to zuulv3
15:15:57 <pabelanger> then we can be done and have cake
15:16:28 <number80> yum
15:16:31 <pabelanger> we've had a few scale issues of the last week, but thanks to tristanC and SF team, we have more servers online
15:16:39 <leanderthal> so many reasons to celebrate!
15:17:09 <misc> "we have cake, so let's celebrate that with cake"
15:17:25 <pabelanger> that's really all I had on zuulv3, unless some questions
15:17:48 <chkumar|ruck> put the cake receipe seperate and let's openstack services make the cake
15:17:49 <ykarel> pabelanger, there needs to be some cleanup right, i see some duplication in playbooks?
15:18:07 <pabelanger> ykarel: yes, once migration finishes, people are free to start cleanup the legacy playbooks
15:18:15 <pabelanger> there is duplication because of zuul-migrate process
15:18:25 <ykarel> pabelanger, ack okk
15:18:41 <amoralej> pabelanger, i've noticed that oooq jobs in rdoinfo gate takes longer in queue in v3, i understand that's becaus we still have few resources for tripleo jobs in v3, right?
15:18:47 <amoralej> until all are migrated
15:19:11 <pabelanger> yes, we still have a slipped nodepool capacity, so we are not at 100% of nodes
15:19:16 <amoralej> ok
15:19:35 <pabelanger> that is last step after tripleo-ci is moved, re org everything in nodepool to make it more efficient
15:19:45 <amoralej> ack
15:19:55 <amoralej> any other question about migration to zuul v3?
15:20:52 <number80> I think we're good
15:20:56 <amoralej> ok
15:21:11 <amoralej> #topic proposal to move RDO distgit repos to openstack/rdo-*
15:21:20 <amoralej> #info https://lists.rdoproject.org/pipermail/dev/2018-July/008806.html
15:21:23 <pabelanger> this one is me too
15:21:27 <amoralej> yeah
15:22:28 <pabelanger> so during the zuulv3 migration, I noticed that our distgit jobs could be pushed upstream into git.openstack.org. I wanted to maybe start the topic and see what the pros / cons are, I know apevec has already replied but would be interested in others
15:23:05 <pabelanger> the main reason I can see, is to get access to a multi cloud testing environment to avoid outages when we have issues with rdocloud
15:23:06 <amoralej> pabelanger, what's the expected pros?
15:23:24 <amoralej> you just replied :)
15:23:25 <pabelanger> plus I think there would be more collaboration with openstack people, since a single gerrit
15:24:21 <amoralej> pabelanger, distgit require different ACLs per distgit. Does it implies a separated repo as we have today in review.r.o?
15:24:40 <pabelanger> I think it comes down to, do we in rdo want to be the only ones responsible for this infra or can we work together upstream and share some of that load
15:25:16 <pabelanger> amoralej: yes, we should have the same functionality in upstream gerrit as gerrit in review.r.o
15:25:21 <number80> I'm personally fine with that
15:25:22 <pabelanger> per project ACLs for example
15:25:31 <number80> yes
15:25:58 <amoralej> may it conflict with rpm-packaging project somehow?
15:26:04 <number80> we don't want people for project A to mingle with project B repo
15:26:17 <number80> amoralej: that's one of the concerns raised when rpm-packaging was created
15:26:18 <amoralej> yeah, that's a requirement
15:26:24 <pabelanger> amoralej: I think it needs a discussion upstream, but I wanted to gauge here first
15:26:29 <amoralej> ok
15:26:30 <pabelanger> but I think they can both live
15:26:45 <number80> Absolutely
15:26:59 <pabelanger> I mean they do today, just on different code review systems
15:27:10 <pabelanger> we're just asking to merge them into a single
15:27:38 <amoralej> pabelanger, could we have depends-on in projects in review.r.o as rdoinfo for reviews in review.o.o?
15:27:46 <jpena> would rdoinfo move as well? There's an awful lot of automation related to it
15:27:54 <pabelanger> okay, I just wanted to start the topic but seems like people don't have a negative reaction so far.
15:27:58 <amoralej> i'm assuming rdoinfo would stay
15:28:02 <pabelanger> amoralej: jpena: yes, depends-on works
15:28:08 <pabelanger> yah, rdoinfo could stay for now
15:28:24 <pabelanger> that is a black box to me, and I don't know all the moving parts right now
15:28:26 <jpena> I'm concerned about political questions being raised about having RDO stuff in upstream infra, but I'm not against it
15:28:27 <rdogerrit> Merged config master: Move some tripleo-ci jobs to zuulv3  https://review.rdoproject.org/r/14612
15:28:38 <Duck> quack
15:28:51 <pabelanger> jpena: we've done it before with debian, so I don't think it is a large issue these days
15:29:00 <pabelanger> but agree, it is something that needs to be discussed
15:29:10 <amoralej> #chair Duck
15:29:11 <openstack> Current chairs: Duck amoralej jpena leanderthal number80 ykarel
15:29:33 <amoralej> i'm not against, similar political concernts
15:29:41 <pabelanger> to me, as long as RDO is the 4 opens, I don't see why it couldn't move to git.o.o
15:29:45 <amoralej> and just to make sure pros as worthy for the effort
15:29:57 <pabelanger> ack
15:30:35 <number80> pabelanger: RDO is supposed to follow the same rules as upstream concerning distribution and collaboration so no issues
15:30:43 <pabelanger> ++
15:31:33 <amoralej> it'd be good to start documenting requirements and side effects in a etherpad
15:31:58 <pabelanger> sure, I can start that. But will need some help
15:32:01 <amoralej> sure
15:32:05 <pabelanger> I'll reply to ML with etherpad link
15:32:39 <pabelanger> but now that we are using zuulv3 here in RDO, the migration upstream should be much easier.  But lets discuss pros / cons first
15:32:50 <pabelanger> that's all I had
15:33:40 <amoralej> pabelanger, i understand there are no limitations in terms of branches, etc...
15:33:42 <amoralej> right?
15:34:13 <amoralej> we can use them as we need
15:34:21 <pabelanger> amoralej: yes, should be okay to create per project branches as needed
15:34:35 <pabelanger> there is tooling upstream to automate it, which is controlled via the openstack-releases team
15:34:49 <pabelanger> but only need to use that if official project
15:35:06 <pabelanger> there is docs around that depending on the project release tag
15:35:15 <pabelanger> I don't see rdo distgit using that howerver
15:35:16 <number80> We can work with them if needed to adapt tooling I guess
15:35:17 <amoralej> yeah, i guess that wouldn't be the case for these repos
15:35:17 <pabelanger> however*
15:35:22 <pabelanger> yah
15:35:29 <pabelanger> it could, but not requirement
15:36:07 <tahini> Hi, I need some help with my openstack install:
15:36:14 <tahini> I installed using packstack on a 1 machine setup (it's a test setup to try it out), using the instructions here: https://www.rdoproject.org/networking/neutron-with-existing-external-network/
15:36:19 <amoralej> #action everyone continue discussion in https://lists.rdoproject.org/pipermail/dev/2018-July/008806.html
15:36:24 <tahini> It worked fine, I could access the network, etc, reboot the machine, openstack went back up, no problem
15:36:37 <tahini> Then I took a week vacation... started the machine again, the external bridge gets a dhcp address, but... no more network access, no ping, no contact with external ip, cannot ssh to the machine or anything
15:36:49 <amoralej> #action pabelanger to create a etherpad to write about distgit movement
15:37:10 <amoralej> tahini, we are in weekly meeting. would you mind to wait for a while?
15:37:23 <amoralej> it will finish in around 20 mins
15:37:45 <tahini> amoralej, no problem, sorry for interrupting the meeting
15:37:51 <amoralej> no problem
15:38:18 <amoralej> ok, i think we can continue the discussion in the mailing list
15:38:27 <amoralej> unless someone has something to add
15:38:28 <sshnaidm|afk> pabelanger, hi, when is it planned to move periodic jobs?
15:38:45 <rdogerrit> Javier Peña proposed rdo-infra/rdo-infra-playbooks master: WIP: Cleanup post-merge of rdo-container-registry  https://review.rdoproject.org/r/14488
15:38:52 <pabelanger> sshnaidm|rover: this afternoon hopefully
15:39:19 <pabelanger> amoralej: +1
15:39:29 <amoralej> ok
15:39:38 <amoralej> #topic next week's chair
15:39:49 <amoralej> who wants to chair next week?
15:40:26 <ykarel> i can take it
15:40:35 <leanderthal> i can do it the week after
15:40:39 <amoralej> #action ykarel will chair next week
15:40:47 <leanderthal> the 18th
15:41:13 <amoralej> #action leanderthal will chair on july the 18th
15:41:28 <amoralej> #topic open floor
15:42:08 <amoralej> any other topic you want to raise?
15:42:44 <amoralej> we have python3 packages for glance and keystone in fedora \o/
15:42:56 <amoralej> and thanks to ykarel we almost have a p-o-i scenario testing it
15:42:56 <jpena> \o/
15:43:05 <leanderthal> \o/
15:44:25 <amoralej> https://review.openstack.org/#/c/579126/ if you want to see it with your own eyes :)
15:44:38 <amoralej> anything else?
15:44:47 <amoralej> otherwise i'll give you 15minutes back
15:45:32 <leanderthal> NICE!
15:45:38 <amoralej> 3
15:45:39 <amoralej> 2
15:45:41 <amoralej> 1
15:45:44 <amoralej> #endmeeting