15:01:19 <amoralej> #startmeeting RDO meeting - 2018-02-07
15:01:20 <openstack> Meeting started Wed Feb  7 15:01:19 2018 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:24 <openstack> The meeting name has been set to 'rdo_meeting___2018_02_07'
15:01:29 <amoralej> #topic roll call
15:01:57 <ykarel> o/
15:02:18 <jpena> o/
15:02:25 <number80> o/
15:02:25 <rbowen> o/
15:02:31 <baha> o/
15:02:32 <mary_grace> o/
15:03:09 <amoralej> #chair ykarel jpena number80 rbowen baha mary_grace
15:03:10 <openstack> Current chairs: amoralej baha jpena mary_grace number80 rbowen ykarel
15:03:46 <rbowen> rohityadav: ping. The meeting is starting. Are yo uhere?
15:03:57 <rohityadav> @rbowen o/ yes
15:04:01 <rohityadav> Hi, I'm Rohit Yadav from the Apache CloudStack project. I reached out to Rich Bowen (@rbowen) and was introduced to Haikel (@number80) to advise on getting CloudStack rpms to CentOS and possible other distributions (Debian, Fedora, Ubuntu etc). I wanted to introduce myself here, and seek advise.
15:04:04 <rbowen> Awesome. I added you to the agenda.
15:04:05 <amoralej> #chair rohityadav
15:04:05 <openstack> Current chairs: amoralej baha jpena mary_grace number80 rbowen rohityadav ykarel
15:04:19 <number80> rohityadav: you're welcome, very happy to have you around :)
15:04:30 <jruzicka> o/
15:04:34 <number80> #chair jruzicka
15:04:34 <openstack> Current chairs: amoralej baha jpena jruzicka mary_grace number80 rbowen rohityadav ykarel
15:04:37 <rohityadav> thanks @rbowen and @number80, and others
15:04:50 <rbowen> Sorry, didn't mean to go out of order for the agenda. Just wanted to make sure you were here. :-)
15:05:10 <amoralej> let's start with first topic
15:05:20 <amoralej> #topic ppc64le status
15:05:31 <chandankumar> \o/
15:05:40 <amoralej> #inf Missing packages: https://lists.rdoproject.org/pipermail/dev/2018-February/008537.html (should be fixed now)
15:05:44 <amoralej> #info Missing packages: https://lists.rdoproject.org/pipermail/dev/2018-February/008537.html (should be fixed now)
15:05:52 <amoralej> number80, is this yours?
15:05:59 <number80> mjturek mentioned that he had missing packages for him to move forward, so I tagged one and rebuilt one
15:06:13 <number80> should not impact other architectures
15:06:24 <number80> if mjturek has anything else to add ^
15:06:37 <amoralej> ok, cool, so everything should be ok in ppc64le now, right?
15:06:46 <number80> And I think him for providing excellent feedback
15:06:52 <number80> s/think/thank/
15:07:10 <number80> amoralej: AFAIK, yes
15:07:39 <amoralej> nice
15:07:41 <mjturek> sorry was afk
15:07:51 <number80> oh, you're right on time :)
15:08:05 <number80> do you want to share status or anything?
15:08:12 <mjturek> :) awesome news from Haikel
15:08:47 <mjturek> number80 nothing at the moment, I've been looking into using weirdo but no jumps in progress this week
15:08:59 <number80> mjturek: keep us notified then
15:09:02 <mjturek> the build seems pretty darn complete though which is really exciting
15:09:05 <mjturek> will do
15:09:06 <number80> amoralej: I think we're good
15:09:12 <amoralej> let's move on
15:09:31 <amoralej> #topic python3 proposal: stabilized fedora for OpenStack
15:09:42 <number80> Big topic so let's keep it short
15:10:26 <number80> In the rational, you can see that we are in a tough spot to test OpenStack python3 until EL8
15:10:54 <number80> rebuilding python3 on EL7 is a lot of work, and Fedora is too fast-moving
15:11:16 <number80> so I suggest a middle ground: using our stabilized mirrors of Fedora
15:11:53 <dmsimard> So we're going back to Liberty days and building everything for Fedora again ?
15:11:56 <number80> The nice thing is that we will be able to leverage CI to validate updates and be able to have our own overrides when needed
15:11:59 <dmsimard> (Trying to find a comparison point)
15:12:21 <number80> dmsimard: in a sense yes
15:12:37 <dmsimard> That is going to put quite a dent in our CI capacity :(
15:12:38 <number80> but it will not be supported for end-users, this is a CI-only thing
15:12:57 <dmsimard> And wasn't accounted for when planning budget so it should be fun
15:13:09 <amoralej> number80, what "stabilized mirros of fedora" means?
15:13:12 <number80> I agree, but this is the most sensible option we have
15:13:29 <number80> amoralej: we will mirror Fedora and block refreshing it if it fails CI
15:13:37 <number80> we may blacklist some updates and maintain overrides
15:13:39 <dmsimard> number80: yes, we'll have to make do
15:14:01 <amoralej> in fact we may need to rebuild or fork in some cases
15:14:11 <jpena> number80: so that'd mean a mirror repo + an overrides deps repo, just like we have in centos today
15:14:14 <amoralej> and put in copr, that's what you mean?
15:14:50 <number80> jpena: yup
15:15:01 <number80> amoralej: for overrides, we'll use copr
15:15:15 <dmsimard> How did we do it back in Fedora ? I was too new to Red Hat back then. Was it a copr ?
15:15:28 <jpena> dmsimard: we used to have a copr repo
15:15:32 <dmsimard> I remember trunk.rdo but where was the deps ?
15:15:35 <dmsimard> okay
15:15:41 <number80> The nice touch is that we fully reuse the work done on DLRN to support copr and the fedora-builder rework by jpena
15:16:01 <jpena> not a big deal, we actually have *a small* copr repo today, from the attempt to get rawhide consistent
15:16:02 <dmsimard> yeah, thankfully most of the tooling is already there
15:16:02 <number80> we might also be able to prepare the switch to modules since copr has support
15:16:14 <dmsimard> and there's a lot of work keeping fedora going in general
15:16:29 <dmsimard> number80: I don't want to sidetrack but does this mean anything for the fedora rdo sig ?
15:16:39 <amoralej> number80, my concern is about the effort to move all packages to python3, test and create a promotion pipeline
15:17:03 <number80> Yes, goal is to minimize this work, and not disrupt CI too much (it should be usable in upstream gate at some point)
15:17:17 <number80> dmsimard: yes, some work will be shared
15:17:44 <dmsimard> amoralej: we don't need to have a lot of coverage, even something minimal will be a great start
15:17:55 <dmsimard> we're not going to have 100% coverage overnight, let's target.... 50% ? and go from there
15:18:14 <dmsimard> I remember seeing something about TripleO on fedora recently ... was it on the ML ? I forget
15:18:27 <number80> Well, I think POI scenarios are enough
15:18:28 <dmsimard> And there was a thread on reddit two weeks ago about people trying to install Packstack on Fedora :)
15:18:40 <dmsimard> number80: p-o-i is not expected to support Fedora though
15:18:40 <number80> we may even not have to packstack variants
15:18:42 <amoralej> i think getting p-o-i and packstack working in fedora will need a relevant work
15:19:05 <jpena> would this be python2 and python3, or would we use it to get ready if one day we go pytho3-only?
15:19:06 <dmsimard> yeah if there's work to do, it's probably more upstream than it is in RDO actually
15:19:07 <number80> dmsimard: we can experiment and figure out other test cases
15:19:23 <dmsimard> We should reach out to ianw who is familiar with the devstack CentOS and Fedora work
15:19:29 <number80> Yup
15:19:50 <number80> Just as a reminder, this is a RFC, we'll have a deeper discussion on devel list afterwards
15:20:16 <number80> if we manage to turn this draft into a concrete plan in time for PTG, that'd be awesome
15:21:21 <amoralej> number80, i think the plan is good, but i have doubts about timeframe
15:21:49 <amoralej> having it ready for rocky looks hard to me
15:22:03 <number80> amoralej: yes, this is a challenge, but we have to start the work this cycle
15:22:05 <jpena> dmsimard, number80: oh, I'd love to spend some time getting packstack to run fine on fedora :)
15:22:16 <amoralej> number80, i agree on that
15:22:24 <number80> jpena: well, I'd love to but I don't want to put pressure on that :)
15:22:42 <number80> #action number80 publish draft on the list and kickstart the discussion on the list
15:22:44 <dmsimard> jpena: I suspect it's one hell of a rabbit hole, I'll help if I can
15:22:45 <jpena> I don't think p-o-i will have a less-hard time than packstack, anyway :)
15:23:00 <amoralej> anyway, imo, having packstack and p-o-i running on fedora is high priority
15:23:02 <number80> I'll add an etherpad to work on that too
15:23:09 <dmsimard> jpena: well before even thinking about p-o-i, we need to add support for fedora in puppet-keystone, glance, nova, cinder, etc
15:24:27 <number80> we may focus on some of them, maybe?
15:24:36 <number80> and progressively expand
15:24:37 <amoralej> dmsimard, what could be the alternative to test?, do you think is there something else that we could use to test?
15:25:08 <dmsimard> amoralej: oh, I'm not implying there's something alternative or easier to test
15:25:25 <amoralej> yeah, i hoped there is something i don't know...
15:25:37 <dmsimard> Kolla had Fedora a long time ago I think
15:25:57 <amoralej> yeah, that's what i was thinking about, i have no idea about kolla/fedora status
15:26:02 <dmsimard> adding binary support in devstack would be a lot of work
15:26:15 <dmsimard> yup.. there's no easy way out
15:26:25 <chandankumar> dmsimard: https://review.openstack.org/#/c/527048/ fedora 27 support in devstack merged 4 weeks ago
15:26:39 <amoralej> yeah, but that's from source, right?
15:26:46 <amoralej> that will not help
15:26:51 <chandankumar> amoralej: yup
15:26:52 <dmsimard> chandankumar: yeah devstack is from source
15:27:01 <dmsimard> but that doesn't mean it's not a source of information
15:27:15 <number80> May I suggest that we move to the next topic? (this is a large one, and we'll be able to expand on that on the list or next week)
15:27:25 <number80> But I'm amazed that everyone has great ideas :)
15:27:50 <chandankumar> I am not sure with devstack fedora 27 + python 3 jobs enabled
15:28:52 <amoralej> number80, ok
15:29:03 <amoralej> let's move on
15:29:25 <amoralej> we may do a specific meeting about this topic after discussion in ML if needed
15:29:36 <jpena> ^ agreed
15:30:08 <number80> sure
15:30:23 <amoralej> #topic RDO test days delayed - Feb 15, 16. http://rdoproject.org/testday/queens/milestone3/
15:30:27 <rbowen> This item is announcement only. Reminders will go out to the various mailing lists in the next day or so. </end of topic>
15:30:37 <number80> do we have news about promotion?
15:30:46 * number80 haven't got to that yet
15:31:19 <amoralej> number80, yes, we have news, bad news to be precise
15:31:24 <number80> oh
15:31:41 <amoralej> we are hitting an issue at undercloud install
15:31:54 <amoralej> so periodic pipeline is failing at the very beginning
15:32:26 <ykarel> amoralej, is that escalated?
15:32:33 <amoralej> i'm not sure
15:32:38 <amoralej> i'll check after the meeting
15:32:52 <ykarel> Ok
15:32:54 <amoralej> anything else about test days?
15:33:01 <rbowen> Nothing from me.
15:33:24 <amoralej> ykarel, yes, it's escalated
15:33:26 <rbowen> If we delay it much longer, we'll probably just skip it and go with the GA test day.
15:33:51 <amoralej> let's see how the issues in promotion progress in next days
15:34:04 <amoralej> #topic Rohit Yadav - Guest from CloudStack to talk about their participation in the Cloud SIG
15:34:11 <rbowen> I am pleased to introduce rohityadav and dahn who are with the CloudStack project. I spoke with them at FOSDEM about the Cloud SIG, and encouraged them to introduce themselves here to discuss how to get CloudStack involved in the SIG.
15:34:16 <amoralej> rohityadav, first of all welcome!
15:34:25 <rohityadav> Hi all
15:34:38 * dahn is silently greeting all
15:34:54 <rbowen> We discontinued the Cloud SIG weekly meeting because it was just RDO.
15:35:01 * ykarel amoralej  yup the patch merged, let's see the next run once it's in consistent
15:35:11 <chandankumar> dahn: rohityadav: Hello, welcome to RDO community :-)
15:35:17 <rbowen> So this also serves as notice that we'll probably be re-starting the Cloud SIG weekly meeting in the next week or two.
15:35:23 <number80> Yep, and I'm willing to resume that, maybe we should start a whenisgood poll to find a new timeslot
15:35:28 <rohityadav> Thanks @rbowen. I'll try again - I'm one of the committers/pmc from the Apache CloudStack project and was searching how we can get CloudStack packages to CentOS and other distros.
15:35:34 <rbowen> I believe we used to do that on Thursdays at 15:00 UTC
15:35:43 <rohityadav> #link http://cloudstack.apache.org
15:35:48 <dmsimard> Really cool to see Cloudstack :D
15:35:49 <rbowen> That's what's still on the official CentOS schedule.
15:35:53 <rohityadav> #link http://packages.shapeblue.com/cloudstack/upstream/
15:36:14 <rohityadav> I've been maintaining the rpm/deb package repos for sometime now ^^
15:36:33 <rohityadav> So, the question is how can we engage?
15:36:45 <dmsimard> Ok I'll add thursday 3pm to my schedule
15:37:14 <rbowen> rohityadav: I see that you sent an introduction to the centos-devel list. So that was step 1.
15:37:16 <number80> rohityadav: first, you need to create a centos account and join the cloud-sig group
15:37:32 <rbowen> If folks could go see that message, and respond to Rohit's questions there, that would be very helpful.
15:37:34 <rohityadav> yes I did @rbowen
15:37:46 <rohityadav> @number80 - how do I do that, on the wiki or someplace else?
15:37:54 <number80> then, ping KB + Arrfab in copy for HA and rbowen and me to approve you in the SIG
15:37:56 <dmsimard> rohityadav: I think there's a great opportunity to collaborate but our toolchain might not be super appropriate for java things. We should chat and see how we can work together.
15:38:03 <number80> rohityadav: lemme find it
15:38:43 <number80> https://wiki.centos.org/SIGGuide#head-2e2e639e9d3d1feb0c7aba15213a909fccbae2f3
15:38:47 <number80> rohityadav: ^
15:38:56 <dahn> I have one question on that
15:39:04 <number80> go ahead
15:39:14 <dahn> Can we provide me as  backup to Rohit in that process ?
15:39:22 <dahn> or is it personal involvement
15:39:37 <rbowen> I think having both of you there would be beneficial to everyone.
15:39:39 <rohityadav> sure @dmsimard, we're indeed publishing centos7 rpm repository and testing against all old and recently CentOS7  both as KVM hosts and the management server host so I hope it works with your toolchain.
15:39:50 <rohityadav> thanks @number80 will follow
15:41:06 <rbowen> dahn: So, yes, I think you should do the same - centos account and then we'll approve your addition to the SIG membership.
15:41:10 <number80> dahn: what rbowen said :)
15:41:32 <dahn> :) ok, now i have a second question
15:41:50 <dahn> is the renewed sig irc meeting starting tomorrow?
15:42:06 <number80> no, I'll send a poll on the centos-devel list for that
15:42:13 <dahn> ok, yet to be scheduled
15:42:15 <dahn> tnx
15:42:16 <number80> let's figure out a time that works for everyone
15:42:23 <rohityadav> I was going to ask that, thanks -- so we discuss and follow on the centos-devel list?
15:42:32 <rbowen> We do have that spot reserved, so if it works for everyone, it's a good default, but I don't know what time zones everyone is in.
15:42:53 <rbowen> But, yes, let's wait for number80's poll, rather than bikeshedding the time here.
15:43:04 <number80> ack
15:43:25 <rohityadav> make sense, we'll follow when the CloudSIG meeting resume from centos-devel list then?
15:43:33 <rohityadav> s/make/makes
15:43:36 <rbowen> Yes.
15:43:42 <rohityadav> ack
15:45:09 <amoralej> ok, so are we done with this topic?
15:45:11 <rbowen> I believe that's it for that topic.
15:45:14 <amoralej> ok
15:45:15 <rohityadav> Yes.
15:45:17 <dahn> yes
15:45:33 <amoralej> #topic Virtual meetup possible dates: [ April 12th, 19th ] Times:?
15:45:48 <rbowen> I'd like to do the Virtual Meetup on April 12th, if that works for everyone. But I'm not sure what times we should do, because $TIMEZONES
15:46:17 <rbowen> And I never brought this to the mailing list, because ... I forgot. So I need to do that ASAP, and start looking for presentations.
15:46:26 <rbowen> But I wondered what people thought reasonable times would be.
15:46:46 <rbowen> We'll be recording, of course, so the entire time range doesn't have to work for everyone.
15:47:28 <rbowen> Anyone have an opinion, or should I just pick a time range that works for me? :-)
15:47:38 <dmsimard> Hmmm
15:47:49 <number80> mid-april should be ok even if it means limiting the number of talks
15:48:07 <dmsimard> I guess something in the North American morning (not too early) would probably be where we have the most people around
15:48:20 <dmsimard> We'd catch NA/EMEA
15:48:34 <rbowen> number80: I believe that's the dates we discussed earlier. Is that too close to Summit?
15:49:14 <number80> maybe, but it should not prevent us to hold it
15:49:22 <dmsimard> It's always too close to a summit or a PTG so we shouldn't let that hold us back
15:49:29 <dmsimard> They overlap every 3 months..
15:49:46 <rbowen> ok, I'll go with April 12th, and start something for talk submissions.
15:49:54 <rbowen> Thanks. Look for details on the mailing list.
15:49:59 <dmsimard> rbowen: thanks for leading this
15:51:05 <amoralej> #action rbowen to send a mail to RDO ML about virtual meetup planing and asking for talk submissions
15:51:18 <amoralej> #topic chair for next meeting
15:51:30 <amoralej> any volunteer?
15:51:52 <rohityadav> @rbowen @number80 - jfyi I've created account and requested to join sig-cloud, my id is rohit (rohit@yadav.cloud). I'll followup on centos-devel@, thanks for having us. Cheers.
15:52:03 <number80> I can do it if nobody else wants it
15:52:12 <amoralej> thanks number80
15:52:22 <number80> rohityadav: ack
15:52:26 <amoralej> #action number80 to chair next meeting
15:52:28 <number80> I also sent a poll on centos-devel
15:52:44 <amoralej> let's open open floor time
15:52:51 <amoralej> #topic open floor
15:53:11 <amoralej> would you like to bring something?
15:53:16 <rbowen> I'm looking for a pub, Thursday night at the PTG, for drinks/snacks RDO social.
15:53:29 <rbowen> If you live in Dublin and have a recommendation, near Croke Park Stadium, ping me off-channel.
15:53:48 <rbowen> Same as last two times - just an place to hang out and some food and drinks. Nothing fancy.
15:54:07 <number80> rbowen: you're awesome :)
15:54:20 <rbowen> We try. :D
15:54:56 <amoralej> i'd like to share that i was talking to several happy RDO/OpenStack users at fosdem
15:55:07 <jruzicka> \o/
15:55:28 <jruzicka> amoralej, any things they were particularly happy with? :)
15:56:13 <amoralej> people tend to emphasize how OpenStack has improved and estibilized over time
15:56:55 <amoralej> i'd say that from a deployment point of view, there is still a lot of segregation of tools
15:57:11 <amoralej> and there is a lot of interest about kubernetes on openstack
15:57:40 <amoralej> everyone asked about it
15:58:04 <jruzicka> true dat. OpenStack survived its hype cycle, grand success :)
15:58:20 <amoralej> yeah, I'd ssay so
15:58:29 <amoralej> and a last topic from me
15:58:46 <amoralej> tasks about queens preparation are ongoing, we'll start branching distgits very soon
15:59:04 <amoralej> so if anyone needs changes before queens GA, let us know
15:59:28 <mary_grace> one last quick note before we close: ICYMI, the Feb RDO Newsletter went out yesterday: https://www.rdoproject.org/newsletter/2018/february/  let me know if you have any questions or feedback!
15:59:57 <rbowen> Thanks, mary_grace!
16:00:42 <amoralej> yeah, a nice summary of the month
16:01:00 <amoralej> ok, so it times to close unless anyone has something else
16:01:04 <amoralej> last call....
16:01:27 <amoralej> #endmeeting