15:04:18 <jpena> #startmeeting RDO meeting - 2017-10-18
15:04:19 <openstack> Meeting started Wed Oct 18 15:04:18 2017 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:22 <openstack> The meeting name has been set to 'rdo_meeting___2017_10_18'
15:04:27 <jpena> #topic roll call
15:04:30 <amoralej> o/
15:04:40 <jpena> #chair amoralej dmsimard EmilienM
15:04:41 <openstack> Current chairs: EmilienM amoralej dmsimard jpena
15:04:49 <jpena> #chair hguemar
15:04:50 <openstack> Current chairs: EmilienM amoralej dmsimard hguemar jpena
15:04:55 <EmilienM> I'm still wondering why you add chairs
15:05:04 <EmilienM> anyone can do #action, etc etc
15:05:27 <jpena> just to see your reaction :P
15:05:40 <amoralej> :D
15:05:45 <hguemar> EmilienM: for all other commands to be logged
15:05:56 <hguemar> (collaborative summary trimming!)
15:06:00 <EmilienM> jpena: it works fine!
15:06:07 <jpena> anyway, let's start with the agenda, it's short today
15:06:16 <jpena> #topic RDO Trunk cleanup for Fedora Rawhide
15:06:35 <rbowen> Present-ish
15:06:55 <jpena> I've been working lately on getting the Fedora Rawhide worker in good shape. Now we only have 10 packages failing to build, and we have bugs/reviews open for most of them
15:07:03 <rdogerrit> Arx Cruz proposed config master: Adding jobs for python-tempestconf  https://review.rdoproject.org/r/10188
15:07:46 <jpena> We have 2 packages that are a bit special: python-hacking and openstack-tripleo-ui
15:08:00 * Duck o/
15:08:30 <jpena> python-hacking requires a version of flake8 way below what we have in Rawhide. There's actually a python-hacking package in Rawhide, with a bunch of patches to make it mostly compatible with flake8 3.x
15:08:57 <jpena> openstack-tripleo-ui depends on its -deps package, which cannot be packaged as such in Rawhide
15:09:04 <chandankumar> jpena: oh sorry i missed it
15:09:05 <hguemar> impossible
15:09:11 <hguemar> #chair chandankumar
15:09:12 <openstack> Current chairs: EmilienM amoralej chandankumar dmsimard hguemar jpena
15:09:17 <jpena> so... We can fix these issues in one of two ways:
15:09:45 <jpena> a) Create a copr repo for dependencies (tripleo-ui-deps, maybe python-construct for ironic-inspector)
15:10:16 <ykarel|afk> o/
15:10:19 <jpena> b) Add a special tag in rdoinfo (something like fedora-master), where we filter out those packages that we can't/don't want to have in Fedora
15:10:48 <jpena> #chair ykarel Duck
15:10:49 <openstack> Current chairs: Duck EmilienM amoralej chandankumar dmsimard hguemar jpena ykarel
15:10:54 <jpena> what do you think?
15:12:00 <dmsimard> I'm trying to think but I don't know
15:12:54 <dmsimard> I don't think we can consider B because that means we can't get a tripleo-ui package
15:13:21 <jpena> we could also use B to not package python-hacking, and use the Rawhide build instead
15:13:36 <dmsimard> who's maintainer for hacking ?
15:14:06 <dmsimard> interesting, doesn't seem to be any of us
15:14:30 <dmsimard> last ones who touched it was mrunge and social
15:14:44 <jpena> https://bugzilla.redhat.com/show_bug.cgi?id=1377125 has details on the whole hacking vs flake8 issue
15:14:45 <openstack> bugzilla.redhat.com bug 1377125 in python-hacking "python-hacking doesn't work with flake8 3.x" [Unspecified,New] - Assigned to mrunge
15:16:02 <dmsimard> I think we have the necessary manpower and connections to address the root issue of hacking so that it's no longer an issue, but the elephant in the room is tripleo-ui-deps especially
15:16:43 <amoralej> copr sounds as an option for tripleo-ui-deps
15:17:11 <dmsimard> I don't think it's realistic to believe that tripleo-ui-deps will be unbundled in the near future
15:17:17 <dmsimard> (and thus a candidate for fedora)
15:17:46 <dmsimard> It's not buildable by delorean, is it ?
15:18:24 <jpena> dmsimard: I think part of the issue was that it uses npm to retrieve all deps, so we want them frozen at a point in time
15:18:28 <jpena> but I'm not sure
15:18:50 <dmsimard> jrist, honza ^ can you give us some input
15:19:08 <dmsimard> where did Haikel go ?
15:19:15 <jrist> heh
15:19:19 <dmsimard> don't see either hguemar or number80
15:19:49 <honza> dmsimard: I don't have any info on unbundling.  Not on any of our roadmaps.
15:20:06 <jrist> +1
15:20:06 <honza> dmsimard: jpena: yes, we use npm
15:20:09 <dmsimard> honza: do you know why we build tripleo-ui-deps on cbs exclusively and not through dlrn ?
15:20:16 <honza> dmsimard: I don't
15:20:19 * jrist either
15:20:30 <dmsimard> you guys
15:20:32 <dmsimard> ಠ_ಠ
15:20:45 <honza> dmsimard: I don't know the different between the two.  number80 does his magic
15:20:57 <dmsimard> ok
15:21:12 <jpena> ok, let's start then by creating a copr, we can always revert if needed
15:21:23 <dmsimard> jpena: +1, and consider option c) build through dlrn
15:21:43 <jrist> that's fine as long as it's clear how do help from the tripleo-ui team
15:21:51 <amoralej> jpena, re. flake8, maybe we can provide a valid version in the copr also?
15:21:53 <dmsimard> jpena: what was the problem with construct ?
15:22:26 <jpena> dmsimard: we have an old version in Rawhide (the one in CBS is ok). There's an open bz, but I'm not sure if we'll get progress soon
15:22:36 <rdogerrit> wes hayutin proposed config master: fix upgrade jobs 'not-registered' feedback  https://review.rdoproject.org/r/10037
15:22:46 <dmsimard> jpena: are you documenting/tracking these issues somewhere ?
15:23:14 <jpena> dmsimard: I have a wip spreadsheet I use for tracking. Other than that, I bug each project one at a time :)
15:24:05 <dmsimard> jpena: ok, just wondering about following the BZs etc
15:24:49 <jpena> ok, time for actions
15:24:51 <dmsimard> jpena: you have the answer(s) you need ?
15:25:16 <jpena> #action jpena to create copr for Fedora deps that can't/won't be included in Rawhide
15:25:21 <jpena> yes, I think we can move on
15:25:30 <jpena> I'm still unsure about hacking, I'll give it a second look
15:25:51 <jpena> let's move on
15:25:57 <jpena> #topic TripleO 'Zuul v3 ask me anything': http://lists.openstack.org/pipermail/openstack-dev/2017-October/123668.html
15:26:18 <jpena> dmsimard: ^
15:26:21 <dmsimard> oi
15:26:30 <dmsimard> I've talked about this already, and I'll sound like a broken record
15:26:46 <dmsimard> but please sign up for the zuul v3 ask me anything next week
15:26:48 <dmsimard> #link http://lists.openstack.org/pipermail/openstack-dev/2017-October/123668.html
15:27:43 <dmsimard> There's not a lot of attendees signed up and Zuul v3 is something that affects everyone working on TripleO and soon it will be deployed for review.rdoproject.org.
15:28:25 <dmsimard> mrunge, larsks, paramite ^ this is good for you guys too, we plan on rolling out Zuul v3 in ~1 month or so
15:28:49 <dmsimard> weshay, panda|rover, weshay, trown, adarazs, myoung ^
15:29:00 <dmsimard> That's it for me
15:29:26 <jpena> next topic?
15:29:36 <dmsimard> Duck: you're next I think
15:29:39 <adarazs> dmsimard: will sign up as soon as I know our sprint ending/planning meetings time. sorry for the delay.
15:29:40 <dmsimard> or rbowen
15:29:51 <jpena> #topic Mailing list migration status
15:30:07 <rbowen> Sorry I'm very distracted.
15:30:08 <rbowen> Let's see
15:30:15 <rbowen> I got email from Karsten and Duck this morning.
15:30:26 <rbowen> Said that we're ready to migrate the list from @redhat.com to rdoproject.org
15:30:32 <rbowen> and split it into dev and user@
15:30:35 <rbowen> Like, this week.
15:30:47 <rbowen> I just want to make sure that we communicate clearly and early.
15:30:52 <Duck> quack
15:31:05 <rbowen> But I'm traveling, so I'm not sure I have read all of the various updates.
15:31:20 <openstackgerrit> Alfredo Moralejo proposed openstack/packstack stable/ocata: Zuul v3 support for Packstack jobs  https://review.openstack.org/513070
15:31:21 <Duck> I said next tuesday or wednesday
15:31:22 <dmsimard> rbowen, Duck: in practice, will there be a redirect from rdo-list@redhat.com ?
15:31:45 <Duck> dmsimard: not planned
15:31:47 <rbowen> Not a "redirect" per se, more like an autoresponder saying "go there". I guess that's sort of a redirect.
15:32:02 <dmsimard> rbowen: ok, an autoresponder is the least we can do, yeah.
15:32:09 <Duck> also this would just delay things indefinitely
15:32:37 <dmsimard> Duck: sure, I just wanted to make sure we didn't "lose" any emails for people not updating their address book or replying to old threads
15:32:44 <Duck> rbowen: could you look at the server if you see anything wrong ?
15:32:51 <rbowen> Duck: ok, next tue/wed is good. Karsten said "this week".
15:32:57 <Duck> dmsimard: yep :-)
15:33:08 <rbowen> Duck: Which server are we talking about here?
15:33:23 <Duck> well, you said 72h mini for announcement, so this does not work
15:33:50 <rbowen> Yes, and the Red Hat Engineering Team has been shuffled a bit, so I want to be certain that we're also communicating with everyone there, so that nobody is surprised.
15:34:02 <rbowen> I think everyone is aware of what's coming, though. Just not when.
15:34:17 <Duck> rbowen: well, lists.rdoproject.org, like the web UI, you can join taiste@ (to avoid mailing real users/devs)
15:34:28 <rbowen> The lists on lists.rdoproject.org look fine/correct.
15:34:54 <Duck> there was some titles and reply address and stuff I fixed while importing (stuff MM3 does but I had to do by scripting)
15:34:59 <rbowen> Are the archives going to get a final sync at the end, then?
15:35:01 <Duck> just to make sure it's fine
15:35:09 <Duck> yes
15:35:11 <Duck> of course
15:35:16 <rbowen> Awesome.
15:35:20 <Duck> it's not very long to import
15:35:22 <rbowen> Then, yes, it all looks great to me.
15:35:33 <Duck> DNS also is fixed on IT side
15:35:34 <rbowen> So it's just the communication that needs done.
15:35:43 <Duck> let me see
15:35:59 <rbowen> I'll write another message to all of the various lists that it should affect. We've already got the updated docs page staged, thanks to Duck.
15:36:03 <Duck> backup is done too
15:36:14 <Duck> later we would add monitoring with dmsimard
15:36:36 <Duck> the PR for the doc is pending, needs review and I'll merge when migration is done
15:37:13 <Duck> so I guess we're ready to go :-)
15:37:34 <Duck> rbowen: I guess maybe you would explain better the reason for splitting in less technical words
15:37:42 <Duck> I can contribute though
15:37:45 <Duck> as you wish
15:38:12 <Duck> so Tuesday or Wednesday mid-morning (JST) is fine
15:38:47 <rbowen> Well, the main reason is to have a place where users can ask questions in a safer environment that isn't innundated by deep technical issues.
15:39:54 <Duck> I get it, just I'm less used to communicate broadly. I gave announcement example I made in the BR, so as you wish
15:40:26 <rbowen> Sure. I'll try to write something this evening or tomorrow morning. I'm very jetlagged right now. :D
15:41:11 <Duck> rbowen: thanks :-)
15:42:36 <jpena> #info mailing lists to be migrated soon, stay tuned for announcement
15:42:49 <jpena> anything else for this topic?
15:44:42 <Duck> Sir
15:44:44 <Duck> no
15:45:34 <jpena> #topic chair for next meeting
15:45:52 <jpena> chandankumar, will you be available to chair next week?
15:47:45 <jpena> or any other volunteer? :D
15:49:11 * hguemar will be in Paris
15:49:37 <amoralej> i can take it
15:49:46 <jpena> thanks amoralej!
15:49:51 <jpena> #action amoralej to chair next meeting
15:49:55 <jpena> #topic open floor
15:50:04 <dmsimard> hguemar: there you are, I was looking for you
15:50:23 <dmsimard> hguemar: is there a specific reason we're building tripleo-ui-deps exclusively from cbs instead of dlrn ?
15:51:30 <openstackgerrit> Merged openstack/packstack stable/pike: Zuul v3 support for Packstack jobs  https://review.openstack.org/513037
15:55:03 <rdogerrit> Sagi Shnaidman proposed config master: fix upgrade jobs 'not-registered' feedback  https://review.rdoproject.org/r/10037
15:58:39 <jpena> we're running out of time, let's continue the discussion after the meeting
15:58:46 <jpena> #endmeeting