15:00:26 <jpena> #startmeeting RDO meeting - 2017-06-07
15:00:32 <number80> pradk: nw :)
15:00:34 <openstack> Meeting started Wed Jun  7 15:00:26 2017 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:38 <openstack> The meeting name has been set to 'rdo_meeting___2017_06_07'
15:00:46 <jpena> #topic roll call
15:00:50 <chandankumar> \o/
15:00:55 <rbowen> yo
15:01:08 <jpena> #chair chandankumar trown rbowen apevec number80
15:01:08 <openstack> Current chairs: apevec chandankumar jpena number80 rbowen trown
15:01:12 <amoralej> o/
15:01:13 <apevec> o/
15:01:19 <jpena> #chair amoralej
15:01:20 <openstack> Current chairs: amoralej apevec chandankumar jpena number80 rbowen trown
15:01:34 <ykarel> o/
15:01:40 <jpena> #chair ykarel
15:01:41 <openstack> Current chairs: amoralej apevec chandankumar jpena number80 rbowen trown ykarel
15:02:14 <jpena> remember that the agenda is at https://etherpad.openstack.org/p/RDO-Meeting, in case you want to add some last-minute topic
15:02:56 <jpena> let's start
15:03:09 <jpena> #topic Doc day, June 8, 9 (Tomorrow!) - https://www.rdoproject.org/events/docdays/
15:03:19 <jpena> rbowen: ^^
15:03:20 <rbowen> We would like to have a moment of your time over the coming two days to improve our website and documentation.
15:03:27 <rbowen> I have opened a number of new tickets over the past few days.
15:03:36 <rbowen> If there's something that bugs you about our website, please open a ticket.
15:03:50 <rbowen> And please consider spending some time tomorrow or Friday helping us fix those things.
15:03:57 <rbowen> #link https://www.rdoproject.org/events/docdays/
15:04:06 <rbowen> #link https://github.com/redhat-openstack/website/issues
15:04:41 <rbowen> /EOM
15:05:35 <jpena> #action everyone contribute to doc days
15:05:39 <rbowen> Yay!
15:05:41 <jpena> next topic?
15:06:06 <rbowen> yes
15:06:09 <jpena> #topic Proposed mailing list move
15:06:11 <rbowen> So, this one is a little more involved.
15:06:30 <rbowen> Anecdotally, some folks in the community don't like to ask beginner questions on a mailing list that is plainly developer-centric
15:06:44 <rbowen> Meanwhile, I've also wanted to move our lists from @redhat.com to @rdoproject.org for some time
15:07:03 <rbowen> I talked with Duck and misc a day or so ago, and they said that this is certainly doable, and made some recommendations
15:07:10 <rbowen> 1) That we use @lists.rdoproject.org instead
15:07:29 <rbowen> 2) that rather than merely forwarding the old list, we add an autoresponder saying that the discussion as moved to the new list.
15:07:42 <rbowen> At the same time, we could split rdo-list into a dev@ and users@ list
15:07:54 <rbowen> I'm looking for feedback about what you folks think about this proposal.
15:08:01 <rdogerrit> Merged openstack/gnocchi-distgit newton-rdo: Update to 3.0.9  https://review.rdoproject.org/r/6987
15:08:10 <apevec> so no doing mass-subscribe of existing users?
15:08:19 <rbowen> Well, that's one of the questions.
15:08:30 <Duck> quack
15:08:36 <Duck> sorry to be late
15:08:37 <rbowen> Whether we could copy over the existing subscriber list, and, if so, whether that would go to dev@ or users@ or both.
15:08:53 <jpena> I like the idea of having two lists, specially if it encourages beginner questions
15:09:01 <rbowen> My inclination would be to copy it over to dev@ and give people detailed instructions of how to move to users@ if they want to.
15:09:11 <chandankumar> apevec: what about dropping a mail to the subscribers, if you want to subscribe to this please click on this and otherwise ignore?
15:09:16 <rbowen> ANd them more aggressively promote the users@ list to beginners.
15:09:35 <rbowen> chandankumar: Yes, that's another option, but I suspect that we would lose a lot of people in the transition.
15:09:47 <apevec> that would be my concern
15:10:05 <apevec> so given current focus copying rdo-list -> dev makes sense
15:10:06 <jpena> yes, I'd rather migrate existing users to dev@ and encourage everyone to subscribe to users@
15:10:08 <rbowen> So my vote would be to copy the list over to dev@ and then promote users@ on that new list as the new place for "support"
15:10:41 <amoralej> yeah, i'd copy subscriber and send a mail with instructions to unsubscribe
15:11:04 <rbowen> I don't know what the timeline is for such a move. Duck and misc are waiting, I believe, for some decisions about these things we're discussing now before they move forward with it.
15:11:19 <rbowen> I am relying on them for details like where this infra actually runs.
15:11:20 <amoralej> rbowen do you now how many subscriber rdo-list has?
15:11:29 <rbowen> Yes, I do. One moment. Grabbing stats
15:11:49 <apevec> amoralej, unsubscribe instructions are in the footer of every post
15:12:01 <rbowen> rdo-list has 851 subscribers
15:12:08 <rbowen> rdo-newsletter has 2370 subscribers
15:12:16 <amoralej> ok
15:12:27 <rbowen> apevec: They are, however, a lot ofpeople ignore that, and some mail clients hide the footers.
15:12:41 <rbowen> So we would want to draw attention to it more directly in an announcement email.
15:12:51 <jpena> btw, where would we host those lists?
15:12:52 <apevec> rbowen, good point
15:13:07 <apevec> jpena, OSAS shared infra I think
15:13:08 <Duck> so we can provide support for hosting it either in OSAS Community Cage or elsewhere if you prefer
15:13:09 <rbowen> Duck, misc: do you want to comment on where these lists might be hosted?
15:13:11 <apevec> w/ other projects
15:13:23 <rbowen> Beat me to it. :-)
15:13:25 <amoralej> yes, we could send an announcement list with info about new users one and unsubscribe instructions
15:13:33 <Duck> we host openinfra.org ML, and Minishift and oVirt are coming
15:13:43 <Duck> with Mailman3
15:13:45 <rbowen> The existing archive would remain where it is, in perpetuity
15:13:49 <jpena> Duck: ok, that's great
15:14:04 <rbowen> We would also provide the new HyperKitty interface for people that prefer that kind of thing, right Duck?
15:14:19 <number80> Why not migrate everyone to both lists and ask people who wants to opt-out from either or both lists?
15:14:22 <Duck> as for migration from 2.1 it was not fine in the past and I'm testing it again with 3.1 out recently for oVirt
15:14:34 <apevec> rbowen, how can we ensure last post in the old archive is pointing to new location?
15:14:37 <rbowen> number80: I thought of that. Do you think that's the right thing to do?
15:14:46 <Duck> yes Hyperkitty is provided
15:14:48 <number80> (we need the experts on the users list otherwise, beginners would not enjoy it much)
15:14:55 <rbowen> apevec: We would close the list to posts from anybody but moderators (ie, me, and a handful of other people)
15:15:02 <apevec> number80, yeah but we need experts willing to help
15:15:05 <apevec> can't force them
15:15:11 <number80> rbowen: I'm inclined to that option, and we can offer opt-out
15:15:12 <Duck> like this https://lists.opensourceinfra.org/
15:15:19 <apevec> so by subscribing they committ answering :)
15:15:33 <number80> apevec: we need to seed initial list, we can turn it to opt-in then
15:15:36 <rbowen> I guess we can subscribe them to both, and then encourage people to unsub from the one they're not interested in, and hope most people stay on both.
15:15:46 <Duck> local accounts as well as social ones are possible
15:15:47 <rbowen> The users list is indeed useless if the experts aren't there to answer their questions.
15:16:12 <rbowen> Does anybody strongly object to number80's proposal here
15:16:15 <amoralej> +1 to subscribe current subscriberts to both
15:16:32 <chandankumar> +1 to number80 proposal
15:16:34 <jruzicka> +1
15:16:36 <number80> I fear the inerty of experts not looking at the other list
15:16:37 <Duck> once the "organizational" part is decided we can start a test instance and polish the config
15:16:39 <apevec> I'm for dev only
15:16:54 <jpena> +1 to number80's proposal. You can always unsubscribe if you want
15:16:57 <rdogerrit> Merged openstack/gnocchi-distgit rpm-master: Update gnocchi project url  https://review.rdoproject.org/r/6998
15:17:01 <number80> #/bu37
15:17:07 <number80> (sorry)
15:17:22 <rbowen> ok, we appear to have general consensus. I will follow up with Duck and misc, and report back next week with some notion of timeline to get this done.
15:17:30 <rbowen> Thank you for your input.
15:17:39 * Duck :-)
15:18:00 <chandankumar> rbowen: one more thing are we moving the list from mailman2 to hyperkitty ?
15:18:04 <rbowen> Note that newsletter@ would also migrate over, but since that is send-only, it's less difficult.
15:18:29 <rbowen> We would be moving from mailman2 to mailman3. HyperKitty would also be available, as that runs on top of MM3.
15:18:47 <chandankumar> ack
15:18:49 <rbowen> ie, you can still participate via email, and don't have to use the clicky clicky if you don't want to.
15:19:04 <chandankumar> hehe
15:19:30 <jpena> ok, moving on?
15:19:37 <rbowen> Done with this topic. Yes.
15:19:38 <rbowen> Thanks.
15:19:47 <jpena> #topic With latest SF version we can create branches via reviews to config project
15:19:56 <amoralej> that's mine
15:20:25 <amoralej> so, now we can create branches in distgits using reviews in config project
15:20:35 <amoralej> what enables it to be used by package maintainers
15:21:02 <amoralej> in the past that was done by RDO cores at new release preparation
15:21:14 <Duck> could I have a chair, I'm a bit tired :-) ?
15:21:20 <amoralej> but some maintainers complaint about why that was not available for them
15:21:35 <jpena> #chair Duck
15:21:36 <openstack> Current chairs: Duck amoralej apevec chandankumar jpena number80 rbowen trown ykarel
15:21:46 <Duck> thanks
15:21:53 <amoralej> so, should we document how to create new branches so that maintainers can get control on that?
15:22:15 <number80> amoralej: yes \o/
15:22:17 <jpena> amoralej: what is the purpose of this, to have a distributed branching process?
15:22:28 <amoralej> yeah, more control for maintainers
15:22:36 <amoralej> if they want|can
15:22:46 <amoralej> of course, if they don't do it on time, we will
15:23:04 <amoralej> but at least they can have more participation in the GA process
15:23:05 <jpena> I'm fine with that, but the config change needs to be approved by one of the maintainers anyway
15:23:09 <amoralej> sure
15:23:36 <amoralej> my idea was to create a doc about what to do for new releases
15:23:45 <amoralej> so that maintainers can follow it
15:24:06 <jpena> sounds good to me
15:24:12 <amoralej> i was thinking if we could trigger it from some change in rdoinfo, to centralize it
15:24:17 <amoralej> but i don't see any easy way
15:24:34 <amoralej> so i think the best is let them send a change directly to the resource
15:25:00 <amoralej> but if anyone has a better idea, let me know
15:25:08 <amoralej> and that was it
15:25:22 <jpena> action item?
15:25:59 <number80> I guess we can also publish a proper schedule with actions for maintainers
15:26:02 <amoralej> #action amoralej to document process for maintainers to prepare packages for new releases
15:26:13 <amoralej> i started writing https://review.rdoproject.org/etherpad/p/gerrit_based_branching
15:26:34 <amoralej> but that has mix of maintainers and rdo cores actions
15:26:46 <amoralej> so i don't know if it's a good idea to publish it
15:26:53 <jruzicka> once it is documented, I can look at automating it with rdopkg
15:27:28 <jruzicka> rdoinfo change -> config change should be doable
15:27:49 <amoralej> ok, i'll reserve some time these two days for this doc
15:28:15 <jpena> next?
15:28:19 <amoralej> yeah
15:28:21 <jpena> #topic rdopkg moved to softwarefactory-project.io
15:28:34 <jruzicka> yup
15:29:04 <jruzicka> #info rdopkg migrated from review.rdoproject.org to https://softwarefactory-project.io
15:29:21 <jruzicka> #info rdopkg github mirror moved from openstack-packages to softwarefactory-project namespace: https://github.com/softwarefactory-project/rdopkg
15:29:46 <jruzicka> #info rdopkg issues tracking still on github: https://github.com/softwarefactory-project/rdopkg/issues
15:30:58 <jruzicka> thanks jpena for valuable assistence
15:31:24 <jpena> you're welcome ;)
15:31:38 <apevec> excellent, all our tooling has a good home now
15:31:59 <apevec> next is automation of releases, this works for dlrn I think?
15:32:16 <jpena> what do you mean apevec?
15:32:16 <amoralej> jruzicka, any plan to release new version of rdopkg?, there is a merged feature i'm interested in for a job in review.r.o
15:32:19 <apevec> only to pypi, rpms repo is next
15:32:29 <jruzicka> finally, jschlueter put rdopkg under analysis, you can see some stats here: https://www.openhub.net/p/rdopkg
15:32:29 <jpena> ah ok
15:32:38 <apevec> jpena, publishing to pypi when tag is pushed
15:32:56 <jpena> yes, the change as merged today
15:33:13 <jruzicka> as well as software factory's integrated RepoXplorer: https://www.openhub.net/p/rdopkg
15:33:39 <jruzicka> amoralej, a plan is to release next version using automated releases
15:33:48 <jruzicka> #action jruzicka to automate rdopkg release
15:33:59 <apevec> jruzicka, is openhub new Ohloh?
15:34:03 <rbowen> Yes.
15:34:04 <apevec> looks familiar
15:34:13 <rbowen> They changed their name 3 or 4 years back now.
15:34:19 <jschlueter> apevec: openhub itself is old
15:34:22 <jruzicka> amoralej, if a new version is required, I can release manually but I wanted to make it happen once and for all :)
15:34:37 <amoralej> i can wait
15:34:44 <jruzicka> apevec, yes, I'm basically following in jpena's footsteps with DLRN, stealing all his hard work :D
15:34:52 <apevec> rbowen, man, I'm old :)
15:35:05 <jschlueter> it's related to blackduck ... and they offer services to opensource communities
15:35:21 <apevec> they don't show project $$$ value anymore?
15:36:00 <jruzicka> they think "rdopkg has a young, but established codebase maintained by a large development team with increasing Y-O-Y commits"
15:36:01 <rbowen> It's still in there somewhere. You just have to dig for it.
15:36:04 <jschlueter> :-)
15:36:13 <jruzicka> furthermore, average time to land for rdopkg is 6 days ;)
15:36:32 <apevec> fun stats
15:36:41 <apevec> but not more I guess :)
15:37:16 <jruzicka> #info rdopkg to appear in fedora repos along with DLRN soonish
15:37:18 <apevec> https://www.openhub.net/p/rdopkg/estimated_cost
15:37:20 <jruzicka> right, jpena? ^
15:37:23 <apevec> $80k
15:37:24 <apevec> not bad
15:37:34 <jpena> jruzicka: yep.
15:37:46 <jruzicka> but we removed lots of code...
15:37:52 <jruzicka> 20 k lines changed by me
15:38:03 <jruzicka> not fair metric as we keep it minimal :)
15:38:10 <jruzicka> "minimal"
15:38:12 <jruzicka> well
15:38:14 <jruzicka> that's it.
15:39:04 <amoralej> neutron has > 5M dollars, not bad
15:39:57 <jpena> so... back to the topic. Anything else to add?
15:41:22 <jruzicka> amoralej, I'll release new version for you then.
15:41:26 <rdogerrit> Yatin Karel created openstack/manila-ui-distgit rpm-master: Fix conflict with openstack-dashboard __init__.py  https://review.rdoproject.org/r/7002
15:42:00 <jpena> #topic chair for next meeting
15:42:09 <amoralej> jruzicka, i can wait for a cuple of weeks
15:42:09 <jpena> any volunteers?
15:42:19 <amoralej> s/cuple/couple/
15:43:14 <jruzicka> I can chair
15:43:24 <jpena> great!
15:43:30 <jpena> #action jruzicka to chair next meeting
15:43:34 <jpena> #topic open floor
15:50:15 <jpena> no more topics, so let's get 10 minutes back
15:50:21 <jpena> #endmeeting