14:02:54 <boris-42> #startmeeting rally
14:02:55 <openstack> Meeting started Mon Jul 27 14:02:54 2015 UTC and is due to finish in 60 minutes.  The chair is boris-42. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:58 <openstack> The meeting name has been set to 'rally'
14:03:15 <boris-42> rvasilets: amaretskiy oanufriev ping
14:03:20 <amaretskiy> hi
14:03:24 <rvasilets> \o
14:04:18 <temujin> hi
14:04:54 <yingjun> Hi
14:05:12 <kun_huang> :)
14:07:33 <kun_huang> boris-42: here
14:08:00 <skraynev> o/
14:08:04 <boris-42> #topic Make Rally framework independent from OpenStack
14:08:33 <boris-42> As far as you know I am working quite a lot on this task
14:08:44 <boris-42> https://review.openstack.org/#/c/203911/
14:08:56 <boris-42> ^ this patch resolves one more place that blocks this effort
14:09:36 <boris-42> e.g. Base runner should know to content of Context object to prepare scenario context
14:09:41 <boris-42> which is terrible
14:10:02 <boris-42> after this patch each context plugin is able to transform context object for scenario
14:10:24 <boris-42> which allows us to make runner independent of context obj
14:11:33 <boris-42> e0ne: rvasilets amaretskiy redixin oanufriev kun_huang yingjun ^ any questions
14:11:46 <amaretskiy> no
14:11:54 <boris-42> everything is clear?
14:12:06 <yingjun> no
14:12:06 <kun_huang> nope, I will watch it
14:12:28 <rvasilets> boris-42, no. Interesting patch which need more patient from me
14:13:20 <temujin> watch it later
14:13:25 <boris-42> okk
14:13:26 <e0ne> i'll review it later today
14:13:46 <boris-42> next topic
14:13:49 <boris-42> #topic [stpierre] create_and_list_<singular> (e.g., create_and_list_image) or create_and_list_<plural> (e.g., create_and_list_users)? We use a mix of both, and should pick one and standardize.
14:14:48 <redixin> +1 for plural
14:15:21 <boris-42> +1 for plural
14:15:27 <boris-42> imho it should be obvious
14:15:42 <rvasilets> yes, +1 for plural
14:15:45 <redixin> who want to make test for this?
14:16:00 <boris-42> redixin:  pboldin LOL=)
14:16:07 <redixin> rofl
14:16:15 <rvasilets> he like regexp
14:16:47 <rvasilets> lets vote) +1 from me for pboldin)
14:16:56 <boris-42> LOL
14:18:45 <boris-42> e0ne: ^
14:18:48 <boris-42> skraynev: ^
14:19:29 <skraynev> boris-42: +1 from me about using plural everywhere
14:19:39 <e0ne> +1
14:19:41 <rvasilets> kun_huang, ^
14:19:48 <rvasilets> temujin, ^
14:20:02 <yingjun> +1
14:20:13 <kun_huang> +1 for plural
14:20:14 <yingjun> plural
14:20:14 <amaretskiy> +1 for plural
14:20:15 <boris-42> #agreed we should use plural everywhere and make hacking rule for this
14:20:31 <boris-42> #topic
14:20:33 <boris-42> #topic [e0ne] verify performance with Rally: compare performance of scenarios after 2 runs
14:20:49 <boris-42> e0ne: this is question to amaretskiy *
14:20:56 <e0ne> in cinder, we want to get in in infra
14:21:09 <boris-42> e0ne: oh you mean to do this in gates?
14:21:13 <e0ne> yep
14:21:42 <boris-42> e0ne: ok then it's questions to me
14:21:50 <e0ne> :)
14:21:52 <amaretskiy> boris-42: I'm ready to start implementing that after having patches related to new reports classes merged - these patches are ready for review (having all +1 from gates)
14:22:00 <kun_huang> e0ne: compare the performance with new patch and without new patch in gate?
14:22:02 <boris-42> amaretskiy: it's a bit different topic
14:22:12 <amaretskiy> boris-42: okay
14:22:23 <amaretskiy> boris-42: I can start this separately
14:22:34 <e0ne> kun_huang: yes. but i understand that we could get false-negative results
14:22:39 <boris-42> amaretskiy: that will be definitely useful
14:22:46 <boris-42> e0ne: yep
14:22:56 <amaretskiy> boris-42: okay, starting work on this patch...
14:23:05 <boris-42> e0ne: because gate jobs are run on different VMs
14:23:29 <e0ne> boris-42: you're right :(
14:23:39 <boris-42> e0ne: and some of VM are 2 times more powerful than other
14:23:49 <boris-42> e0ne: so I hade some ideas about this
14:24:07 <kun_huang> e0ne: boris-42 is it possible to do this in 3rd CI?
14:24:16 <boris-42> e0ne: e.g. running few benchmarks to measure CPU/IO/MEM/Ne
14:24:28 <boris-42> kun_huang: that is possible
14:24:49 <boris-42> e0ne: and then using this number normalize results
14:25:01 <boris-42> e0ne: but it's quite hard task imho
14:25:16 <e0ne> boris-42: sure
14:25:29 <kun_huang> e0ne: boris-42 https://01.org/sites/default/files/styles/project_screenshot/public/lkp-homepage.gif?itok=PHTL0syr
14:25:40 <e0ne> boris-42: and it will be implemented maybe only in N release
14:25:47 <kun_huang> in linux kernel, they do the job like this
14:26:02 <boris-42> e0ne: yep like that
14:26:20 <boris-42> kun_huang: so the thing is that in OpenStack they want to do this on every patch
14:26:22 <boris-42> kun_huang: in CI
14:26:52 <rvasilets> boris-42, we could find after some running of task the weakest vm. And start to use it like measure value) That try to find const that athoer vm have relitevaly to 'basic' vm. And try to divide avery value in proper graphic by this const maybe
14:27:18 <boris-42> rvasilets: that won't work
14:27:33 <boris-42> rvasilets: we need to find the way to normalize results
14:27:34 <rvasilets> it would be work fine of we have some permanent set of vms
14:27:52 <boris-42> rvasilets: nope it won't work because you can get merged patch
14:28:02 <boris-42> rvasilets: that destroys performance (e.g. 2 times)
14:28:20 <boris-42> rvasilets: after that you won't be able to merge anything because all other VMs won't be so powerful
14:28:25 <boris-42> and you will block gates
14:28:41 <boris-42> as well the idea is to have this job fully automatic
14:28:59 <e0ne> boris-42: +1
14:29:05 <boris-42> e.g. if performance was improved it should automatically find new baseline
14:30:48 <rvasilets> boris-42, agree
14:30:56 <boris-42> okay so someday we will work on this
14:31:07 <boris-42> but there are simpler and more important tasks at this point
14:31:27 <boris-42> as well we should prepare performance trends reports
14:31:32 <boris-42> which amaretskiy is already working on
14:31:34 <boris-42> e0ne: ^
14:31:50 <kun_huang> sounds good
14:31:53 <e0ne> great!
14:33:52 <boris-42> #agreed We will finish this task someday
14:34:16 <boris-42> #topic [rvasilets] Replace depraceted oslo.db code
14:34:24 <boris-42> rvasilets: so^
14:35:31 <rvasilets> #link https://review.openstack.org/#/c/205530/ Why looking at logs I found that https://github.com/openstack/oslo.db/blob/master/oslo_db/sqlalchemy/enginefacade.py#L830
14:35:50 <rvasilets> We have depraceted usage of oslo.db at code
14:36:00 <rvasilets> so I decide ro write a small patch
14:36:21 <rvasilets> if you like this idea please review it
14:36:22 <rvasilets> eom
14:36:46 <boris-42> rvasilets: yep we should do this
14:38:23 <kun_huang> it seems reasonable for me
14:38:43 <kun_huang> that's the suggestion from oslo
14:39:44 <yingjun> +1
14:39:56 <kun_huang> btw boris-42 rvasilets e0ne  does gate-rally-dsvm-verify block everyone now?
14:40:13 <boris-42> kun_huang: not sure
14:40:23 <amaretskiy> #agreed gate-rally-dsvm-verify looks broken
14:40:26 <boris-42> kun_huang: I had to do the stuff and didn't track rally for last 4 days
14:40:34 <boris-42> #topic  gate-rally-dsvm-verify looks broken
14:40:35 <rvasilets> нуы
14:40:36 <rvasilets> yes
14:40:41 <rvasilets> they a blocked
14:40:44 <boris-42> okay I will take a look today at it
14:40:48 <boris-42> and try to unblock it
14:40:54 <rvasilets> from 23 tp 24th
14:41:03 <rvasilets> nigth
14:41:04 <rvasilets> https://review.openstack.org/#/c/198877/4
14:41:09 <rvasilets> looks like by this patch
14:41:17 <rvasilets> I have talk with redixin
14:41:54 <rvasilets> and he thin that problem that we don;t have permissions at absolute paths
14:42:33 <redixin> rvasilets, did you try to install tempest into venv?
14:42:56 <rvasilets> I tried but found some other issues
14:43:18 <rvasilets> and I don't now what is they mean)
14:43:22 <boris-42> rvasilets: uh oh
14:44:26 <rvasilets> Do it install only with cloud or without too?
14:45:24 <rvasilets> Devstack have broken for me now. And without cloud I got following http://paste.openstack.org/show/405924/
14:47:48 <boris-42> rvasilets: ok guys
14:47:58 <boris-42> we will disucss this in rally chat
14:48:07 <boris-42> #topic Open discussion
14:48:07 <rvasilets> ok
14:48:14 <boris-42> do we have something to discuss?
14:48:36 <kun_huang> none from me
14:48:42 <amaretskiy> nothing special from me
14:48:45 <rvasilets> No. Nothing significant)
14:50:49 <boris-42> okay let's finish meeting
14:50:55 <boris-42> #endmeeting