14:08:09 <boris-42> #startmeeting Rally
14:08:09 <openstack> Meeting started Mon Jul 20 14:08:09 2015 UTC and is due to finish in 60 minutes.  The chair is boris-42. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:08:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:08:13 <openstack> The meeting name has been set to 'rally'
14:08:16 <boris-42> kun_huang: ping
14:08:18 <boris-42> amaretskiy: ping
14:08:30 <boris-42> redixin: ping
14:08:32 <amaretskiy> boris-42: hi
14:08:35 <kun_huang> :) let's start
14:08:38 <boris-42> stpierre: ping
14:08:44 <stpierre> pong
14:08:51 <yingjun> :)
14:08:53 <boris-42> oanufriev: ping
14:08:55 <boris-42> yingjun: hi
14:09:03 <yingjun> hi
14:09:16 <redixin> hi
14:09:53 <boris-42> okay
14:10:14 <boris-42> #topic Meeting agenda and how to make people work on it not at the very last moment
14:10:30 <boris-42> okay guys it's not ok to make agenda at very last point of time...
14:10:46 <boris-42> any ideas how to improve this?
14:11:07 <e0ne> hi
14:11:59 <amaretskiy> boris-42: maybe ask responsible man to repeat agenda by email at friday ?
14:12:28 <boris-42> rvasilets: ^
14:12:38 <stpierre> yeah, an earlier deadline is the only way that's going to happen. otherwise people will always remember something they want to add just before meeting time
14:12:43 <boris-42> rvasilets: maybe it's better not on friday?
14:12:54 <boris-42> stpierre: yep but today it was empty *
14:13:00 <boris-42> stpierre: 30 minutes ago
14:13:14 <rvasilets> Sorry, but now meeting manager stpierre, no?
14:14:00 <stpierre> i think a friday deadline makes sense
14:14:02 <rvasilets> I was sent email previously at thursday
14:14:20 <rvasilets> As boris-42 suggested to me
14:14:23 <stpierre> oh, i didn't even realize that was part of the job
14:14:41 <boris-42> rvasilets: so I believe you can just
14:14:45 <boris-42> rvasilets: send reminders
14:14:50 <temujin> hi all
14:14:55 <boris-42> rvasilets: so we would avoid such situtations
14:14:58 <boris-42> temujin: hi therer
14:15:00 <rvasilets> ok, I will sent reminders
14:15:04 <boris-42> rvasilets: thanks
14:15:12 <rvasilets> at what day you want?
14:15:25 <rvasilets> friday ok7
14:15:30 <yingjun> maybe anyone remember this may send email on friday?
14:15:45 <rvasilets> #vote
14:15:52 <rvasilets> #vote +1
14:16:13 <boris-42> what about Thursday?
14:16:23 <boris-42> because Friday is hard day
14:17:01 <amaretskiy> #vote for thursday
14:17:31 <kun_huang> both okay for me :)
14:17:37 <yingjun> #vote +1
14:17:38 <rvasilets> its reasonable too
14:18:02 <rvasilets> so lets it would be thursday?
14:18:12 <stpierre> thursday sounds good for a reminder
14:18:22 <boris-42> okay
14:18:47 <boris-42> #agreed meeting reminder on Thursday
14:18:54 <boris-42> okay next topic
14:19:21 <boris-42> #topic  [boris-42] Splitting Rally framework and OpenStack (updates)
14:19:58 <boris-42> Okay there were few patches
14:20:12 <boris-42> that makes rally framework independet from OpenStack
14:20:35 <boris-42> this https://review.openstack.org/#/c/202366/
14:20:59 <boris-42> is required for patch that will make our context responsible for mapping resources for each scenario iteration
14:21:25 <boris-42> e.g. I will move this code https://github.com/openstack/rally/blob/master/rally/task/runner.py#L47-L58
14:21:29 <boris-42> to ContextManager
14:21:41 <boris-42> I am going to publish this patch today later
14:21:48 <boris-42> any questions?
14:22:43 <amaretskiy> no questions
14:22:50 <kun_huang> nope
14:22:50 <rvasilets> no
14:23:33 <boris-42> great so after this step
14:23:44 <boris-42> we will have just 2 more things to refactor
14:24:00 <boris-42> task.verification and task.types
14:24:12 <boris-42> to run rally tasks with OpenStack clouds
14:24:27 <boris-42> and finally be able to start working on tox-self
14:24:39 <boris-42> functional testing that can be run without cloud
14:25:06 <boris-42> okay moving to next topic
14:25:17 <boris-42> #topic  [boris-42] Support of benchmarking multi API versions of projects with same plugins
14:26:01 <boris-42> So recently we introduced openstack scenario https://github.com/openstack/rally/blob/master/rally/plugins/openstack/scenario.py
14:26:20 <boris-42> It means that now we have place for OpenStack magic
14:26:31 <boris-42> that won't affect rally framework
14:26:52 <boris-42> so the idea is that we will have special context for openstack_api_versions
14:27:05 <boris-42> where you can specify info what python clients to create
14:27:20 <boris-42> and there will be validator for all scenarios (which versions they support)
14:27:40 <boris-42> and a bit magic in osclients and openstack.scenario to make this work
14:27:57 <boris-42> so overall it will be simple patch
14:28:02 <boris-42> any questions?
14:28:23 <rvasilets> look forward to you "a bit magic". No
14:28:37 <amaretskiy> great! no questions
14:28:43 <kun_huang> the purpose is good but it seems a bit magic
14:28:55 <kun_huang> do we need multiple python clients?
14:29:02 <stpierre> will it be trivial to test multiple versions in the same task? or will we need to specify multiple task configs to test, say, user creation on keystone v2 and v3?
14:30:01 <boris-42> kun_huang: no we don't need it
14:30:18 <boris-42> stpierre: we will be able to test different versions in the same task
14:30:24 <stpierre> awesome
14:30:32 <stpierre> do you have an example of how the task config will look?
14:30:33 <boris-42> stpierre: with the same benchamrks =)
14:30:44 <boris-42> stpierre: just one more conetxt
14:31:01 <boris-42> stpierre: "openstack_api": {"cinder": 2}
14:31:09 <kun_huang> okay, look forward on this
14:31:28 <stpierre> will lists work? e.g., {"keystone": [2, 3]} would run the scenario with keystone v2 and v3?
14:31:40 <boris-42> stpierre: nope
14:31:52 <boris-42> stpierre: you have to speicfy to different test case
14:31:55 <stpierre> okay, so i will need to duplicate the config
14:32:05 <stpierre> that's kind of a shame. could we make lists work?
14:32:17 <boris-42> stpierre: use jinja2 template
14:32:20 <stpierre> oh!
14:32:27 <stpierre> good, carry on :)
14:32:32 <boris-42> stpierre: it's bad idea to break the logic
14:32:36 <boris-42> stpierre: of whole rally
14:32:51 <boris-42> stpierre: and idea of having simple task format without any magic
14:33:07 <boris-42> stpierre: to make from one scenario 2
14:33:15 <stpierre> yeah, makes sense
14:33:24 <boris-42> especially when you can make a for with 2 args
14:33:24 <stpierre> i wasn't thinking of how backwards that would be
14:34:33 <boris-42> stpierre: I mean there is nothing non backward in my proposal
14:35:03 <boris-42> stpierre: we are just adding via context info about required versions and use them when we are initializing clients in openstack.scneario class
14:35:10 <boris-42> stpierre: +verificators
14:35:20 <stpierre> yeah, it all makes sense
14:35:21 <stpierre> thanks
14:36:39 <e0ne> boris-42: it's great!
14:37:57 <boris-42> okay guys
14:38:00 <boris-42> next topic
14:38:11 <boris-42> #topic [amaretskiy] Status for patches related to new streaming Reports generation:
14:39:06 <amaretskiy> there were some comments regarding changes in these patches, so last week I implemented these changes
14:39:34 <amaretskiy> and now all patches are done - I'm currently trying to get +1 from jenkins for some of them
14:39:49 <amaretskiy> making recheck and fixing issues
14:40:03 <amaretskiy> so now at least 2 patches are ready for review right now
14:40:08 <amaretskiy> these patches are:
14:40:19 <amaretskiy> https://review.openstack.org/#/c/201611/
14:41:03 <amaretskiy> #link https://review.openstack.org/#/c/201611/
14:41:14 <amaretskiy> #link ps://review.openstack.org/#/c/159458/
14:41:46 <amaretskiy> another patches in thread (all patches are in dependency) are on their way to get +1 from gates
14:41:57 <amaretskiy> so please make reviews
14:42:17 <rvasilets> #link https://review.openstack.org/#/c/159458/
14:42:41 <amaretskiy> rvasilets: thanks
14:42:54 <amaretskiy> so, please review them
14:43:38 <amaretskiy> I believe other 2 patches (https://review.openstack.org/#/c/146814/ and https://review.openstack.org/#/c/169828/) will be ready today
14:43:49 <amaretskiy> but in any case they are ready for review too
14:43:51 <amaretskiy> eom
14:44:47 <kun_huang> rvasilets: no problems
14:45:09 <boris-42> amaretskiy: ok thanks
14:45:25 <boris-42> amaretskiy: ok thanks
14:46:03 <boris-42> amaretskiy: ok thanks
14:46:37 <boris-42> test
14:46:40 <boris-42> test
14:46:42 <amaretskiy> :)
14:49:22 <boris-42> ping
14:49:32 <rvasilets> boris-42, pomg
14:49:55 <rvasilets> #topic Ironic benchmarks
14:50:07 <boris-42> p
14:50:16 <rvasilets> ok lets move further
14:51:03 <rvasilets> I have finished Ironuc benchmarks
14:51:10 <rvasilets> *Ironic
14:51:15 <rvasilets> #link https://review.openstack.org/#/c/186064/
14:51:30 <rvasilets> And now I strongly need for review
14:51:52 <rvasilets> I have requesteed a few times for a wekk in Rally irc chat for review
14:51:54 <boris-42> ppp
14:52:09 <rvasilets> and Yair promised to me to review it a week ago
14:52:23 <rvasilets> but there is now review from core teeam on this patch
14:52:42 <rvasilets> also it was reviewed by Ironuc cores few times
14:52:55 <rvasilets> So please review it
14:53:05 <rvasilets> #help need review
14:53:10 <rvasilets> boris-42, eom
14:53:32 <boris-42> test
14:53:33 <rvasilets> #topic free discussion
14:53:44 <rvasilets> is there any question?
14:54:17 <amaretskiy> no
14:54:32 <kun_huang> nope
14:55:02 <yingjun> any progress about API?
14:56:09 <amaretskiy> yingjun: do you mean https://review.openstack.org/#/c/182245/ ?
14:56:10 <kun_huang> yingjun: it is just updated before meeting
14:56:16 <boris-42_> ping
14:56:18 <boris-42_> whou works
14:56:28 <rvasilets> boris-42_, pong
14:56:41 <yingjun> amaretskiy, yep
14:56:43 <boris-42_> not sure that I will be able to end meeting
14:56:53 <rvasilets> boris-42_, I will end
14:57:05 <boris-42_> rvasilets: you can't end the meeting
14:58:07 <rvasilets> yingjun, as I understand It now on review
14:58:41 <rvasilets> and after amaretskiy finished his report he will take part on it maintance
14:59:05 <amaretskiy> kun_huang: please remind who handle spec https://review.openstack.org/#/c/182245/ ? I thought that is you :)
14:59:06 <boris-42> #endmeeting