21:01:27 <markmcclain> #startmeeting quantum
21:01:27 <openstack> Meeting started Mon Apr  1 21:01:27 2013 UTC.  The chair is markmcclain. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:30 <openstack> The meeting name has been set to 'quantum'
21:01:42 <markmcclain> #info agenda https://wiki.openstack.org/wiki/Network/Meetings
21:02:05 <markmcclain> #topic Announcements
21:02:08 <enikanorov> hi
21:02:18 <salv-orlando> hi
21:02:40 <alexpilotti> hi
21:02:47 <markmcclain> #info RC2 was released last week.  I thought we had escaped without any major bugs, but one has popped up.
21:03:04 <markmcclain> https://bugs.launchpad.net/quantum/+bug/1162626
21:03:07 <uvirtbot> Launchpad bug 1162626 in quantum "lb-vip and security groups don't work together" [High,Confirmed]
21:03:19 <danwent> not sure if the title is accurate anymore
21:03:23 <markmcclain> arosen has been tracking this one down
21:03:29 <markmcclain> arosen want to fill us in?
21:04:06 <salv-orlando> he commented on the bug about 15 minutes ago
21:04:08 <enikanorov> not lb-vip specific
21:04:18 <danwent> i think he's working on it right now
21:04:18 <arosen> markmcclain:  yup
21:04:34 <enikanorov> the same happens with dhcp or router ports if floating ip is associated
21:05:04 <danwent> i think it may have been intentional for dhcp ports
21:05:05 <arosen> markmcclain: the issue is there is no route in the namespace for the vip-ip
21:05:23 <arosen> yup i think that's intentional for dhcp ports
21:05:34 <arosen> as they don't need a route to the default gw
21:06:17 <Nachi> I'm not sure why lb is working on my test lab if there are no route..
21:06:33 <danwent> Nachi, are you connecting from the local subnet?
21:06:35 <Nachi> It looks like not the problem of security group
21:06:38 <Nachi> danwent: yes
21:06:48 <danwent> this problem will only happen if you are not on the local subnet
21:06:58 <Nachi> danwent: Ah it make sence thanks
21:07:00 <danwent> (e.g., via a floating IP, or a VM on another subnet connected to the same router)
21:07:02 <arosen> Nachi:  right it's not a security group problem. It's a route issue. I'll update the bug.
21:07:15 <Nachi> arosen: thanks
21:07:35 <markmcclain> Seems like this bug is significant enough that should look into fixing it prior to release
21:07:38 <danwent> floating IPs + VIPs seem like a likely deployment model, so to me this seems important
21:07:54 <danwent> not to mention multi-tier apps
21:08:02 <markmcclain> agreed
21:08:16 <danwent> this late in the game, i would suggest that only this single change is made for an RC3
21:08:45 <danwent> (rather than piling in other changes that may be targeted for a stable release…. we don't have much time for additional testing, and I like that the change would be scoped only to lbaas)
21:09:01 <mestery> +1 to that idea danwent
21:09:06 <markmcclain> danwent: I agree
21:09:34 <gongysh> I think we need unicode bug https://review.openstack.org/#/c/25489/
21:09:35 <simple_bot1235> I got pinged!
21:09:47 <gongysh> should be candidate.
21:09:58 <gongysh> unicode is important in Asia market
21:10:16 <danwent> that is a python-quantumclient change, no?
21:10:22 <danwent> (or at least that review is)
21:10:22 <Nachi> gongysh: +1
21:10:41 <salv-orlando> yes, it's a client side change
21:10:45 <gongysh> https://review.openstack.org/#/c/25482/
21:10:55 <gongysh> there are two parts.
21:10:55 <danwent> the client is released separately
21:11:02 <salv-orlando> as always
21:11:06 <danwent> yeah, i thought I saw a server side change
21:11:10 <danwent> do you have that review?
21:11:15 <gongysh> server side and client side.
21:11:21 <gongysh> I reviewed server side.
21:11:33 <danwent> my bias is to delay everything until the next stable release unless it completely prevents a key use case
21:11:46 <salv-orlando> excluding unit tests is a small change
21:12:22 <danwent> salv-orlando: ok, let's make a note that we should review that as well for possible inclusion in RC3
21:12:26 <danwent> we will talk with ttx about it.
21:12:27 <gongysh> I think the unit tests is not big for the unicode one.
21:12:41 <salv-orlando> danwent: agreed
21:13:06 <markmcclain> salv-orlando and danwent do you all want to review that change?
21:13:17 <danwent> can someone send a link?
21:13:25 <markmcclain> https://review.openstack.org/#/c/25482/5
21:14:02 <mikal> :wq
21:14:08 <danwent> ok, that seems like a pretty safe change
21:14:16 <danwent> save that text mikal !
21:14:23 <mikal> Doh
21:14:27 <danwent> :)
21:14:29 <markmcclain> haha
21:15:02 <danwent> gongysh: that change seems to only be in an error handler, am i missing something?
21:15:26 <gongysh> that is for serializer to str msg.
21:15:27 <salv-orlando> it probably has to do with __str__ vs __repr__ but I'm not sure
21:15:36 <danwent> ah, missed the change below the tests
21:15:52 <gongysh> particularly to exception one.
21:16:18 <danwent> is this code change inline with what other projects are already doing to handle unicode?
21:16:29 <danwent> if so, we can consider the change pretty safe
21:16:39 <danwent> since it is effectively already been tested in other projects
21:16:41 <gongysh> yes, this is inline with olso's wsgi.
21:17:15 <danwent> ok, assuming the review check out, i'm OK with in an RC3 if markmcclain + salv-orlando are
21:17:41 <danwent> change to non-test code is tiny, and we can validate against other code already in another project
21:17:55 <salv-orlando> I am ok with RC-3. There also very good coverage
21:17:59 <salv-orlando> from unit tests side
21:18:04 <markmcclain> danwent: I think this is a good candidate to include in RC3
21:18:13 <danwent> do we need another client release as well?
21:18:44 <markmcclain> the client concerns me more
21:18:49 <markmcclain> there are no tests
21:19:04 <gongysh> I will ask him to write test codes.
21:19:18 <gongysh> that is why I don't review that patch.
21:19:58 <gongysh> will we release another release of client for the server RC3?
21:20:14 <markmcclain> The client is on it's own release cycle, so we can push a 2.2.1 when we're ready
21:20:23 <gongysh> ok
21:21:03 <markmcclain> Any other release blocking bugs?
21:21:27 <markmcclain> #topic Grizzly Documentation
21:21:30 <danwent> ok, we need both of those bugs tagged with grizzly-backport-potential
21:21:40 <markmcclain> danwent: I'll take care of it
21:21:55 <danwent> markmcclain: thx.  we'll ping ttx and give him the news :(
21:22:34 <markmcclain> #action markmcclain and danwent to update ttx on release candidate bugs
21:22:41 <danwent> #info on the admin docs side, there has been some progress, but a lot of items are still outstanding, with the release on thursday
21:22:45 <danwent> #link https://bugs.launchpad.net/openstack-manuals/+bugs?field.tag=quantum
21:22:58 <danwent> right now, i'm just focusing on community-wide items, which are marked as 'high'
21:23:09 <annegentle> danwent: as long as you are honest about what's done/not done, we won't "cut a docs release" for a few weeks
21:23:27 <annegentle> danwent: not that I want to delay you, but just letting you know what we've done historically
21:23:37 <danwent> annegentle: yup, but I want to at least have enough for a basic setup done by the release
21:23:42 <annegentle> danwent: perfect
21:24:07 <danwent> hehe, yeah.  more advanced features and different knobs one can tweak are ok to come in late, but in terms of getting the basic thing up, I'd like that done ASAP
21:24:17 <danwent> markmcclain says this is already in progress: https://bugs.launchpad.net/openstack-manuals/+bug/1099573
21:24:20 <uvirtbot> Launchpad bug 1099573 in openstack-manuals "Quantum Metadata Proxy should be documented" [High,Confirmed]
21:24:43 <danwent> given that this changed substantially since folsom, i think this is really important
21:24:50 <danwent> https://bugs.launchpad.net/openstack-manuals/+bug/1099574
21:24:51 <uvirtbot> Launchpad bug 1099574 in openstack-manuals "Quantum DB migration" [High,Confirmed]
21:25:16 <markmcclain> danwent: just as important as the first
21:25:23 <danwent> agreed.
21:25:34 <markmcclain> I'll get them polished so that I can push for review
21:25:42 <danwent> getting lbaas docs in so people can tested is valuable:
21:25:43 <danwent> https://bugs.launchpad.net/openstack-manuals/+bug/1156828
21:25:45 <uvirtbot> Launchpad bug 1156828 in openstack-manuals "q-admin: basic lbaas workflow" [High,Confirmed]
21:25:51 <danwent> https://bugs.launchpad.net/openstack-manuals/+bug/1157034
21:25:53 <uvirtbot> Launchpad bug 1157034 in openstack-manuals "quantum lbaas install - Ubuntu" [High,Confirmed]
21:26:22 <danwent> i'm going to update those 4 items to be critical priority, so we can focus on getting them done this week.
21:26:26 <danwent> rkukura: around?
21:26:34 <rkukura> yes
21:26:55 <danwent> just wanted to understand status of rhel docs
21:27:25 <danwent> so far, i've mainly be testing with ubuntu, so i don't have as good of a feel there, but its very important as well.
21:28:09 <rkukura> I don't have any update on the status - not sure if others have been working on this or not
21:28:25 <danwent> ok, so currently there is http://docs.openstack.org/trunk/openstack-network/admin/content/install_fedora.html
21:29:08 <danwent> I'll file an issue for someone to re-test with grizzly, identify spots where changes are needed
21:29:26 <markmcclain> danwent: sounds good
21:29:39 <rkukura> +1
21:29:40 <danwent> based on what annegentle said, i guess its ok if those aren't updated for a while, though perhaps we should put a warning note in there
21:30:02 <danwent> in the mean time, as I wouldn't want somebody thinking they had been updated for grizzly, just because other parts of the doc had been
21:30:24 <danwent> #action #danwent file issue on updating fedora install docs, add warning to docs in teh mean time
21:30:41 <danwent> salv-orlando: how are API docs looking?
21:30:52 <salv-orlando> https://bugs.launchpad.net/openstack-api-site/+bugs?field.tag=netconn-api
21:31:04 <salv-orlando> All patches but two are under review
21:31:23 <salv-orlando> I am reviewing all of them, should finish my round of review by tomorrow.
21:31:41 <salv-orlando> We still are missing two extensions
21:31:58 <salv-orlando> bug 1157159
21:32:00 <uvirtbot> Launchpad bug 1157159 in openstack-api-site "Quantum API - Document Port Bindings Extension" [High,New] https://launchpad.net/bugs/1157159
21:32:10 <salv-orlando> this is mine, and I will push the documents for review tomorrow
21:32:13 <danwent> that one isn't really user-facing, so isn't a big deal
21:32:19 <salv-orlando> indeed
21:32:22 <danwent> but its good for completeness
21:32:27 <salv-orlando> the one I would like to see in really is
21:32:31 <salv-orlando> byg 1157156
21:32:35 <salv-orlando> bug 1157156
21:32:37 <uvirtbot> Launchpad bug 1157156 in openstack-api-site "Quantum API - Extra Route extension" [High,New] https://launchpad.net/bugs/1157156
21:32:43 <salv-orlando> As it it also used by many plugins
21:32:53 <danwent> k, makes sense
21:33:01 <salv-orlando> it is currently assigned to nati-ueno, but can reassign if he's busy
21:33:09 <salv-orlando> It should not take too much time to document
21:33:10 <danwent> well, sounds like we've made good progress on teh API side
21:33:21 <danwent> so now the admin docs folks need to play catch-up :)
21:33:31 <danwent> ok, anything else on the docs side?
21:34:10 <gongysh> If we need to update the use case diagram?
21:34:50 <nati_ueno> salv-orlando: I'll do this ticket in this week. sorry
21:34:52 <danwent> gongysh: are you talking about diagrams like http://docs.openstack.org/trunk/openstack-network/admin/content/use_cases_tenant_router.html ?
21:35:00 <gongysh> I mean add metadata agent/proxy stuff.
21:35:05 <salv-orlando> nati_ueno: ok, thanks
21:35:27 <danwent> gongysh: metadata agent/proxy install is being covered by markmcclain .  the nova flags needed are already in
21:35:42 <danwent> the overall topology diagram should be updated to show the metadata agent though
21:35:52 <danwent> let me see if i already have that noted in one of the bugs, one sec
21:36:07 <danwent> yeah: https://bugs.launchpad.net/openstack-manuals/+bug/1152838
21:36:08 <uvirtbot> Launchpad bug 1152838 in openstack-manuals "update quantum physical layout diagram" [High,Triaged]
21:36:29 <gongysh> http://docs.openstack.org/trunk/openstack-network/admin/content/figures/2/figures/demo_flat_install.png
21:36:53 <gongysh> that is one of them.
21:37:14 <danwent> ah, yeah, there are other diagrams in the demos....
21:37:18 <salv-orlando> I wouldn't include metadata in tenant use cases, but this is my opinion only
21:38:00 <danwent> the above bug is only for the main quantum physical layout.  i'd file another bug for those demos… there may be other commands that need to be updated in them along with the diagrams
21:39:09 <gongysh> ok
21:39:22 <markmcclain> gongysh: you going to file the bug for the demos?
21:39:36 <danwent> yeah, there's definitely text updates needed as well
21:39:47 <danwent> as they currently don't install the metadata agent
21:39:51 <gongysh> I will try to see if we need to change them.
21:40:11 <gongysh> If these cases speaks to the medata data access, we need to update.
21:40:15 <danwent> i'm also concerned about the fact that the demos disable namespaces
21:40:46 <danwent> markmcclain: will that work with metadata proxy?
21:40:55 <danwent> i forget if that requires namespaces or not
21:41:27 <markmcclain> danwent: double checking
21:41:28 <gongysh> dhcp isolated metadata requires namespace.
21:41:43 <gongysh> l3 metadata doesnot.
21:41:52 <danwent> ah, ok.
21:42:05 <markmcclain> gongysh: is correct
21:42:17 <danwent> yeah, as long as you use one router… that makes sense
21:42:44 <danwent> i'm a little worried that our demos suggest running l3-agent + dhcp-agent on the same host without namespaces
21:42:45 <gongysh> yes, one router is fine with non-namespace.
21:43:10 <markmcclain> danwent: that will be problematic as there is already a proposed patch to explicitly prevent it
21:43:11 <gongysh> danwent, I will scan them.
21:43:12 <danwent> but we can take this offline
21:43:45 <danwent> gongysh: let's just tackle this as part of the bug for updating the demo scenarios for grizzly
21:44:02 <danwent> ok, anything else on docs?
21:44:12 <markmcclain> #action #gongysh to file a bug to update demo docs
21:44:44 <markmcclain> Thanks Dan for the docs update.
21:44:54 <markmcclain> #topic Portland Design Summit
21:45:07 <markmcclain> It's April which means the design summit is a little less than two weeks away.
21:45:17 <markmcclain> #info Our sessions run Monday, Tuesday, and Wednesday.
21:45:35 <markmcclain> Last week we put out the call for proposals and you responded.  Our track is now overflowing.
21:45:56 <markmcclain> I wish we could schedule them all, but we only have a finite amount of time.
21:46:15 <markmcclain> We had several popular topics: FWaaS, L3 Modularity, and VPNaaS.
21:47:02 <markmcclain> I also want to add that testing was popular too.  It is good to see the community interested into way to Quantum tests more efficient and complete.  These kinds of topics really help everyone.
21:47:43 <markmcclain> Since we have more proposals than available slots, we will have to merge some sessions together.
21:48:11 <gongysh> I think we should have a session to make L2 and current L3 can replace nova-network well.
21:48:11 <markmcclain> Some of the proposers have already begun to coordinate which is a good head start.
21:48:31 <markmcclain> gongysh: That session is already pre-approved in the Nova track
21:48:41 <gongysh> great, thanks
21:48:43 <markmcclain> It should take place on Thursday
21:49:13 <markmcclain> A few topics will be moved to discussion via the mailing line or to the unconference space.
21:50:07 <markmcclain> It does not mean the topic is unimportant or unwanted it is just that certain topics are better discussed in person and others can easily be worked out via email.
21:51:19 <markmcclain> I'll be working on the schedule this week and a rough schedule will be available by the next team meeting.
21:51:53 <markmcclain> Any questions on the design summit sessions?
21:52:06 <nati_ueno> When we have beer sessions?
21:52:12 <marun> salv-orlando: would like to coordinate with you regarding: http://summit.openstack.org/cfp/details/235
21:52:12 <danwent> sunday night
21:52:12 <gongysh> haha
21:52:28 <danwent> details are TBD.. markmcclain and i are working on it
21:52:32 <nati_ueno> agha my fligh is midnight of sunday..
21:52:48 <danwent> nati_ueno: well then you will have some catching up to do when you hit the bars later that night :)
21:52:56 <nati_ueno> danwent: hehe
21:53:44 <danwent> ok, sounds good
21:53:51 <danwent> portland should be a lot of fun
21:54:00 <salv-orlando> marun: sure - feel free to use the Openstack dev mailing list or send me an email
21:54:09 <marun> salv-orlando: will do
21:54:19 <danwent> i can smell the beer already!
21:55:03 <danwent> ok, sounds like we can end this one a bit early...
21:55:09 <amotoki> next stable release is planned?
21:55:13 <markmcclain> # open discussion
21:55:24 <markmcclain> amotoki:  Folsom or Grizzly stable release?
21:55:32 <amotoki> Folsom
21:55:58 <markmcclain> I believe the stable team is targeting some late next
21:55:58 <gongysh> danwent: I think there are only some kinds of animals who can have such smart noses.
21:56:17 <danwent> gongysh: actually, its just b/c i have a beer right next to me :P
21:56:55 <gongysh> danwent: I can smell now too.
21:57:03 <markmcclain> amotoki: http://lists.openstack.org/pipermail/openstack-stable-maint/2013-March/000353.html
21:57:03 <salv-orlando> danwent: btw, is it a holiday today in the US? If not you should not be drinking during office hours :p
21:57:06 <danwent> gongysh: its a little early for now, no?
21:57:23 <danwent> salv-orlando: its always a party in my office :P
21:57:38 <danwent> salv-orlando: you're not going to report me, are you?
21:57:51 <amotoki> markmcclain: thanks. I haven't run Folsom release recently.
21:57:56 <salv-orlando> I think I'll join you (but next monday, not today)
21:58:06 <danwent> amotoki: i couldn't find a pointer to the next one
21:58:18 <danwent> amotoki: i'd potentially ask during the team meeting tomorrow
21:58:48 <markmcclain> danwent: I linked the thread in the stable ML
21:59:05 <markmcclain> you got distracted by the beer :p
21:59:10 <danwent> markmcclain: ah, missed that.. indeed!
21:59:30 <gongysh> danwent: then I know why my docs patches did not get reviewed these days.
21:59:37 <gongysh> :)
21:59:45 <annegentle> gongysh: hee
21:59:57 <danwent> gongysh: that beer isn't going to just drink itself :P
22:00:20 <danwent> beer helps write docs, but does not help review them
22:00:32 <gongysh> got it. :)
22:00:40 <markmcclain> Ok.. well its time… let's put a good push to finish up the docs so that folks who try Grizzly have a great experience.
22:00:43 <markmcclain> #endmeeting