14:00:17 <gmann> #startmeeting qa
14:00:18 <openstack> Meeting started Tue Feb 16 14:00:17 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:22 <openstack> The meeting name has been set to 'qa'
14:00:48 <gmann> who all here today?
14:01:29 <kopecmartin> hi o/
14:02:32 <gmann> let's wait for couple of min.
14:03:28 <kopecmartin> sure
14:05:40 <gmann> kopecmartin: seems two of us only.
14:05:50 <kopecmartin> yeah :)
14:05:59 <gmann> I would like to discuss on cutting new release for Tempest, so let's directly jump on those and skip the general agenda
14:06:10 <kopecmartin> ok
14:06:31 <gmann> and gate status we can check
14:06:40 <gmann> #topic Gate Status Checks
14:07:13 <gmann> stable/stein started failing with Tempest and plugins master, for neutron it did break
14:07:29 <gmann> capping Tempest 26.0.0 for stable/stein is merged #link https://review.opendev.org/c/openstack/devstack/+/774103
14:07:53 <gmann> and plugins also can cap the plugins compatible version in stein job
14:08:23 <gmann> py2 fixes are not merged yet, I need to fix the review comments
14:08:53 <gmann> #link https://review.opendev.org/q/I5b2217d85e6871ca3f7a3f6f859fdce9a50d3946
14:09:03 <gmann> any other gate failure?
14:09:29 <kopecmartin> I'm not aware of any other
14:09:49 <gmann> cool
14:09:51 <gmann> #topic Periodic jobs Status Checks
14:10:01 <gmann> #link https://zuul.openstack.org/builds?job_name=tempest-full-victoria-py3&job_name=tempest-full-ussuri-py3&job_name=tempest-full-train-py3&pipeline=periodic-stable
14:10:09 <gmann> #link https://zuul.openstack.org/builds?job_name=tempest-all&job_name=tempest-full-oslo-master&pipeline=periodic
14:10:11 <gmann> its all green
14:10:17 <gmann> tempest-all also green now
14:10:24 <kopecmartin> \o/
14:10:29 <gmann> #topic Sub Teams highlights (Sub Teams means individual projects under QA program)
14:10:31 <gmann> Tempest
14:10:52 <gmann> we need to cut new release for tempest run new interface to be used by plugins
14:11:31 <gmann> I will open the bug for devstack/tempest for plugins not tested with Tempest master, so that we can track that issue separately
14:11:36 <openstackgerrit> Lajos Katona proposed openstack/tempest master: WIP: Add live migration with trunk test  https://review.opendev.org/c/openstack/tempest/+/774689
14:11:41 <kopecmartin> perfect
14:11:45 <gmann> #action gmann to open bug for devstack/tempest for plugins not tested with Tempest master.
14:12:01 <gmann> and for new release, did your fix merge?
14:12:14 <kopecmartin> yes
14:12:27 <gmann> perfect
14:12:29 <gmann> #link https://review.opendev.org/c/openstack/tempest/+/774835
14:12:47 <gmann> few patches I would like to wait for new release
14:13:03 <gmann> 1. #link https://review.opendev.org/c/openstack/tempest/+/773159
14:13:06 <gmann> this is in gate
14:13:16 <gmann> 2. #link https://review.opendev.org/c/openstack/tempest/+/773177/3
14:13:29 <gmann> this I will work today, need only unit test
14:14:05 <gmann> 3. https://review.opendev.org/c/openstack/tempest/+/774913
14:14:18 <gmann> this need devstack patches to merged first
14:14:34 <gmann> so 3rd I can do after release too if it taking time so let's see
14:14:48 <gmann> kopecmartin: anything from your side, you want to include in new release?
14:15:03 <kopecmartin> we merged a ton of patches regarding the scenario manager effort
14:15:12 <kopecmartin> do we want to mention that in the releasenotes for this release?
14:15:28 <gmann> not yet until we declare that it is stable
14:15:35 <gmann> we can cut one more new release for that
14:15:47 <kopecmartin> ok, makes sense
14:16:17 <kopecmartin> i don't have probably any patch which should be merged before the relase
14:16:25 <gmann> cool.
14:16:25 <kopecmartin> i'll check after the meeting, if any i'll ping you
14:16:34 <gmann> kopecmartin: that is all from my side, anything you would like to discuss before we close office hour?
14:16:47 <kopecmartin> it's also worth to mention that we will go forward with patches removing six
14:16:54 <kopecmartin> #link https://review.opendev.org/q/project:openstack/tempest+status:open+topic:remove-six
14:17:01 <gmann> ah right
14:17:21 <kopecmartin> I made a few comments there
14:17:23 <gmann> six removal is all good now and we can merge them anytime, do not need to wait for release time or so
14:17:49 <kopecmartin> good
14:18:16 <gmann> if we do not hear anything from authors in this week then either of us can fix those and merge.
14:18:36 <gmann> let me add actions
14:18:57 <gmann> #action gmann to cut the Tempest new release after required patches merged
14:19:13 <gmann> #action kopecmartin /gmann to follow up on six removal patches
14:19:24 <gmann> anything else?
14:19:28 <kopecmartin> great
14:19:29 <kopecmartin> bugs?
14:19:50 <kopecmartin> there is one with high priority which has a fix
14:19:52 <gmann> any critical bug you would like to talk?
14:19:53 <kopecmartin> #link https://review.opendev.org/c/openstack/tempest/+/642237
14:19:55 <gmann> sure
14:20:18 <gmann> #topic Bug Triage (last 30 min)
14:20:27 <gmann> #link https://review.opendev.org/c/openstack/tempest/+/769238/1
14:20:40 <gmann> #link https://review.opendev.org/c/openstack/tempest/+/642237
14:20:41 <gmann> this one
14:20:52 <gmann> I need to review that, again forget
14:20:57 <kopecmartin> sure, np
14:21:04 <gmann> I think this also need to get merged before release
14:21:21 <kopecmartin> it would be better
14:21:23 <gmann> 4. release candidate #link https://review.opendev.org/c/openstack/tempest/+/642237
14:21:38 <gmann> I will review after my breakfast
14:22:06 <kopecmartin> this is not a bug, but it's last patch related to pdf documentation QA effort
14:22:08 <kopecmartin> #link https://review.opendev.org/c/openstack/eslint-config-openstack/+/752227/
14:22:27 <kopecmartin> just wanted to bring this up
14:23:22 <gmann> done still no link in generated doc
14:23:25 <gmann> #link https://098ce36f4570c4ae2179-f63b2c309fc0040fbb4a377b77794f40.ssl.cf2.rackcdn.com/752227/11/check/nodejs-run-docs/babd34e/docs/
14:23:58 <kopecmartin> ah, will fix that today
14:24:07 <gmann> ack
14:24:10 <gmann> thanks
14:24:27 <kopecmartin> last one
14:24:37 <kopecmartin> #link https://bugs.launchpad.net/tempest/+bug/1668407
14:24:39 <openstack> Launchpad bug 1668407 in tempest "os-assisted-volume-snapshots client is not available" [Low,In progress] - Assigned to Martin Kopec (mkopec)
14:24:52 <kopecmartin> i found a related patch
14:24:54 <kopecmartin> #link https://review.opendev.org/c/openstack/tempest/+/466902
14:25:12 <kopecmartin> however it turned out that the client is meant to be used by cinder internally
14:25:27 <kopecmartin> which made me wondering if the bug is still valid
14:25:29 <kopecmartin> as it's quite old
14:25:44 <kopecmartin> s/client/API
14:26:36 <gmann> kopecmartin: yeah but there is no better way we differentiate such APIs, update volume attachment is another example and i think we do have test for that
14:26:42 <gmann> we can add this client.
14:27:21 <gmann> we have two patches up for that
14:27:38 <gmann> let me see which one is close and then we can work on those
14:27:48 <gmann> either of onwe
14:28:46 <gmann> any other bug to discuss?
14:29:02 <kopecmartin> no,that's all
14:29:25 <gmann> ok, let's close office hour then
14:29:33 <gmann> thanks kopecmartin for joining
14:29:37 <gmann> #endmeeting