14:01:31 <gmann> #startmeeting qa
14:01:32 <openstack> Meeting started Tue Feb  2 14:01:31 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:36 <openstack> The meeting name has been set to 'qa'
14:01:48 <kopecmartin> hi all o/
14:01:50 <gmann> who all here today?
14:03:06 <gmann> kopecmartin: seems two of us
14:03:13 <kopecmartin> it seems so
14:03:20 <lpiwowar> Hi
14:03:35 <gmann> lpiwowar: hi
14:04:01 <gmann> let's start anyways
14:04:03 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
14:04:07 <gmann> today agenda ^^
14:04:39 <gmann> #topic Announcement and Action Item (Optional
14:04:53 <gmann> nothing on this, no AI from previous meeting
14:05:06 <gmann> #link Wallaby Priority Items progress
14:05:15 <gmann> #link https://etherpad.opendev.org/p/qa-wallaby-priority
14:05:27 <soniya29> hello all
14:05:35 <gmann> soniya29: hi
14:06:05 <paras333> no update from my end, I will be working on it this week
14:06:05 <gmann> for RBAC testing strategy, L45: we have most of the patches merged
14:06:11 <kopecmartin> no updates from my side wrt priority items
14:06:13 <gmann> but i see some bug for system admin
14:06:34 <gmann> this one #link https://review.opendev.org/c/openstack/tempest/+/773173/3
14:06:37 <gmann> kopecmartin: ^^
14:06:58 <gmann> also adding reno and fixing some todo #link https://review.opendev.org/c/openstack/tempest/+/773159/5
14:07:09 <gmann> after these I think we can close this item
14:07:57 <gmann> kopecmartin: soniya29 anything to bring on scenario manager?
14:08:01 <soniya29> I am working on the remaining stuffs of sceanrio managaer
14:08:26 <gmann> #link https://review.opendev.org/q/topic:bp/tempest-scenario-manager-stable+status:open+
14:08:29 <gmann> soniya29: great
14:08:51 <kopecmartin> almost all reviews up, need just core reviews  basically
14:09:07 <soniya29> two patches are up and i will be adding another two which would complete - non-private apis stuff
14:09:18 <gmann> yeah, 2-3 are hanging for single +2 for long
14:09:48 <gmann> I did not propose the single core review yet, I will do right after meeting that will help to merge these fast
14:10:08 <gmann> #action gmann to propose single core review merge policy for Tempest
14:10:17 <gmann> anything else on wallaby priority
14:11:16 <gmann> let's move if nothing
14:11:18 <gmann> #topic Gate Status Checks
14:11:47 <soniya29> gmann, I have gone through the patrole links you passed in the earlier meetings. So do the patrole maintainance item requires reviewing of the patches or any other help is required?
14:11:49 <gmann> get-pip things are merged for py2.7/3.5 in all required stable
14:12:09 <gmann> soniya29: nice, let's talk that in patrole topic
14:12:18 <soniya29> sure
14:12:23 <gmann> any other gate failure anyone noticing ?
14:12:39 <kopecmartin> maybe this
14:12:40 <kopecmartin> #link https://bugs.launchpad.net/tempest/+bug/1914037
14:12:42 <openstack> Launchpad bug 1914037 in tempest "scenario tests tempest.scenario.test_network_v6.TestGettingAddress fails" [Undecided,New]
14:13:46 <gmann> kopecmartin: is it happening all the time or randomly?
14:14:13 <kopecmartin> i'd say randomly, i haven't notice such an issue in our gates
14:14:21 <kopecmartin> it occurred in tempest-slow
14:14:51 <gmann> ah, and do we have tempest-slow running on rocky gate ?
14:14:55 <kopecmartin> we had a patch merged which was supposed to address this
14:14:56 <kopecmartin> #link https://review.opendev.org/c/openstack/tempest/+/763621
14:15:05 <kopecmartin> but seems it's not working for ipv6?
14:15:07 <kopecmartin> let me check
14:16:10 <gmann> yeah we do run, i am checking nova gate #link https://review.opendev.org/c/openstack/nova/+/758735
14:16:28 <gmann> and it does fail with same error
14:16:55 <gmann> anyways let's discuss it in bug section
14:17:15 <gmann> Periodic stable gate is green: #link https://zuul.openstack.org/builds?job_name=tempest-full-victoria-py3&job_name=tempest-full-ussuri-py3&job_name=tempest-full-train-py3&pipeline=periodic-stable
14:17:42 <gmann> Periodic master: tempest-all still broken #link https://zuul.openstack.org/builds?job_name=tempest-all&job_name=tempest-full-oslo-master&pipeline=periodic
14:18:01 <gmann> #topic Sub Teams highlights (Sub Teams means individual projects under QA program)
14:18:04 <gmann> Tempest
14:18:27 <gmann> many open reviews #link https://review.opendev.org/q/project:openstack/tempest+status:open
14:19:16 <kopecmartin> swift availability in tempest-full-py3
14:19:17 <kopecmartin> #link https://review.opendev.org/c/openstack/tempest/+/763981
14:19:21 <gmann> as we already talked on review policy changethat can improve it
14:19:43 <kopecmartin> seems it needs a few more modifications
14:20:03 <gmann> ok, I did not get the comment
14:20:52 <gmann> kopecmartin: i mentioned about swift in L145
14:21:01 <gmann> sorry L125
14:21:45 <kopecmartin> i meant that if the swift was enabled it would be set accordingly in tempest.conf under service section , but in master and victoria run it's not
14:21:54 <gmann> ah it should run on master and ussuri onwards. I think branch variant not working or correctly set
14:22:10 <kopecmartin> yeah, something like that
14:22:19 <gmann> i need to check zuul inventory. Will check and update accordingly
14:22:25 <gmann> thanks kopecmartin for checking that
14:23:52 <gmann> I see some patches for removing thr six
14:23:57 <gmann> #link https://review.opendev.org/q/topic:%2522remove-six%2522+(status:open+OR+status:merged)+project:openstack/tempest
14:24:16 <gmann> I think we can do that as Tempest is branchless and no backport issue here
14:24:30 <gmann> anything else on Tempest?
14:24:42 <kopecmartin> #link https://review.opendev.org/c/openstack/tempest/+/763981
14:24:52 <kopecmartin> oh, but that's more a bug
14:25:08 <kopecmartin> so we can discuss that at the end
14:25:19 <gmann> 763981 ?
14:25:27 <gmann> or you mean to paste other review
14:25:35 <kopecmartin> #link https://bugs.launchpad.net/tempest/+bug/1911044
14:25:36 <openstack> Launchpad bug 1911044 in tempest "tempest still uses unittest2 after converting to python3 only" [Medium,Confirmed]
14:25:40 <kopecmartin> yeah, sorry, i meant this ^^
14:25:42 <gmann> ah i see
14:25:54 <gmann> yeah we can do in bug topic
14:25:59 <gmann> Patrole
14:26:02 <gmann> soniya29: go ahead
14:26:51 <soniya29> gmann, we were discussing about patrole maintainance in wallaby ptg
14:26:57 <gmann> #link https://review.opendev.org/q/project:openstack/patrole+status:open
14:27:00 <gmann> yeah
14:27:37 <soniya29> So in that action item is reviewing patches is required or anything else?
14:28:51 <gmann> soniya29: its both and keep gate green. there are many API policy changes happen on project side so we need to do some changes in patrole to fix those
14:29:19 <gmann> soniya29: also as you see many of the open review are merge conflict. if we can rebase/continue those that will be great
14:29:38 <soniya29> gmann, okay
14:29:44 <gmann> and later in wallaby cycle we can judge if patrole is stable and we can release it as stable version or not
14:30:03 <soniya29> sure
14:30:19 <gmann> feel free to reachout for any help or discussion anytime
14:30:29 <soniya29> gmann, yeah
14:30:48 <gmann> soniya29: thanks for heads up and help
14:30:54 <gmann> Devstack
14:31:18 <gmann> there are two thing I will bring here and need more attention/review
14:31:38 <gmann> # centos-8-stream job #link https://review.opendev.org/c/openstack/devstack/+/759122
14:31:58 <gmann> and devstack Async task support
14:32:04 <gmann> #link https://review.opendev.org/c/openstack/devstack/+/771505
14:32:48 <gmann> I am testing 771505 locally and we do have job also with async mode in same patch to check the difference. async mdoe is disabled by default
14:33:22 <gmann> you can try and review that and feel free to add your observation
14:33:43 <gmann> and make dansmith happy if we can merge this :)
14:34:08 <gmann> Grenade
14:34:09 <dansmith> I probably need to clean up the commit message
14:34:15 <dansmith> but I will do that
14:34:24 <gmann> +1
14:35:00 <gmann> #link https://review.opendev.org/q/project:openstack/grenade+status:open
14:35:19 <gmann> nothing much on grenade but there are couple of review need feedback
14:35:41 <gmann> or even more, anyways let's continue reviewing those
14:35:46 <gmann> Hacking
14:35:55 <gmann> #link https://review.opendev.org/q/project:openstack/hacking+status:open
14:36:06 <gmann> paras333: anything you would like to bring here
14:36:35 <paras333> gmann: nothing major on this
14:36:43 <gmann> ok
14:36:46 <paras333> tox lower constraint job has been removed
14:37:04 <paras333> temporarily, do there a plan of keeping it in future?
14:37:20 <gmann> yeah, I am testing direct deps on l-c for nova and other project. i can do that for hacking also if that make it green without much fix
14:37:32 <paras333> gmann: ack, thanks
14:37:41 <gmann> #action gmann tro hacking l-c job with direct deps
14:37:46 <gmann> #topic Gate Blocker Fix / Urgent Change
14:37:56 <gmann> any urgent review other than what we already discussed ?
14:38:37 <gmann> #topic Open Discussion
14:38:40 <gmann> nothing here too
14:38:50 <gmann> #topic Bug Triage (last 30 min)
14:39:00 <gmann> let's do bug thing now
14:39:11 <gmann> first is this #link https://bugs.launchpad.net/tempest/+bug/1914037
14:39:13 <openstack> Launchpad bug 1914037 in tempest "scenario tests tempest.scenario.test_network_v6.TestGettingAddress fails" [Undecided,New]
14:40:14 <gmann> kopecmartin: so this change fix for master and all but did not fix for rocky? https://opendev.org/openstack/tempest/commit/4ad346e6497d4fbad9e379e8ed50730a0b6b55a3
14:40:35 <gmann> mean it fix in master Tempest but rocky use tempest 23.0.0 so it is broken in rocky gate?
14:41:00 <openstackgerrit> Dan Smith proposed openstack/devstack master: Async task support  https://review.opendev.org/c/openstack/devstack/+/771505
14:41:12 <tosky> I was late for the open discussion, sorry for  the OT, but there is this devstack refactoring for cinder-backup that is needed to proper test a new driver (cinder/s3): https://review.opendev.org/c/openstack/devstack/+/770171
14:41:43 <kopecmartin> gmann: yeah, seems so, the bug mentions that the problem is in stable/rocky
14:42:11 <kopecmartin> but that's very old release, do we still support that?
14:42:51 <gmann> tosky: i see, ack thanks for brining that. yeah we need some job with those configure to see the result
14:43:07 <gmann> kopecmartin: i have not triage that but does this fix it ? -https://opendev.org/openstack/tempest/commit/4ad346e6497d4fbad9e379e8ed50730a0b6b55a3
14:43:30 <gmann> seems so from bug comment
14:43:36 <kopecmartin> gmann: i didn't verify, but it seems so
14:43:43 <gmann> ok
14:43:49 <kopecmartin> the review is tied to this bug
14:43:50 <kopecmartin> #link https://bugs.launchpad.net/tempest/+bug/1903433
14:43:52 <openstack> Launchpad bug 1903433 in neutron "The duplicate route in l3 router namespace results in North-South traffic breaking" [Medium,In progress] - Assigned to yangjianfeng (yangjianfeng)
14:44:02 <gmann> then we cannot fix it for rocky as it is in EM stage and use old tempest
14:44:03 <kopecmartin> which was very similar issue like the current one, only with ipv4 not ipv6
14:45:13 <kopecmartin> i wrote a comment asking for confirmation if only rocky release is affected
14:45:19 <gmann> ok but that did not backported to rocky
14:45:40 <kopecmartin> that's correct
14:45:42 <gmann> so what we can do is we can skip the test for stable rocky and move unblock the tempest-slow
14:45:49 <openstackgerrit> Eric Harney proposed openstack/devstack-plugin-ceph master: Test fix for bug #1913449  https://review.opendev.org/c/openstack/devstack-plugin-ceph/+/773698
14:45:51 <openstack> bug 1913449 in Cinder "rbd/rados lib changes in ceph pacific prevents c-vol to initialize properly" [Undecided,New] https://launchpad.net/bugs/1913449 - Assigned to Eric Harney (eharney)
14:46:00 <gmann> and if any  fix from neutron or so fix or so then we can unskip it
14:46:21 <kopecmartin> ok
14:46:38 <gmann> I acn push that with bug skip and feature flag may be
14:46:40 <gmann> can
14:47:01 <kopecmartin> ok, sounds greawt
14:47:03 <kopecmartin> great
14:47:44 <kopecmartin> let's move on
14:47:50 <kopecmartin> we have a fix
14:47:52 <kopecmartin> #link https://review.opendev.org/c/openstack/tempest/+/642237
14:47:55 <gmann> kopecmartin: as tempest does not support any EM stable branch and due to its brachless nature it is not possible for us to backport the things
14:47:59 <kopecmartin> for a high old priority bug:
14:48:07 <kopecmartin> #link https://bugs.launchpad.net/tempest/+bug/1613819
14:48:08 <openstack> Launchpad bug 1613819 in tempest "v3 credentials client does not honour the configured domain" [High,In progress] - Assigned to Lukas Piwowarski (lukas-piwowarski)
14:48:37 <kopecmartin> *old high priority bug :D
14:48:44 <gmann> kopecmartin: this on right #link https://review.opendev.org/c/openstack/tempest/+/642237
14:48:53 <kopecmartin> gmann: yes
14:49:04 <openstackgerrit> Dan Smith proposed openstack/devstack master: Async task support  https://review.opendev.org/c/openstack/devstack/+/771505
14:49:15 <gmann> cool, this is in my list i was waiting for other system scope things to merge first
14:49:27 <gmann> will review it by today or tomorrow most probably
14:49:42 <kopecmartin> ok
14:49:47 <kopecmartin> #link https://bugs.launchpad.net/tempest/+bug/1911044
14:49:49 <openstack> Launchpad bug 1911044 in tempest "tempest still uses unittest2 after converting to python3 only" [Medium,Confirmed]
14:49:55 <kopecmartin> seems like we still use unittest2
14:50:39 <kopecmartin> it seems that unittest2 has been a part of a workaround as i commented in comment #3
14:50:50 <gmann> yeah
14:51:14 <gmann> testtool still not removed it due to backward compatibility #link https://github.com/testing-cabal/testtools/pull/277
14:51:50 <gmann> I think we just need to be careful about stable branch testing which is rain onwards
14:51:54 <gmann> *train
14:52:18 <gmann> and kopecmartin you are saying we need to bump the stestr constraint in train ?
14:53:07 <kopecmartin> i thought so, i need to recheck, i forgot the context
14:53:34 <gmann> did stestr dropped the workaround ?
14:55:13 <kopecmartin> no idea, i'll need to check
14:55:33 <gmann> it seems yes https://github.com/mtreinish/stestr/blob/master/stestr/subunit_runner/run.py
14:56:29 <gmann> #link https://github.com/mtreinish/stestr/commit/e2d2fab911a5e696f1092560342aa26b91cbc5ff#diff-45f3f6acc69b6f83389b916cb009a1092d9c08fa0419f7c9e82832467ef5b1f8
14:56:47 <gmann> kopecmartin: 3.0.0 removed it
14:57:26 <kopecmartin> so we cannot drop it now
14:57:41 <kopecmartin> #link https://opendev.org/openstack/requirements/src/branch/stable/train/upper-constraints.txt#L366
14:57:45 <kopecmartin> as train uses 2.5.1
14:57:54 <gmann> but train still need to support py2.7 and use stestr 2.5.1
14:58:35 <gmann> I need to give more thought on this about all combination of  py and stable branch version :) to avoid any break
14:58:53 <gmann> I will comment on bug later
14:59:00 <gmann> we are 3 min left
14:59:17 <kopecmartin> i don't have anything else
14:59:25 <gmann> any critical bug or other high priority to bring here?
15:00:18 <gmann> ok, let's close the office hour then
15:00:22 <gmann> thanks all for joining
15:00:25 <gmann> #endmeeting