14:00:08 <masayukig> #startmeeting qa
14:00:11 <openstack> Meeting started Tue Dec 22 14:00:08 2020 UTC and is due to finish in 60 minutes.  The chair is masayukig. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'qa'
14:00:19 <masayukig> hi, who all here today?
14:00:28 <kopecmartin> hi o/
14:00:46 * masayukig probably missed conversation due to the irccloud outage..
14:00:59 <gmann> o/
14:02:01 <masayukig> ok, let's start
14:02:10 <soniya29|rover> hello
14:02:26 <masayukig> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
14:02:40 <masayukig> ^^^ this is the agenda
14:02:53 <masayukig> #topic Announcement and Action Item (Optional)
14:03:40 <masayukig> One thing I'd like to announce is that "Cancelling the next office hour on Dec 29 due to the holiday season" if no objection
14:03:57 <masayukig> I'll send an email later
14:04:05 <gmann> we can cancel for next two office hour i think
14:05:30 <masayukig> gmann: ok, we'll cancel Jan 5, too.
14:05:58 <gmann> +1
14:06:09 <masayukig> ok, cool
14:06:40 <masayukig> #action masayukig send an email about canceling qa office hour
14:07:03 <masayukig> gmann: I can see two action items
14:07:09 <masayukig> gmann add periodic jobs result checks in office hour agenda
14:07:15 <masayukig> gmann remove community goal tracking from agenda
14:07:25 <gmann> yeah both are done
14:07:33 <masayukig> thanks. great :)
14:07:38 <masayukig> ok, let's move on
14:07:54 <masayukig> #topic Wallaby Priority Items progress
14:08:22 <masayukig> #link https://etherpad.opendev.org/p/qa-wallaby-priority
14:08:34 <masayukig> any updates?
14:09:03 <gmann> nothing from my side
14:09:18 <paras333> I am sorry I am still working on the centralized stuff, I might be having some update after new year
14:09:30 <paras333> just had some reorg and moved to ironic team here
14:09:36 <paras333> :)
14:09:53 <masayukig> ok :)
14:09:59 <masayukig> let's move on
14:10:01 <kopecmartin> scenario manager effort is practically done, reviews needed
14:10:03 <kopecmartin> #link https://review.opendev.org/q/topic:bp/tempest-scenario-manager-stable+status:open
14:10:26 <gmann> kopecmartin: ack, will take a look today
14:10:37 <masayukig> kopecmartin: thanks
14:11:12 <masayukig> #topic OpenStack Events Updates and Planning
14:11:26 <masayukig> I have nothing, let's skip
14:11:43 <masayukig> #topic Gate Status Checks
14:11:52 <masayukig> How's the gate status?
14:12:08 <gmann> there are few failure
14:12:38 <gmann> stable/rocky is now fixed - #link https://review.opendev.org/c/openstack/stackviz/+/767063
14:13:02 <gmann> but stackviz-nodejs10-run-test-browser job is broken which i need to disable for now
14:13:13 <gmann> #link https://bugs.launchpad.net/stackviz/+bug/1908606
14:13:14 <openstack> Launchpad bug 1908606 in StackViz "stackviz-nodejs10-run-test-browser failing in gate" [Undecided,New]
14:13:21 <masayukig> gmann: thanks for the fixing!
14:13:23 <masayukig> hmm..
14:13:49 <gmann> I will move this to firefox like horizon did
14:14:09 <gmann> and there were few race condition for volume detach tests, failure observed in nova gate
14:14:19 <gmann> I think both fixes are merged, let me check
14:14:41 <gmann> #link https://review.opendev.org/c/openstack/tempest/+/767515
14:15:03 <gmann> this is grenade #link https://review.opendev.org/c/openstack/grenade/+/767569
14:15:54 <masayukig> thank for the stackviz. I haven't time to look into that lately.. yeah, moving to firefox sounds reasonable to me.
14:16:05 <gmann> next is bindep things for stable/train which is finally merged #link https://review.opendev.org/c/openstack/devstack/+/766622
14:16:16 <gmann> yeah
14:16:40 <masayukig> cool
14:17:07 <gmann> patrole member job is also failing seem #link https://review.opendev.org/c/openstack/patrole/+/768119
14:17:29 <gmann> 2020-12-21 19:20:37,894 99223 DEBUG    [patrole_tempest_plugin.policy_authority] Policy action "os_compute_api:os-admin-actions:reset_network" not found in policy files: [] or among registered policy in code defaults for nova service.
14:17:36 <gmann> yeah patrole gate is also broken
14:17:42 <gmann> I will fix that after meeitng
14:17:50 <gmann> humm, everything failing seems :)
14:18:25 <masayukig> thank you very much for your effort
14:18:29 <gmann> these are updates on gate status. I might have missed few which we fixed in last week
14:19:36 <masayukig> ok, we can discuss it later if we have missed something
14:20:17 <masayukig> move on
14:20:19 <masayukig> #topic Periodic jobs Status Checks
14:20:28 <masayukig> #link https://zuul.openstack.org/builds?job_name=tempest-full-victoria-py3&job_name=tempest-full-ussuri-py3&job_name=tempest-full-train-py3&pipeline=periodic-stable
14:20:36 <masayukig> looks good
14:20:53 <masayukig> #link https://zuul.openstack.org/builds?job_name=tempest-all&job_name=tempest-full-oslo-master&pipeline=periodic
14:21:03 <gmann> few ussuri job failure
14:21:18 <gmann> but seems it is not failing much so good.
14:21:41 <gmann> idea here is to keep monitor the periodic job which we never do usually
14:21:54 <gmann> tempest-all is still failing on personality tests
14:22:15 <gmann> it seems timeout started now
14:22:40 <masayukig> yea
14:22:56 <masayukig> from Dec 20
14:23:35 <gmann> but initial failure was on personality tests which is deprecated things in nova for newer microversion but still valid things for older microversions
14:23:51 <gmann> I will not be able to check this in this week, someone else need to take this
14:25:21 <masayukig> hmm, it seems that the personality tests are still failing https://zuul.openstack.org/build/aec635262b914522bdc98355698f30e4/log/job-output.txt#28432
14:27:03 <masayukig> me neither.. :(
14:27:48 <masayukig> But we're going to the holidays, though..
14:28:09 <masayukig> anyway, let's move on if nothing else on this topic
14:29:02 <gmann> sure
14:29:08 <masayukig> #topic Sub Teams highlights (Sub Teams means individual projects under QA program)
14:29:44 <masayukig> gmann: thanks for updating #link https://review.opendev.org/c/openstack/devstack/+/755415
14:30:15 <gmann> yeah this was left until i saw and checked the another flag for neutron
14:30:32 <gmann> and found that we have not finished these Victoria setting yet
14:31:06 <gmann> there are no new extensions from neutron yet otherwise it coulda have started failing in gate
14:31:16 <gmann> new extensions for wallaby
14:31:25 <masayukig> yeah
14:32:54 <masayukig> kopecmartin: I think you wanted to mention about #link https://review.opendev.org/c/openstack/tempest/+/767968 ?
14:33:48 <kopecmartin> .. yeah, i gave +2 as i don't know how to fix the releasenote for 25.0.0 and 25.0.1 :/
14:34:31 <gmann> yeah, let's merge the 26.0.0 and I will check 25.0.1 sometime in next week
14:34:47 <kopecmartin> with 25.0.1 there is a slightly different issue, but I can't figure out why or what's wrong
14:34:50 <gmann> 25.0.0 cannot be fixed as per release team
14:35:14 <masayukig> gmann: +1
14:35:25 <gmann> yeah, i have not looked into detail yet but  commit used in that is of master commit
14:35:37 <masayukig> kopecmartin: yeah, I didn't dig #link https://review.opendev.org/c/openstack/tempest/+/767535 yet, though.
14:35:37 <gmann> so it should pass theoretically
14:36:16 <masayukig> it's so complicated for me :(
14:36:25 <gmann> once 25.0.1 is fixed and we have page then we need to link it for Victoria release page as there is no release note lonk for Tempest
14:36:29 <gmann> link
14:36:43 <masayukig> And sorry for bothering both of you
14:36:44 <masayukig> yeah
14:36:48 <kopecmartin> totally, reno does a weird magic there to discover (or not discover) tags
14:36:59 <gmann> anyways we can merge 26.0.0 which is not related to 25.0.1 failure
14:37:05 <gmann> yeah
14:37:08 <masayukig> yes
14:38:32 <kopecmartin> +A
14:38:38 <masayukig> kopecmartin: thanks!
14:38:56 <masayukig> Anything else on this topic?
14:39:23 <gmann> thanks
14:39:26 <kopecmartin> not from my side
14:39:47 <masayukig> ok, let's move on
14:39:57 <masayukig> #topic Gate Blocker Fix / Urgent Change
14:40:07 <masayukig> any urgent patches?
14:41:06 <masayukig> It seems nothing..?
14:41:45 <masayukig> #topic Open Discussion
14:42:12 <masayukig> I don't see any topic on the agenda. Let's skip if nothing
14:42:15 <kopecmartin> FYI, i pushed patches to remove deprecated tempest.manager
14:42:17 <kopecmartin> #link https://review.opendev.org/q/topic:%2522tempest_manager%2522+(status:open+OR+status:merged)
14:42:32 <kopecmartin> a few projects still use it , even after years of deprecation
14:42:51 <masayukig> kopecmartin: ++ cool
14:42:55 <gmann> kopecmartin: +1, is failure for this change or not related
14:43:07 <kopecmartin> some of the projects may not be active anymore
14:43:14 <gmann> many project l-c job broken so might not be
14:43:19 <kopecmartin> gmann: no failure, i just noticed it's time to remove it
14:43:27 <gmann> i see
14:43:47 <masayukig> I see
14:43:51 <gmann> I think this is good trigger for non active projects which I can take further in TC to retire them
14:44:08 <masayukig> gmann: +1
14:44:53 <masayukig> ok, let's move on if nothing else
14:45:01 <masayukig> #topic Bug Triage (last 30 min)
14:45:09 <masayukig> #link https://etherpad.openstack.org/p/qa-bug-triage-wallaby
14:45:18 <masayukig> kopecmartin: your turn
14:46:02 <openstackgerrit> Ghanshyam proposed openstack/stackviz master: Move stable stein job definition in tree  https://review.opendev.org/c/openstack/stackviz/+/768212
14:46:48 <openstackgerrit> Ghanshyam proposed openstack/tempest master: Remove stable/stein testing jobs  https://review.opendev.org/c/openstack/tempest/+/768118
14:46:56 <gmann> kopecmartin: ^^ stebale/stein jobs
14:48:04 <masayukig> maybe, he's busy now..
14:48:15 <masayukig> ?
14:48:38 <gmann> yeah seems so
14:49:16 <gmann> seems number is down for bug
14:49:19 <gmann> no critical bugs
14:49:32 <gmann> but we have high priority bugs 2 in Tempest and 1 in devstack
14:49:52 <masayukig> yeah
14:50:07 <masayukig> #link https://bugs.launchpad.net/devstack/+bug/1906322
14:50:08 <openstack> Launchpad bug 1906322 in devstack "pip 20.3 break devstack: ERROR: Links are not allowed as constraints" [High,New]
14:50:09 <kopecmartin> sorry, i went out of batter, so my system shut down :D
14:50:18 <masayukig> #link https://bugs.launchpad.net/tempest/+bug/1401726
14:50:19 <openstack> Launchpad bug 1401726 in tempest "Tempest IPv6 scenario tests use IPv4 and floating IPs to connect and test" [High,Confirmed] - Assigned to Paras Babbar (pbabbar)
14:50:23 <masayukig> #link https://bugs.launchpad.net/tempest/+bug/1613819
14:50:24 <openstack> Launchpad bug 1613819 in tempest "v3 credentials client does not honour the configured domain" [High,In progress] - Assigned to Lukas Piwowarski (lukas-piwowarski)
14:50:44 <masayukig> kopecmartin: np :)
14:51:15 <masayukig> kopecmartin: any comments on the bugs?
14:51:47 <kopecmartin> not really, i've been busy with osf projects lately
14:52:42 <kopecmartin> 1613819 is blocked by https://review.opendev.org/q/topic:admin-auth-system-scope+(status:open+OR+status:merged)
14:53:11 <gmann> I added greande and stackviz also in etherpad for bug tracking. at least to know if any critical bugs etc
14:54:10 <kopecmartin> ok
14:54:33 <masayukig> kopecmartin: gmann ok, thanks.
14:55:19 <masayukig> Anything else? I think we can close the office hour if nothing
14:55:41 <gmann> nothing from me for today
14:55:51 <kopecmartin> neither from me
14:55:54 <masayukig> ok, thank you all!
14:55:56 <gmann> happy holidays guys!
14:56:05 <masayukig> you too!
14:56:12 <masayukig> #endmeeting