14:01:09 <gmann> #startmeeting qa
14:01:10 <openstack> Meeting started Tue Nov  3 14:01:09 2020 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:14 <openstack> The meeting name has been set to 'qa'
14:01:22 <gmann> how all here today?
14:01:26 <gmann> how
14:01:28 <gmann> who
14:01:33 <kopecmartin> gmann: hi o/
14:03:02 <paras333> o/
14:03:16 <gmann> let's start
14:03:26 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
14:03:28 <gmann> today agenda ^^
14:03:39 <gmann> #topic Announcement and Action Item (Optional)
14:04:08 <gmann> one annoucncement is about new time of office hour which is now at 14 UTC (old time was 13 UTC)
14:04:44 <gmann> there is issue on eavesdrop for this updates which frickler already reported/discussing to opendev
14:04:59 <gmann> #topic Wallaby Priority Items progress
14:05:09 <gmann> #link https://etherpad.opendev.org/p/qa-wallaby-priority
14:05:32 <gmann> this ^^ etherpad has all the working items we decided for wallaby cycle.
14:05:46 <gmann> I assigned the owner of each item
14:06:19 <paras333> ack, thanks
14:06:22 <gmann> any update on any of them?
14:06:37 <gmann> or we just finished the PTG so tracking in next week or so will be good
14:06:57 <paras333> yup, no update right now
14:07:20 <gmann> yeah form me too, nothing
14:07:22 <kopecmartin> tempest cleanup #link https://review.opendev.org/745814 ready for review, I resolved comments
14:07:36 <kopecmartin> but that's all for nw
14:07:37 <kopecmartin> now
14:07:44 <gmann> kopecmartin: thanks, will check today
14:08:00 <gmann> is DNM testing patch refreshed with new result or need recheck ?
14:08:32 <kopecmartin> yes, i put some links in the review to point out the results
14:08:39 <gmann> cool
14:08:45 <kopecmartin> i ran the DNM multiple times mocking different scenarios
14:09:03 <gmann> ko
14:09:05 <gmann> ok
14:09:46 <gmann> #topic OpenStack Events Updates and Planning
14:09:54 <gmann> we finished PTG last week
14:10:13 <gmann> I have also summarized it on ML,
14:10:21 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-October/018346.html
14:10:22 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-October/018365.html
14:11:09 <gmann> PTG seems ok but virtual summit was not so powerful for me :)
14:11:38 <gmann> #topic Sub Teams highlights
14:12:02 <gmann> Tempest
14:12:22 <gmann> #link  https://review.opendev.org/#/q/project:openstack/tempest+status:open
14:12:27 <gmann> we have lot of open review
14:12:52 <gmann> and lot of work in scenario manager #link https://review.opendev.org/#/q/topic:bp/tempest-scenario-manager-stable+(status:open+OR+status:merged)
14:13:04 <gmann> I am adding these in my list
14:13:14 <kopecmartin> the scenario manager is going fine, most of the reviews are already up
14:13:27 <gmann> nice
14:14:14 <gmann> I am doing RBAC work review, my testing devstack patches still failing which i need to debug
14:14:42 <paras333> i have added one api test for test attach scsci disk with confid drive
14:14:48 <paras333> up for review #link https://review.opendev.org/#/c/758848/
14:15:12 <paras333> this was the issue we faced in nova when we enabled config drive with scsi disk
14:15:26 <paras333> #link https://launchpad.net/bugs/1867075
14:15:28 <openstack> Launchpad bug 1867075 in OpenStack Compute (nova) train "Arm64: Instance with Configure Drive attach volume failed failed" [Low,Fix committed] - Assigned to sean mooney (sean-k-mooney)
14:15:35 <gmann> ok, I need to check that. have not looked yet
14:15:47 <paras333> yeah no problem, no rush on that
14:16:16 <gmann> Patrole
14:16:21 <gmann> #link https://review.opendev.org/#/q/project:openstack/patrole+status:open
14:16:28 <gmann> not much progress in patrole side
14:16:41 <gmann> Hacking
14:16:43 <gmann> #link https://review.opendev.org/#/q/project:openstack/hacking+status:open
14:16:59 <gmann> paras333: let's review the open one and then we can release hacking new version
14:17:12 <paras333> gmann: yeah sure
14:17:12 <gmann> I think sean two match we can merge
14:17:28 <paras333> yup I have looked it briefly, looks good to me
14:17:36 <paras333> i will review it today
14:17:41 <gmann> #action gmann paras333 to review the open patches for hacking and then release
14:17:43 <gmann> thanks
14:18:05 <paras333> can you show me how to do the release stuff, any patch to look at?
14:18:06 <gmann> from devstack side we have two things
14:18:29 <gmann> I can add one, its with independent release model and need PTL +1
14:19:03 <paras333> ack
14:19:23 <gmann> we do not have release liaison or QA i think and default is PTL.
14:19:43 <paras333> make sense
14:19:58 <gmann> to speed up things, i will ask masayukig to add me there so that we can merge things faster
14:20:21 <gmann> #action add release liaison in release team doc
14:21:03 <gmann> there is one issue reported from devstack side, comoute node failure is not reported early and it end up failing tests later - https://zuul.openstack.org/build/d6fa643e420644f1bc9d9ef5ab2427c1/log/job-output.txt#55340
14:21:46 <gmann> i need to check it after office hour, frickler idea is to fail it early which is how it should be
14:22:17 <gmann> anything else to updates form any subteam ?
14:23:08 <gmann> #topic Community goal tracking
14:23:28 <gmann> I need to update etherpad to add wallaby cycle goal.
14:23:50 <gmann> as per current goal proposal, we might not need any updates from QA side
14:24:06 <gmann> #topic Bug Triage
14:24:24 <kopecmartin> I prepared a few bugs to discuss here #link https://etherpad.opendev.org/p/qa-bug-triage-wallaby
14:24:41 <kopecmartin> i'd start with pdf doc effort
14:24:47 <gmann> sure
14:24:57 <kopecmartin> i was checking how much is done and how much is missing
14:25:10 <kopecmartin> most of the reviews are already merged #link https://review.opendev.org/#/q/topic:feature/pdf_doc+(status:open+OR+status:merged)
14:25:26 <kopecmartin> there are a few projects though when I'm not sure what to do
14:25:30 <openstackgerrit> Lajos Katona proposed openstack/tempest master: Test for changing QoS policy with min bw of bound port  https://review.opendev.org/743695
14:25:36 <kopecmartin> they're mentioned in the etherpad
14:25:58 <kopecmartin> those are the projects which don't have any zuul jobs implemented yet, most likely no documentation at all
14:26:21 <gmann> kopecmartin: for cookiecutter repo we do not need
14:26:25 <kopecmartin> thanks gmann, i see you're adding comments there
14:26:41 <kopecmartin> anyone please add your comments if you have any thoughts to the etherpad
14:27:31 <gmann> devstack-vagrant also same
14:27:51 <kopecmartin> i'll update the storyboard regarding the effort after the meeting #link https://storyboard.openstack.org/#!/story/2006070
14:28:26 <kopecmartin> perfect thanks gmann for the comments
14:28:37 <kopecmartin> moving on #link https://review.opendev.org/#/c/673342/
14:28:42 <gmann> kopecmartin: added comments on etherpad, let's skip those repo as no doc other than README
14:29:03 <kopecmartin> it has already core reviews, but i'd like to get more than just 2, just to be sure ;)
14:29:04 <gmann> kopecmartin: i had this open for review but did not di
14:29:06 <gmann> do
14:29:15 <gmann> I will do today for sure
14:29:31 <kopecmartin> perfect, moving on #link https://bugs.launchpad.net/tempest/+bug/1844535
14:29:32 <openstack> Launchpad bug 1844535 in tempest "several tests fail when image_ref_alt is set to non-cirros image" [Medium,In progress] - Assigned to Weronika Sikora (shushuda)
14:29:44 <kopecmartin> i has a patch up #link https://review.opendev.org/#/c/682904/
14:30:04 <kopecmartin> it's interesting bug, if we wanna support different images than just cirros - as we discussed on PTG - we might need it
14:30:38 <kopecmartin> s/support/'run on gates'
14:31:00 <gmann> did not we use image_ssh_user for sshing on those alt image >
14:31:01 <gmann> ?
14:31:51 <kopecmartin> yes
14:32:07 <kopecmartin> although the patch mentions an edge case i would say
14:32:19 <kopecmartin> At this moment, only image_ssh_user is present in the config
14:32:19 <kopecmartin> of Tempest. It's set to cirros by default and used for
14:32:19 <kopecmartin> SSH connections in tests. However, several tests build
14:32:21 <kopecmartin> instances with image_ref_alt, but still use image_ssh_user to
14:32:23 <kopecmartin> connect, which results in failure if image_ref_alt is set to
14:32:25 <kopecmartin> a non-cirros image.
14:32:29 <gmann> i see
14:33:03 <gmann> at first glance it make sense but i need to check how test using the alt images.
14:33:17 <kopecmartin> yup sure
14:33:32 <kopecmartin> moving on #link https://bugs.launchpad.net/tempest/+bug/1861592
14:33:33 <openstack> Launchpad bug 1861592 in tempest "Move 'gabbi_tempest_path' to gabbi-tempest plugin" [Medium,In progress] - Assigned to Martin Kopec (mkopec)
14:33:45 <gmann> i think we will find many such things when paras333 will have non-cirros image testing
14:34:03 <gmann> for gabbi-tempest plugin i think i had patch up
14:34:07 <kopecmartin> easy fix, however it's blocked on gabbi - its gate is failing
14:34:19 <kopecmartin> can anyone help us with fixing the gate?
14:34:23 <gmann> #link https://review.opendev.org/#/c/705339/
14:34:32 <kopecmartin> i briefly checked it. however, didn't find the problem
14:34:50 <gmann> seems like it is not active anymore
14:34:53 <gmann> #link https://review.opendev.org/#/q/project:x/gabbi-tempest
14:34:59 <paras333> gmann: yeah , I will check this bug while testing
14:35:00 <gmann> last patcch merged 2 years ago
14:35:09 <kopecmartin> ah
14:35:22 <gmann> after chris move away from openstack
14:35:51 <gmann> who all using gabbi-tempest ?
14:35:51 <kopecmartin> ok then, so there's nothing we can do about the bug then, i'll close it
14:35:56 <kopecmartin> i don't know :D
14:36:34 <gmann> seems heat, cinder, grenade
14:36:37 <gmann> #link http://codesearch.openstack.org/?q=gabbi-tempest&i=nope&files=&repos=
14:37:11 <gmann> I think we need to cleanup this. I will check those usage and see if we can move the tempest var setting on users side
14:37:32 <gmann> and then update the tempest patch #link https://review.opendev.org/#/c/705340/
14:37:48 <kopecmartin> sounds good
14:38:10 <gmann> I remember in past when tempest was not setting this var, few gabbi-tempest job failed
14:38:54 <gmann> If no maintainer for gabii-tempest then i think we need to move those jobs from gate or test in different way
14:39:05 <gmann> I will bring it on ML too
14:39:16 <kopecmartin> yeah, that'd be great
14:39:32 <gmann> #action gmann to bring the gabbi-tempest on ML and accordingly move forward on tempest bug
14:39:48 <tosky> cinder doesn't use it
14:40:05 <tosky> the file which contains that variable is only a copy of the tempest one
14:40:13 <tosky> I tried to keep the two files in sync
14:40:18 <gmann> i see
14:40:26 <tosky> I suspect it's the same for grenade
14:40:31 <tosky> the only user iirc is/was heat
14:40:36 <gmann> then we can first remove those if no gabbi -tempest used
14:40:53 <gmann> yeah heat i know they use but not sure job is passing fine or not
14:41:07 <gmann> ricolin: ^^
14:41:53 <gmann> let's mvoe next
14:42:05 <kopecmartin> #link https://bugs.launchpad.net/tempest/+bug/1801159
14:42:07 <openstack> Launchpad bug 1801159 in tempest "test_dhcp_stateful_fixedips_duplicate and test_dhcp_stateful_fixedips works incorrect with Contrail SDN" [Undecided,In progress] - Assigned to Mykola Yakovliev (vegasq)
14:42:11 <kopecmartin> it has a fix
14:42:19 <kopecmartin> but  the problem is we can't verify the fix, the gates don't use Contrail SDN
14:42:31 <gmann> link?
14:42:44 <kopecmartin> #link https://review.openstack.org/614866
14:43:19 <gmann> i think we can ask neutron team to review this.
14:43:28 <gmann> slaweq: can you please check this https://review.opendev.org/#/c/614866/8
14:43:38 <slaweq> gmann: sure
14:43:38 <gmann> not urgent but whenever you have time
14:43:50 <slaweq> ok
14:43:50 <gmann> slaweq: thanks
14:44:11 <kopecmartin> perfect, moving on #link https://bugs.launchpad.net/tempest/+bug/1860129
14:44:13 <openstack> Launchpad bug 1860129 in tempest "Tempest test tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.test_subnet_details fails when there is some additional nameserver configured in guest VM" [Medium,In progress] - Assigned to Slawek Kaplonski (slaweq)
14:44:19 <kopecmartin> is it a bug when there is a non dns server in /etc/resolve.conf?
14:45:06 <kopecmartin> i guess slaweq could have some insight here too
14:45:47 <kopecmartin> i see you had a review up, but then you abandoned it .. should it be addressed on tempest is the final question :)
14:46:00 <slaweq> I thinkn that this can be closed
14:46:04 <slaweq> sorry for the noise
14:46:22 <kopecmartin> ok, np
14:46:29 <gmann> cool, thanks
14:46:41 <kopecmartin> next #link https://bugs.launchpad.net/tempest/+bug/1863161
14:46:43 <openstack> Launchpad bug 1863161 in tempest "stackviz failing on stable jobs with py3.5 while installation" [Undecided,In progress] - Assigned to Ghanshyam Mann (ghanshyammann)
14:46:48 <kopecmartin> do we still need to keep this bug open?
14:46:56 <gmann> stackviz was fixed and we have job also runnign there
14:47:26 <gmann> but we thought of not failing job on stackviz failure which i had tempest patch up but did not update it
14:47:35 <gmann> I will er-look that and update on etehrpad
14:47:44 <kopecmartin> gmann: thanks
14:47:58 <kopecmartin> another for discussion #link https://bugs.launchpad.net/tempest/+bug/1827065
14:48:00 <openstack> Launchpad bug 1827065 in tempest "Add support for setting quotas for dynamic users" [Undecided,In progress] - Assigned to Martin Kopec (mkopec)
14:48:03 <kopecmartin> Add support for setting quotas for dynamic users
14:48:10 <kopecmartin> this might be beneficial in cases the default quota in the deployment is too small for tempest tests to pass
14:48:16 <kopecmartin> basically it's adding an option for a user to set a different than default quotas in the test projects created by Tempest
14:49:00 <gmann> last time i asked about exact use case for this
14:49:14 <gmann> Temepst run on default quota
14:49:37 <gmann> I think we can mark as incomplete untill author reply the use case
14:49:54 <kopecmartin> i think the author replied, let me check
14:50:14 <kopecmartin> this was the reply in the review: "The issue is when your default quota is too small for a test to pass, but may be functional for other use cases."
14:50:32 <gmann> is there reivew for that?
14:50:41 <kopecmartin> it's definitely not very often use case
14:50:44 <kopecmartin> yeah #link https://review.opendev.org/#/c/656534/
14:51:23 <gmann> thanks
14:51:39 <gmann> i did not notice that on review, my bad. I will reply on review
14:51:58 <kopecmartin> ok, thanks
14:52:11 <kopecmartin> moving on #link https://bugs.launchpad.net/tempest/+bug/1764375
14:52:13 <openstack> Launchpad bug 1764375 in tempest "Support for HTTP proxy URL is broken" [Undecided,In progress] - Assigned to Federico Ressi (fressi-redhat)
14:52:16 <kopecmartin> still valid?
14:54:08 <gmann> patch is abandon so not sure it is valid, i cannot remember exact note on this. may be we need to try this before closing
14:54:40 <kopecmartin> ok
14:54:46 <gmann> let's triage further in next office hours as we need to cover open discussion also.
14:55:08 <kopecmartin> ok, we made some progress, which is awesome
14:55:33 <gmann> thanks kopecmartin for er-starting it, this is how our office hour become more productive by spending at elast 30 min on bugs discussion
14:55:51 <gmann> #topic Critical Reviews
14:56:19 <gmann> I think we should rename this to 'Urgent/Gate Fixes Review'
14:56:24 <gmann> what you say
14:56:38 <gmann> and only track urgent or gate fixes here as urgent review
14:57:23 <kopecmartin> agree, would be more descriptive
14:57:33 <gmann> yeah, I will update it
14:57:37 <gmann> #topic Open Discussion
14:57:49 <gmann> there is one item there
14:57:51 <gmann> (TomStappaerts) Devstack does not work on centos8 with stable/ussuri. I backported a fix here: https://review.opendev.org/#/c/746500/ . Are there other actions we need to do?
14:58:13 <gmann> this patch is merged, not sure if centos8 job still failing ?
14:59:00 <gmann> it is passing here https://review.opendev.org/#/c/756489/
14:59:26 <gmann> so no action item for this
14:59:30 <gmann> i will remove it from agenda
15:00:19 <gmann> also i am thinking we should move 'Critical Review' and 'Open Discussion' topic above bug triage so that we can spend last 30 min on bug things and also cover open discussion if there are many items there
15:00:39 <kopecmartin> makes sense
15:00:44 <gmann> like cover everything first  in first 30 in min and then bug
15:00:53 <gmann> k i will update agenda
15:01:05 <gmann> #action gmann to updatae agenda to move Bug triage at last
15:01:26 <gmann> thats all for today, thanks all for joining
15:01:33 <gmann> #endmeeting