13:30:54 <gmann> #startmeeting qa
13:30:55 <openstack> Meeting started Tue Apr  7 13:30:54 2020 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:30:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:30:58 <openstack> The meeting name has been set to 'qa'
13:30:59 <gmann> who all here today ?
13:31:08 <kopecmartin> hello
13:31:17 <soniya29> hello
13:32:12 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting
13:32:44 <gmann> agenda for today, we will try to finish today office hour fast due to m-3 things to complete
13:32:56 <gmann> #topic Announcement and Action Item (Optional)
13:33:15 <gmann> one announcement - welcome kopecmartin to the core team.
13:33:24 <kopecmartin> gmann: thank you
13:33:42 <soniya29> kopecmartin: congrats
13:34:51 <gmann> #topic OpenStack Events Updates and Planning
13:35:07 <gmann> as you all might know, we are going to have Virutal PTG.
13:35:27 <gmann> I will plan the same for QA also based on topics we want to discuss.
13:35:39 <gmann> please add your topic to discuss in this etherpad - https://etherpad.openstack.org/p/qa-victoria-ptg
13:36:14 <gmann> kopecmartin: or soniya29 you can write the scenario manager things here and we can discuss that
13:36:26 <kopecmartin> sure, we'll do
13:36:38 <soniya29> gmann: sure. we will
13:36:41 <gmann> or any other topic. like cleanup cli to move to main jobs in gate
13:37:04 <gmann> thanks. and based on that we will plan the total time etc
13:37:27 <gmann> #topic Sub Teams highlights (Sub Teams means individual projects under QA program)
13:37:32 <gmann> Tempest
13:38:08 <gmann> there is stein gate issue for tempest-full i  have not looked into yet. we will check that in bug topic
13:38:11 <gmann> Patrole
13:38:39 <gmann> I think patrole gate is up but i have merged many policy on nova side so it might be broken. I will check and fix after m-3
13:38:43 <gmann> Grenade
13:39:10 <gmann> I need to re-review the zuulv3 jobs. again after m-3
13:39:35 <gmann> anything else on team highlights ?
13:40:21 <gmann> jumping to bugs things.
13:40:24 <gmann> #topic Bug Triage
13:40:51 <gmann> kopecmartin: go ahead
13:41:14 <kopecmartin> we have quite many patches to review , i put them in the etherpad
13:41:20 <kopecmartin> #link https://etherpad.openstack.org/p/qa-bug-triage-ussuri
13:41:46 <kopecmartin> most of the high priority ones are quite simple, so if you have some time, please, have a look
13:42:13 <kopecmartin> the bug numbers are still decreasing, which is great news
13:42:22 <gmann> great,
13:42:40 <gmann> i will be able to start review after m-3 which is friday this week
13:42:54 <gmann> this is bug i was talking about for stein gate
13:42:58 <gmann> #link https://bugs.launchpad.net/tempest/+bug/1871327
13:42:59 <openstack> Launchpad bug 1871327 in tempest "stable/stein tempest-full job fails with "tempest requires Python '>=3.6' but the running Python is 2.7.17"" [Undecided,New]
13:43:29 <gmann> not sure why tempest-full even it is py2 job not using the py3 venv on stein. I will this today if get time
13:44:04 <gmann> all the job using master tempest and have py3.6 on system should use the same in their venv irrespective of they are py2 or py3 job
13:44:40 <gmann> kopecmartin: any other critical gate blocking bug ?
13:44:43 <paras333> ack
13:45:10 <kopecmartin> gmann: no
13:45:24 <gmann> ok
13:45:28 <gmann> #topic Critical Reviews
13:45:33 <gmann> any critical review ?
13:45:46 <kopecmartin> critical no
13:45:54 <kopecmartin> just those mentioned in the etherpad
13:46:05 <gmann> ok.
13:46:07 <gmann> #topic Open Discussion
13:46:19 <gmann> I added one topic there
13:46:36 <gmann> Cleanup the QA project for non-active members
13:47:09 <gmann> I saw there are many sub projects still has members in core list who are not active or not working in openstack any more. I will cleanup those.
13:47:33 <kopecmartin> how many projects are we talking about?
13:47:46 <gmann> #action gmann to cleanup the QA sub projects core list.
13:48:03 <gmann> kopecmartin: i have to check like bashate is one example
13:48:14 <kopecmartin> ah ok
13:48:20 <gmann> hacking is another
13:48:28 <gmann> next is - Volunteer for 'Hacking's maintainer.
13:48:52 <kopecmartin> I need to check how many attention it would require
13:49:03 <gmann> we need volunteer if someone can stepup for hacking projects. we usually maintain it as traffic is less
13:49:23 <gmann> but having few active in core list will be good. I will keep doing in that
13:49:25 <tosky> re: grenade, just in case: we should be good hopefully: tempest logs are captured, branches are defined in a single role (even though it's called twice)
13:49:50 <gmann> tosky: thanks for update. I will check it after m-3
13:50:09 <gmann> twice is ok, we can optimize the job later and let's get the base stuff working in
13:50:58 <gmann> any other topic to discuss today ?
13:51:11 <paras333> Do we support windows instance to be used with tempest test?
13:51:52 <gmann> as long as nova is configure with hyperV and all it should.
13:51:55 <gmann> and image etc
13:52:21 <paras333> I mean I know some may take more than 300 secs to be available with volume backed and all and saw some issues there so
13:52:22 <gmann> there is no specific dependency of Tempest on instance type
13:52:51 <gmann> from Tempest side issue or env not booting instance ?
13:53:42 <paras333> it takes sometime more than 300 sec to boot with virtual size of windows image is more than 40 GB as that require 40 GB volume as well to attach
13:53:57 <paras333> so I have seen timeout issue appearing
13:54:07 <paras333> from the waiters
13:54:18 <gmann> did you check nova logs ?
13:54:31 <gmann> 40 GB wow
13:54:46 <paras333> yup doing it without tempest worked fine
13:54:56 <paras333> like manually running it
13:55:18 <paras333> anyways I will share the logs if it support, thanks!
13:55:19 <gmann> it can be test timeout or service side timeout.
13:55:23 <gmann> cool
13:55:57 <gmann> there is HyperV CI on nove gate which run tempest on window VM so it work for sue
13:55:58 <gmann> sure
13:56:10 <gmann> but that large config, i am not sure.
13:56:17 <gmann> anything else?
13:56:23 <paras333> gmann:  ack
13:57:00 <gmann> ok let's close for today
13:57:04 <gmann> thanks everyone for joining
13:58:31 <gmann> #endmeeting