09:00:12 <gmann> #startmeeting qa
09:00:13 <openstack> Meeting started Thu Apr 12 09:00:12 2018 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:17 <openstack> The meeting name has been set to 'qa'
09:00:37 <gmann> who all here today ?
09:00:43 <mguiney> o/
09:00:44 <afazekas> 0/
09:00:54 <gmann> hi
09:00:54 <frickler> o/
09:01:50 <gmann> let's start
09:01:53 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
09:01:59 <gmann> today agenda ^^
09:02:44 <gmann> #topic Announcement and Action Item (Optional)
09:03:09 <gmann> nothing in this for today. no AI from previous meeting
09:03:35 <dirk> frickler: will do
09:03:39 <gmann> #topic Rocky Priority Items progress
09:03:55 <gmann> #link https://etherpad.openstack.org/p/qa-rocky-priorities-tracking
09:04:25 <gmann> let's cover the items which has progress and need reviews
09:04:27 <gmann> 1. Zuul v3 native jobs - andreaf
09:05:11 <gmann> #link https://review.openstack.org/#/q/topic:multinode_zuulv3+(status:open+OR+status:merged)
09:05:21 <gmann> #link https://review.openstack.org/#/q/topic:grenade_zuulv3+(status:open+OR+status:merged)
09:05:39 <gmann> andreaf: had patches up for review. multinode on queens and grenade one on master
09:06:06 <gmann> i did not get time to review grenade one. i will put these in my list for tomorrow for sure
09:06:45 <gmann> complete details of items are here - https://etherpad.openstack.org/p/zuulv3-native-devstack-tempest-jobs
09:06:47 <gmann> #link https://etherpad.openstack.org/p/zuulv3-native-devstack-tempest-jobs
09:07:04 <gmann> frickler: anything on this from you ?
09:08:41 <gmann> anyways let's move next meantime
09:08:43 <gmann> 2. Remove Deprecated APIs tests from Tempest. - gmann
09:08:43 <frickler> I can look into the stable patches for devstack
09:08:57 <gmann> frickler: ok, thanks that will be helpful
09:09:15 <gmann> #link     https://review.openstack.org/#/q/status:open+branch:master+topic:volume-default-testing-v3
09:09:35 <gmann> i have patches ready for volume v3 and seem some review from zhufl
09:09:44 <gmann> i will check those and updated accordingly
09:10:02 <openstackgerrit> Federico Ressi proposed openstack/tempest master: Fix code to pass pep8 Tox environment.  https://review.openstack.org/560360
09:10:03 <openstackgerrit> Federico Ressi proposed openstack/tempest master: Forbid log to write to stdout  https://review.openstack.org/560073
09:10:03 <openstackgerrit> Federico Ressi proposed openstack/tempest master: Fix test_http test case.  https://review.openstack.org/559102
09:10:04 <openstackgerrit> Federico Ressi proposed openstack/tempest master: Fix support for proxy URL from tempest.conf  https://review.openstack.org/559069
09:10:24 <gmann> 3. Tempest Items:
09:10:50 <gmann> no progress on this except we have microversion caps patches on tempest tests
09:11:11 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/clear-deprecated-api
09:11:17 <gmann> this series basically.
09:11:50 <gmann> and this is base patch which  we need to merge first - https://review.openstack.org/#/c/557907/
09:11:52 <gmann> #link https://review.openstack.org/#/c/557907/
09:12:33 <gmann> reviews on base patch are welcome and helpful to get those patches in
09:12:52 <gmann> 4. Running patrole on gate- felipemonteiro
09:13:22 <gmann> felipe has progress in this
09:13:24 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/patrole+branch:master+topic:policy-feature-flags
09:13:36 <gmann> #     https://review.openstack.org/#/c/547851/
09:13:40 <gmann> #link     https://review.openstack.org/#/c/547851/
09:14:02 <gmann> we are going with feature flag to solve this and make patrole runnable on stable branch
09:14:12 <gmann> i need to re-review the updated changes
09:14:39 <gmann> which i will be able to do next week early
09:14:50 <gmann> 5. Interop test for adds-on project - gmann
09:15:37 <gmann> for this i still need to write something bets practice for interop tests and check with mugsie on what all help they need
09:15:55 <gmann> 6. Tempest CLI unit tests improvement - mguiney
09:16:09 <gmann> mguiney: ^^
09:16:48 <mguiney> hello!
09:17:25 <mguiney> i have been a little underwater, and this meeting is a little tricky to make (ots 2am here) which is why ive been quiet
09:17:43 <gmann> mguiney: oh, sorry about that
09:18:14 <gmann> mguiney: anyways, in case you have any review ready please keep adding those in etherpad so that we can review those as per priority
09:18:20 <mguiney> i do need a little clarification on what sector of the existing unit tests needs improvement, exactly
09:18:31 <gmann> mguiney: sure
09:19:05 <mguiney> is it a matter of "more coverage", or more of "updates for new festures", etc
09:19:17 <gmann> mguiney: actually we had few issues we faced while updating the CLI code and that were not captured due to no UT coverage
09:19:31 <mguiney> ahhhhhhh ok
09:19:34 <gmann> mguiney: more coverage. current coverage is too less
09:19:34 * andreaf sneaks in
09:20:08 <gmann> mguiney: i will update the info and history patches on etherpad so that you can get idea about what all kind of coverage we need
09:20:22 <mguiney> excellent, thank you
09:20:46 <mguiney> hopefully i should be able to get some eork done on that shortly :)
09:20:48 <gmann> #action gmann to put more info on CLI UT coverage requirement on etherpad
09:21:01 <gmann> mguiney: nice, thanks for help on this.
09:22:10 <gmann> let's move next
09:22:22 <gmann> 8. Future of OpenStack-Health - masayukig
09:22:37 <gmann> #link https://review.openstack.org/#/c/547866/
09:22:58 <gmann> masayukig: updated the review link which o-h guys can review.
09:23:16 <gmann> mtreinish: for you :) #link https://review.openstack.org/#/c/547866/
09:23:50 <gmann> anything else on Rocky item tracking ?
09:24:04 <chandankumar> gmann: On containerization tempest job
09:24:09 <chandankumar> I have few updates to share
09:24:28 <gmann> chandankumar: sure, please go ahead
09:24:29 <gmann> 9. Consuming Kolla tempest container source image in CI     - chandankumar
09:24:31 <chandankumar> I have enabled containerized tempest job for tripleo
09:24:38 <chandankumar> https://review.openstack.org/#/c/551442/
09:24:42 <gmann> chandankumar: did not see any update on etherpad so skipped today
09:24:48 <chandankumar> http://tripleo.org/cistatus.html
09:24:55 <gmann> #link https://review.openstack.org/#/c/551442/
09:25:00 <gmann> #link http://tripleo.org/cistatus.html
09:25:06 <chandankumar> grep for undercloud-containers jobs is consumeing tempest container
09:25:20 <chandankumar> I will be replacing tripleo tempest gate with this one
09:25:32 <gmann> chandankumar: nice
09:25:33 <chandankumar> as well as I will start poking with kolla ansible
09:25:41 <chandankumar> that's it from my side
09:25:52 <gmann> chandankumar: thanks for that and updates
09:26:23 <gmann> chandankumar: i have added the review link on etherpad, though we might not be able to review completely but good to have links there
09:26:33 <gmann> chandankumar: please update the same for kolla CI review also
09:26:36 <chandankumar> gmann: sure
09:26:59 <gmann> chandankumar: thanks again
09:27:13 * chandankumar will be out for a while.
09:27:19 <gmann> #topic OpenStack Events Updates and Planning
09:27:31 <gmann> next coming event is Vancouver Summit
09:27:57 <gmann> action item is to collect the topic for forum
09:27:59 <gmann> #link https://etherpad.openstack.org/p/YVR-qa-brainstorming
09:28:10 <gmann> feel free to add your idea there
09:28:37 <gmann> i will check the latest topic and submit by tomorrow
09:29:29 <gmann> one of our default topic is feedback on QA projects and tooling etc
09:29:55 <gmann> something which can be good is Extreme testing but not sure samP plan on that
09:31:13 <gmann> thats all on this
09:31:19 <gmann> #topic Sub Teams highlights (Sub Teams means individual projects under QA program)
09:32:04 <gmann> Tempest
09:32:11 <gmann> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
09:32:42 <gmann> pep8 seems failing now
09:33:17 <gmann> #link https://review.openstack.org/#/c/560360/
09:33:33 <gmann> there is patch up for correcting it on code side.
09:33:41 <gmann> ll check sometime during night
09:35:35 <zhufl> don
09:35:43 <gmann> zhufl: hi
09:35:52 <gmann> zhufl: finally on IRC :)
09:36:03 <zhufl> dont understand patch 560360
09:36:09 <gmann> other update is to get this base patch review #link https://review.openstack.org/#/c/557907/
09:36:32 <gmann> zhufl: i have not checked yet and failure too
09:36:37 <zhufl> I use a blue tooth keyboard on my mobile phone now:)
09:37:47 <gmann> zhufl: it will fix the failure
09:37:49 <gmann> #link http://logs.openstack.org/07/557907/7/check/openstack-tox-pep8/2a062d7/job-output.txt.gz
09:38:22 <gmann> i am waiting for the gate results
09:38:36 <gmann> or let me check pep8 only
09:39:20 <gmann> it  pass seems - http://logs.openstack.org/60/560360/3/check/openstack-tox-pep8/4715b13/
09:39:55 <gmann> so let's get this in to fix pep8
09:40:01 <zhufl> pep8 enables some new checks?
09:40:23 <zhufl> e。g。,w503
09:40:38 <gmann> zhufl: not sure, i just saw it in meeting
09:40:57 <zhufl> o
09:41:01 <gmann> did not dig into the cause
09:41:13 <zhufl> heh
09:41:31 <gmann> we will check on this after office hour
09:41:38 <gmann> anything else on tempest
09:42:30 <gmann> next  Patrole
09:43:07 <gmann> updates here is to get the feature flag things in and run patrole jobs for stablle branch
09:43:18 <gmann> then multi policy checks
09:43:35 <gmann> once that is done we can mark a stable release for patrole
09:44:13 <gmann> thats all on patrole
09:44:34 <gmann> anything else have any updates from subteam ?
09:44:40 <frickler> devstack
09:44:54 <frickler> I've been doing some cleanup on bugs and reviews
09:45:10 <gmann> frickler: sure, please go ahead
09:45:23 <frickler> and I'm also planning do set up a different office hour for it
09:45:41 <gmann> frickler: ok. you have link of patches ?
09:45:52 <frickler> can discuss later, just if folks are interested to join, that would be nice
09:46:05 <frickler> not yet, I'll draft up something soon
09:46:12 <gmann> frickler: ok
09:46:31 <gmann> it is nice idea, any Thing your sorted out for that
09:46:41 <gmann> *you
09:46:44 <tosky> not sure if it was discussed again, but with the new extended policy for branches, what is the plan for stable/ocata?
09:46:49 <gmann> i mean time
09:47:19 <gmann> tosky: it will stay in our CI as long as EOL
09:47:24 <gmann> like newton
09:47:48 <tosky> does it mean that, after fixing the new zuulv3 stuff for queens and pike, we need to backport the native job to stable/ocata too?
09:49:18 <gmann> tosky: i am not 100% sure but i think ocata one can stay on zuulv2 but need to check with infra team on plan of keeping zuulv2 things.
09:49:29 <gmann> or plan for ocata
09:49:30 <frickler> IIUC it will be up to each project to decide how much effort they want to put into that
09:49:53 <frickler> we are running zuulv3 but the legacy jobs should still continue to work
09:49:55 <gmann> yea it is little more effort for QA if we make it for ocata also
09:50:31 <tosky> I'm asking because I killed the legacy jobs from sahara, enabling the zuulv3 only, the week before ocata was supposed to be killed
09:50:37 <gmann> is extended time defined for ocata?
09:51:04 <tosky> so right now, apart from pep8 and unit tests, I have no working tempest and scenario jobs for ocata :D
09:51:14 <tosky> for sahara
09:51:15 <frickler> gmann: I think it was extended by 6 months, but with the recent stable policy change that may not be the end
09:51:30 <gmann> humm
09:51:59 <frickler> tosky: I think you should better ask stable team and/or TC
09:52:00 <gmann> i remember we have kept stable ocata on zuulv2 only
09:53:01 <gmann> yea, tosky can tell us if any new EOL dates or how other stuff going for ocata support
09:53:06 <frickler> gmann: zuulv2 is no longer running, but the job that were in place are legacy v3 jobs now
09:53:12 <tosky> I have no idea about the exact dates
09:53:22 <gmann> frickler: yea i mean legacy zuulv3
09:53:43 <tosky> during the PTG I ended up in the room where this was discussed but after the meeting, and I was told about this extension, but I don't know much more
09:53:55 <gmann> have not converted to v3 completely
09:54:01 <tosky> so I was hoping that it was communicated more precisely and I simply lost that notice/email
09:54:15 <gmann> yea, i know it was not concluded in PTG at least
09:55:06 <gmann> but i personally prefer not to put effort on that which is more for us. but again it depends if we get clarity on exact dates for EOl ocata
09:56:35 <gmann> 4 min left so let's move next
09:57:02 <gmann> i will skip Bug Triage today as not much time left.
09:57:08 <gmann> #topic Open Discussion
09:57:23 <gmann> jlvillal pinged and added agenda on hacking release
09:57:34 <gmann> which we can do i think
09:57:44 <gmann> i will check and release it tomorrow.
09:58:07 <gmann> #action gmann to make release for hacking
09:58:13 <gmann> 2 min left
09:58:21 <gmann> anything else to discuss from anyone
09:59:53 <gmann> ok let's close it for today
09:59:59 <gmann> thanks all for joining
10:00:03 <gmann> #endmeeting