08:00:32 <gmann_> #startmeeting qa
08:00:32 <openstack> Meeting started Thu Feb 22 08:00:32 2018 UTC and is due to finish in 60 minutes.  The chair is gmann_. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:35 <openstack> The meeting name has been set to 'qa'
08:00:41 <masayukig> heh
08:01:06 <gmann_> who all here today?
08:01:22 <masayukig> p/
08:01:25 <masayukig> o/
08:02:07 <gmann_> let's wait for couple of min
08:02:29 <masayukig> ok
08:04:54 <gmann_> let's start
08:05:05 <gmann_> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_Feb_22nd_2018_.280800_UTC.29
08:05:15 <gmann_> today agenda ^^
08:05:46 <gmann_> #topic Previous Meeting Action review
08:05:58 <gmann_> no AI from last meeting
08:06:06 * masayukig nods
08:06:09 <gmann_> #topic Rocky PTG Planning
08:06:22 <gmann_> #link https://etherpad.openstack.org/p/qa-rocky-ptg
08:06:29 <gmann_> #link https://ethercalc.openstack.org/Rocky-PTG-QA-Schedule
08:06:43 <gmann_> ^^ i prepared the schedule for PTG
08:07:04 <gmann_> and make the order also in same way in etherpad
08:07:14 <masayukig> cool, thanks
08:07:28 <gmann_> masayukig: is stestr time ok?
08:08:29 <masayukig> gmann_: yeah, it works for me, but I don't know about mtreinish
08:08:33 <gmann_> ok
08:08:59 <mguiney> o/ (lurking)
08:09:14 <gmann_> i need to send mail for interop and deprecation API test topic on ML to get more attention from all stack-holders
08:09:18 <gmann_> i wil do it today
08:09:42 <gmann_> #action gmann to send ML for PTG interop and deprecation API test sessions
08:10:09 <masayukig> k
08:10:18 <masayukig> mguiney: hi!
08:10:24 <gmann_> other things for PTG is to have a QA night with some food and drink
08:10:54 <gmann_> i will add a doodle vote today and send mail to select the date.
08:11:29 <masayukig> +1 :)
08:11:55 <gmann_> tuesday is Official PTG Networking Reception
08:12:15 <gmann_> #action gmann to send the QA night plan on ML
08:12:22 <gmann_> anything else for PTG?
08:13:02 <masayukig> gmann_: I added some on the retrospective
08:13:06 <masayukig> https://etherpad.openstack.org/p/qa-queens-retrospective
08:13:15 <masayukig> #link https://etherpad.openstack.org/p/qa-queens-retrospective
08:13:16 <gmann_> i see thanks
08:14:02 <gmann_> let's move next
08:14:04 <gmann_> #topic Tempest
08:14:32 <gmann_> i pushed the tempest release for 18.0.0 to mark the start of Rocky
08:14:45 <gmann_> #link https://review.openstack.org/#/c/546906/1
08:14:53 <gmann_> it need reno in tempest
08:14:58 <gmann_> #link https://review.openstack.org/#/c/546903/
08:15:12 <gmann_> masayukig: ^^ we need to merge this first
08:16:13 <masayukig> gmann_: k, I'll check them tomorrow
08:16:29 <gmann_> masayukig: thanks
08:16:38 <gmann_> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
08:16:43 * andreaf lurks aroud
08:16:44 <gmann_> these are open review for tempest
08:17:10 <gmann_> masayukig: saw your unit tests patch? we have less coverage for CLI?
08:17:48 <masayukig> gmann_: yes, I think so. especially for option combinations
08:18:30 <gmann_> i see
08:19:05 <gmann_> let's talk about it in PTG also durign code sprint etc
08:19:54 <masayukig> gmann_: yeah! I just added about it on the retrospective etherpad :)
08:19:54 <andreaf> I saw a comment on the stestr for tempest CLI that just merged that that patch breaks
08:20:32 <andreaf> #link https://review.openstack.org/#/c/504345/
08:21:12 <andreaf> but I have not validated that
08:21:29 <masayukig> andreaf: yeah, it's true..
08:22:14 <andreaf> gmann_ did that go into the new release?
08:22:29 <gmann_> andreaf: yea just pushed that
08:22:41 <gmann_> #link https://review.openstack.org/#/c/546906/1
08:22:48 <gmann_> #link https://review.openstack.org/#/c/546903/
08:22:57 <andreaf> ok I guess we can push a fix and then another minor release
08:22:59 <gmann_> secodn one is tempest reno which we need to merge forst
08:23:01 <gmann_> first
08:23:24 <andreaf> chandankumar do you want to look into fixing that issue?
08:23:34 <gmann_> we have time if something urgent we want to fix
08:24:24 <gmann_> otherwise we can always do minor release in PTG
08:24:44 <masayukig> andreaf: what's the issue?
08:24:55 <masayukig> https://review.openstack.org/#/c/504345/ ?
08:25:21 <masayukig> I already pushed a patch for it as a first step.
08:25:21 <andreaf> masayukig gmann_ I don't know sorry maybe no issue I just saw the comment on the fly before going to sleep I haven't validated it
08:25:32 <masayukig> :)
08:25:35 <andreaf> masayukig ah ok
08:26:21 <andreaf> thanks!
08:26:58 <gmann_> yea unit testing is something we should do more
08:27:04 <gmann_> ok, let's move
08:27:09 <andreaf> so on Tempest
08:27:20 <masayukig> andreaf: no problem
08:27:28 <andreaf> https://review.openstack.org/#/c/544521/ is not critical maybe but I'd really like to see that merged as a first step
08:27:46 <andreaf> then the plugin sanity job needs to be fixed because atm is really broken
08:28:06 <andreaf> and if we don't fix it we might as well drop it :)
08:28:06 <gmann_> sure
08:28:18 <gmann_> plugin sanity job is timeout or what was issue?
08:28:48 <andreaf> gmann_ well POST FAILURE is what I'm fixing in my patch
08:28:58 <gmann_> k
08:29:01 <andreaf> but apart from that the job is not doing what it means to do
08:29:19 <andreaf> it tries to install plugins one by one with install list remove for each plugin
08:29:48 <andreaf> but remove is not working so plugins are accumulating and at the end the job reports that all plugins are broken
08:30:10 <andreaf> also it would be nice to improve job reporting but ok that's less critical
08:30:39 <gmann_> remove is not working you mean we are not doing it correctly or some issue?
08:31:15 <andreaf> I mean that in the test venv plugins are not removed - I don't know why
08:31:41 <gmann_> k
08:31:58 <andreaf> anyways I'm pushing hard on the ansible / multinode stuff and chandankumar is busy so perhaps someone has time to have a look
08:32:10 <andreaf> or at least merge the initial patch that hides the issue
08:32:32 <gmann_> ok
08:32:40 <gmann_> ll check that tomorrow
08:33:11 <andreaf> thanks
08:33:33 <gmann_> anything else for Tempest?
08:34:28 <gmann_> let's move next
08:34:36 <gmann_> #topic Critical Reviews
08:34:45 <gmann_> #link https://review.openstack.org/#/c/546903/
08:34:53 <gmann_> this is ready now andreaf masayukig ^^
08:35:11 <gmann_> we still not marked newton EOL in tempest. i do not know if it really EOL
08:35:14 <andreaf> ok
08:35:29 <gmann_> but we can always do it later when it is confirmed.
08:35:34 <andreaf> yeah newton EOL... I'm confused by that
08:35:53 <andreaf> we still run newton jobs
08:36:14 <gmann_> :) me too. yea and i do not find newton branch for porjects
08:36:20 <andreaf> and newton is the only branch that still runs nova-net
08:36:28 <andreaf> so I guess it's a sensitive issue
08:36:30 <gmann_> ll catch tonyb in PTG
08:36:50 <gmann_> yea. we will try to remove nova-net code in rocky if we can :)
08:37:22 <gmann_> anyways, once tempest reno patch is merged i will the hash in release patch
08:37:41 <gmann_> any other review on priority
08:39:37 <gmann_> got network disconnected
08:39:44 <gmann_> did i miss any msg?
08:40:17 <andreaf> nope
08:40:24 <andreaf> this devstack patch https://review.openstack.org/#/c/546765/
08:40:38 <andreaf> #link https://review.openstack.org/#/c/546765/ it would be nice to move forward on that
08:41:04 <gmann_> k
08:41:32 <gmann_> added in my list
08:42:11 <gmann_> let's move to open
08:42:15 <gmann_> #topic Open Discussion
08:42:38 <gmann_> anything else to discuss
08:43:17 <gmann_> ok i also have nothing more
08:43:26 <gmann_> let's close the meeting then
08:43:30 <masayukig> ok
08:43:37 <gmann_> see you all in Dublin, have safe flight
08:43:42 <masayukig> \o/
08:43:46 <masayukig> you too
08:43:55 <gmann_> thanks
08:43:56 <gmann_> #endmeeting