08:00:42 <gmann> #startmeeting qa
08:00:43 <openstack> Meeting started Thu Aug 10 08:00:42 2017 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:47 <openstack> The meeting name has been set to 'qa'
08:00:48 <eumel8> thx ianychoi. have a nice evening :)
08:00:59 <gmann> who all here today?
08:01:00 <ianychoi> :) (sorry qa team)
08:01:05 <masayukig> o/
08:01:10 <masayukig> ianychoi: np :)
08:01:11 <gmann> ianychoi: you are welcome here too :)
08:01:25 <zhufl> hello
08:01:25 <masayukig> heh
08:01:27 <blancos> o/
08:01:28 <ianychoi> gmann, oh then o/  :)
08:01:59 <gmann> let's wait for min to join more people
08:02:18 <masayukig> gmann: +1
08:03:17 <gmann> masayukig: its holiday for you too from today?
08:03:55 <masayukig> gmann: nope, it's from tomorrow :)
08:04:07 <gmann> ohk
08:04:17 <gmann> let's start
08:04:21 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_August_10th_2017_.280800_UTC.29
08:04:25 <gmann> ^^ today agenda
08:04:51 <gmann> #topic Previous Meeting Action review
08:05:09 <gmann> #action gmann to send ML for upcoming removal of deprecated interfaces and its affect on stable branches
08:05:29 <gmann> i have done done it yet, i am collecting all plugins using those decorator and send send mail to them
08:05:39 <gmann> i should be doing it on monday at max
08:05:56 <gmann> #topic PTG
08:06:08 <gmann> #link https://etherpad.openstack.org/p/qa-queens-ptg
08:06:44 <gmann> help hours idea seems good progress but we need more sessions  proposal for discussion
08:07:05 <gmann> if anyone have any write those to etherpad
08:07:46 <gmann> masayukig: zhufl blancos what s status for you guys for PTG availability?
08:08:04 <blancos> I won't be going ): But felipemonteiro will be there
08:08:13 <masayukig> gmann: I could get the budget, eventually :)
08:08:17 <zhufl> gmann: I am trying to take back my passport:(
08:08:37 <gmann> blancos: i see. that's good that felipe can join
08:08:44 <gmann> masayukig: ohh
08:08:59 <gmann> zhufl: still in process state?
08:09:08 <zhufl> gmann: yeah
08:09:10 <gmann> masayukig: that is good news
08:09:17 * masayukig nods
08:09:24 <gmann> zhufl: oh, that's not good
08:09:43 <zhufl> gmann: half a year passed:)
08:10:04 <gmann> zhufl: hummm, can you ask them either reject it or approve it :)
08:10:22 <zhufl> gmann: yeah I am trying that:)
08:10:22 <masayukig> zhufl: oh..
08:10:31 <gmann> anyways let's add proposal ideas on etherpad as almost month left for PTG
08:11:20 <gmann> #topic Gate Stability
08:11:30 <masayukig> gmann: yeah, I'll do that after the summer vacation
08:11:41 <gmann> masayukig: +1
08:11:57 <gmann> anything on gate from anyone. its stable as of now
08:12:54 <gmann> #topic Specs Reviews
08:13:10 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
08:13:17 <gmann> ^^ current spec
08:13:46 <gmann> i have reviewed HA one  #link https://review.openstack.org/#/c/443504/
08:14:03 <gmann> it is close as first spec and after that we will have detail design spec
08:15:08 <gmann> samP is in mexico for ops meeting, and updated about feedback he is getting from there on destructive testing
08:15:23 <gmann> after that he will update spec accordingly
08:15:36 <masayukig> nice
08:16:06 <gmann> another spec we need to review before PTG is patrole one
08:16:07 <gmann> #link https://review.openstack.org/#/c/461140/
08:16:22 <gmann> based on that we can discuss it f2f if needed
08:17:50 <gmann> feel free to push spec for sessions if anything you want to discuss in PTG
08:18:04 <gmann> anything else to discuss on spec?
08:18:50 <gmann> let's move then
08:18:52 <gmann> #topic Tempest
08:19:10 <gmann> Test.py as stable
08:19:21 <gmann> #link https://etherpad.openstack.org/p/tempest-test-module-stable
08:19:35 <gmann> ^^ etherpad for things to make test.py stable
08:20:17 <gmann> andreaf replied on my concern there and its all are in good shape now
08:20:56 <zhufl> can CONF be used in test.py in the future?
08:21:10 <gmann> i think only thing i want to check is extensions decorator
08:21:44 <gmann> zhufl: it will be there from now itself as it has dependency on CONF
08:22:07 <gmann> zhufl: its not possible to remove dependency of CONF from it. it will be huge change
08:22:22 <zhufl> gmann: I think so too:)
08:22:38 <gmann> zhufl: so it ok to have CONF there and not move into /lib but declare it as stable interface from current location
08:22:56 <zhufl> gmann: nice
08:23:34 <gmann> making them stable means adding test.py in https://docs.openstack.org/tempest/latest/plugin.html
08:23:52 <masayukig> gmann: will you discuss this thing in the PTG? or we don't need that?
08:23:57 <zhufl> gmann: oh, i c
08:23:59 <gmann> and publish it as stable
08:24:32 <gmann> masayukig: we can discuss if we have any concern on those otherwise its good to go. i think andreaf can finish it before PTG itself :)
08:25:02 <gmann> but one thing to note is once we declare it as stable we need to treat it as /lib files and we cannot modify
08:25:36 <gmann> so now only we can try to shrink it as much as possible
08:25:56 <masayukig> gmann: sounds nice about finishing it :)
08:25:57 <gmann> if you have more ideas or any concern feel free to comment on that etherpad
08:26:05 <zhufl> gmann: cannot modify? or modify with a reno?
08:26:33 <gmann> zhufl: no, we need to maintain the backward compatibility there like stable interface inside /lib/*
08:26:57 <zhufl> gmann: oh
08:27:13 <gmann> if anything needs to be change that has to go with deprecation things
08:27:52 <masayukig> gmann: sure, I'll look at it and comment on it if I have that :)
08:28:08 <gmann> nice
08:28:31 <gmann> next is Bug Triage:
08:29:03 <gmann> #link https://etherpad.openstack.org/p/pike-qa-bug-triage
08:29:30 <gmann> it was chandankumar turn but he was busy with visa things last week so could not have much proress
08:30:12 <gmann> currently we have 6 new bugs, let's try to make it 0
08:30:42 <gmann> next week is prateek trun.
08:31:26 <gmann> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
08:31:30 <masayukig> gmann: yeah, we can do it :)
08:31:46 <gmann> ^^ these are current patches in tempest
08:31:48 <gmann> masayukig: +1
08:32:07 <gmann> keep the good review.
08:32:14 <gmann> anything else on tempest side
08:33:26 <gmann> let's move next then
08:33:39 <gmann> #topic Patrole
08:33:49 <gmann> #link https://review.openstack.org/#/q/project:openstack/patrole
08:34:00 <gmann> blancos: take the control
08:34:12 <blancos> There's not much to report right now
08:34:29 <blancos> I believe Felipe added a few things to the PTG etherpad to talk about in Denver
08:34:35 <gmann> what is next or current things in patrole, keep adding the remaining tests?
08:35:01 <blancos> We have a few more tests we're adding, currently working on adding more things to a stable interface, and cleaning up code
08:35:19 <blancos> Next big steps will come after current open spec reviews are reviewed and merged
08:35:55 <gmann> nice
08:36:09 <gmann> i have many people in my company mainly openstack SI team and they are interesting to contribute, i asked them to check the patrole
08:36:27 <masayukig> nice
08:36:43 <blancos> gmann That would be great :)
08:37:01 <martinkopec> :q
08:37:02 <gmann> i will discuss with flelipe where they can help
08:37:09 <gmann> in PTG
08:37:40 <gmann> they would not be full time so i do not want to have any ownership of things on them but yea they can help on ongoing effort for sure
08:38:45 <gmann> #link Critical Reviews
08:39:13 <gmann> blancos: anyways can you check this https://review.openstack.org/#/c/491679/
08:39:24 <gmann> i do not have other critical review as of now
08:39:57 <gmann> anyone has reviews which need more reviews and speedy way
08:40:32 <gmann> i saw andreaf pushing many patches for test.py stable
08:40:38 <gmann> its good series to review
08:40:39 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:test_module_stable
08:41:26 <gmann> #topic Open Discussion
08:41:54 <gmann> anything more to discuss
08:42:06 <zhufl> Gate seems not working well now
08:42:13 <gmann> zhufl: oh
08:42:15 <chandankumar> gmann: zhufl please have a look on this https://review.openstack.org/#/c/488497/
08:42:46 <gmann> zhufl: what is failing
08:43:10 <gmann> its seems stable branches
08:43:22 <masayukig> too long queue?
08:43:34 <gmann> not stable one
08:43:51 <zhufl> gmann: masayukig: yeah, maybe
08:44:06 <zhufl> chandankumar: ok
08:44:30 <gmann> zhufl: same failure on multiple patches ?
08:45:03 <gmann> i did find, i think its randome
08:45:15 <zhufl> gmann: seems not exactly name failure
08:45:25 <gmann> but let's monitor the gate carefully as it is rc time and very critical
08:46:19 <gmann> may be we can check this a very first things in morning.
08:46:29 <gmann> till Pike is released
08:47:00 <masayukig> yeah
08:47:16 <gmann> anything else form anyone.
08:47:22 <andreaf> o/
08:47:33 <gmann> andreaf: hi, we are almost done :)
08:47:37 <andreaf> sry I'm late
08:47:48 * masayukig is waving
08:48:03 <gmann> andreaf: last things we were discussing about gate and keep it monitor daily til Pike is released
08:48:10 <zhufl> andreaf: nice to see you:)
08:48:26 <andreaf> zhufl o/ nice to see you
08:48:33 <gmann> andreaf: to keep release smooth and on time
08:48:35 <andreaf> gmann: yeah we have to fee nodes
08:48:48 <andreaf> so there's going to be backlog building up
08:49:08 <andreaf> also I think some network issues in the infra vanilla cloud where being investigated
08:49:17 <gmann> ok
08:50:46 <andreaf> I hope to see as many of you as possible in Denver! :)
08:50:55 <masayukig> \o/
08:50:55 <gmann> yea
08:51:00 <andreaf> blancos: sry you won't be there
08:51:14 <andreaf> zhufl: hopefully you'll get your visa in time!
08:51:30 <zhufl> andreaf: wish so:)
08:51:33 <gmann> yea
08:52:34 <gmann> anything else from anyone
08:52:53 <andreaf> BTW thanks all for contributions on https://etherpad.openstack.org/p/qa-queens-ptg - there is still time to add new ideas in there
08:53:06 <gmann> +1
08:53:55 <gmann> last but not the least. let's congrat andreaf for his second term as PTL !
08:54:39 <zhufl> congrats!
08:54:55 <masayukig> yeah!!! congrats!!!
08:55:03 <andreaf> gmann: thanks :) it's my honour to serve you all
08:55:52 <zhufl> happy to be working with such a team and such a leader:)
08:56:16 <gmann> zhufl: yup
08:56:21 <masayukig> zhufl: +1
08:56:24 <gmann> if nothing else, let's close the meeting
08:56:35 <gmann> 3 ...
08:56:42 <gmann> 2 ..
08:56:49 <gmann> 1 .
08:56:52 <masayukig> thanks all
08:56:54 <gmann> #endmeeting