08:03:24 <gmann> #startmeeting qa
08:03:25 <openstack> Meeting started Thu Jul 27 08:03:24 2017 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:03:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:03:29 <openstack> The meeting name has been set to 'qa'
08:03:46 <gmann> who all are here today
08:03:49 <andreaf> o/
08:03:51 <blancos> o/
08:03:56 <zhufl> o/
08:04:00 <masayukig> \p
08:04:25 <andreaf> \o_O/
08:04:43 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_July_27th_2017_.280800_UTC.29
08:04:46 <masayukig> heh
08:04:53 <gmann> today agenda ^^
08:05:12 * andreaf refurbishing at home may be affecting his mental health
08:05:21 <gmann> #topic Previous Meeting Action review
08:05:29 <chandankumar> \o/
08:05:31 <gmann> no action item from last meeting
08:05:41 <gmann> #topic PTG
08:06:03 <gmann> #link https://etherpad.openstack.org/p/qa-queens-ptg
08:06:10 <gmann> etherpad for ptg ideas
08:06:16 <gmann> thanks andreaf
08:07:02 <andreaf> gmann: TheJulia added a topic in there for grenade/ironic - I think the description is clear enough but let me know if you have questions
08:07:09 <gmann> please start writing ideas for PTG discussion
08:07:25 <gmann> yea
08:07:43 <gmann> andreaf, Wednesday - Friday: QA sessions ?
08:07:48 <andreaf> gmann: I'll soon add in there a few standard ones about planning & priorities for various projects
08:08:19 <andreaf> gmann: yeah - though I think discussion session we can probably squeeze in in a day or two
08:08:20 <gmann> andreaf, QA sessions first 2 days right
08:08:40 <chandankumar> andreaf: we might host a sprint onsite a ptg to split their plugin in a seperate repo one day.
08:09:01 <chandankumar> might be volunteers from different project can join and do the split together
08:09:12 <andreaf> chandankumar, gmann the first two days will be QA help room
08:09:28 <andreaf> chandankumar, gmann: and my idea was to have a walkthrough session for migrating plugins
08:09:34 <gmann> andreaf, are we targeting all 56 days? not like previous one. cover all sessions discussion on first 2 days and then code sprint with whi all available
08:09:58 <gmann> 56 -> 5 days
08:10:04 <andreaf> chandankumar: but I like the idea also of people coming and doing their migration with our help
08:10:13 <andreaf> gmann: heh 56 sounded a bit too long :P
08:10:34 <gmann> heh:)
08:11:00 <andreaf> gmann: yeah so Monday Tuesday is help room, so no QA team internal discussions / sessions
08:11:10 <chandankumar> andreaf: added one more point to tempest plugin split walkthrough
08:11:11 <andreaf> gmann: Wed and maybe Thursday QA team sessions
08:11:22 <andreaf> gmann: the rest sprint
08:11:27 <gmann> andreaf, but if we target last 3 days for sessions etc then it will conflict with other projects sessions
08:11:30 <gmann> like nova for me
08:11:53 <gmann> i thought it will be like atlanta PTG
08:12:16 <chandankumar> i will be joining tripleo and kolla session if needed, i want to have a topic on how to test tempest in kolla
08:12:19 <andreaf> gmann: well you should have told that ttx when he proposed this planning :)
08:12:31 <gmann> oh
08:12:41 <gmann> i missed something on ML
08:12:49 <andreaf> gmann: I'm sure we can find a schedule that works
08:13:01 <andreaf> gmann: would you be attending all of the nova sessions?
08:13:24 <gmann> andreaf, not all but most of them may be
08:13:57 <andreaf> gmann: uhm ok that might be an issue but I don't think we can address it until we have more concrete details on sessions & co
08:14:14 <gmann> hummm
08:14:31 <andreaf> gmann: if there's no alternative we can still put some session in the first two days
08:15:01 <andreaf> the thing is that also in the 1st two days there'll be conflicts - with all the SIG / WG sessions going on
08:15:20 <andreaf> like API WG interop WG and others
08:15:26 <gmann> yea, mostly inter project things
08:15:47 <andreaf> gmann: so we'll have to do a bit of magic with the planning
08:15:51 <gmann> and QA is in horizontal projects
08:16:17 <andreaf> gmann: once we have a good idea about what we want to discuss as a team we can do a better plan
08:16:30 <gmann> ok
08:16:53 * gmann need to check ML. missed imp one seems
08:17:27 <gmann> anyways let's move. ll check the details
08:18:11 <gmann> all, add your ideas in this etherpad #link https://etherpad.openstack.org/p/qa-queens-ptg
08:18:23 <andreaf> gmann: tbh no planning will be perfect - I think ttx proposal is quite reasonable
08:18:24 <gmann> #topic Gate Stability
08:18:58 <gmann> andreaf, yea but i did not know horizontal and vertical things changed
08:19:44 <gmann> #link https://etherpad.openstack.org/p/pike-gate-issue-categotisation
08:20:00 <gmann> seems like no assignee on this except chandankumar
08:20:46 <gmann> on thing came on gate for stable branch and grenade testing for cinder mainly where data_utils changes broke them
08:21:01 <gmann> we reverted that and i sent mail also about fixing their stable branches
08:21:10 <gmann> and pushed many of the stable branches fix
08:21:51 <gmann> #link http://lists.openstack.org/pipermail/openstack-dev/2017-July/120086.html
08:22:00 <gmann> i mentioned about 1 month time to fix
08:22:08 <gmann> cinder fix is already merged
08:22:22 <gmann> i hope 1 month time is enough
08:23:05 <masayukig> gmann: thanks, do you need volunteers?
08:23:44 <gmann> masayukig, for review mainly. projects has to merge their submitted patches
08:24:05 <gmann> and same thing going to happen with this also #link https://review.openstack.org/#/c/486830/
08:24:05 <patchbot> patch 486830 - tempest - Remove deprecated test.idempotent_id decorator
08:24:36 <masayukig> gmann: ok, feel free to ping me for that reviews.
08:24:41 <gmann> we have pushed fixed on all plugin on master branch
08:24:50 <gmann> masayukig, those are on tempest plugin side
08:25:03 <masayukig> gmann: yeah,
08:25:09 <gmann> but not sure how to address stable branches fixes
08:25:21 <andreaf> gmann: we're getting quite close to having a good surface of stable interfaces, hopefully this won't be so much of a problem in the future
08:25:30 <masayukig> gmann: but I think it's better than nothing :)
08:25:31 <gmann> masayukig, thanks.  list is in ML #link http://lists.openstack.org/pipermail/openstack-dev/2017-July/120086.html
08:26:12 <gmann> andreaf, hope so but for test.idempotent_id same issue will come for stable branches
08:26:27 <masayukig> gmann: ok, I put them on my list
08:26:34 <gmann> will ML information work? i do not think plugins care or read that :)
08:27:12 <gmann> qa team fixing by ourself on master branch, only thing they have to do is cherry pick if they want
08:27:24 <andreaf> gmann: if we tag the project in the email I think it's good - it doesn't hurt to go into the IRC channel and ping folks directly as well though
08:27:33 <gmann> but that did not happen for data_utils with 5 month time period
08:27:59 <gmann> andreaf, humm. ok
08:28:16 <andreaf> gmann: yeah we probably waited a bit too long there - what's your proposal otherwise?
08:28:55 <gmann> andreaf, i do not have any other, i think we can do that as max.
08:29:35 <gmann> we donot want to break gate even its issue on plugin side
08:30:15 <gmann> i was thinking , i can backport fix for test.idempotent_id also and ping project on ML or IRC about merge if needed
08:30:36 <gmann> and when we remove test.idempotent_id and anyone break we do not revert and ask their stable branch patch to merge
08:30:41 <gmann> is it ok?
08:32:09 <gmann> andreaf, or you want like we did for scenario manger, keep posting to pending projects
08:32:21 <gmann> and remove only once all are done
08:33:22 <andreaf> gmann: sounds like a good plan - only I think we need to advertise it to the ML
08:33:25 <andreaf> gmann: how many plugins will be affected you think?
08:34:00 <andreaf> gmann: for scenario it was a bit different since we wanted to do a lot of changes to scenarios (which we didn't yet) and the idea was to decouple as much as possible
08:34:43 <gmann> andreaf, number might be large. need to check where all we merged
08:34:59 <gmann> andreaf, +1 for ML advertising etc
08:35:37 <gmann> #action gmann to send ML for upcoming removal of deprecated interfaces and its affect on stable branches
08:36:03 <gmann> anything else on gate things ?
08:36:25 <gmann> #topic Specs Reviews
08:36:39 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
08:37:04 <andreaf> no topic Tempest today?
08:37:19 <gmann> i started review on HA spec #link https://review.openstack.org/#/c/443504/
08:37:20 <patchbot> patch 443504 - qa-specs - Added spec for high availability testing
08:37:25 <andreaf> never mind - I'd like reviews and comments on https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:prepare_clients_stable
08:37:28 <andreaf> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:prepare_clients_stable
08:37:29 <gmann> coming :)
08:38:21 <gmann> as discussed in last meeting, we will have 2 spec for HA 1. for idea, 1. arch
08:38:27 <andreaf> gmann: great we need to review specs before the PTG so that we are prepared to talk about them there if needed
08:38:37 <gmann> andreaf, yea
08:38:48 <andreaf> I haven't done that yet though
08:39:18 <gmann> i will concentrate on next week as feature freeze on other projects today
08:39:20 <gmann> #topic Tempest
08:39:38 * andreaf just realises we were talking about spec reviews not critical reviews :S
08:39:49 <gmann> andreaf, go head now
08:40:34 <andreaf> So we have the patches for credential providers merged now, which is great thanks all for the good work on that
08:40:37 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:prepare_clients_stable
08:41:01 <andreaf> There are a few more patches to be done to finish the work of making test.py stable
08:41:04 <andreaf> #link https://review.openstack.org/#/c/487482/
08:41:04 <patchbot> patch 487482 - tempest - Mark credentials_factory stable for plugins
08:41:19 <andreaf> #link https://review.openstack.org/#/c/486165/
08:41:20 <patchbot> patch 486165 - tempest - Fix verify config API version checks
08:41:30 <andreaf> #link https://review.openstack.org/#/c/484384/16
08:41:31 <patchbot> patch 484384 - tempest - Only set clients when service/api is available
08:41:37 <andreaf> and more to come
08:41:48 <gmann> andreaf, thanks. nice work
08:42:02 <andreaf> the last one I wanted to have comments on - since it may be controversial - but I think it's for the best
08:42:19 <gmann> sure
08:42:22 <andreaf> the idea is to only set the client aliases in the Manager object if a service / api version is available
08:42:40 <gmann> sure i will check tomorrow
08:42:59 <andreaf> which means that if a test forgets to declare a service as a dependency or if it relies on an outdated version we will know
08:43:44 <gmann> andreaf, i added few comments on etherpad for stable test module - https://etherpad.openstack.org/p/tempest-test-module-stable
08:44:04 <andreaf> the patch breaks one of the puppet jobs because of murano though but since murano is installed from release I don't think we have any alternative other than break that and fix it later
08:44:43 <gmann> ok
08:45:19 <gmann> but will they break before tempest release
08:45:23 <andreaf> gmann: thanks for the comments
08:45:39 * gmann 15 min left
08:45:48 <andreaf> gmann: I don't like having to make clients.py stable, but I see no alternative - not doing that would require a large amount of work on both tempest and plugins
08:46:05 <andreaf> and no-one as the time to do that - and I really want this work to be finished by end of Pike
08:46:25 <andreaf> so we can start queens with stable interfaces done and thinking about something else
08:46:27 <gmann> andreaf, yea, that is huge work
08:46:47 <andreaf> gmann: we might still do it over time and end up deprecating clients.py
08:46:55 <andreaf> gmann: but I would not bet on that
08:47:00 <gmann> andreaf, +1 for that. we are doing lot of work for stable interface things and fixing plugin
08:47:11 <gmann> ok
08:47:40 <gmann> let's move next. time is less.
08:47:43 <gmann> Bug Triage
08:47:49 <gmann> masayukig, your turn this week
08:47:51 <gmann> go ahead
08:47:57 <masayukig> yeah,
08:48:03 <gmann> #link https://etherpad.openstack.org/p/tempest-weekly-bug-report
08:48:14 <masayukig> gmann: thanks
08:48:30 <gmann> andreaf, sorry for moving further in case i stopped you writing more
08:48:46 <masayukig> now, the number of new bugs is 3. Not so bad count
08:48:50 <andreaf> it's ok
08:48:55 <gmann> masayukig, nice, thanks
08:49:06 <andreaf> but you missed the #topic command
08:49:17 <gmann> andreaf, its under tempest only :)
08:49:18 <masayukig> And I actually didn't do that much for that.. :-p
08:49:31 <gmann> masayukig, any key bug or something
08:49:42 <andreaf> gmann: ah right - sorry
08:49:52 <masayukig> gmann: I don't see that so far.
08:50:03 <gmann> ok
08:50:11 <masayukig> But high importance bugs are still 7
08:50:35 <gmann> next week it is mkopec
08:50:47 <gmann> #topic Patrole
08:50:56 <gmann> #link https://review.openstack.org/#/q/project:openstack/patrole
08:51:05 <gmann> blancos, anything to bring up
08:51:21 <blancos> gmann Nothing at the moment
08:51:35 <gmann> ok
08:51:52 <gmann> anyone else want to discuss  on patrole ?
08:52:18 <gmann> #topic Critical Reviews
08:52:52 <gmann> any more critical reviews other than andreaf mentioned about stable cred one
08:54:00 <andreaf> not really critical but nice to have I think
08:54:02 <andreaf> #link https://review.openstack.org/#/c/352292/
08:54:03 <patchbot> patch 352292 - tempest - Try to register all service clients
08:54:19 <andreaf> better error handling for service client registration from plugins
08:54:29 <gmann> ok
08:55:03 <gmann> andreaf, any plugin moved to new way of service client registration ?
08:55:22 <gmann> let's discus under open
08:55:22 <gmann> #topic Open Discussion
08:55:25 <andreaf> gmann: manila folks are looking into it
08:55:29 <gmann> nice
08:55:55 <andreaf> but I hope to advertise that a bit as well during the PTG as part of the migration to a dedicated repo
08:56:18 <gmann> andreaf, +1 nice idea
08:56:23 <chandankumar> +1
08:56:38 <andreaf> I propose a hands-on session on that for Sydney as well (writing a plugin that depends on multiple plugins)
08:56:46 <masayukig> ++
08:56:52 <gmann> cool
08:56:55 <masayukig> (for both)
08:57:03 <chandankumar> taking neutron case would be interesting
08:57:05 <zhufl> cool
08:57:22 <andreaf> the tricky bit for service clients from plugins is that they are not marked as stable interfaces like tempest ones
08:57:32 <chandankumar> neutron have lots of dependent plugins
08:57:36 <andreaf> but I also think once they work nicely they are not likely to change either
08:57:53 <gmann> humm, hope so
08:58:13 <gmann> 2 min left, anything else to bring up
08:58:36 <chandankumar> nothing from my side
08:58:45 <masayukig> nope
08:58:50 <andreaf> I mentioned in the last meeting that I'm considering office hours
08:58:56 <andreaf> as alternative to meetings
08:59:09 <gmann> ok
08:59:16 <andreaf> but I have investigate further into that
08:59:29 <andreaf> and also I'd like to hear opinion from everyone
08:59:39 <andreaf> just something to think about until next meeting :)
08:59:40 <masayukig> not bad idea
08:59:46 <chandankumar> good idea
08:59:58 <gmann> andreaf, did not get completely, you mean more early ?
09:00:08 <gmann> let's move to qa channel.
09:00:12 <gmann> thanks all
09:00:13 <gmann> #endmeeting