09:01:13 <gmann> #startmeeting qa
09:01:14 <openstack> Meeting started Thu Jan 26 09:01:13 2017 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:01:17 <openstack> The meeting name has been set to 'qa'
09:01:29 <gmann> hi, who all here today
09:01:42 <zhufl> me:)
09:01:57 <masayukig> o/
09:01:58 <dmellado> o/ hey gmann
09:02:11 <gmann> dmellado: hi
09:02:22 <gmann> zhufl:  nice, thanks.
09:02:50 <chandankumar> Hello guys!
09:02:55 <dmellado> hey chandankumar!
09:03:01 <gmann> chandankumar: hi, nice to see you
09:03:07 <dmellado> btw gmann, we should change the email to say CET and not CEST anymore
09:03:10 <masayukig> chandankumar zhufl dmellado hi!
09:03:14 <dmellado> I was about to miss the meeting because of that!
09:03:15 <gitudaniel> o/ hi everyone, first time here :)
09:03:18 <dmellado> hey masayukig!!!
09:03:25 <masayukig> gitudaniel : welcome!!
09:03:26 <Noam_> hi
09:03:27 <dmellado> welcome gitudaniel
09:03:29 <gmann> gitudaniel:  hi welcome
09:03:34 <gmann> Noam_:  hi
09:03:37 <Noam_> first time here also
09:03:40 <chandankumar> masayukig: gitudaniel gmann Hello
09:03:42 <dmellado> welcome too ;)
09:03:52 <gmann> dmellado:  ah, ok ll change its all confusing to me always :)
09:04:03 <gmann> let's start
09:04:04 <dmellado> gmann: it'd be CET 10:00
09:04:05 * masayukig is surprised that there are a lot of people this time
09:04:05 <dmellado> xD
09:04:16 <dmellado> masayukig: heh xD
09:04:19 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_January_26th_2017_.280900_UTC.29
09:04:34 <gmann> ^^ agenda
09:04:48 <gmann> #topic PTG
09:05:07 <gmann> #link https://etherpad.openstack.org/p/qa-ptg-pike
09:05:12 <masayukig> dmellado: :)
09:05:16 <gmann> so this is etherpad for QA PTG
09:05:31 <gmann> lot of topic this time
09:05:36 <gmann> it is actually nice
09:05:46 <gmann> if anyone have more feel free to add
09:06:16 <masayukig> gmann : cool :)
09:06:16 <dmellado> who owns the first one? infra team?
09:06:27 <chandankumar> gmann: just one question, can anyone attend ptg virtually also?
09:06:53 <gmann> chandankumar:  ah, i am not sure there are such arrangement
09:06:59 <gmann> #link http://lists.openstack.org/pipermail/openstack-dev/2017-January/110909.html
09:07:00 <masayukig> dmellado: the next PTL?
09:07:08 <gmann> ^^ this says some tooling for PTG
09:07:23 <masayukig> I have one question, how many slots do we have?
09:07:28 <dmellado> masayukig: maybe
09:07:31 <dmellado> that's a goof question
09:07:40 <dmellado> gmann: well, we can always be active at the IRC and etherpads
09:07:42 <gmann> dmellado:  yea i think clarkb  gave idea and we can discuss in PTG
09:07:57 <masayukig> great
09:08:01 <gmann> masayukig:  this time no slot, its just room book for full 2 days
09:08:02 <dmellado> I don't see why can't we allow virtual attendees (on best effort, though)
09:08:07 <bkopilov> good idea
09:08:13 <gmann> chandankumar:  you cannot join?
09:08:22 <chandankumar> gmann: till now not sure!
09:08:44 <gmann> we can allocate the group there around tables and work on each items
09:09:02 <gmann> chandankumar:  ohhk
09:09:06 * dmellado trying to make that happen
09:09:13 <masayukig> gmann: hrmm, I think we should make time slots
09:09:15 <gmann> dmellado:  great +1
09:09:36 <masayukig> otherwise, it will be an endless discussion :-p
09:09:45 <dmellado> heh +1 masayukig
09:09:55 <gmann> masayukig:  so discuss can be with all attendee right
09:10:21 <dmellado> gmann: masayukig maybe we can discuss that there
09:10:25 <gmann> masayukig: dmellado  i saw a mail on those arrangement, i think oomichi  also send
09:10:33 <dmellado> after seeing the final attendees and the amount of people interested on each topic
09:10:38 <gmann> dmellado: i feel better to prepare before going
09:10:55 <dmellado> gmann: we can use the etherpad for that too
09:11:00 <masayukig> dmellado, gmann : ok, cool
09:11:03 <gmann> we have only 2 days and topics are more this time so we have to plan well before
09:11:05 <dmellado> how about adding a new section
09:11:09 <dmellado> interested:
09:11:09 <gmann> dmellado:  yea
09:11:11 <dmellado> or something
09:11:20 <masayukig> gmann +1
09:11:30 <dmellado> chandankumar: that way you'l be also able to add yourself there too
09:11:54 <gmann> #link http://lists.openstack.org/pipermail/openstack-dev/2017-January/110985.html
09:12:10 <gmann> dmellado:  nice idea, we can add that
09:12:13 * chandankumar added a field coowner on etherpad
09:12:29 <gmann> #action add interested section on PTG topics
09:12:48 <gmann> so above mail is for discussion how arrangement will be there in PTG
09:13:39 <gmann> but many of them are more towards coding side so that people can just start making group on interested one and contribute
09:13:47 <gmann> like tempest-lib, cleanup etc
09:14:31 <gmann> so we can divide like groups working on those and in parallel discussion on other topic
09:14:40 <masayukig> gmann: will it be like an mid-cycle meetup?
09:15:03 <gmann> but we should not overlap the discussion topics where many people want to join all discussion
09:15:19 <gmann> masayukig:  i think mid-cycle + design sessions
09:15:23 <dmellado> gmann: masayukig I was also thinking about how to organize the 'session' topics
09:15:32 <dmellado> is there any idea for having actual slots?
09:15:38 <dmellado> I'm thinking about the plugin talk
09:15:40 <masayukig> gmann : ok
09:15:53 <gmann> sessions need broader discussion, we can go like we used to do in design sessions
09:16:20 <gmann> and sessions more on just coding side can go like we used to have in mid-cycle
09:16:28 <dmellado> +1
09:16:36 <chandankumar> +1
09:16:36 <gmann> dmellado:  you mean cross project one like?
09:16:43 <dmellado> yeah, exactly
09:17:05 <dmellado> I'll be re-doing the plugin one, in order to summarize the discussion on the TC proposal
09:17:18 <dmellado> mtreinish: ^^ would you like to co-present that with me too?
09:17:23 <gmann> dmellado:  that is nice point and not sure how that will go as very few people from other projects might show on first 2 days
09:17:25 <chandankumar> gmann: dmellado we might need cross project discussion for tempest plugin side
09:17:41 <dmellado> chandankumar: yeah, that's what I was thinking out loud
09:17:41 <gmann> chandankumar:  yea
09:18:08 <chandankumar> IT would be also good if we get one member from each openstack project to participate so that they can start spliting tempest plugins
09:18:31 <dmellado> chandankumar: well, I guess the talk would be a mean for that
09:18:32 <gmann> dmellado:  did you add all related projects in "Interaction with another project"
09:18:42 <dmellado> the TC proposal have yet to be accepted
09:18:48 <gmann> based on that we can ask projects representative for those sessions
09:18:50 <dmellado> gmann: I guess I'd just say *all*
09:19:02 <dmellado> I mean, that'd affect every project that has an in-tree tempest plugin
09:19:10 <dmellado> I'll try to put out a list later on
09:19:16 <dmellado> andreaf: didn't you already had one around?
09:19:16 <gmann> chandankumar:  that is perfect  one but we do not have members from all projects :)
09:20:26 <chandankumar> dmellado: have so many contacts, he can find out representative xD
09:20:34 <dmellado> heh xD
09:20:37 <gmann> but i doubt members from vertical teams will show up in mon and Tues
09:20:55 <dmellado> gmann: I can try to bring along at least some folks, deff
09:20:57 <gmann> yea he is all rounder
09:21:00 <masayukig> heh
09:21:08 <gmann> dmellado:  cool
09:21:14 <dmellado> at least neutron/manila/ironic
09:21:42 <gmann> ok let's figure out how we can do cross projects sessions efficiently
09:21:45 <Alex_Staf> neutron is here :)
09:21:53 <masayukig> great :)
09:22:02 <gmann> #action gmann  to find out how we can do cross projects sessions efficiently
09:22:09 <gmann> Alex_Staf: cool,
09:22:23 <gmann> Alex_Staf: so will you be there on first 2 days at PTG?
09:22:35 <Alex_Staf> gmann, mmmm nope
09:22:43 <dmellado> gmann: I'll bring ihar
09:22:46 <Alex_Staf> I am not arriving unfortunately
09:22:52 <dmellado> even if I'll have to get him a beer
09:22:54 <gmann> ohk
09:22:54 <dmellado> xD
09:23:02 <gmann> dmellado: +1
09:23:03 <masayukig> +1
09:23:13 <dmellado> Alex_Staf: sorry for not getting you another one too, I owe you one! :D
09:23:32 <chandankumar> +1, we need lots of beer if more cross project will join xD
09:23:37 <Alex_Staf> dmellado, yes u do :)
09:23:42 <gmann> how about sending mail for what all projects representative we need for what all kind of sessions ?
09:23:47 <dmellado> +1
09:23:48 <chandankumar> *project represntative
09:23:56 <dmellado> that'd be nice
09:24:00 <gmann> so that projects gets notify and they can attend/plan on interested one
09:24:10 <masayukig> cool
09:24:11 * Alex_Staf opens txt, "dmellado : 1 beer " :wq
09:24:12 <dmellado> action for oomichi to send email about the session?
09:24:20 <dmellado> Alex_Staf: heh
09:24:31 <gmann> ok
09:24:47 <gmann> great ll do that
09:25:00 <gmann> anything on PTG, any query, doubt, feedback etc
09:25:34 <dmellado> maybe we'll have to organize some lunch/dinner there
09:25:37 <dmellado> do we have anyone local?
09:25:49 <masayukig> mtreinish ?
09:25:55 <gmann> +1 we can have dinner planned
09:26:11 <gmann> yea mtreinish is local only :)
09:26:40 <gmann> ok let's move then
09:26:44 <gmann> #topic Specs Reviews
09:26:55 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
09:27:17 <gmann> i think most of the spec in same shape
09:27:44 <gmann> anyone knows anything on HA testing one -https://review.openstack.org/#/c/399618/
09:27:58 * dmellado checking
09:28:22 <dmellado> Looks stalled
09:28:27 <masayukig> hrm, yeah
09:28:46 <gmann> we need to catch Timur on that
09:28:55 <gmann> anything else on spec ?
09:29:00 <masayukig> +1
09:29:05 <dmellado> yeah, do you know if he'll be attending the PTG?
09:29:19 <gmann> do not know
09:29:26 <gmann> ll reach to him today
09:29:37 <dmellado> gmann: cool
09:29:39 <masayukig> cool
09:29:57 <gmann> #topic Tempest
09:30:02 <ekuris_> hi :) I  dont know if this is the time to ask but I would like to know if this patch is valid and acceptable https://review.openstack.org/#/c/425211/
09:30:06 <Alex_Staf> Guys I need to consult with you regarding some cleanup decision. As in neutron/tests/tempest/scenario/<any test >  we are using functions from neutron/tests/tempest/scenario/base.py with are classmethod, we can't use in those functions addCleanup method as it requires object and not class, so where do propose to add the call for the addCleanup.
09:30:26 <gmann> ekuris_: sure, we can check after meeting
09:30:33 <Alex_Staf> what in your opinion is the best way to do it
09:30:36 <ekuris_> gmann,  thanks :)
09:31:00 <dmellado> ekuris_: I'd try for it to first pass the gates ;)
09:31:20 <gmann> Alex_Staf: you can do cleanup in resource_cleanup (or tearDown if you have)
09:31:23 <masayukig> dmellado , ekuris_ : heh, yup
09:31:43 <gmann> Alex_Staf:  but any link will be more helpful to suggest the best way
09:31:53 <ekuris_> dmellado,  i know I just send it to recheck , it fails on  something that not related to my patch
09:32:22 <chandankumar> ekuris_: I have added one more recheck then we can have a look on gates if it fails
09:32:35 <gmann> Alex_Staf: mainly resources created in base class function can be cleanup in teardownClass
09:32:46 <Alex_Staf> gmann, https://github.com/openstack/neutron/blob/master/neutron/tests/tempest/scenario/test_basic.py
09:33:13 <ekuris_> chandankumar,  ok no problem  thanks
09:33:28 <gmann> Alex_Staf: and you want to clean resource created in this - setup_network_and_server
09:33:57 <gmann> Alex_Staf: you should be able to do in https://github.com/openstack/neutron/blob/master/neutron/tests/tempest/scenario/base.py#L40
09:34:17 <gmann> Alex_Staf:  ping me or anyone if us on qa channel we can help more if needed
09:34:23 <Alex_Staf> gmann, yes . In this case it is deleted due to end of class. If i wil put there another test function it will create objects for both and delete all only on the end . I do not want that
09:34:39 <zhufl> Sometimes if we want to"addCleanup" in resource_setup, we will use:
09:34:41 <zhufl> @classmethod
09:34:41 <zhufl> def _addCleanupClass(cls, function, *arguments, **keywordArguments):
09:34:41 <zhufl> cls._cleanup_resources.append((function, arguments, keywordArguments))
09:34:57 <gmann> Alex_Staf:  you can then create in setUp and cleanin teardown
09:35:13 <Alex_Staf> in the test ? gmann
09:35:27 <gmann> if you are crating class level resource means you want those till at end
09:35:29 <gmann> Alex_Staf:  yes
09:35:53 <gmann> Alex_Staf:  setUp and terdown gets called before and after each tests respectively
09:35:58 <dmellado> either that or you can add a self.addCleanUp and pass the objects
09:36:11 <gmann> yea
09:36:14 <masayukig> I think this is a good topic for the qa channel or in the free discussion?
09:36:21 <gmann> let's discuss on qa channel
09:36:24 <gmann> masayukig: yea
09:36:25 <gmann> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
09:36:26 <dmellado> +1
09:36:37 <gmann> so those are open review on tempest
09:37:11 <Alex_Staf> ok thanks guys I need to proccess and look into all that info u provided :)
09:37:38 <gmann> Alex_Staf: cool, feel free to ping if anything else needed
09:37:46 <gmann> so on tempest side anything people want to discuss ?
09:37:57 <gmann> i think we just keep reviewing the current patches
09:38:13 <Alex_Staf> gmann, tnx man
09:38:16 <dmellado> Alex_Staf: also do check http://docs.openstack.org/developer/tempest/HACKING.html#test-fixtures-and-resources
09:38:36 <gmann> next is Bug Triage
09:38:39 <gmann> Alex_Staf: np!
09:38:47 <gmann> #link https://etherpad.openstack.org/p/ocata-qa-bug-triage
09:38:52 <gmann> chandankumar:  seems like your turn?
09:39:14 <gmann> #link report- https://etherpad.openstack.org/p/tempest-weekly-bug-report
09:39:19 <Alex_Staf> dmellado, tnx I will
09:39:25 <chandankumar> gmann: I have added the report here https://etherpad.openstack.org/p/tempest-weekly-bug-report
09:39:27 <gmann> chandankumar:  go ahead on this week report
09:39:39 <chandankumar> from last two week
09:39:53 <chandankumar> Week progress:
09:39:55 <chandankumar> # New bugs:  0 -> 1
09:39:58 <chandankumar> # Open bugs: 130 -> 131
09:39:59 <chandankumar> # In-progress bugs: 59 -> 58
09:40:00 <openstack> bug 130 in Launchpad itself "Multiple paragraphs in DOAP project description field" [Medium,Fix released] https://launchpad.net/bugs/130 - Assigned to Morgan Collett (morgan)
09:40:16 <gmann> chandankumar: cool
09:40:31 <gmann> chandankumar:  anything you want to discuss on specific bug
09:40:38 <chandankumar> I need to improve more on bug triaging, will get better incoming days
09:40:54 <chandankumar> onme query what if a bug got a review but review got abandoned
09:41:07 <gmann> chandankumar:  no prob, take the open one we have to cleanup those
09:41:16 <chandankumar> will i chnage the status of bug from inprogress to confirm
09:41:24 <chandankumar> or will i keep as it is/
09:41:41 <gmann> chandankumar:  open that again, i mean change to confirmed/triage/new state as applicable
09:42:04 <chandankumar> got that!
09:42:05 <gmann> chandankumar: yea if patches are abandon then its not in progress
09:42:25 <gmann> chandankumar:  thanks for your help.
09:42:35 <masayukig> so, one thing, https://bugs.launchpad.net/tempest/+bug/1610994
09:42:35 <openstack> Launchpad bug 1610994 in tempest "test_connectivity_between_vms_on_different_networks doesn't work on OVH" [Medium,Fix released]
09:42:48 <masayukig> Is this really fixed?
09:43:06 <masayukig> I guess this is just a workaround (skip).
09:43:27 <gmann> masayukig: nice catch
09:43:34 <gmann> yea we should not mark it fix released
09:43:48 <gmann> just keep it confirmed
09:44:21 <chandankumar> gmann: sure, i need to improve on that
09:44:27 <chandankumar> masayukig: Thanks for the catch
09:44:29 <gmann> masayukig:  can you move that back?
09:44:32 <dmellado> also did you guys check this email thread?
09:44:38 <gmann> chandankumar:  no prob we all learn like that only
09:44:42 <dmellado> still no open bug but interesting at least
09:44:45 <dmellado> http://lists.openstack.org/pipermail/openstack/2017-January/018413.html
09:45:00 <masayukig> gmann : yup, done
09:45:02 <masayukig> chandankumar : np :)
09:45:32 <gmann> dmellado:  not yet, ll look into that
09:45:44 <gmann> dmellado: is it same thing of v3 policy one ?
09:45:56 <masayukig> #link http://lists.openstack.org/pipermail/openstack/2017-January/018413.html
09:46:05 <dmellado> gmann: yeah, it also seems that the keystone v3 non-voting gate is using the older policy.json which is compatible with v2 as well
09:46:24 <dmellado> which I thought it wouldn't be using
09:46:46 <dmellado> jamespage: thanks for bringing that out ^^
09:47:01 <gmann> looks like we have another mail also related on that
09:47:02 <jamespage> o/
09:47:09 <jamespage> dmellado, yw
09:47:10 <gmann> jamespage:  hi
09:47:30 <jamespage> tbh it was gnuoy who tripped over the issue
09:47:57 <gmann> and keystone team working on that separately right ?
09:48:25 <dmellado> seems like it, I'll ping rodrigods later, he ought to be sleeping now
09:49:03 <dmellado> but imho this is worth opening a bug
09:49:09 <gmann> dmellado:  rodrigods  replied on mail in details
09:49:18 <gmann> dmellado:  but is it tempest bug ?
09:49:21 <dmellado> saw it, that's why I'll ask him later
09:49:34 <dmellado> gmann: maybe a keystone one, and point out that it affects tempest?
09:50:06 <gmann> dmellado:  yea and rodrigods mentioned to work in policy meeting seems
09:50:21 * masayukig needs to go in 5 min... :(
09:50:24 <dmellado> gmann: I'll get to talk to him later re: the bug
09:50:27 <dmellado> let's move on
09:50:30 <gmann> let's move 10 min keft
09:51:01 <gmann> let's skip DevStack + Grenade if nothing on those
09:51:08 <masayukig> +1
09:51:12 <dmellado> +1
09:51:15 <gmann> #topic openstack-health
09:51:19 <gmann> masayukig:  ^^
09:51:24 <masayukig> ok,
09:51:29 <masayukig> I found that, now, it seems like openstack-health gate something wrong, maybe, due to JS libraries or something. I'll try to fix it next week..
09:51:49 <masayukig> #link https://review.openstack.org/#/q/project:openstack/openstack-health status:open
09:52:20 <gmann> masayukig:  oh
09:52:22 <masayukig> That's all from my side, actually
09:52:36 <gmann> masayukig:  thanks
09:52:43 <gmann> #topic Patrole
09:52:53 <gmann> #link https://review.openstack.org/#/q/project:openstack/patrole
09:52:54 <dmellado> is DavidPurcell around?
09:53:04 <gmann> so this is RBAC testing one
09:53:18 <gmann> seems like no
09:53:25 <jamespage> for reference on keystone v3/tempest issues (https://launchpad.net/bugs/1659515)
09:53:25 <openstack> Launchpad bug 1659515 in tempest "Some tests fail when running keystone v3 with policy.v3cloudsample.json" [Undecided,New]
09:53:35 <dmellado> jamespage: ack, thanks!
09:54:00 <gmann> sems like nice progress in patrole
09:54:18 <dmellado> gmann: yeah, IIRC David mentioned that they're migrating the code from the former repo
09:54:24 <dmellado> so progress ought to be good ;)
09:54:26 <masayukig> great :)
09:54:36 <gmann> cool, thats very nice
09:54:45 <gmann> #topic Critical Reviews
09:54:53 <gmann> any critical reviews from anyone
09:55:06 <dmellado> ekuris_: would you like to put again your review link? ;)
09:55:26 <gmann> #link https://review.openstack.org/#/c/425211/
09:55:31 <gmann> dmellado:  ekuris_  this one
09:55:40 <gmann> ll check this, but may be tomorrow
09:55:49 <dmellado> +1, I'll check once jenkins has passed
09:56:03 <gmann> i have one for improving the common volume backed things in create server
09:56:06 <masayukig> so, I need to go, bye all, see you around :)
09:56:10 <ekuris_> dmellado,  gmann  yes this one
09:56:11 <gmann> #link https://review.openstack.org/#/c/405089/
09:56:13 <dmellado> masayukig: get some rest!
09:56:21 <gmann> ll be nice if you guys can review
09:56:23 <masayukig> dmellado: thanks :)
09:56:30 <gmann> masayukig:  thanks , bye
09:56:42 * masayukig is waving
09:56:52 <gmann> if no more review then let's jump to open
09:56:57 <ekuris_> dmellado,  I add you as reviewer
09:57:03 <dmellado> ekuris_: ack
09:57:09 <gmann> #topic Open Discussion
09:57:29 <gmann> one thing i want to check who all can attend PTG
09:57:40 <gmann> dmellado: zhufl  ? you are in right
09:58:00 <gmann> chandankumar:  get budget from your boss, it will be nice  to be there
09:58:02 <dmellado> gmann: yeah, I'll try bringin chandankumar along
09:58:05 <dmellado> still in discussions
09:58:12 <gmann> dmellado:  wow, great
09:58:39 <Noam_> i would like to get review to the following commit in devstack https://review.openstack.org/#/q/owner:noama%2540mellanox.com+status:open+project:openstack-dev/devstack basicly expanding stack deploy scenarios
09:58:53 <gmann> zhufl: you know all details about PTG right
09:59:33 <gmann> Noam_: sure, ll try to check
09:59:37 <gmann> 2 min left
09:59:42 <gmann> anything else from anyone
09:59:48 <Noam_> thanks
10:00:47 <dmellado> let's close this
10:01:05 <gmann> yea.  thanks everyone for joining.
10:01:08 <gmann> #endmeeting