09:00:21 <gmann> #startmeeting qa
09:00:22 <openstack> Meeting started Thu Dec 15 09:00:21 2016 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:25 <openstack> The meeting name has been set to 'qa'
09:00:57 <gmann> Hello, who's here today?
09:01:08 <DavidPurcell> o/
09:01:55 <gmann> DavidPurcell:  hi
09:02:10 <gmann> let's wait for some time for more people to join
09:02:14 <DavidPurcell> good morning :)
09:02:23 <gmann> morning
09:02:50 <gmann> masayukig:  andreaf  dmellado  hi
09:03:12 <masayukig> o/
09:03:15 <dmellado> o/ gmann morning
09:03:17 <dmellado> hi guys
09:03:41 <gmann> morning
09:05:02 <gmann> let's start
09:05:05 <oomichi> hi
09:05:15 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_December_15th_2016_.280900_UTC.29
09:05:25 <gmann> ^^ Today's agenda
09:05:31 <masayukig> oomichi : oh, too early for you?
09:05:49 <oomichi> masayukig: I am in Japan now
09:05:57 <gmann> oomichi: hi
09:06:06 <masayukig> oh, cool, I see :)
09:06:09 <gmann> #topic Specs Reviews
09:06:24 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
09:06:46 <gmann> most spec under review and waiting on author side
09:06:50 <gmann> on this one  - https://review.openstack.org/#/c/410250/
09:07:13 <dmellado> oh, oomichi welcome back ;)
09:07:15 <gmann> i did not get why we have to revert this instead of just updating if needed
09:07:41 <oomichi> gmann: yeah, I also cannot get the reason yet
09:07:57 <gmann> but my point is policy.json cannot be removed immediately
09:08:01 <DavidPurcell> I wasn't sure why they wanted a revert either.  Do we know the timeline on the change they're making?
09:08:02 <oomichi> gmann: maybe he just wanted to get feedback more?
09:08:18 <gmann> oomichi: may be
09:08:25 <oomichi> by reverting
09:08:48 <gmann> DavidPurcell:  well even they have merged i think older way still in support
09:09:21 <gmann> I was thinking like go with current spec and if we need to adopt new middleware way then it can be done
09:09:42 <oomichi> gmann: yeah, I don't think we can remove the old(?) style soon
09:09:43 <gmann> spec is just to make policy bits testing which way that can be done/changed there
09:09:53 <masayukig> I think the revert commit needs more explanation in the commit message at least.
09:10:18 <oomichi> masayukig: ++
09:10:20 <gmann> masayukig:  yea, i asked few query on review let's wait for reply may be
09:10:45 <oomichi> to be honest, I really want to -2 because the commit message doesn't explain why
09:10:52 <DavidPurcell> gmann:  I like that approach.  I think it should be reasonably easy to adapt tests from policy.json into tests for middleware once the new approach is released
09:10:53 <dmellado> yeah, it's not really clear at all why they'd like to put that up
09:11:05 <dmellado> I'll -1 it and ask for the commit message to be clarified
09:11:36 <gmann> DavidPurcell:  yea, thats how a testing tool should do actually
09:11:52 <gmann> anyways let's wait for more clarity there
09:12:14 <gmann> any other spec to discuss ?
09:12:19 <oomichi> gmann: yeah, nice direction
09:13:03 <oomichi> gmann: maybe my new spec will be abandoned soon
09:13:20 <oomichi> the decorator seems very small without spec enough
09:13:26 <gmann> oomichi: which one?
09:13:32 <gmann> #link https://review.openstack.org/#/c/405637/
09:13:36 <gmann> oomichi: yea
09:13:47 <oomichi> gmann: https://review.openstack.org/#/c/405637/
09:13:55 * andreaf o/
09:13:56 <gmann> m +2 on abandon :)
09:13:57 <oomichi> gmann: yeah, that is
09:14:00 <gmann> andreaf: hi
09:14:24 <oomichi> gmann: abondoned it now
09:14:28 <dmellado> oomichi: then should we just go ahead on the implementation without bp?
09:14:41 <gmann> yes
09:14:41 <oomichi> dmellado: yeah, I am feeling it is
09:14:57 <gmann> spec is too heavy for that :)
09:15:16 <gmann> oomichi: did all patches ready before updating spec
09:15:32 <oomichi> gmann: yeah, I think so
09:15:51 <oomichi> gmann: and the implementation is already done with applying the comments,
09:15:58 <dmellado> +1
09:15:58 <oomichi> thanks all for the comments anyways :)
09:16:02 <gmann> yea
09:16:25 <gmann> m almost ok with that waiting for andreaf  feedback on that
09:16:27 <gmann> #link https://review.openstack.org/#/c/405781/
09:16:46 <gmann> anyways let's change topic and discuss this in Tempest
09:16:56 <gmann> #topic Tempest
09:17:00 <andreaf> gmann: heh sorry I will check it after the meeting
09:17:10 <gmann> andreaf:  sure
09:17:17 <oomichi> andreaf: thanks
09:17:24 <gmann> on tempest, gate is blocked now on liberty jobs
09:17:36 <gmann> as liberty EOL and nova liberty branch no more and job fail
09:17:49 <oomichi> gmann: oh, I didnt know that
09:18:06 <gmann> there are patches to remove the liberty job from tempest
09:18:08 <gmann> #link https://review.openstack.org/#/c/410928/1
09:18:33 <gmann> which is all together with other changes and other base patches also
09:18:37 <gmann> this can take time to merge
09:18:38 <oomichi> gmann: nice picking up, I will review it soon
09:18:51 <gmann> so i separately created another one
09:18:53 <gmann> #link https://review.openstack.org/#/c/411113/
09:19:08 <gmann> ^^ this one, just remove tempest liberty jobs
09:19:25 <gmann> but ok with any of them gets merged first
09:19:28 <masayukig> gmann : is that included in 410928?
09:19:36 <gmann> pinged infra team on channel but still need reivew
09:19:49 <gmann> masayukig:  yes, but with all other cleanup
09:20:07 <dmellado> gmann: I'll get some infra attention on this, it'd be great to have it merged asap
09:20:14 <gmann> it seems to be impression that no one runs liberty as voting job
09:20:25 <masayukig> yeah
09:20:43 <gmann> dmellado: yea, i pinged all guys there just waiting for them to approve either patch
09:20:53 <oomichi> yeah, https://review.openstack.org/#/c/411113/ needs to be merged soon
09:21:43 <gmann> yea
09:21:49 <dmellado> if liberty will no longer be tested in the gates
09:22:03 <dmellado> should we create a tag announcing that tempest will no longer support it?
09:22:31 <tosky> I was going to ask the same, iirc tempest is tagged also when an openstack release is retired
09:22:32 <andreaf> dmellado: yeah good point
09:22:57 <gmann> dmellado:  yea nice point
09:23:12 <gmann> oomichi:  ^^ can you do ?
09:23:15 <andreaf> oomichi: I guess that's one for you :)
09:23:19 <oomichi> tosky: yeah, the tag should be added when each EOL
09:23:29 <masayukig> "PTL's work"
09:23:35 <oomichi> gmann: yeah, I will do that after removing jobs
09:23:50 <gmann> #action oomichi needs to tag tempest on liberty EOL
09:23:52 <gmann> oomichi: thanks
09:24:40 <gmann> next is open review on tempest
09:24:42 <gmann> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
09:25:18 <gmann> as gate is blocked but we can keep doing +2, +1 may be :)
09:25:57 <gmann> another thing on gate is puppet jobs also failing
09:25:59 <masayukig> or -1, -2 :-p
09:26:01 <gmann> #link https://review.openstack.org/#/c/409670/
09:26:07 <jordanP> hi (I am late sorry)
09:26:11 <gmann> masayukig:  yes thats always valid :)
09:26:11 <dmellado> hey jordanP
09:26:15 <gmann> jordanP:  hi
09:26:42 <gmann> i pinged EmilienM  on that, i suspect its due to liberty EOl only
09:27:23 <oomichi> gmann: puppet jobs are using liberty also?
09:27:34 <masayukig> gmann : I hope so
09:27:40 <gmann> oomichi:  not sure, from log i did not find out the reason actually
09:27:52 <oomichi> gmann: oh, OK
09:28:09 <gmann> but i think they have some of the liberty branches using in their testi ng
09:28:43 <dmellado> if that's the case, they'd all broken too, yeah
09:29:12 <gmann> let's wait for their finding
09:29:49 <gmann> anything on tempest side more or we jump to bug
09:30:11 <oomichi> gmann: ++ for jumping to bug triage
09:30:19 <gmann> ok
09:30:30 <gmann> so this week dmellado  your turn ?
09:30:32 <gmann> #link https://etherpad.openstack.org/p/ocata-qa-bug-triage
09:30:37 <dmellado> yep, I'll take it over until next week
09:30:39 <gmann> #link https://github.com/oomichi/bug-counter#current-graph
09:30:46 <gmann> #link https://etherpad.openstack.org/p/tempest-weekly-bug-report
09:31:21 <oomichi> ah, I didn't update the graph this week. sorry about that: https://github.com/oomichi/bug-counter#current-graph
09:31:23 <gmann> dmellado:  oh, i thought this week, 8 - 15
09:31:28 <dmellado> andreaf: maybe you could update (in case you didn't do it last week)
09:31:51 <dmellado> gmann: chandankumar was assigned for that time in between
09:31:56 <jordanP> what about automatically closing very old bugs ? Like 2 years old ?
09:31:58 <dmellado> but he told me that he got somehow deleted
09:31:59 * gmann dates confuse always as those are end dates not start dates
09:32:11 <andreaf> dmellado: oomichi updated the graph I think
09:32:30 <andreaf> jordanP: yes we need some type of pruning like that
09:32:33 <dmellado> gmann: then I'm confused too
09:32:41 <tosky> but not automatic closing, please
09:32:41 <gmann> jordanP:  +1 but after looking into those not just directly
09:32:57 <masayukig> tosky : ++
09:33:00 <gmann> most of them not be valid
09:33:02 <dmellado> was my turn this week then? I was expecting to do this from 15-22
09:33:09 <gmann> dmellado:  yea
09:33:20 <jordanP> yes, don't close bugs that still seems valid or bug with high priority, of course
09:33:22 * dmellado mistook the dates then
09:33:23 <gmann> ok let's put date range there to avoid confusion
09:33:33 <jordanP> +1 for date range
09:33:51 <gmann> #action gmann  to add date range on bug triage etherpad
09:33:57 <masayukig> ++
09:34:00 <dmellado> ++
09:34:20 <gmann> ok so we can skip this week until andreaf  want to highlight any one bugs from last week
09:34:20 <dmellado> if that's the case I'll take a look with rodrigods too, but I'd say he thought the dates were different too
09:34:27 <gmann> andreaf:  you did lot of cleanup
09:34:52 <gmann> new bug count is in single digit o/
09:34:53 <oomichi> ah, this week report should be dmellado
09:35:13 <masayukig> gmann : \o/ cool!
09:35:14 <dmellado> oomichi: I mistook the dates and thought my turn was from today 'til next wed
09:35:16 <oomichi> andreaf has done already on the previous meeting
09:35:31 <andreaf> gmann: I mostly went through bugs in new state - some where old and not valid anymore - so I think jordanP has a point we need to do the same also for bugs in triaged and in progress state
09:35:50 <gmann> +1
09:35:52 <oomichi> dmellado: ok, I put your name for the next meeting
09:35:58 <dmellado> oomichi: thanks!
09:36:08 <oomichi> dmellado: thank you also :)
09:36:09 <gmann> and in progress we might need to open/close as many of the patches might be abandon
09:36:17 <dmellado> oomichi: but toally +1 for the date range, I mistook it xD
09:36:17 <jordanP> ok, so let's agree we can try to be more "aggressive" in closing bugs older than 2 years
09:36:23 <andreaf> one good news is that not the non-admin / test-accounts job are almost back to green - only one issue left with swift tests
09:36:35 <masayukig> jordanP : +++
09:36:43 <oomichi> dmellado: yeah, it was easy to misread the etherpad
09:36:47 <gmann> andreaf:  great, you rocks :)
09:36:58 <dmellado> jordanP: ++, there should be quite the old bugs that are not even valid anymore
09:37:00 <andreaf> jordanP: if that the info command, or is there a "decision" meeting bot command?
09:37:06 <dmellado> I'll take a look and clean them up too
09:37:15 <tosky> I didn't say to not close them, but just to at least read them before closing
09:37:17 <gmann> jordanP:  yea thats should be fine.
09:37:32 <tosky> there could be a "bug re-triaging" session
09:37:33 <dmellado> tosky: maybe you'd like to join the cleanup these days :D
09:37:35 <masayukig> tosky : yes, of course, we should do that
09:37:36 <oomichi> tosky: yeah, that is good before closing
09:37:40 <gmann> tosky:  yea not close just by time after reading and ll be quick to close
09:37:40 <jordanP> well, I don't know about the meeting bot, I am not the chair here :)
09:37:56 <jordanP> let's make it an "info" :)
09:38:11 <tosky> dmellado: if it's after the next two weeks, sure
09:38:18 <andreaf> #agreed we can try to be more "aggressive" in closing bugs older than 2 years
09:38:30 <gmann> andreaf: thanks
09:38:45 <andreaf> only chair can do that I fear
09:38:55 <andreaf> gmann: so you have to do it if you want :D
09:39:05 <andreaf> https://github.com/openstack-infra/meetbot/blob/master/doc/Manual.txt#L138
09:39:07 <gmann> again ?
09:39:18 <jordanP> yes
09:39:20 <gmann> #agreed we can try to be more "aggressive" in closing bugs older than 2 years
09:39:24 <andreaf> I think mine is not taken into account
09:39:24 <masayukig> hah
09:39:28 <dmellado> heh
09:39:31 <gmann> same :)
09:39:31 <jordanP> awesome
09:39:34 <jordanP> oups
09:40:02 <jordanP> nevermind I guess, let's move on maybe
09:40:06 <dmellado> yep
09:40:09 <gmann> yea
09:40:14 <gmann> ll check later
09:40:49 <gmann> andreaf:  on account job, v3 one is also done
09:41:20 <andreaf> gmann: I need a +W https://review.openstack.org/#/c/410677/
09:42:06 <gmann> andreaf: nice, +1
09:42:12 <gmann> andreaf:  thanks
09:42:18 <dmellado> andreaf: +1, added yolanda to have a look too
09:42:41 <gmann> dmellado:  yolanda is near by you ?
09:42:58 <dmellado> gmann: I was speaking with her just before the meeting, yeah
09:43:14 <oomichi> andreaf: is that voting job?
09:43:16 <gmann> dmellado:  can ask her to approve liberty job patches
09:43:24 <dmellado> gmann: I guess she already did
09:43:26 <dmellado> could you check?
09:43:29 <gmann> oomichi:  :)
09:43:52 <andreaf> oomichi: experimental only
09:43:54 <gmann> dmellado: nice thanks
09:43:59 <dmellado> gmann: np
09:44:04 <oomichi> andreaf: ah, I got it
09:44:32 <oomichi> +1
09:44:49 <jordanP> btw, did you notice any failure with the ssh job ?
09:45:23 <gmann> jordanP:  it was all ok till noon i think
09:45:36 <gmann> https://review.openstack.org/#/c/409670/
09:45:40 <masayukig> jordanP : link?
09:46:03 <jordanP> no link, because no failure :)
09:46:09 <jordanP> I want the job to be voting
09:46:10 <masayukig> heh
09:46:18 <jordanP> that's why I am asking if it's stable
09:46:23 <gmann> jordanP:  big +1
09:46:38 <gmann> may be we can do soon after health dashboard data of week or 2
09:46:39 <andreaf> jordanP: good point I need to check that
09:46:57 <jordanP> what do you prefer guys: 1) make it voting ? 2) reconfigure gate-tempest-dsvm-neutron-full-ubuntu-xenial so that it enabled ssh-validation ?
09:47:39 <oomichi> I tend to prefer 1)
09:47:40 <gmann> only diff in both is ssh only right
09:47:47 <dmellado> I'd take 1) as it'd be cool to have both of them just in case
09:47:57 <gmann> yea 1 make sense
09:48:11 <gmann> both would not be good, we can keep 1 i think
09:48:12 <oomichi> it seems easy to distinguish different factor
09:48:34 <jordanP> ok
09:48:40 <dmellado> yaeh, so agreed on 1) them? :D
09:48:51 <gmann> oh sorry
09:48:56 <andreaf> gmann: you can use the agreed command again :D
09:49:00 <gmann> i was on 2 side if only diff is ssh
09:49:16 <gmann> after agree :)
09:49:18 <andreaf> gmann: heh ok not yet
09:49:45 <gmann> if both same then we can make only single job
09:50:01 <gmann> who want to check that
09:50:09 <jordanP> (I prefer 2 myself)
09:50:12 <jordanP> I'll check
09:50:16 <gmann> jordanP: me too
09:50:20 <gmann> jordanP: thanks
09:50:26 <dmellado> jordanP: gmann: how about keeping both of them and drop after we're sure that it's stable
09:50:26 <jordanP> we already have a big number of jobs
09:50:41 <dmellado> if you're safe on that, then I don't really mind but I'll wait a bit
09:50:52 <andreaf> #link http://status.openstack.org/openstack-health/#/g/build_name/periodic-tempest-dsvm-neutron-full-ssh-master
09:50:58 <jordanP> we can take a small risk, given it will be easy to revert
09:50:59 <gmann> #action jordanP  to check diff between neutron jobs and ssh one
09:51:15 <gmann> andreaf: thanks
09:51:41 <jordanP> andreaf, thanks. So stable for the last 7 days, which is good
09:51:48 <gmann> after 5 its looks stable
09:51:58 <jordanP> thanks to andreaf's work
09:52:10 <gmann> yea, nice work andreaf
09:52:13 <masayukig> yeah
09:52:25 <gmann> ok, only 8 min left
09:52:32 <gmann> let;s move to next
09:52:34 <andreaf> it was a lot of contributions from the team to make that job stable
09:52:41 <gmann> we can skip devstack if nothing on that
09:52:52 <dmellado> +1 on skip from my side
09:53:12 <gmann> ok
09:53:21 <gmann> #topic openstack-health
09:53:30 <gmann> #link https://review.openstack.org/#/q/project:openstack/openstack-health+status:open
09:53:37 <gmann> masayukig: your turn
09:53:40 <jordanP> I encourage tempest reviewers to also review devstack changes, it's really informative
09:53:47 <masayukig> gmann : yeah,
09:53:50 <andreaf> jordanP: +1
09:53:54 <gmann> jordanP:  +1
09:54:19 <dmellado> yeah, totally
09:54:34 <gmann> #agreed tempest reviewers to also review devstack changes, it's really informative
09:54:35 <masayukig> jordanP : ++
09:54:40 <masayukig> heh
09:54:43 <gmann> :(
09:54:50 <masayukig> o-h: only one graph fix patch was approved, and there are some tiny fixing patches are there, but I think it's not so much active these week.
09:55:09 <oomichi> not only devstack, all core projects ;)
09:55:11 <andreaf> openstack=health is getting quite nice, it's faster now, and the user feedback and the graphs are nicer
09:55:19 <andreaf> so good job on that!
09:55:30 <gmann> very nice.
09:55:32 <masayukig> andreaf : !!! :)
09:55:50 <oomichi> yeah, it is easy to know the situation of all projects
09:56:00 <masayukig> that's it from my side.
09:56:10 <masayukig> 4 min
09:56:23 <gmann> masayukig:  ok, thanks for your hardwork on that
09:56:30 <gmann> #topic Critical Reviews
09:56:39 <gmann> any critical reviews on priority
09:57:31 <gmann> ok, may be once gate is open :)
09:57:36 <dmellado> heh
09:57:39 <masayukig> :)
09:57:56 <gmann> please check mine then
09:57:58 <gmann> #link https://review.openstack.org/#/c/409634/
09:58:01 <gmann> and dependent one
09:58:25 <andreaf> one note from my side - a few periodic jobs have been renamed - the node type is not in the name (ubuntu-xenial) so you have to include that in case you had some bookmark
09:58:25 <gmann> after object client to lib we can finish all service cleints
09:58:42 <gmann> andreaf:  nice thanks
09:58:45 <andreaf> gmann: yay
09:58:49 <jordanP> yeah, we should focus on finishing the migration
09:58:53 <gmann> #info a few periodic jobs have been renamed - the node type is not in the name (ubuntu-xenial) so you have to include that in case you had some bookmark
09:58:58 <dmellado> andreaf: so now avery node would be just ubuntu-xenial
09:58:59 <gmann> jordanP:  yea
09:59:05 <dmellado> and it's just not explicitly marked, isn't it?
09:59:06 <jordanP> we are almost there
09:59:11 <gmann> yea
09:59:18 <gmann> let;s jupo to open
09:59:25 <gmann> #topic Open Discussion
09:59:31 <tosky> when is the right time to restart the disussion (pike) about always splitting tempest plugins (https://review.openstack.org/#/c/369749/) ?
09:59:46 <dmellado> tosky: that's a good question too
10:00:00 <gmann> tosky:  may be in feb starting
10:00:10 <gmann> 1 min left
10:00:15 <dmellado> just before the PTG, although I'm pretty sure we'll have to bring
10:00:18 <dmellado> the cross-project session again
10:00:32 * masayukig nods
10:00:37 <DavidPurcell> Speaking of splitting plugins, project for RBAC plugin is awaiting governance
10:00:37 <gmann> ok thanks all, let's move to qa for further discussion  if any
10:00:46 <gmann> #endmeeting