08:59:19 <gmann> #startmeeting qa
08:59:20 <openstack> Meeting started Thu Sep  8 08:59:19 2016 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:59:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:59:24 <openstack> The meeting name has been set to 'qa'
08:59:40 <gmann> who's here for today?
08:59:50 <masayukig> o/
09:00:04 <hferenc> \o
09:00:22 * masayukig was surprised at a little bit early starting :)
09:00:39 <gmann> masayukig: hferenc:  hi
09:00:47 <gmann> masayukig: oh is it :)
09:00:52 <dmellado> hi guys
09:00:53 <hferenc> hi
09:01:06 * dmellado too was surprised, xD
09:01:19 <masayukig> dmellado : heh :)
09:01:45 <gmann> its was already 09.00 UTC in my PC :)
09:02:29 <gmann> andreaf: afazekas mkoderer : ping for meeting in case available
09:02:31 <masayukig> gmann : heh, you need a ntpd or something like that :)
09:02:49 <gmann> masayukig: its from internet how it can be wrong :)
09:02:59 <dmellado> gmann: lol
09:03:11 <gmann> anyways let's start the meeting
09:03:20 * masayukig nods
09:03:23 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_September_8th_2016_.280900_UTC.29
09:03:34 <gmann> Today agenda ^^
09:04:14 <gmann> #topic Newton Priorities
09:04:23 <gmann> #link https://etherpad.openstack.org/p/newton-qa-newton-priorities
09:04:50 <gmann> we will not go with each topic.
09:05:30 <gmann> I think the highest priority cleanup one is around 40% done
09:05:48 <masayukig> cool
09:06:13 <gmann> but there are lot of things still pending which we can target in code sprint
09:06:49 <gmann> for other items also we will discuss in code sprint
09:07:02 <dmellado> gmann: I'd like to get some help on the test class hierarchy squash on the code sprint
09:07:03 <gmann> oomichi might be picking up the priority one there
09:07:17 <dmellado> for the lib/migration I thing we're on pretty good track
09:07:18 <gmann> dmellado: great, but you can always start before that also :)
09:07:46 <gmann> dmellado: only service client but there are many things pending for migration
09:08:07 <gmann> but that we covers one by one not so urgent
09:09:07 <gmann> anyways let's move
09:09:13 <dmellado> in any case for the remaining items I guess we'll cover that in the sprint
09:09:15 <dmellado> yeah
09:09:24 <gmann> dmellado: true
09:09:26 <gmann> #topic QA Code Sprint
09:09:38 <gmann> #link https://wiki.openstack.org/wiki/Sprints/QAInfraNewtonSprint
09:09:44 <gmann> details here ^^
09:09:54 <gmann> there are still 5 seats available
09:10:28 <gmann> i am surprised not to see andreaf name there
09:10:43 <dmellado> gmann: he was going to be on PTO, IIRC
09:10:45 <dmellado> so he couldn't make it
09:10:58 <gmann> ahh
09:11:33 <gmann> i remember to see his name there but do not know
09:11:44 <gmann> anyways here is etherpad link for collecting the ideas
09:11:47 <gmann> #link https://etherpad.openstack.org/p/qa-infra-newton-midcycle
09:12:08 <gmann> write up your idea/items you are planning to work if not listed already
09:12:36 <masayukig> ok
09:13:29 <gmann> if nothing on this can we move to next topic
09:13:50 <dmellado> let's move on
09:13:59 <gmann> #topic Specs Reviews
09:14:09 <gmann> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
09:14:43 <gmann> not much new spec but we should review the exiting one
09:14:58 <gmann> i did not get chance to look into those since 1 month seems
09:15:06 <gmann> anyone has any updates or want to discuss
09:16:34 <gmann> ok let's jump to next one
09:16:36 <gmann> #topic Tempest
09:16:45 <gmann> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
09:16:49 <gmann> ^^ ongoing reviews
09:17:07 <dmellado> I could use some +2+A on the ones that already got a +2 from oomichi
09:17:10 <dmellado> https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/consistent-service-method-names
09:17:11 <gmann> many has +2 one so review those
09:17:45 <gmann> dmellado: yea :) you will for sure
09:18:00 <dmellado> gmann: so please do review them if you've the time ;)
09:18:16 <gmann> dmellado: sure but may be tomorrow, i have to prepare the visa doc today
09:18:27 <dmellado> gmann: oh, no prob, thanks in any case!
09:18:33 <gmann> dmellado: anyways nice progress in identity clients
09:18:44 <dmellado> we'll tackle volume ones now
09:19:00 <gmann> hope we will finish all clients by code sprint
09:19:24 <gmann> next is Bug triage things
09:19:36 <gmann> oomichi: started a graph collection on those
09:19:39 <gmann> #link https://github.com/oomichi/bug-counter#current-graph
09:20:13 <masayukig> #link https://github.com/oomichi/bug-counter/blob/master/tempest_bug_count.png
09:20:17 <masayukig> is this?
09:20:21 <gmann> masayukig: how about including existing bugs data in dashboard may be critical/hogh priority  one
09:20:49 <gmann> masayukig: yea
09:21:11 <gmann> that can give more eyes from project on critical open bugs?
09:21:44 <gmann> but not sure masayukig and mtreinish can provide opinion on this
09:21:52 <dmellado> I think it's a nice idea
09:22:06 <masayukig> gmann : which dashboard? o-h?
09:22:13 <gmann> masayukig: yea
09:22:56 <masayukig> hrm, it seems nice.
09:23:24 <gmann> ok. anyways let's decide that later
09:23:37 <masayukig> sure :)
09:23:38 <gmann> we stopped doing the regular  bug traige and open bug count is high seems
09:24:10 <gmann> i remember many people volunteers for that in last summit :)
09:24:24 <dmellado> gmann: masayukig how about adding a bug fixing section to the mid-cycle items
09:24:42 <jordanP> bug fixing is not something you do "one day" and be done with it
09:24:53 <jordanP> we have to do it, every week
09:25:00 <gmann> we can discuss this also in code sprint may be assigning a permanent or turn wise
09:25:09 <masayukig> +1 jordanP
09:25:16 <dmellado> jordanP: I know, but at least if we could get rid of some stuff by the code sprint it'd be nice
09:25:19 <gmann> jordanP: yea but if we have someone looking up daily for those will be nice
09:25:19 <jordanP> I have this handy bookmark: https://bugs.launchpad.net/tempest/?field.searchtext=&orderby=-importance&field.status%3Alist=NEW
09:25:46 <jordanP> most of the bug reports are not real bug, most of the work is actually replyinq/asking some question
09:25:47 <gmann> yea count is 30
09:26:09 <gmann> weekly also works if we have some assignee there
09:26:12 <dmellado> +1 to adding bug triage/assignment to weekly meeting
09:26:38 <gmann> yea, let's add that in code sprint agenda
09:26:54 <gmann> #action gmann to add bug triage topic in code sprint etherpad
09:27:27 <gmann> next one is from hferenc
09:27:33 <gmann> hferenc: please go ahead
09:27:44 <hferenc> okay
09:28:08 <hferenc> first of all i'm aware of what a -2 means
09:28:21 <hferenc> and i sort of agree with oomichi
09:28:41 <hferenc> however i cannot find a way to implement this in nova
09:29:00 <jordanP> link ?
09:29:04 <hferenc> sry
09:29:13 <hferenc> #link https://review.openstack.org/#/c/315786/
09:29:14 <patchbot> patch 315786 - tempest - Add test case to test the reset action of libvirt ...
09:29:16 <dmellado> hferenc: about that, I might've some related stuff
09:29:17 <gmann> #link https://review.openstack.org/#/c/315786/
09:29:18 <patchbot> patch 315786 - tempest - Add test case to test the reset action of libvirt ...
09:29:33 <gmann> hferenc: you mean to add test in nova?
09:29:34 <dmellado> there was some stuff in nova that we wanted to tackle but we needed to interact directly with libvirt
09:29:35 * andreaf o/
09:29:36 <dmellado> and I was proposing this
09:29:47 <dmellado> https://review.openstack.org/#/c/366091/
09:29:47 <patchbot> patch 366091 - openstack-infra/project-config - Adds a new project: nova-tempest-staging
09:29:52 <dmellado> I was going to bring this on the open discussion
09:30:01 <dmellado> hey andreaf o/
09:30:21 * masayukig waves
09:30:28 <dmellado> hferenc: could you please summarize the issue you were tackling?
09:30:59 <gmann> dmellado: any example on that category  which cannot go in tempest or nova
09:31:08 <andreaf> hello everyone, sorry I'm late
09:31:15 <gmann> yea that will be nice to understand background
09:31:19 <gmann> andreaf: hi,
09:31:30 <hferenc> the test would verify that everything happens if hw:watchdog_action extra spec is set
09:31:38 <dmellado> gmann: in my case, basically from what I was told, things that should interact directly with libvirt
09:31:47 <hferenc> i was able to verify tho whole process in tempest
09:32:18 <hferenc> however the solution is kind of on the edge regarding the tempest design priciples
09:32:27 <jordanP> I kinda agree this is going to be hard to maintain in Tempest
09:32:41 <jordanP> it's a very small feature that I doubt a lot of people use
09:33:30 <hferenc> but the libvirt driver is mocked in nova functional test so i can only check whether the flavor has a specific flag
09:33:50 <gmann> hferenc: yea that is fake driver nova use
09:33:57 <hferenc> yepp
09:34:18 <hferenc> so i cannot check what happen when that flag is set
09:34:47 <masayukig> hmm, should we have a new tempest test repository for like these niche cases..?
09:35:07 <dmellado> masayukig: I think that'd be great
09:35:18 <jordanP> I think if it's a feature valuable to hferenc then it's the way to go, imo
09:35:19 <gmann> humm, am not sure why we cannot do in tempest
09:35:41 <dmellado> gmann: could we add such feature in tempest?
09:35:47 <dmellado> interacting with libvirt in such way?¿
09:35:55 <gmann> only issue i see about the waiting on rebooting of instance by watchdog
09:36:09 <andreaf> hferenc, dmellado, masayukig, gmann: the test does not involve much more than nova really, so it sounds like something that should be tested in nova
09:36:13 <jordanP> libvirt only tests are not really nice to Xen/VMWare etc...
09:36:35 <gmann> yea something we can skip for others driver
09:36:49 <jordanP> and we would have to maintain image_ref_watchdog, a specific glance image
09:36:49 <gmann> andreaf: actually in nova, tests use fake driver only
09:37:14 <andreaf> hferenc, gmann: I understand that nova functional tests use the fake driver today, but that doesn't mean that it can't be changed if there is a use case
09:37:50 <andreaf> it may be possible to extend the fake driver to cover what you need, or to have a different job that uses a real hypervisor
09:38:01 <gmann> andreaf: hferenc yea, i remember there was plan to build up full stack for nova testing in nova
09:38:15 <jordanP> and this requires CONF.validation.run_validation which we don't have enabled in the gate jobs by default
09:38:25 <gmann> but i think in Atlanta summit
09:38:45 <jordanP> meah, overall atm, imo, it's a bad idea to support this inside Tempest itself
09:38:46 <gmann> jordanP: thats should be ok to run on ssh job only
09:39:05 <hferenc> jordanP: the watchdog image is the same as the original images, except that i added one extra kernel module for the watchdog device
09:39:09 <gmann> but yea driver specific things  yes we should be carefull
09:39:17 <jordanP> which ssh-jobs ? The flaky ones, non voting ? The jobs no one is taking care of ?
09:39:35 <gmann> jordanP: :), yea we will make voting that soon
09:40:22 <jordanP> I heard that a long time ago already. I am all on favor of making it voting but we need to do it step by step. The more tests we throw that required ssh_validation, the harder it will be to stabilize the job
09:40:41 <andreaf> gmann, jordanP: still I don't think this belongs into tempest - it can be written in tempest format but it doesn't have to live in the tempest tree
09:40:57 <dmellado> andreaf: that was as well my idea
09:41:09 <dmellado> my concern is about where putting up those kind of tests
09:41:17 <dmellado> should we try to 'unify' those
09:41:28 <jordanP> tempest-plugin
09:41:35 <dmellado> I'm afraid of upcoming 'tempest-like' style repos coming up
09:41:46 <gmann> tempest like repo is not good idea
09:41:50 <dmellado> jordanP: yep, that was the idea on here
09:41:50 <gmann> plugin suits then
09:41:54 <dmellado> https://review.openstack.org/#/c/366091/
09:41:54 <patchbot> patch 366091 - openstack-infra/project-config - Adds a new project: nova-tempest-staging
09:42:02 <jordanP> that's the point of tempest/lib, to have a lot of tempest like repo, no ?
09:42:11 <dmellado> gmann: andreaf jordanP would you mind commenting there as well when you get the chance?
09:42:32 <dmellado> if that's acceptable, I'd like to have some ack from your side there
09:42:44 <gmann> dmellado: ok
09:42:58 <jordanP> ok
09:43:21 <gmann> but this case can be in nova side with full stack testing framework or plugin
09:43:54 <gmann> anyways let's comment in reviews
09:44:16 <gmann> i need to think more on this if can not be in tempest
09:45:04 <masayukig> 15 mins left
09:45:07 <gmann> anything more on Tempest side or we move on ?
09:45:11 <gmann> masayukig: yea
09:45:39 <gmann> if nothing on devstack and grenade let's jump to dashboard one
09:45:45 <hferenc> we can move on i think
09:45:54 <gmann> #topic openstack-health
09:46:02 <gmann> masayukig: andreaf anything on this
09:47:04 <andreaf> I was looking forward to a new release of subunit2sql - but it may be already there I didn't check yet
09:47:16 <masayukig> so, timothyb89 are now trying to improve/reimplement the some graphs on it.
09:47:56 <masayukig> And I've heard mtreinish has some ideas to add graphs. But it is not started yet.
09:47:56 <gmann> ok
09:48:19 <masayukig> And I put one small patch for improving the top page loading.
09:48:28 <gmann> more graphs does not make it more heavy :)
09:48:29 <patchbot> Error: I haven't seen graphs.
09:48:48 <masayukig> https://review.openstack.org/#/c/367172/
09:48:48 <patchbot> patch 367172 - openstack-health - Add caching on get_all_runs_time_series_by_key for...
09:48:59 <gmann> why ERROR by patchbot
09:49:11 <masayukig> lol
09:49:16 <jordanP> "Recently, the home page loading time is so long and I'm really annoyed every time." <<--- yes
09:49:44 <jordanP> we should really do something about it, slow loading time makes o-h not super usable
09:50:08 <gmann> yea that true. may be more caching thing can help
09:50:15 <masayukig> jordanP : yeah, I think there are some reason. one is api side, the other is rendering graphs.
09:50:42 <masayukig> my patch tries to improve api-db side.
09:51:03 <gmann> masayukig: nice
09:51:36 <masayukig> That's all from me
09:51:40 <gmann> ok let's wait for masayukig patch to see fast loading
09:51:42 <gmann> masayukig: Thanks
09:51:54 <gmann> #topic Critical Reviews
09:52:03 <gmann> any critical reviews from anyone
09:52:53 <gmann> ok, then i have 3 not so critical but need 1 more +2
09:53:02 <gmann> #link https://review.openstack.org/#/c/365859/
09:53:02 <patchbot> patch 365859 - tempest - Define separate inherited_roles_client for inherit...
09:53:04 <gmann> #link https://review.openstack.org/#/c/366611/
09:53:04 <patchbot> patch 366611 - tempest - Move v3 roles_client to library interface
09:53:11 <gmann> #link https://review.openstack.org/#/c/366641/
09:53:11 <patchbot> patch 366641 - tempest - Move v3 inherited_roles_client to library interface
09:53:19 <gmann> please review
09:53:38 <dmellado> gmann: I'll do, and that'll be also great to have merged asap as I've some patches dependant on those ;)
09:53:41 <masayukig> I already +2 later two patches :)
09:53:53 <dmellado> thanks, masayukig
09:53:54 <gmann> masayukig: yea thanks
09:54:05 <gmann> dmellado: yes, we will finish identity v3 ones
09:54:11 <gmann> 5 min left
09:54:13 <gmann> #topic Open Discussion
09:54:22 <gmann> anything else to discuss
09:54:43 <dmellado> masayukig: if you could also have a look at the patches that already have +2 here, that'd be great
09:54:46 <dmellado> https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/consistent-service-method-names
09:55:15 <masayukig> dmellado : sure, will do tomorrow :)
09:55:39 <jordanP> This patch: https://review.openstack.org/#/c/344184 Python3 relaated
09:55:40 <patchbot> patch 344184 - tempest - py3: Miscellaneous fixes
09:55:40 * masayukig puts it in his todo list
09:55:46 <hferenc> i just wanted to say thanks for the ideas about the watchdog think, i'd appreciate some comments i you have any further ones
09:55:59 <jordanP> we should really make Python3 happen, are everybody else is going to wait for us
09:56:03 <dmellado> hferenc: thanks to you, I'll comment in there
09:56:09 <dmellado> jordanP: +1
09:56:25 <gmann> jordanP: yea, ll  do tomorrow for sure, love those kind of patch
09:56:34 <gmann> hferenc: sure, thanks
09:57:13 <masayukig> hferenc : yeah, I'll have a look
09:57:13 <gmann> ok, if nothing more, we close the meeting
09:57:14 <gmann> 3...
09:57:21 <dmellado> 2...
09:57:24 <gmann> :)
09:57:27 <gmann> 1.
09:57:28 <dmellado> xD
09:57:31 <gmann> Thanks all
09:57:33 <masayukig> \o/
09:57:36 <gmann> #endmeeting