17:01:14 <mtreinish> #startmeeting qa
17:01:15 <openstack> Meeting started Thu Oct  8 17:01:14 2015 UTC and is due to finish in 60 minutes.  The chair is mtreinish. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:20 <openstack> The meeting name has been set to 'qa'
17:01:21 <mtreinish> ok, without the typo this time
17:01:27 <cdent> o/
17:01:29 <rfolco> o/
17:01:31 <mtreinish> who's here for today's meeting
17:01:37 <timello> o/
17:01:39 <mtreinish> man, you guys are faster than me :)
17:01:45 <mtreinish> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Proposed_Agenda_for_October_8th_2015_.281700_UTC.29
17:01:52 <mtreinish> ^^^ Today's agenda
17:02:22 <mtreinish> sdague, dtroyer: around?
17:03:07 <mtreinish> well, let's get started
17:03:20 <mtreinish> #topic Mitaka Summit Prep
17:03:31 <mtreinish> #link https://etherpad.openstack.org/p/mitaka-qa-summit-topics
17:03:35 <dwalleck> o/
17:03:50 <mtreinish> just a reminder to add topics to the brainstorming etherpad
17:04:10 <mtreinish> we've got 8 slots and 9 proposals so if you add one your odds are pretty good :)
17:04:32 <cdent> that list reminds me of a question: is the health dashboard running somewhere for public consumption somewhere?
17:04:36 <mtreinish> I think we'll have to do the deciding soonish
17:04:46 <mtreinish> cdent: not quite yet, there is still a bit of work on that front
17:04:55 <mtreinish> you can spin it up locally using real data though
17:05:00 <cdent> cool thanks
17:05:14 <mtreinish> cdent: if you want to test it locally I can give you a hand with that post-meeting
17:05:43 <cdent> I'll give it a go some time later (after this I'm off to dinner)
17:05:44 * mtreinish had to learn some dark secrets of js packaging to work on it :(
17:05:55 <mtreinish> ok cool
17:06:08 <mtreinish> ok does anyone have anything to discuss on this topic?
17:06:16 * andreaf lurks around for now
17:07:05 <dpaterson> 0/
17:07:25 <mtreinish> ok, I guess not
17:07:27 <mtreinish> let's move on
17:07:29 <mtreinish> #topic Specs Reviews
17:07:37 <mtreinish> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
17:07:53 <mtreinish> we actually have a new spec proposal this week from SpamapS:
17:08:03 <mtreinish> #link https://review.openstack.org/230183
17:08:18 <SpamapS> o/
17:08:20 <mtreinish> the first one in a while
17:08:29 * mtreinish lets SpamapS sell his spec :)
17:08:36 <SpamapS> Lets measure things!
17:09:39 <SpamapS> Please have a quick read if you're interested. I'm pushing hard to give us a picture of how hard we're hammering our backend services.
17:10:11 <dwalleck> sounds interesting. I'll have a peek
17:10:18 <SpamapS> The goal is to have some data about this as change ocurrs, and then start doing some large scale changes to reduce (or even in some cases _remove_) use of backend services through various means and by adding some new ones.
17:10:39 <SpamapS> For instance, keystone is ripe for more caching.
17:10:54 <SpamapS> But we don't have much of a picture of how hard it actually hits the database versus the hit/miss ratio on memcached.
17:11:42 <SpamapS> And even more fun.. we're abusing rabbitmq *and* mysql for locking in Cinder and Heat, but using a DLM might have a significant positive impact on how much we utilize the mq and database.
17:12:01 <SpamapS> Also, who doesn't love more graphs?
17:12:04 <mtreinish> yeah, and the nice thing is this will also provide a framework and template for how to expand this for other metrics in the future when new questions arise
17:12:51 <mtreinish> heh, everyone likes colors
17:13:09 <mtreinish> ok, does anyone have anything else on specs today? (either SpamapS's or in general)
17:14:11 <mtreinish> #topic Tempest
17:14:24 <mtreinish> ok does anyone have anything to discuss about tempest this week?
17:14:55 <rfolco> mtreinish, have a question about devstack/tempest regarding flavors, not sure if can use this time :)
17:15:02 <mtreinish> rfolco: go for it
17:15:13 <mtreinish> rfolco: it's not like anyone else spoke up :)
17:15:32 <rfolco> I have a question about flavors on devstack/tempest. Since the memory requirements changed for ppc64, I sent a patch to stop creating nano/micro flavors and to start using DEFAULT_INSTANCE_TYPE=m1.tiny, 512MB - https://review.openstack.org/#/c/226905. However, the flavor_ref_alt would be m1.small - 2G, which works fine, but too large� waste of RAM.
17:15:32 <rfolco> Would be reasonable to introduce CUSTOM_FLAVOR_ALT=<ram_size> so I can have a smaller favor_alt for resize scenarios, as 768MB ?
17:15:43 <mtreinish> rfolco: although I'm not sure I want to here about power and how you need giant guests to work on it
17:16:20 <mtreinish> rfolco: sure I think that's fine
17:17:03 <rfolco> mtreinish, thanks
17:17:13 <mtreinish> rfolco: heh, was that it? :)
17:17:44 <rfolco> mtreinish, will submit the patch for review on this path then.. that's what I meant
17:18:05 <mtreinish> rfolco: heh, nm
17:18:14 <mtreinish> ok is there anything else on tempest for this week?
17:18:58 <mtreinish> I guess one thing to note is that the tempest-lib service client migrations are in full swing
17:18:58 <andreaf> mtreinish: just a heads up I started working on the migration of cred providers to tempest-lib
17:19:20 <mtreinish> so if people could keep an eye on tempest-lib that'll help that move quickly
17:19:32 <mtreinish> andreaf: ok cool, that'll be good to have
17:19:32 <andreaf> mtreinish: will do
17:20:04 <andreaf> mtreinish: the only bit that is blocked is the tenant isolation provider, which requires the identity client to be in tempest-lib
17:20:06 <mtreinish> andreaf: on that note, I started an etherpad somewhere with things we need to migrate to tempest-lib (when I was working on the ec2 tempest plugin)
17:20:11 <andreaf> mtreinish: but that should happen soon
17:20:12 <mtreinish> I'll have to dig that up and put it on the ML
17:20:26 <andreaf> mtreinish: ok thanks
17:20:35 <mtreinish> andreaf: can't we pass it the client object?
17:21:07 <andreaf> mtreinish: sure that's the way it is now, but it would be a  bit odd to have something in tempest-lib which depends on an object in tempest
17:21:30 <mtreinish> andreaf: heh, that's how the rest client was for a long time until we migrated auth
17:21:34 <mtreinish> but I agree it is weird
17:22:24 <mtreinish> ok, is there anything else to discuss on tempest this week?
17:22:25 <andreaf> mtreinish: anyways the identity client should be in tempest-lib relatively soon
17:22:39 <mtreinish> andreaf: ok cool
17:23:30 <mtreinish> ok, lets move on
17:23:32 <mtreinish> #topic Devstack
17:23:45 <mtreinish> does anyone have something to discuss about devstack this week?
17:23:50 <mtreinish> dtroyer, sdague: ?
17:25:36 <mtreinish> ok, I guess not. Let's move on
17:25:45 <mtreinish> #topic Grenade
17:26:01 <mtreinish> anyone have anything to discuss on grenade this week?
17:26:30 <mtreinish> I guess the big news here (and for devstack too) is that we've branched eveything for liberty
17:26:44 <mtreinish> so now on master changes we're running liberty->master
17:26:55 <mtreinish> which sdague drove forward, there were some headaches IIRC
17:27:45 <mtreinish> ok, is there anything else on grenade?
17:28:46 <mtreinish> #topic OpenStack Health
17:29:16 <mtreinish> ok so does anyone have anything to discuss on the openstack-health dashboard
17:29:31 <mtreinish> I can run down a quick status if anyone wants
17:29:45 <andreaf> mtreinish: that would be nice
17:29:45 <glauco> mtreinish: it would be great
17:29:55 <dwalleck> So I was trying to follow the dev setup and somewhere between npm and gulp, I'm failing :)
17:30:20 <mtreinish> dtroyer: yeah the js install stuff is awful
17:30:42 <mtreinish> dwalleck: improves the docs: https://review.openstack.org/#/c/231746/4
17:30:47 <mtreinish> because those extra steps are so obvious
17:31:05 <dwalleck> ahh cool, I'll take a look
17:31:18 <mtreinish> dwalleck: there is a follow on step for mac too :)
17:31:25 <mtreinish> as for the status right now we're still working on getting the 3 main pages working with real data
17:31:44 <mtreinish> the first page (an overview of all runs with per project groups) is in a good place
17:32:06 <ccarrara> mtreinish: maybe we need some ui/ux improvements only.
17:32:08 <dwalleck> mtreinish: hehe :)
17:32:08 <mtreinish> the second page has the angular pieces but still needs api query support
17:32:21 <mtreinish> ccarrara: sure, this is all iterative
17:32:30 <mtreinish> we need to get a starting point running
17:32:38 <mtreinish> then we can make lots of improvements easily
17:32:40 <ccarrara> mtreinish: We think the second page already has api support.
17:32:43 <dwalleck> I don't know if there's any place you guys need specific help, but this something I absolutely need and would like to throw some cycles at
17:33:00 <glauco> mtreinish:  https://review.openstack.org/#/c/231668/
17:33:05 <mtreinish> #link https://review.openstack.org/#/c/231668/
17:33:10 <mtreinish> yes that's the patch in progress
17:33:15 <mtreinish> I was discussing what's already landed
17:33:20 <ccarrara> nice
17:33:32 <mtreinish> dwalleck: sure, that would definitely help
17:33:44 <andreaf> dwalleck: sure I think help is always welcome
17:33:47 <mtreinish> dwalleck: the more hands on deck we can get things running for real
17:34:41 <ccarrara> the lack of information about the tasks in progress and the target to achieve in the project can be a obstacle to income helps
17:34:47 <dwalleck> cool. I'll be lurking around more, so I'll start poking around
17:35:05 <mtreinish> ccarrara: well we should be using an etherpad, but that kinda fizzled away
17:35:05 <ccarrara> I don't know if we can improve this in any way
17:35:11 <mtreinish> I'll see if I can fix that soon
17:35:13 <ccarrara> agree
17:35:38 <mtreinish> the other big thing is getting the real deployment stuff working
17:35:47 <mtreinish> there are a couple patches in progress for that:
17:35:56 <mtreinish> #link https://review.openstack.org/232255
17:36:02 <andreaf> mtreinish: I think once we have the fist pages up and running we could start using specs, in the meanwhile the etherpad should be good to see what's going on
17:36:03 <mtreinish> for real config support on the frontend
17:36:32 <mtreinish> oh it looks like the wsgi container support landed when I wasn't looking
17:36:46 <glauco> #link https://review.openstack.org/#/c/227849/9/
17:36:57 <glauco> currently working on the improvements suggested by mtreinish
17:37:33 <mtreinish> glauco: yep, that'll be how we deploy it with puppet
17:37:43 <mtreinish> there will be a corresponding system config patch to use it when it's ready
17:37:58 <mtreinish> andreaf: oh, yeah specs might be a good review mechanism for adding pages
17:38:27 <mtreinish> ok, so my summary was kinda a mess :)
17:38:35 <mtreinish> but was there anything else to discuss on this topic?
17:38:54 <ccarrara> mtreinish: maybe we couldn't help so much :)
17:38:55 <andreaf> mtreinish: was there any news on ci-watch?
17:39:00 <timothyb89> to interject, here's a running snapshot of the current master branch: http://208.94.241.194:8080/#/
17:39:08 <timothyb89> for those looking for an example
17:39:11 <mtreinish> #link http://208.94.241.194:8080/#/
17:39:21 <mtreinish> timothyb89: heh, that's actually really helpful I think
17:39:22 <glauco> cool!
17:39:22 <mtreinish> thanks
17:39:36 <mtreinish> andreaf: I think they're still working on that on the infra side
17:39:39 <andreaf> timothyb89: cool thanks
17:39:47 <mtreinish> andreaf: or did you mean the ci-watch spec?
17:40:02 <andreaf> mtreinish: I meant the actual service
17:40:10 <andreaf> mtreinish: from the infra folks
17:40:13 <mtreinish> (it's not at all confusing that the spec for this work was labelled ci-watch and the 3rd party dashboard service is called ci-watch)
17:40:22 <mtreinish> andreaf: I haven't been following it too closely
17:40:29 <mtreinish> but I think they're making progress there
17:40:46 <andreaf> mtreinish: I guess we should have a new spec, reflecting the initial 4 pages, just for sake of tracking it?
17:40:59 <andreaf> mtreinish: a spec in the qa-specs repo
17:41:07 <mtreinish> andreaf: is that you volunteering to write it?
17:41:14 <andreaf> mtreinish: yep, indeed
17:41:16 <mtreinish> because that would probably help
17:41:29 <mtreinish> #action andreaf to write qa spec for the work in progress on openstack-health
17:41:36 <mtreinish> it's all sorts of official now :)
17:42:07 <mtreinish> ok, is there anything else on this topic?
17:43:13 <glauco> andreaf: I would like to help on this spec as well, if possible
17:43:47 <mtreinish> ok, lets move on
17:43:49 <mtreinish> #topic Critical Reviews
17:43:50 <andreaf> glauco: sure I'll put up an initial draft
17:43:56 <andreaf> glauco: and we can take it from there
17:44:04 <mtreinish> does anyone have any reviews they'd like to get extra eyes on?
17:44:16 <dpaterson> yes
17:44:25 <dpaterson> https://review.openstack.org/#/c/224338/
17:44:39 <mtreinish> #link https://review.openstack.org/#/c/224338/
17:44:44 <mtreinish> oh, that's an important one
17:44:51 <glauco> yes. If we could get some reviews on https://review.openstack.org/#/c/231668/
17:45:04 <mtreinish> we get at least 1 question a week because the docs recommended method of running tempest fails
17:45:08 <andreaf> mtreinish: no so critical, but this is the series for preparing the cred provider migration, at least the part I have up until now: # link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/tempest-library,n,z
17:45:20 <mtreinish> so if people could review dpaterson's patch that would be good
17:45:29 <mtreinish> #link https://review.openstack.org/#/c/231668/
17:45:38 <mtreinish> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/tempest-library,n,z
17:45:58 <mtreinish> andreaf: I think you messed up the formatting, i'm not sure it was gonna get picked up
17:46:17 <andreaf> mtreinish: thanks
17:46:20 <mtreinish> and I have 1 this week too:
17:46:21 <mtreinish> #link https://review.openstack.org/232592
17:46:40 <mtreinish> which is kinda simple, but something I hit in testing the tempest_ec2 plugin I've been playing with
17:47:21 <mtreinish> ok, are there any other reviews to bring up?
17:47:52 <andreaf> mtreinish: +2
17:48:14 <mtreinish> andreaf: thanks
17:48:25 <mtreinish> ok, lets open the floor
17:48:28 <mtreinish> #topic Open Discussion
17:48:38 <mtreinish> Does anyone have anything to discuss which wasn't on the agenda?
17:51:05 <mtreinish> ok, I guess let's end it here today
17:51:08 <mtreinish> thanks everyone
17:51:13 <mtreinish> #endmeeting