09:00:57 <oomichi> #startmeeting qa
09:00:58 <openstack> Meeting started Thu Oct  1 09:00:57 2015 UTC and is due to finish in 60 minutes.  The chair is oomichi. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:01:01 <openstack> The meeting name has been set to 'qa'
09:01:17 <oomichi> who all here today?
09:01:35 <andreaf> o/
09:01:35 <jordanP> hi
09:01:47 <oomichi> andreaf: jordanP: hi :-)
09:01:56 <andreaf> hi
09:02:42 <jordanP> hum not  a lot
09:02:45 <oomichi> looks like we 3 only today also
09:02:57 <oomichi> yeah, gmann is not good helth condition now
09:03:06 <jordanP> :(
09:03:06 <oomichi> he is off today
09:03:26 <oomichi> masayukig also is super busy now
09:03:55 <oomichi> ok, let's start meeting
09:04:07 <oomichi> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Proposed_Agenda_for_October_1st_2015_.280900_UTC.29
09:04:13 <oomichi> ^^^ today agenda
09:04:28 <oomichi> #topic Mitaka Summit Prep
09:04:44 <oomichi> #link https://etherpad.openstack.org/p/mitaka-qa-summit-topics
09:05:05 <oomichi> there are some topics proposed already
09:05:34 <oomichi> we need to post topics before 5th this month
09:05:54 <masayukig> o/
09:06:00 <jordanP> oomichi, with an extented description ?
09:06:08 <oomichi> andreaf already proposed
09:06:16 <oomichi> jordanP: do you have more topics?
09:06:23 <jordanP> not really
09:06:31 <oomichi> jordanP: yeah, if you have, it is nice
09:06:39 <oomichi> masayukig: hello ;)
09:06:58 <oomichi> jordanP: which topic do you want to extend?
09:07:09 <jordanP> oomichi, I meant, some descriptions are empty
09:07:19 <jordanP> for some sessions, there's only a title
09:07:36 <masayukig> oomichi: I have to leave in 30 mins, though.. :)
09:07:39 <oomichi> jordanP: ah, I see. Most topics without it
09:08:02 <oomichi> yeah, we need to write descriptions before 5th
09:08:45 <oomichi> masayukig: ok, fine. do you have topic idea for tokyo summit sessions?
09:09:34 <masayukig> oomichi: sorry, I don't have enough time to think about it... :(
09:09:57 <oomichi> we have 8 slots and 8 proposals. so all proposals will be approved in this situation :)
09:10:10 <oomichi> masayukig: no problem
09:11:18 <oomichi> someone has topics about this, or it is fine to move to the next topic?
09:11:52 <oomichi> ok
09:11:59 <oomichi> #topic Specs Reviews
09:12:16 <oomichi> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
09:12:52 <oomichi> at this time also, most qa-specs have -1 and we need to update them
09:13:14 <jordanP> I am still interested at the "Restructure Scenarios" BP
09:13:49 <oomichi> jordanP: it gets very old now
09:14:01 <jordanP> I'll try to refresh it, give it some more thought
09:14:13 <andreaf> jordanP: thanks
09:14:16 <oomichi> jordanP: cool
09:14:41 <oomichi> jordanP: did you talk about it with yfried
09:14:49 <oomichi> jordanP: ?
09:14:56 <jordanP> not yet
09:15:07 <jordanP> I will
09:15:23 <oomichi> jordanP: thanks :) it is nice to go forward
09:15:44 <oomichi> #action jordanP will update https://review.openstack.org/#/c/101232/
09:16:42 <oomichi> does someone need to talk about qa-specs more?
09:17:41 <oomichi> #topic Tempest
09:18:19 <oomichi> I'd like to talk about service clients dev situation.
09:18:44 <oomichi> a new tempest-lib which contains the first compute service client has been already released.
09:18:51 <oomichi> as 0.9.0.
09:19:13 <jordanP> great
09:19:16 <oomichi> but tempest doesn't use it yet because g-r patch is not merged yet
09:19:39 <oomichi> #link https://review.openstack.org/#/c/227599/
09:20:00 <oomichi> after merging it, temepst will use it and start migration
09:20:21 <oomichi> next tempest-lib will be 0.10.0, not 1.0.0
09:20:33 <oomichi> with including all compute service clients
09:21:00 <oomichi> so now we are concentrating on migrating compute service clients to tempest-lib
09:21:09 <oomichi> #link https://etherpad.openstack.org/p/tempest-lib-service-client-migration
09:21:09 <jordanP> is it that bad that the g-r patch is not merged ? Can't it yet a bit ?
09:21:47 <oomichi> jordanP: before -rc release(making stable branch), g-r should be frozen.
09:22:12 <oomichi> jordanP: and now -rc is released. so I guess the patch will be merged soon, I hope :)
09:22:43 <jordanP> oomichi, right now we added some clients in tempest-lib but these clients have not been removed from tempest right ?
09:22:58 <oomichi> jordanP: perfectly right
09:23:02 <jordanP> k
09:23:33 <oomichi> jordanP: to be honest, I'd like to remove them from Tempest because we need to sync the code between tempest and tempest-lib if taking much time
09:23:40 <oomichi> for migration
09:23:40 <jordanP> oomichi, do you have a script, a procedure to remove them from tempest after the g-r patch merge ?
09:23:50 <jordanP> oomichi, excatly
09:24:10 <oomichi> jordanP: ah, we don't have. but that is really nice idea
09:24:36 <oomichi> jordanP: we can remove them safely if the script checks code sync
09:24:38 <jordanP> if we have something automated, we can procede with the removal very quickly
09:24:50 <oomichi> jordanP: +1 :)
09:25:32 <oomichi> we need to do that in long-term for the other service clients. so that will be helpful for us
09:25:38 <jordanP> (I can"t do it in the next week, I am busy writting a manila driver... but the week after should be better for me)
09:25:54 <oomichi> jordanP: thanks
09:26:31 <oomichi> #action jordanP oomichi think the script for removing migrated service clients from tempest
09:27:13 <oomichi> jordanP: are you working for manila itself also?
09:27:43 <jordanP> oomichi, I am mostly writting a driver for my company. Not a lot of other contributions
09:28:05 <oomichi> jordanP: cool, I see
09:28:22 <jordanP> I am in thr dark side, the vendor side :D
09:28:42 <oomichi> jordanP: no, that is not dark side ;-)
09:29:03 <oomichi> jordanP: right side from company viewpoint
09:29:16 <jordanP> yep :)
09:29:46 <oomichi> jordanP: andreaf: do you have topics for tempest?
09:30:10 <andreaf> oomichi: nothing to add on my side
09:30:16 <jordanP> I am good. There was some issues lately with the removal of Cinder v1
09:30:20 <jordanP> but it has been reverted
09:30:21 <oomichi> I got a nice idea for service clients, and all from me
09:31:06 <oomichi> jordanP: now temepst is testing cinder v1 or v2?
09:31:22 <jordanP> oomichi, both today
09:31:27 <oomichi> to be honest, I cannot catch current situation for that
09:31:29 <jordanP> but yesterdan only Cinder v2
09:31:38 <jordanP> but 2 days ago, both again :)
09:32:18 <jordanP> so now, it's back to what it used to be a few days ago
09:32:56 <oomichi> jordanP: devstack was changed to use cinder v2 few days ago
09:33:08 <oomichi> and problem happened I guess
09:33:33 <jordanP> oomichi, yep (more precesily, devstack was change to not run cinder v1 by default)
09:33:39 <oomichi> because heat gate test used cinder v1, right?
09:34:18 <oomichi> ah, I need to know current situation more after meeting
09:34:28 <jordanP> yes, after meeting :)
09:34:31 <oomichi> jordanP: thanks
09:34:56 <oomichi> #topic DevStack
09:35:11 <oomichi> maybe we can skip this topic
09:35:27 <oomichi> #topic Grenade
09:35:33 <oomichi> this also
09:36:04 <oomichi> ok, let's move to the next topic
09:36:14 <oomichi> #topic OpenStack Health
09:36:20 <oomichi> this also?
09:36:56 <jordanP> I haven"t really catched up with this yet
09:37:12 <oomichi> jordanP: yeah, I also.
09:37:24 <oomichi> #link https://etherpad.openstack.org/p/PuDfHylBgI
09:38:00 <andreaf> oomichi: I don't have much updates on this myself, I was a few days on holidays and need to catch-up
09:38:23 <oomichi> andreaf: ok, fine
09:38:32 <oomichi> let's move to the next topic
09:38:42 <oomichi> #topic Critical Reviews
09:39:05 <oomichi> someone has patches necessary to be reviewed?
09:39:07 * andreaf has to leave early today - he will catch the rest from the meeting logs
09:39:43 <oomichi> andreaf: see you :)
09:41:04 <oomichi> there are not so many topics today, but it is fine to finish now I feel.
09:42:08 <oomichi> thanks all
09:42:15 <oomichi> #endmeeting