17:01:06 <mtreinish> #startmeeting qa
17:01:06 <openstack> Meeting started Thu Feb 12 17:01:06 2015 UTC and is due to finish in 60 minutes.  The chair is mtreinish. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:10 <openstack> The meeting name has been set to 'qa'
17:01:12 <mtreinish> helps to spell start correctly...
17:01:20 <mtreinish> hi, who's here today?
17:01:30 <dkranz> here
17:01:32 <gema> o/
17:01:35 <andreaf> o/
17:01:56 <mtreinish> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Proposed_Agenda_for_February_12th_2015_.281700_UTC.29
17:02:02 <mtreinish> ^^^ Today's agenda
17:02:04 <7YUAAB0C9> o/
17:02:10 <dtroyer> o/
17:02:38 <mtreinish> ok let's get started
17:02:44 <mtreinish> #topic Specs Reviews
17:02:48 <jlanoux> hi
17:02:49 <fnaval> o/
17:02:55 <mtreinish> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
17:03:03 <mtreinish> does anyone have an open spec review to bring up
17:03:05 <mtreinish> or discuss
17:03:06 <mtreinish> ?
17:03:52 <dkranz> mtreinish: It's not our spec, but folks here should be aware of https://review.openstack.org/#/c/150653
17:04:16 <mtreinish> dkranz: oh, yeah that's a good one to bring up
17:04:19 <dmorita> o/
17:04:50 <mtreinish> I think sdague has done a good job outlining testing and the direction we should be moving towards in it
17:05:11 <dkranz> mtreinish: agreed, and there is an intersection with our discussions around tempest futures
17:05:20 <mtreinish> probably something others here would like to read too
17:05:40 <mtreinish> dkranz: yeah, it's part of the reason why I wrote https://review.openstack.org/152683
17:05:44 <dkranz> mtreinish: a number of folks have asked me about functional tests in tempest vs in projects
17:06:28 <dkranz> mtreinish: and we do not have a clear answer except at the boundaries: integration tests in, detailed project-specific functional tests out
17:07:06 <mtreinish> dkranz: well that's mostly because a lot of it is still new
17:07:32 <dkranz> mtreinish: right, so the question is do we wait until Vancouver for further discussion/resolution about that?
17:07:44 <mtreinish> I think things will get more clear as the patterns for doing things evolve
17:08:13 <mtreinish> dkranz: I think it'll be a continual conversation
17:08:21 <mtreinish> which will also take place in Vancouver
17:08:23 <dkranz> mtreinish: ok, so we will continue to deal with issues of where tests belong on an ad-hoc basis for a while
17:08:52 <mtreinish> dkranz: sure, but we can also use it as an exercise to help explore how one could test something outside of tempest
17:09:08 <dkranz> sure
17:09:33 <mtreinish> ok, are there any other specs to discuss?
17:10:33 <mtreinish> lets move on then
17:10:41 <mtreinish> #topic Blueprints
17:10:58 <mtreinish> ok, does anyone have an in progress BP they'd like to discuss?
17:11:14 <dkranz> client-returns one value
17:11:22 <mtreinish> dkranz: sure
17:11:28 <dkranz> I put the review link at the end of the agenda
17:11:37 <dkranz> I am planning to wrap this up soon
17:11:49 <mtreinish> awesome, how many clients do you have left? :)
17:11:57 <dkranz> But I saved the high-impact for rebase ones for last so reviews would be appreciated
17:12:20 <dkranz> object and compute servers are the main ones remaining
17:12:24 <mtreinish> ok
17:12:36 <dkranz> Just a few more hours work I think
17:12:49 <mtreinish> cool, that'll be good to finally finish
17:13:14 <mtreinish> object will be interesting because it uses headers more than other projects
17:13:28 <dkranz> yes, that's why I left it for last
17:13:38 <mtreinish> heh, fair enough
17:13:53 <mtreinish> ok are there any other blueprints to bring up?
17:13:57 <dkranz> but it is really just one extra line "resp = xxx().response" and the rest of the code does not change
17:14:18 <mtreinish> dkranz: yeah that's a good point
17:15:17 <mtreinish> ok, well I guess I should mention we pushed out another tempest-lib release yesterday
17:15:23 <andreaf> mtreinish: I missed a few minutes - are you talking about bps now?
17:15:40 <mtreinish> this time just a small point release fixing a subunit-trace bug with not passing through stdout
17:15:43 <mtreinish> andreaf: yes
17:16:08 <dkranz> mtreinish: is the process of pushing a new tempest-lib release documented somewhere?
17:16:30 <mtreinish> dkranz: yes, on https://wiki.openstack.org/wiki/QA/releases
17:16:41 <mtreinish> it still has some gaps, I need to flush it out some more
17:16:58 <dkranz> mtreinish: ok, cool
17:17:20 <mtreinish> it's also slightly out of date (we don't have to bump setup.cfg anymore)
17:17:55 <mtreinish> andreaf: did you have a bp (or 3) to bring up?
17:18:28 <andreaf> mtreinish: yes
17:18:50 <andreaf> mtreinish: resource-cleanup #link https://blueprints.launchpad.net/tempest/+spec/resource-cleanup
17:19:30 <andreaf> so it turns out that issues we saw were due to set_network_resource being called at the wrong point in time, due to the split of resource cleanup
17:20:08 <mtreinish> andreaf: yeah, it needed to be called before the isolated creds call
17:20:11 <andreaf> I'm working on a patch that temporary solve that by detecting this situation and doing a re-setting up network resources
17:20:30 <andreaf> #link https://review.openstack.org/153681
17:20:49 <andreaf> it almost passes now I think, there are still a few failures I need to look at
17:21:12 <andreaf> in the process I also worked on dropping _interface from everywhere
17:21:13 <mtreinish> andreaf: ok, I'll take a look. We have to be careful becase it was originally written so that leaf classes got first prio for the network_resource settings
17:21:23 <andreaf> yes indeed
17:21:25 <andreaf> https://review.openstack.org/#/q/topic:bp/resource-cleanup++status:open,n,z
17:21:43 <andreaf> there is a large number of patches for this bp, so reviews and comments are very welcome
17:22:05 <andreaf> next bp is the tempest lib one
17:22:07 <mtreinish> wow, that is quite a few
17:22:32 <andreaf> indeed :)
17:22:37 <andreaf> #link https://blueprints.launchpad.net/tempest/+spec/tempest-library
17:22:51 <andreaf> on the tempest lib I'm working on migrating auth module
17:23:18 <andreaf> the preparation work is almost done, first patch just merged, two more to go:  #link https://review.openstack.org/#/q/topic:libify_auth++status:open,n,z
17:23:53 <andreaf> more reviews are welcome as I'd like the code to be nice before we migrate to lib
17:24:30 <andreaf> on the ssh auth one #link https://blueprints.launchpad.net/tempest/+spec/ssh-auth-strategy
17:24:33 <mtreinish> andreaf: yeah, this is a high prio one to migrate
17:24:38 <mtreinish> because it's needed for a lot of things
17:25:29 <andreaf> mtreinish: yep indeed - it should sit together with rest client asap anyways :)
17:26:18 <andreaf> mtreinish: btw there's a fix from jamie on auth.py, I think that should go in before we migrate
17:26:42 <andreaf> mtreinish: to better support domain scoped tokens
17:27:06 <mtreinish> andreaf: sure
17:27:26 <andreaf> #link https://review.openstack.org/#/c/154773/
17:27:31 <andreaf> ok
17:27:40 <andreaf> back to the ssh auth bp
17:28:26 <andreaf> jlanoux and nithyag_ are doing good progress there, working on the initial patches that define the common framework for instance validation
17:29:14 <andreaf> https://review.openstack.org/#/q/topic:bp/ssh-auth-strategy++status:open,n,z
17:29:17 <andreaf> still WIP though
17:29:41 <mtreinish> andreaf:is it something we need to get more eyes on?
17:30:18 <andreaf> mtreinish: probably not yet, they're still WIP, but soon enough
17:30:28 <mtreinish> ok
17:30:35 <jlanoux> mtreinish: not yet. we still have a bit of work on the remote client qnd it will be ready for review
17:31:39 <andreaf> mtreinish: so not many news on the test accounts one, only that some of the work done for other bps may help a bit for test-accounts as well :)
17:32:07 <mtreinish> heh, sure. I need to get back to my patch for that too
17:32:17 <mtreinish> andreaf: any other bps otherwise let's move on
17:32:18 * andreaf thinks he has taken enough time of the meeting now for bps
17:32:35 <mtreinish> ok then let's move on
17:32:49 <mtreinish> #topic Devstack
17:32:54 <mtreinish> dtroyer: still around?
17:32:58 <dtroyer> yo
17:33:04 <sdague> o/ as well
17:33:44 <sdague> been helping people move to devstack external plugins quite a bit
17:33:46 <dtroyer> I'm working through the move-things-into venvs process, first cut client venv up for review in https://review.openstack.org/151513
17:33:56 <sdague> opendaylight is over there now
17:33:59 <sdague> which is nice
17:34:18 <sdague> and I think gnochi is using it as well
17:34:58 <sdague> also put this out on the list for discussion - http://lists.openstack.org/pipermail/openstack-dev/2015-February/056738.html
17:35:12 <dtroyer> sdague: should we have a place (wiki??) where we ask people to note their external plugin use so we have a chance to find them should a breaking chance be required?
17:35:15 <sdague> the beginnings of grenade external interface thoughts
17:35:49 <sdague> dtroyer: honestly, I was thinking we should have a known plugins list in the devstack docs, which would also let people advertise their projects in devstack official documentation
17:35:59 <mtreinish> sdague: sure, maybe we want to have a spec for planning that out
17:36:16 <sdague> mtreinish: yeh, right now, I wanted just an email thread to poke at it
17:36:30 <dtroyer> sdague: that works, and lends the air of authenticity folks want by being in the repo directly
17:36:55 <sdague> I feel like with the devstack external plugins we were close in the spec, but had to make a bunch of code changes to get a thing that was right
17:37:38 <sdague> so if we get a good ML discussion that's probabyl good enough to prototype
17:38:40 <dtroyer> . env9 admin
17:38:59 <dtroyer> which of course is my secret lair security code
17:39:09 <mtreinish> sdague: ok, I'm just not sure it's gonna get the right attention on the ML
17:40:13 <mtreinish> but we can give it a shot
17:40:28 <cdent> sdague: is trying hard to be a good citizen in response to recent concerns, which I applaud
17:40:43 <cdent> but it is probably true that attention will be insufficient
17:40:57 <mtreinish> cdent: heh, I was trying to avoid bringing up that thread :)
17:41:00 <cdent> :)
17:41:05 <sdague> honestly, I expect this gets more attention on the ML than as a qa-spec
17:42:32 <sdague> anyway, I think that's about it on those fronts.
17:42:42 <mtreinish> ok, does anyone else have anything else to discuss on devstack (and I guess grenade too)
17:43:20 <mtreinish> then let's move on
17:43:24 <mtreinish> #topic Bugs
17:43:31 <mtreinish> #link https://etherpad.openstack.org/p/Tempest-bug-report
17:44:12 <mtreinish> doesn't look like are bug growth has changed too much
17:44:22 <dkranz> So I'm doing triage this week and mtreinish next, but we need more volunteers after that
17:44:23 <mtreinish> dkranz: you took the triage rotation this week, anything standout?
17:44:33 <dkranz> https://etherpad.openstack.org/p/qa-bug-triage-rotation
17:44:47 <dkranz> mtreinish: not really. Most new bugs were immediately addressed
17:45:00 <dkranz> mtreinish: One new one just came in that I have yet to look at
17:45:14 <mtreinish> ok, we probably should also concentrate on working through the backlog at some point too
17:45:25 <mtreinish> because that's been kinda static in size
17:45:53 <dkranz> mtreinish: right, I don't think a lot of folks are going through old bugs and trying to fix them
17:46:21 <mtreinish> maybe we should schedule a day to work to concentrate on that in the near future
17:46:36 <dkranz> mtreinish: good idea
17:47:00 <mtreinish> #action mtreinish to plan a day to work through triaged bug backlog
17:47:12 <mtreinish> okay is there anything else to discuss on bugs?
17:47:57 <mtreinish> #topic Critical Reviews
17:48:12 <mtreinish> okay, does anyone have any reviews they feel could use extra attention?
17:48:31 <mtreinish> now is the time to bring them up
17:49:37 <mtreinish> well if no one else has anything I'll paste one
17:49:38 <dkranz> mtreinish: just the ones I put there. The servers one just needed another rebase.
17:49:39 <mtreinish> #link https://review.openstack.org/155103
17:49:52 <mtreinish> the first step on making the tempest-lib docs useful
17:49:58 <mtreinish> dkranz: oh sry, forgot that link
17:50:12 <mtreinish> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/clients-return-one-value,n,z
17:50:45 <mtreinish> does anyone else have a review?
17:50:52 <andreaf> this one: https://review.openstack.org/#/c/153621/
17:50:58 <andreaf> #link https://review.openstack.org/#/c/153621/
17:51:23 <andreaf> is the _interface cleanup, I rebased it a few times already so I'd like to get it through asap
17:51:35 <andreaf> also it should be merged before the auth migration to lib
17:51:49 <mtreinish> andreaf: ok, sure should be a simple cleanup
17:52:24 <mtreinish> andreaf: fwiw, I think tempest-lib's rest client sets the interface to json
17:52:32 <mtreinish> but we can discuss that after the meeting
17:52:45 <mtreinish> if there aren't any other review let's open the floor
17:52:50 <mtreinish> #topic Open Discussion
17:53:05 <mtreinish> Does anyone have a topic to discuss which wasn't on the agenda?
17:53:55 <dkranz> I was wondering how we will make sure all tests are correctly tagged once we start to gate on subsets
17:54:27 <dkranz> Perhaps we should have a nightly job that stubs out all clients that are "not tagged" for each service
17:54:38 <mtreinish> dkranz: well I think it comes down to service tagging well
17:54:55 <dkranz> mtreinish: right, I was thinking about ways to enforce that
17:54:56 <mtreinish> dkranz: that might not work because for a lot of tests which use the dir name as part of the filter
17:55:25 <dkranz> mtreinish: that's ok, we just have to treat that as an implicit tag and make sure it is not calling some other service
17:55:36 <dkranz> mtreinish: anway, just something to think about
17:55:48 <mtreinish> dkranz: or if we are we service tag it (which is why that's there)
17:55:55 <dkranz> right
17:56:06 <dkranz> but we could be missing some now and we would not know
17:57:03 <mtreinish> yeah, the enforcement has always been tricky
17:58:34 <mtreinish> ok is there anything else? otherwise let's end here
17:59:28 <mtreinish> thanks everyone
17:59:30 <mtreinish> #endmeeting