19:01:08 <briancurtin> #startmeeting python-openstacksdk
19:01:09 <openstack> Meeting started Tue Jun 10 19:01:08 2014 UTC and is due to finish in 60 minutes.  The chair is briancurtin. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:12 <openstack> The meeting name has been set to 'python_openstacksdk'
19:02:18 <briancurtin> #info agenda at https://wiki.openstack.org/wiki/Meetings/PythonOpenStackSDK#Agenda_for_2014-06-10_1900_UTC
19:02:36 <briancurtin> If you're here for the python-openstacksdk meeting, say hi
19:02:39 <briancurtin> Brian Curtin, Rackspace
19:02:45 <Alex_Gaynor> Alex Gaynor, Rackspace
19:02:52 <terrylhowe> Terry Howe, HP
19:03:00 <edleafe> Ed Leafe, Rackspace
19:03:23 <jamielennox> Jamie Lennox, Red Hat
19:03:28 <jamielennox> hi
19:03:47 <Alex_Gaynor> jamielennox: isn't it like midnight for you? That's dedication!
19:04:15 <jamielennox> Alex_Gaynor: 5am, and 2nd of the day
19:04:23 <briancurtin> #topic https://review.openstack.org/#/c/98917/ - Important auth fixes
19:04:45 <briancurtin> so that review is the root of a few of the example changes, so i figure start with that. it's fairly small, only i've reviewed it though
19:06:13 <jamielennox> terrylhowe: do yoy have a need for passing **kwargs through on get_token?
19:06:19 <jamielennox> #link https://review.openstack.org/#/c/98917/1/openstack/auth/identity/base.py
19:06:38 <Alex_Gaynor> Just did a quick review, it looks fine to me, besides the comment I left.
19:07:09 <Alex_Gaynor> If someone replies to that I'm sure we can have that merged before the meeting ends
19:07:27 <terrylhowe> jamielennox: I don’t have a need right now, but figured there might be a possibliity the transport would need it
19:07:59 <jamielennox> if so then no problem, i'm pretty sure i didn't pass kwargs through there on purpose but if you've come across a case then i'm happy to go with it
19:08:57 <jamielennox> ok, can i recommend being really careful passing **kwargs around like that because it can become a real pain to maintain compatability in the future
19:09:12 <Alex_Gaynor> ==jamielennox
19:10:27 <terrylhowe> that is fine, looking at session right now, and it doesn’t pass in kwargs at the moment
19:11:09 <jamielennox> in the ksc case most of using **kwargs was just a sink that would ignore params it didn't understand yet
19:12:06 <terrylhowe> I’d be okay with removing kwargs from those guys if everyone feels that is best
19:12:23 <briancurtin> yeah, that sounds best
19:12:58 <jamielennox> terrylhowe: ++
19:13:07 <jamielennox> easy to add back if a case ever comes up
19:13:19 <terrylhowe> cool
19:13:27 <briancurtin> yep. seems like a better idea to know for sure that we need them, so +1
19:14:30 <briancurtin> #action Terry will remove the kwargs, should be good to go at that point
19:14:37 <briancurtin> #topic https://review.openstack.org/#/c/97829/ - Example code reorg and auth examples
19:14:58 <briancurtin> hmm, Dean isn't here - he -2'ed this one
19:15:30 <terrylhowe> well, he -2ed the previous patch
19:15:39 <terrylhowe> I think I’ve addressed his concerns
19:16:05 <briancurtin> i think so as well, just wondered if he was around to take a look yet
19:17:13 <jamielennox> i'm good with that one
19:19:17 <briancurtin> Ed brings up a good point about where the examples are aimed at, but i put that as an item to talk about generally at the end
19:19:38 <briancurtin> other than that, i think this is probably good to move on, and Dean can chime in whenever
19:19:57 <briancurtin> #topic https://review.openstack.org/#/c/98524/ - Example session command
19:20:40 <briancurtin> At the top of it all, this change is now much more slimmed down as things have moved into those other reviews. i +2ed this latest set
19:22:16 <jamielennox> +2 as well
19:25:33 <briancurtin> #topic: identifying example audiences
19:26:50 <terrylhowe> I kind of like the super simple examples and allow the devs to jump in try out whatever they like
19:27:12 <terrylhowe> I just want to create something and see it work in some basic way
19:27:42 <terrylhowe> edleafe: and perhaps Dean feel differently
19:27:53 <briancurtin> edleafe: is there anything at the moment we should change?
19:27:59 <Alex_Gaynor> Right now I've just been treating examples as "for internal consumption" not for any sort of end users
19:28:11 <edleafe> Yeah, what Alex said
19:28:19 <briancurtin> in general I kind of like when an example gives somewhat of a 'user story', but i dont know if we're at the point now where we have many user stories besides internal devs
19:28:29 <edleafe> I don't really see the benefit of example code for internal devs
19:28:44 <edleafe> BDD, anyone?  ;-)
19:29:15 <edleafe> We're writing a tool to make devs' lives simpler and easier
19:30:10 <edleafe> If I came in cold and saw a bunch of examples that dove deep into the internals, I'd figure that this wasn't the sort of SDK I needed.
19:30:54 <jamielennox> i think the examples reflect the deep internals because that's really all we have at the moment
19:31:20 <edleafe> Then why are we spending time on them instead of getting closer to an MVP?
19:31:26 <jamielennox> as we get higher level we obviously add those examples but i don't see a problem with examples for like the session object because the intent is not to hide that from people
19:31:49 <briancurtin> edleafe: i dont think we're going to end up with one directory containing all levels of example code, from internals to "i want to use swift"
19:32:17 <Alex_Gaynor> Eventually I would expect that the examples for end users would be in the docs/ directory :-)
19:33:23 <briancurtin> yep. this is just another thing that will grow to fit the needs as this continues on. maybe this dir eventually becomes /internals/examples, who knows
19:33:54 <edleafe> jamielennox: I don't think you should hide it, but if your examples feature it, that's what users will think is the way to use the SDK
19:34:04 <terrylhowe> well, examples are for SDK devs or SDK users?
19:34:18 <edleafe> briancurtin: why do internal devs need examples??
19:34:23 <briancurtin> so they can write code?
19:34:30 <briancurtin> so they can build thigns?
19:34:34 <briancurtin> what are we hired for?
19:35:30 <jamielennox> edleafe: because at some point i expect the various services to start chipping in there own features, so there is a need for them to understand how the library works
19:35:38 <briancurtin> if i want to know how to quickly setup a session but my goal is like 10 things away from dealing with session stuff, i might just want a quick piece of code to show me so i can get on with my job
19:35:45 <edleafe> I always thought that's what the code itself, including tests, was supposed to do
19:36:08 <jamielennox> not being argumentative, i think the examples will grow until the point where we need to figure them out, but there is reason for both
19:36:16 <Alex_Gaynor> I suspect some of this will go away as we have examples of how to add a service, but without the examples how would the first person know how to add (say) swift suport?
19:36:33 <Alex_Gaynor> I hope these can eventually just be replaced with the code itself.
19:36:38 <Alex_Gaynor> But there's a chicken/egg thing I think
19:36:46 <edleafe> Alex_Gaynor: that's a code smell to me
19:39:21 <terrylhowe> This has been a very confusing discussion
19:40:53 <briancurtin> so we're making a bunch of code and people need to know how to use it: examples seem fine to me
19:41:16 <edleafe> My only concern is that, based on experience, if you have example code, newcomers to the SDK will look at those and pattern their work on that
19:41:31 <briancurtin> so we should identify what the examples are aimed at
19:41:43 <edleafe> But if no one else feels that that could be an issue, so be it
19:42:08 <terrylhowe> edleafe: that is definitely true
19:42:27 <briancurtin> i don't think we're going to put this current example on the rackspace site and have our customers building things like this - it's going to live in the repo for us in this meeting
19:47:26 <briancurtin> i think this is just a bridge we'll cross when we get to it. for now we just document and examplement (that's a new word) what we have and enable people to build on what's available
19:48:04 <terrylhowe> sounds good to me
19:48:23 <jamielennox> +1
19:48:57 <briancurtin> #topic building out resouces
19:49:22 <briancurtin> i was at two conferences and in transit to and from russia for a while, so i haven't really hacked on much, so i have nothing to add here...but does anyone else?
19:49:55 <terrylhowe> I’ve done a little work on a glance image resource, it needs lots more
19:50:38 <terrylhowe> I should have something rough sometime this week
19:51:16 <briancurtin> cool. i'm going to start poking around as well, likely swift
19:56:16 <briancurtin> 4 min left, anything else to add?
19:57:45 <Alex_Gaynor> Seems like no, thanks everybody!
19:57:47 * Alex_Gaynor -> lunch
19:58:08 <edleafe> c ya!
19:58:09 <briancurtin> #action Terry working on Glance resource, Brian on Swift
19:58:12 <briancurtin> thanks all
19:59:25 <briancurtin> #endmeeting