#openstack-meeting-3: python-openstacksdk

Meeting started by briancurtin at 19:00:28 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/PythonOpenStackSDK <- Agenda (briancurtin, 19:00:53)
    2. https://wiki.openstack.org/wiki/SDK-Development/PythonOpenStackSDK <- General Project Info (briancurtin, 19:01:11)

  1. https://review.openstack.org/#/c/79435/ (briancurtin, 19:04:03)
  2. look into better mocking with requests (check with Kenneth et. al) (briancurtin, 19:15:31)
    1. ACTION: look into better mocking with requests (check with Kenneth et. al) (briancurtin, 19:15:46)
    2. ACTION: confirm state of HTTPretty usability with regard to verifying mocks/stubs (briancurtin, 19:16:35)

  3. using URLObject (briancurtin, 19:17:01)
    1. https://alice:1234@github.com/zacharyvoase/urlobject?spam=eggs#foo (jnoller, 19:25:54)
    2. ACTION: Alex_Gaynor outline a justification of why to use URLObject and add it as a dependency (briancurtin, 19:31:55)
    3. ACTION: Alex_Gaynor remove Rackspace-isms in example code, as pointed out by dolphm (briancurtin, 19:38:23)

  4. Design Summit topic(s) (briancurtin, 19:44:38)
    1. http://summit.openstack.org/cfp/details/34 (jnoller, 19:46:50)


Meeting ended at 19:59:55 UTC (full logs).

Action items

  1. look into better mocking with requests (check with Kenneth et. al)
  2. confirm state of HTTPretty usability with regard to verifying mocks/stubs
  3. Alex_Gaynor outline a justification of why to use URLObject and add it as a dependency
  4. Alex_Gaynor remove Rackspace-isms in example code, as pointed out by dolphm


Action items, by person

  1. Alex_Gaynor
    1. Alex_Gaynor outline a justification of why to use URLObject and add it as a dependency
    2. Alex_Gaynor remove Rackspace-isms in example code, as pointed out by dolphm
  2. dolphm
    1. Alex_Gaynor remove Rackspace-isms in example code, as pointed out by dolphm
  3. UNASSIGNED
    1. look into better mocking with requests (check with Kenneth et. al)
    2. confirm state of HTTPretty usability with regard to verifying mocks/stubs


People present (lines said)

  1. jnoller (77)
  2. briancurtin (50)
  3. dolphm (20)
  4. jamielennox (20)
  5. wchrisj (13)
  6. edleafe (12)
  7. bknudson (9)
  8. dtroyer (9)
  9. openstack (3)
  10. mfer (2)
  11. Alex_Gaynor (2)


Generated by MeetBot 0.1.4.