16:05:36 <ewindisch> #startmeeting Python3
16:05:37 <openstack> Meeting started Thu Apr  4 16:05:36 2013 UTC.  The chair is ewindisch. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:05:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:05:40 <openstack> The meeting name has been set to 'python3'
16:05:51 * dhellmann misread that error message and was worried he was here for the wrong meeting
16:05:54 <dhellmann> o/
16:05:55 <ewindisch> so, besides me being late again - who do we have ? :)
16:06:32 <dhellmann> hi, sorry I missed the first meeting last week and thanks for getting the ball rolling on this!
16:06:59 <ewindisch> anyone else for the roll-call?
16:07:43 <ewindisch> dhellmann: no problem. Hopefully the momentum can be maintained - I'm a bit concerned nobody seems to be here, though.
16:07:55 <dhellmann> markmcclain had another obligation this week
16:08:04 <ewindisch> being release day doesn't help, I'm sure.
16:08:14 <dhellmann> true
16:08:25 <ewindisch> #topic action items last meeting
16:08:26 <rpodolyaka> Hello, guys! I'm with you :)
16:08:43 <ewindisch> 1. ewindisch follow up with -infra to discuss gating
16:08:49 <ewindisch> hello rpodolyaka.
16:09:39 <ewindisch> honestly, I didn't have a lot to do with this because markmcclain was still working on a py3 test.
16:09:49 <ewindisch> 2. markmacclain to look at writing a py3 test
16:09:55 <ewindisch> he isn't here… so
16:10:08 <ewindisch> #action ewindisch to chase down markmacclain, ask about py3 test
16:10:26 <ewindisch> 3. dripton to dig through oslo deps for version compat
16:10:57 <ewindisch> dripton did this.
16:11:01 <ewindisch> #link https://wiki.openstack.org/wiki/Python3Deps
16:11:13 <dhellmann> ewindisch: I updated the notes from that to answer the question about stevedore or cliff (I forget which it was)
16:11:26 <dhellmann> both should work with 3.3
16:11:33 <dhellmann> we're targeting 3.3, right?
16:12:04 <ewindisch> dhellmann: that isn't decided. It seems conclusive we need to support at *least* 3.2
16:12:08 <dhellmann> ah
16:12:12 <dhellmann> I misremembered
16:12:53 <dhellmann> I guess we'll have to see what we can do with the dependencies before making a final call on that.
16:13:07 <ewindisch> It was intended to review dripton's dependency analysis and use that as part basis for making a recommendation to the TC
16:13:33 <ewindisch> 4. ewindisch to look at PSF sponsorship
16:13:45 <dhellmann> the eventlet issue is going to be painful
16:13:53 <ewindisch> dhellmann: yeah.
16:14:12 <dhellmann> ewindisch: did you have any luck with sponsorship?
16:14:22 <rpodolyaka> I filled some missing deps on wiki and tried to make one of the deps (mox) to be compatible with both Python 2.x and Python 3.x but it has turned out to be a bit harder than I thought...
16:14:23 <ewindisch> I did look at this. It seems we could ask for funding, if we have things that we'd want to fund. That would probably be a sprint, or perhaps seeking a PSF sponsorship for eventlet folks ;-)
16:14:55 <ewindisch> really the question isn't if we can get money, the question is what would we use it for?
16:15:03 <dhellmann> good point
16:15:18 <dhellmann> sprint funding is pretty easy to get, but the OpenStack foundation could probably cover those expenses, too
16:15:39 <ewindisch> I thought it would've been good if we had a sponsored sprint at the summit, but a bit too late for that now.
16:16:14 <dhellmann> funding longer term development would also be something to look at, if we can identify someone interested in doing the work on an upstream dependency
16:16:50 <ewindisch> right. eventlet specifically comes to mind.
16:17:32 <ewindisch> and finally…
16:17:34 <ewindisch> 5. dripton create wiki pages
16:17:36 <dhellmann> I wonder (pie in the sky) if we should just consider moving to tulip instead of porting eventlet. More "modern". 
16:17:37 <ewindisch> completed ;)
16:18:07 <ewindisch> #topic async framework / eventlet
16:18:26 <ewindisch> dhellmann: I'm thinking the same thing.
16:18:42 <dhellmann> if we're going to make the leap...
16:18:50 <ewindisch> or… porting eventlet to PEP3156
16:19:14 <dhellmann> I don't know enough about the implementation to know if that's possible
16:19:29 <dhellmann> how much of our code actively knows about eventlet?
16:20:05 <ewindisch> note that if we decide to use Tulip or PEP3156, that work presently depends on Python3.3
16:20:13 <romcheg> There seems to be only a reference implementation for Tulip...
16:20:25 <rpodolyaka> dhellmann: wsgi modules in every project, some workarounds on DB pooling...
16:20:28 <ewindisch> dhellmann: the rpc stuff is pretty tied to it, but it could be switched out easily enough, I think.
16:20:31 <dhellmann> romcheg: yeah, it's early but parts of it will be in python 3.4 when it's done
16:20:36 <ewindisch> the web parts are probably more tightly coupled
16:20:42 <dhellmann> rpodolyaka: also the rpc lib, probably?
16:20:48 <ewindisch> dhellmann: yes, rpc.
16:21:18 <dhellmann> ewindisch: well, that fits with my goal to have us stop using our own wsgi module in favor of pecan and wsme :-)
16:21:34 <ewindisch> dhellmann: if we did that, we could switch off eventlet a whole lot easier.
16:21:35 <dhellmann> the rpc bit is more troubling, but at least it is isolated if we have to make major changes
16:21:47 <dhellmann> ewindisch: I will add that to my notes for the summit session
16:22:14 <ewindisch> dhellmann: of course, pecan doesn't support Python 3 either.
16:22:39 <dhellmann> are you sure?
16:22:55 <ewindisch> well, not according to the PyPi categories.
16:23:10 <dhellmann> ah, I'll check into that
16:23:19 <dhellmann> the intent is certainly to support it, but maybe it's not quite there yet
16:23:32 <romcheg> Neither does wsme — Python 3.3 is not supported
16:23:49 <dhellmann> christophe is quite open to patches, so we could get that updated
16:24:03 <ewindisch> romcheg: it supports python 3.2, and very little changed there. I suspect it probably works on 3.3, or could be made to work easily
16:24:23 <dhellmann> yeah, that's probably just a matter of updating the tox.ini file
16:24:41 <romcheg> ewindisch: yeah, probably easier than porting eventlet to py3
16:26:26 <ewindisch> dhellmann: for RPC, we might be able to drop-in replace eventlet with anything else that provides (co)threading.
16:26:35 <ewindisch> However, I know that for ZeroMQ, I used patterns that I would've avoided if not for eventlet and its behaviorisms. I'm not certain if that code would need to be rewritten, or if moving to PEP3156  would simply *allow* it to be rewritten.
16:26:59 <dhellmann> those modules are pretty small, and the api is well defined. it might actually be simpler to just write new implementations.
16:27:16 <dhellmann> I'd rather do a little extra work than live with extra layers of indirection
16:27:16 <ewindisch> dhellmann: for 3156?
16:27:36 <dhellmann> yeah, across the rpc drivers
16:27:39 <dhellmann> not just zmq
16:27:55 <ewindisch> I can't imagine rewriting the implementations.
16:27:59 <dhellmann> the question is really what the upstream libraries we're using do
16:28:17 <dhellmann> I just mean openstack.common.rpc, not all of kombu, etc.
16:29:04 <dhellmann> it's a lot of work, but the question is whether it's better to do it or live with layers of crud for a while
16:29:39 <ewindisch> dhellmann: I can't see rewriting or even heavily refactoring each of the impl_* files in a single release. Worse, we're talking about trying to stabilize and push these into their own library at some point.
16:30:05 <ewindisch> dhellmann: I think that the eventlet problem has little to do with any cleanup/refactoring effort there.
16:30:14 <dhellmann> agreed
16:30:56 <ewindisch> anyway, we should have someone look seriously at PEP3156, eventlet, and tulip.
16:31:23 <dhellmann> yeah, I just wanted to point out that we should consider options besides trying to force-fit eventlet just so we don't have to change our own code :-)
16:32:44 <ewindisch> dhellmann: I agree. I honestly think that there is a chance PEP3156 could be a good thing. If we supported that, it might be configurable to choose eventlet, gevent, zeromq, or twisted eventloops. (or whatever)
16:32:55 <dhellmann> +1
16:33:40 <ewindisch> not sure that making that pluggable would work in practice, just as I'm not sure that anything but RabbitMQ works with our Kombu driver, but we can dream. :)
16:33:54 <ewindisch> so if that is wrapped up…
16:33:57 <dhellmann> :-)
16:34:52 <ewindisch> I'd like to create an action item for someone(s) to look at tulip / pep3156
16:34:55 <ewindisch> but there aren't many people here
16:35:07 <ewindisch> and I think we're all busy with the summit prep
16:35:14 <romcheg> I can do that
16:35:18 <dhellmann> yeah, I can't really commit to anything until after ODS
16:35:20 <dhellmann> great!
16:35:28 <ewindisch> romcheg: thanks!
16:35:54 <ewindisch> #action romcheg investigate PEP3156 / tulip / eventlet issues
16:36:02 <ewindisch> #topic meeting schedule
16:36:22 <ewindisch> so one thing I forgot to ask last week was if this time / frequency worked for everyone.
16:36:34 <dhellmann> it works great for me, it's right after the ceilometer meeting
16:37:10 <ewindisch> it works great for me too, but I set the time :)
16:37:45 <ewindisch> dhellmann: is there a reason the ceilometer meeting was split into alternating schedules?
16:38:27 <dhellmann> we have a few core members in the Asia-Pacific region
16:38:34 <dhellmann> it's easier for them to attend the meetings on wednesdays
16:39:00 <dhellmann> we have to try to span Europe, US, and Australia/China (I think)
16:39:12 <ewindisch> I thought as such.
16:39:57 <ewindisch> well, the other issue is frequency… I didn't want to overburden people with meetings, so I set it every other week.
16:40:20 <ewindisch> regardless, I wanted to bring this up  in today's meeting, but we don't have enough people to decide.
16:40:24 <ewindisch> deferring until after ODS
16:40:27 <dhellmann> I think that makes a lot of sense, too. At least until we make some significant progress, I'm not sure there will be much to talk about every week.
16:40:52 <ewindisch> #topic open discussion
16:42:11 <ewindisch> dhellmann: agreed
16:42:28 <dhellmann> do we have any ODS sessions planned? would it make sense to get together for an open space session, at least?
16:42:44 <ewindisch> there is an ODS session planned.
16:42:56 <dhellmann> good, I'll watch for that when the schedule is released
16:43:11 <ewindisch> it is preapproved, unlike my other proposals :)
16:43:46 <dhellmann> heh
16:44:15 <ewindisch> dhellmann: think it would be valuable if someone did a lightning talk? <unfortunately, I don't have the time>
16:44:42 <dhellmann> I don't remember lightning talks on the schedule from last time. Did I just miss them?
16:44:49 <ewindisch> you must have missed them.
16:44:56 <ewindisch> they've been very badly promoted
16:45:00 <ewindisch> and attended
16:45:17 <dhellmann> I remember them from the Folsom summit
16:45:38 <ewindisch> hmm. I think they had them?
16:46:12 <ewindisch> I'll follow up with Kathy or Stefano. I really hope they have them again, and better promote them as well.
16:46:25 <dhellmann> I don't see them on http://openstacksummitapril2013.sched.org/
16:50:16 <ewindisch> yeah, I just sent an email to Stefano / Thierry / Kathy
16:50:41 <ewindisch> anyway, unless there is anything else, I'll #endmeeting
16:50:56 * dhellmann has nothing to add
16:51:03 <ewindisch> thanks romcheg, dhellmann!
16:51:05 <ewindisch> #endmeeting