15:00:31 <mwhahaha> #startmeeting puppet-openstack
15:00:31 <openstack> Meeting started Tue Dec 13 15:00:31 2016 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:34 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:37 <mwhahaha> #link https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20161213
15:00:39 <iurygregory> yay \o/
15:00:43 <mwhahaha> hola people
15:00:57 <beagles> o/
15:01:01 <iurygregory> o/
15:01:36 <mwhahaha> just a few items this week
15:01:49 <mwhahaha> we'll give people a minute
15:03:20 <mwhahaha> ok lets start
15:03:28 <mwhahaha> #topic review past action items
15:03:34 <mwhahaha> EmilienM to collect openstack deprecations and file launchpad bugs: need to be postponed
15:03:59 <EmilienM> hello
15:04:12 <mwhahaha> if anyone wants to help out with finding a solution for identify deprecations that would be nice
15:04:27 <EmilienM> ok this time I take the action
15:04:34 <EmilienM> sorry I've postponed it 324 times
15:04:41 <EmilienM> I'll create a spreadsheet
15:04:45 <mwhahaha> k
15:04:47 <mwhahaha> thanks
15:04:47 <EmilienM> so we can distribute the work
15:05:02 <mwhahaha> mwhahaha to sync with openstack release team about metadata.json updates - postponed until after ocata-2
15:05:06 <EmilienM> #action EmilienM to create a deprecations spreadsheet and see how we can distribute the work
15:05:29 <EmilienM> mwhahaha: so CI worked well with my change in zuul / layout?
15:05:31 <mwhahaha> that'll probably have to wait until after the holidays or something. i'll poke the release team next week to gauge their availability
15:05:35 <EmilienM> did we save resources and gate was working well?
15:05:40 <EmilienM> I haven't followed much
15:05:42 <mwhahaha> EmilienM: yea
15:05:53 <mwhahaha> i was able to get all the version bumps in fairly quickly
15:06:00 <EmilienM> nice, I'm glad it helps
15:06:14 <EmilienM> infra doesn't like this patter in zuul/layout, because it's a bit dangerous
15:06:18 <EmilienM> pattern*
15:06:49 <mwhahaha> we've got bigger ci issues than skipping a few files :D
15:06:57 <EmilienM> but with zuul v3 we'll be able to do more
15:07:12 <mwhahaha> cool
15:07:23 <mwhahaha> moving on to the main items. just a few things to mention
15:07:31 <mwhahaha> #topic ocata-2 release this week
15:07:38 <EmilienM> oh noes! already?
15:07:45 <mwhahaha> going to push a release patch to release what we have
15:07:55 <iurygregory> yeah
15:07:56 <iurygregory> :D
15:08:01 <mwhahaha> there probably isn't much difference from ocata-1 but just an fyi
15:08:08 <EmilienM> mwhahaha: quick question, what new modules are we releasing this cycle?
15:08:21 <mwhahaha> let me see
15:08:44 <mwhahaha> ec2api
15:08:48 <iurygregory> new - ec2api watcher
15:08:49 <mwhahaha> octavia
15:08:51 <mwhahaha> and watcher
15:08:57 <EmilienM> ec2api sounds fair, we have good testing
15:09:18 <EmilienM> same for watcher
15:09:24 <EmilienM> octavia: joker
15:09:31 <EmilienM> do we have testing ^?
15:09:38 <mcunietti> hi all, operators meetup here?
15:09:41 <mwhahaha> it's got a beacker
15:09:46 <mwhahaha> er beaker
15:09:49 <EmilienM> beagles: have you already tested puppet-octavia ?
15:09:57 <EmilienM> beagles: do you think the module is "ready" somehow?
15:10:13 <EmilienM> mcunietti: you're in puppet-openstack meeting here
15:10:36 <EmilienM> le
15:10:42 <beagles> I think there's work left to do
15:11:09 <beagles> I've been swamped off of octavia for weeks, so I can't give a good characterization honestly
15:11:34 <beagles> but.. considering the timing, I may have to shuffle if that's going to make it
15:11:44 <beagles> s/may/will/
15:12:17 <EmilienM> I won't -1 a release for this module
15:12:26 <EmilienM> but it might be a bit prematured imho
15:12:48 <EmilienM> the problem with releasing it is that from now we need to deprecate things
15:13:03 <EmilienM> it's a loss of time if nobody uses the module
15:13:19 <mwhahaha> well no one will use it if we don't release it and give it attention
15:13:33 <EmilienM> that's also a good point, that's why I won't -1 it :)
15:14:04 <mwhahaha> anyway yes we should see if there's more that needs to be done in the next few weeks
15:14:16 <beagles> ack.. considering it hasn't been touched for a bit - I'll push back a bit here and give it some love. I'd feel better about it if it in any case
15:14:24 <mwhahaha> but it is it at least installing, which is more than we do for some of the other modules
15:15:04 <mwhahaha> ok moving on to the next topic
15:15:12 <mwhahaha> #topic nova cells v2
15:15:16 <EmilienM> oh noes
15:15:27 <mwhahaha> nova's making cells v2 required in ocata
15:15:32 <mwhahaha> so we've got a bug since we didn't support it
15:15:37 <mwhahaha> https://bugs.launchpad.net/tripleo/+bug/1649341
15:15:38 <openstack> Launchpad bug 1649341 in puppet-nova "Undercloud upgrade fails with "Cell mappings are not created, but required for Ocata"" [Critical,In progress] - Assigned to Alex Schultz (alex-schultz)
15:16:00 <mwhahaha> there are some issues that we've been working with nova around how the setup process works
15:16:24 <EmilienM> are we going to backport that thing?
15:16:30 <mwhahaha> yea i think we should
15:16:30 <EmilienM> (it sounds like a feature to me)
15:16:41 <EmilienM> (or a bug, depending on which point of view)
15:16:52 <mwhahaha> it should be off but the problem is that people might need to do it for upgrades
15:16:59 <mwhahaha> so having it in newton will help with that
15:17:10 <EmilienM> and disabled by default. Sounds good to me
15:17:22 <mwhahaha> we had a user recently who was working through a mitaka -> newton upgrade which included trusty -> xenial
15:17:36 <mwhahaha> so he managed to get newton modules working with the xenial mitaka packages
15:17:50 <mwhahaha> i think this might be a case where at least having the ability to enable it is beneficial
15:18:21 <mwhahaha> anyway back to the commands to sync it, currently it requires transport-url to be passed to the nova-manage
15:18:33 <mwhahaha> there's a change that hopefully will be in ocata to make that read from the config, https://review.openstack.org/#/c/409970/
15:18:58 <mwhahaha> so we'll need to document that for ocata people may need to use transport_url in the config if they aren't providing it
15:19:06 <mwhahaha> it's another upgrade process thing
15:19:25 <mwhahaha> anyway i'm working on it this week as it's blocking package promotions
15:19:42 <EmilienM> is it ? https://dashboards.rdoproject.org/rdo-dev
15:19:48 <EmilienM> why are we 0 day?
15:19:59 <mwhahaha> i have no idea
15:20:34 <mwhahaha> are the puppet ci and rdo promition ci seperate?
15:20:37 <EmilienM> let us know if you need help / reviews
15:20:44 <EmilienM> yes they are
15:20:50 <EmilienM> puppet ci is testing latest consistent
15:20:54 <EmilienM> and if it pass, it promotes
15:21:06 <EmilienM> so right now our Puppet CI is testing 0 day openstack
15:21:15 <EmilienM> that's why I'm surprised it works :D
15:21:29 <EmilienM> maybe they pin nova? but I would be surprised
15:21:41 <mwhahaha> not sure it's another thing i need to look at today
15:22:27 <mwhahaha> #topic Open Discussion, Bug and Review triage
15:22:33 <mwhahaha> anyone have anything else they want to chat about?
15:23:04 <iurygregory> not from me
15:23:08 <EmilienM> I'm good too
15:23:21 <EmilienM> let's get back to work ! etoomanymeetings
15:23:32 <iurygregory> yay
15:23:32 <mwhahaha> pretty much
15:23:38 <mwhahaha> ok thanks everyone
15:23:40 <mwhahaha> #endmeeting