15:00:35 <mwhahaha> #startmeeting puppet-openstack
15:00:37 <openstack> Meeting started Tue Nov  1 15:00:35 2016 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:40 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:48 <iurygregory> o/
15:00:51 <mwhahaha> hello
15:00:52 <mkarpin> Hi!
15:00:53 <EmilienM> o/
15:01:00 <zhongshengping> hi
15:01:10 <dtantsur> o/
15:01:16 <beagles> o/
15:01:24 <zhongshengping> o/
15:01:35 <mwhahaha> #topic past action items
15:01:51 <mwhahaha> EmilienM to collect openstack deprecations and file launchpad bugs - postponed
15:01:56 <EmilienM> #link https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20161101
15:02:04 <EmilienM> mwhahaha: sorry. Couldn't get it yet
15:02:17 <mwhahaha> mwhahaha to propose a virtual midcycle for next year - i'll propose something this week. need to look at the calendar and such
15:02:22 <EmilienM> and I won't be able to deliver that before ocata-2
15:02:45 <mwhahaha> yea i've start some work on that stuff as well, so we'll just keep it visible for now
15:02:55 <EmilienM> mwhahaha: I would suggest to sync with other sprints
15:02:59 <EmilienM> there is an etherpad somewhere
15:03:04 <EmilienM> https://wiki.openstack.org/wiki/Sprints
15:03:19 <EmilienM> also https://wiki.openstack.org/wiki/VirtualSprints
15:03:21 <dtantsur> EmilienM, "collect openstack deprecations" any help needed from ironic side?
15:03:41 <EmilienM> dtantsur: yes, it would be awesome
15:03:58 <EmilienM> dtantsur: the idea is to look at ironic logs when you deploy ironic with puppet-ironic
15:04:15 <EmilienM> dtantsur: and update config if some warnings are sent about config changes
15:04:23 <dtantsur> ack
15:04:29 <EmilienM> dtantsur: https://etherpad.openstack.org/p/puppet-openstack-ci-logstash-queries
15:04:46 <mwhahaha> k lets start the topics as some of these are relevant :)
15:04:47 <EmilienM> we could have a query for Ironic, I use this query for logstash: build_name: *puppet* AND message: "deprecated" AND message: "option"
15:05:16 <dtantsur> EmilienM, ok, I'll try to find some time to review/fix ironic things
15:05:24 <beagles> EmilienM: I can do the same for neutron
15:05:31 <EmilienM> beagles: excellent
15:05:40 <EmilienM> please let me know if you need guidance to find the warnings
15:05:46 <beagles> ack
15:05:48 <mwhahaha> #topic puppet 3 EOL
15:05:52 <EmilienM> thanks guys
15:06:17 <mwhahaha> so puppet 3 is being EOL by puppet at the end of the year and my understanding is that we're going to push for no more puppet 3 support as part of this cycle
15:06:31 <EmilienM> right
15:06:34 <mwhahaha> I'll be sending a note out but we need to make sure that tripleo, fuel, packstack support puppet 4
15:06:40 <EmilienM> if I can recap what we said a summit:
15:06:55 <EmilienM> most people still on puppet3 are on old releases of puppet openstack (mitaka, etc)
15:07:06 <EmilienM> and plan to move forward with puppet4 in newton and beyond
15:07:19 <EmilienM> so my guess is that for ocata, everyone will use puppet4
15:07:34 <EmilienM> mwhahaha: packstack / tripleo does. We're making the switch asap
15:07:41 <mwhahaha> k
15:07:48 <EmilienM> mwhahaha: I'll sync with #rdo folks this week about $topic
15:07:51 <mwhahaha> mkarpin: do you know of an ETA for puppet 4 in fuel?
15:07:59 <mwhahaha> or if it's even being worked on
15:08:14 <mkarpin> mwhahaha no I don't know (
15:08:19 <mwhahaha> ok thanks
15:08:19 <mkarpin> i will check
15:08:37 <mwhahaha> #action mwhahaha send email to ML about puppet 3/4
15:08:45 <degorenko> mwhahaha: afaik fuel already supports puppet4
15:08:57 <EmilienM> #action EmilienM synd with RDO about puppet upgrade for packstack/tripleo
15:09:15 <mwhahaha> degorenko: i know that there was work but I was unsure if a puppet 4 package was being used.
15:09:30 <EmilienM> right ^ that's the real question
15:09:38 <EmilienM> because we're going to add some puppet4 syntax one day
15:09:40 <iberezovskiy> degorenko, puppet package isn't updated and I'm not sure we've merged all required changes
15:09:42 <mwhahaha> anyway we can follow up with that
15:09:49 <degorenko> yeah, got it, probably we just need to install puppet4 package
15:09:53 <iberezovskiy> we need to figure this out
15:09:55 <degorenko> syntax tests passed on puppet4
15:10:24 <EmilienM> syntax is not enough :)
15:10:33 <EmilienM> trust me, functional tests found many more things
15:10:40 <degorenko> i trust you :)
15:10:49 <mwhahaha> I assume we won't break it for a while but it's something to keep an eye on
15:11:00 <mwhahaha> anyway moving on
15:11:07 <mwhahaha> #topic Ocata work
15:11:13 <mwhahaha> #link https://docs.google.com/spreadsheets/d/1GV4v-T8E7Sq6GDE12pcTk_i0hFaVrDGnIDDVikXrQ34/edit?usp=sharing
15:11:34 <mwhahaha> just a reminder there's a spreadsheet tracking some of the initiatives for this cycle
15:11:42 <EmilienM> I love this doc
15:11:44 <mwhahaha> feel free to pick up one some of the items if you have time.
15:12:00 <iurygregory> today i'll spam all other authtoken patches haha :D
15:12:12 <EmilienM> iurygregory: ++
15:12:26 <iurygregory> also i'll add the support for sahara =D
15:12:33 <mwhahaha> so far we've made some good progress so lets keep it up
15:12:45 <mwhahaha> #topic rabbitmq connection configuration deprecation
15:12:51 <iurygregory> but the admin_* options cant be deprecated since they use for trust
15:13:01 <mwhahaha> along the lines of ocata work, i noticed that the rabbitmq stuff has been deprecated so i've started messaging this
15:13:39 <mwhahaha> we need to make sure that transport_url is supported by all the modules that use oslo messaging
15:13:53 <EmilienM> right. AFIK some projects like Swift don't use Oslo Messaging
15:13:58 <mwhahaha> i've started going down the list to ensure they support it
15:14:02 <mwhahaha> #link https://review.openstack.org/#/q/topic:transport_url
15:14:32 <mwhahaha> yup swift is always the weird one
15:14:44 <EmilienM> mwhahaha: https://review.openstack.org/#/q/branch:master+topic:bug/1625198
15:14:46 <EmilienM> no?
15:15:03 <mwhahaha> yea that too
15:15:23 <EmilienM> ah ok 2 things
15:15:30 <EmilienM> deprecation + add the transport url thing
15:15:37 <mwhahaha> yea
15:16:22 <mwhahaha> anyway just an FYI on some stuff that we should hopefully try and get as part of ocata-1 which is coming up soon
15:16:29 <mwhahaha> #topic Open Discussion, Bug and Review triage
15:16:37 <mwhahaha> just fyi designate and magnum are still broken
15:16:44 <iurygregory> =(
15:16:48 <iurygregory> magnum too?
15:16:48 <mwhahaha> I need to follow up with RDO on those
15:17:03 <mwhahaha> magnum added marathon
15:17:05 <mwhahaha> which isn't packaged
15:17:06 <mkarpin> wanted to ask about this bug - https://bugs.launchpad.net/puppet-glance/+bug/1627824
15:17:09 <openstack> Launchpad bug 1627824 in puppet-glance "glance_image provider uses v1 of the api" [Medium,Confirmed] - Assigned to Nikita Karpin (mkarpin)
15:17:19 <mwhahaha> mkarpin: sure what's up?
15:17:46 <mkarpin> so we need somehow download image before uploading it to glance ?
15:17:49 <EmilienM> fyi ocata-1 is in 2 weeks
15:18:07 <mkarpin> v2 does not support remote location...
15:18:11 <mwhahaha> mkarpin: yea for supporting images from remove location
15:18:53 <mwhahaha> so we should provide a way to configure a temporary download location as part of the provider so people can configure it
15:18:55 <mkarpin> we need to implement this downloading directly in provider&
15:18:57 <mwhahaha> but maybe default to /tmp
15:19:05 <mkarpin> ahh understood
15:19:32 <EmilienM> mhh
15:19:45 <EmilienM> sounds like we want a feature in glance api v1 back in v2?
15:19:54 <EmilienM> it sounds a bug in Glance to me
15:19:57 <mwhahaha> pretty sure they won't add it
15:20:07 <mwhahaha> it's more of a security issue
15:20:17 <mwhahaha> if someone provides a really big image, glance could get ddos'd
15:20:29 <EmilienM> yeah
15:20:32 <mwhahaha> it makes sense why they dropped it, but it's annoying from an operator standpoint
15:20:44 <mwhahaha> so we just need to try and make it less crappy
15:21:02 <EmilienM> maybe check size of file before
15:21:07 <EmilienM> and set an hard limit
15:21:16 <EmilienM> like 10g or something?
15:21:34 <mwhahaha> we could do a logic check to make sure there's enough free space
15:21:44 <mwhahaha> but i wouldn't cap it
15:21:49 <EmilienM> k
15:22:03 <mwhahaha> i don't think people are using http urls to upload 10g glance images
15:22:12 <mwhahaha> if they are, they have bigger issues
15:22:32 <mwhahaha> and they definitely aren't using the puppet provider :D
15:22:42 <mkarpin> aha, ok I will try to work out something than))
15:23:08 <EmilienM> mkarpin: thx
15:23:16 <mwhahaha> anyway any other topics or bugs people want to chat about?
15:24:35 <EmilienM> sounds like we're good
15:24:35 <mwhahaha> I'll take that as a no
15:24:48 <mwhahaha> ok eveyone thanks for coming out, time to get back to work
15:24:49 <beagles> :)
15:24:51 <mwhahaha> #endmeeting