15:00:10 <mwhahaha> #startmeeting puppet-openstack
15:00:11 <openstack> Meeting started Tue Oct  4 15:00:10 2016 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:16 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:23 <mwhahaha> #link https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20161004
15:00:26 <mkarpin> HI!
15:00:39 <tlbr> o/
15:00:45 <mwhahaha> hey folks
15:00:46 <iurygregory> o/
15:00:49 <iurygregory> hello
15:00:53 <_ody> o/
15:00:54 <myatsenko> hi
15:01:35 <mwhahaha> we'll give people a minute
15:03:08 <mwhahaha> ok lets start
15:03:14 <mwhahaha> #topic past action items
15:03:20 <mwhahaha> mwhahaha to send ML notes about os_workers - http://lists.openstack.org/pipermail/openstack-dev/2016-September/104819.html
15:03:28 <mwhahaha> mwhahaha to create google spreadsheet to track updates - https://docs.google.com/spreadsheets/d/1GV4v-T8E7Sq6GDE12pcTk_i0hFaVrDGnIDDVikXrQ34/edit?usp=sharing
15:03:36 <mwhahaha> EmilienM to investigate how to find OpenStack deprecations in Puppet CI with logstash queries - http://lists.openstack.org/pipermail/openstack-dev/2016-October/105010.html
15:04:00 <mwhahaha> so that was it on items from last week, any questions on these?
15:04:17 <EmilienM> hiiiiii
15:04:24 <degorenko> o/
15:04:40 <mkarpin> maybe stupid question but where i can fin logstash itself &
15:04:44 <mkarpin> ?
15:04:50 <mkarpin> find*
15:04:50 <EmilienM> mkarpin: its in the etherpad :)
15:05:11 <EmilienM> mwhahaha: how do we prioritize the work
15:05:23 <EmilienM> we have to manage 1) puppet deprecations 2) openstack deprecations
15:05:47 <mkarpin> EmilienM I saw the queries, but where I should put them?
15:05:52 <mwhahaha> which work the deprecation stuff?
15:06:08 <degorenko> mkarpin, https://etherpad.openstack.org/p/puppet-openstack-ci-logstash-queries
15:06:18 <EmilienM> mkarpin: http://logstash.openstack.org/#/dashboard/file/logstash.json
15:06:23 <EmilienM> there is a search bar
15:06:38 <EmilienM> mwhahaha: well, looking at the queries results, we have a bunch of work :)
15:06:47 <mwhahaha> ok i haven't looked at the output yet
15:06:56 <mkarpin> EmilienM thanks! that's what my question was about
15:07:14 <EmilienM> mwhahaha: take a coffee before
15:07:20 <mwhahaha> we can create bugs for each module with the deprecations
15:07:54 <EmilienM> cool
15:07:55 <mwhahaha> the puppet deprecations we should probably give some time and do those mid cycle
15:07:59 <EmilienM> I can have a look after the release
15:08:05 <EmilienM> I agree
15:08:06 <mwhahaha> we should probably capture the openstack ones first
15:08:44 <EmilienM> I'll start to capture openstack deprecations in launchpad
15:08:47 <EmilienM> maybe other can help too
15:09:06 <iurygregory> i can help
15:09:10 <mwhahaha> sure let's collect some info first and then we can figure out how much work it is
15:09:22 <EmilienM> ok
15:09:38 <EmilienM> #action EmilienM to collect openstack deprecations and file launchpad bugs
15:09:48 <EmilienM> I'll try to do it for next week but I'm not sure
15:09:55 <mwhahaha> sure
15:10:01 <mwhahaha> ok moving on
15:10:02 <mwhahaha> #topic PTG (aka Project Teams Gathering) in Atlanta Feb 20-24
15:10:04 <EmilienM> for sure it will be done by end of next week
15:10:17 <mwhahaha> Do we need a presence? Is this something people would find useful?
15:10:50 <mwhahaha> I'm not sure we do given that we don't have a bunch of stuff for summit either.
15:11:04 <EmilienM> that's a good question, over the last Summits, I felt like Puppet OpenStack team doesn't need much presence at conferences, we manage everything on IRC/ML
15:11:28 <EmilienM> though it's a good occasion to cheer a beer with mfisch when he pays for it
15:11:34 <mwhahaha> we also don't have a lot of complex feature work to talk about either
15:11:45 <iurygregory> we should have a beer in barcelona
15:11:56 <mfisch> also the modules are in way better shape
15:11:58 <mwhahaha> so i think i'll let them know we won't have a formal presence in atlanta. perhaps next time
15:12:45 <EmilienM> mwhahaha: sounds good to me. Maybe we can ask again on openstack-dev and operators?
15:12:56 <EmilienM> just to make sure (:
15:13:03 <mwhahaha> I'll send a note on openstack-dev
15:13:14 <mwhahaha> not sure if the PTG will have an operator section
15:13:20 <mwhahaha> thought it was mostly development focused
15:13:23 * mwhahaha shrugs
15:13:44 <mwhahaha> #action mwhahaha send a note to ML about PTG
15:13:54 <mwhahaha> #topic Open Discussion, Bugs, Reviews, etc.
15:14:08 <mkarpin> i wanted to discuss this bug https://bugs.launchpad.net/puppet-nova/+bug/1600294
15:14:09 <openstack> Launchpad bug 1600294 in puppet-nova "Unable to disable log_dir by setting to false" [High,Triaged]
15:14:30 <mwhahaha> thought we documented that
15:14:32 <EmilienM> I have one request today, I would like to release a new puppet-heat. See https://review.openstack.org/#/c/381901/
15:14:33 <iurygregory> wow i remember this i think
15:14:38 <iurygregory> yeah
15:15:04 <mkarpin> so we need to it for all modules?
15:15:04 <mwhahaha> so the false thing is that we need to document in the parameter, you set it to $::os_service_default to disable it not false
15:15:23 <mkarpin> aha understood
15:15:26 <mwhahaha> i thought i had updated the comments for the modules where we incorrectly said false disables it
15:15:30 <mwhahaha> if not then yes, it needs to be update
15:16:13 <EmilienM> mkarpin: can you make sure it's updated everywhere in the doc?
15:16:28 <mkarpin> EmelienM yep will do!
15:16:45 <EmilienM> nice name
15:16:55 <mkarpin> sorry EmilienM )
15:17:10 <EmilienM> :) don't worry, it happens to me every time
15:17:11 <mwhahaha> oh it was log_file not log_dir, https://review.openstack.org/#/q/topic:fix-log-file-comment
15:17:33 <mwhahaha> either way yea we need to make sure we consistently specify that it should be $::os_service_default not false to disable such things
15:17:57 <mwhahaha> EmilienM: do we need puppet-swift as well?
15:18:09 <EmilienM> mwhahaha: most probably, for ipv6
15:18:17 <EmilienM> I didn't think about it, I'll submit it after meeting
15:18:23 <mwhahaha> k
15:18:41 <mwhahaha> so any other topics/bugs/etc?
15:18:50 <iurygregory> about authtoken
15:19:03 <mwhahaha> the removal of the old stuff?
15:19:04 <iurygregory> we should send something to the ML?
15:19:07 <iurygregory> yeah
15:19:32 <mwhahaha> yea send an ML,i think that's another one that should wait until mid-cycle or at least a few weeks after the final release before we start removing stuff
15:20:00 <EmilienM> I agree
15:20:07 <iurygregory> and let people awera that not all modules have authtoken class (like sahara)
15:20:28 <iurygregory> and the removal is only in some modules right?
15:20:29 <tlbr> where is the best place to put/take task and start working on it ?
15:20:35 <mwhahaha> iurygregory: do you want to send a note and say we're targeting the end of October to start that work?
15:20:36 <tlbr> could you please help me with that
15:20:47 <iurygregory> mwhahaha, i can send
15:20:54 <mwhahaha> tlbr: for some of the bigger items we're tracking here, https://docs.google.com/spreadsheets/d/1GV4v-T8E7Sq6GDE12pcTk_i0hFaVrDGnIDDVikXrQ34/edit#gid=0
15:21:24 <mwhahaha> tlbr: so if you'd like to start tackling some of them, just put your name in there as a place holder for things without bugs
15:21:41 <tlbr> mwhahaha, thank you! And what about smaller tasks ?
15:21:51 <mwhahaha> #action iurygregory to send an ML note about removal of old authtoken options
15:22:01 <EmilienM> otherwise, you can start by reviewing some patches or pick some bugs in launchpad, you can find them at launchpad/puppet-nova for example (we have a launchpad per module)
15:22:22 <mwhahaha> tlbr: i think the bugs have all been triaged in launchpad so you can look there. some of the items in the spreadsheet are pretty small
15:22:33 <mwhahaha> os_workers fact is mostly a smaller trival fix per module
15:22:44 <tlbr> mwhahaha, got it, thank you!
15:23:24 <mwhahaha> ok any other questions?
15:23:24 <tlbr> EmilienM, thanks, will take a look
15:23:38 <iurygregory> nope
15:23:50 <mkarpin> no
15:23:51 <EmilienM> tlbr: sure thing and let us know on #puppet-openstack if you need more assistance
15:23:58 <tlbr> EmilienM, ok :)
15:24:05 <EmilienM> sounds good to me
15:24:07 <mwhahaha> ok, sounds good. thanks everyone
15:24:13 <mwhahaha> #endmeeting