15:00:12 <mwhahaha> #startmeeting puppet-openstack
15:00:13 <openstack> Meeting started Tue Sep 27 15:00:12 2016 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:18 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:18 <mwhahaha> #link https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20160927
15:00:27 <iurygregory> o/
15:00:29 <mwhahaha> hola peoples
15:00:52 <iurygregory> hello
15:01:04 <_ody> o/
15:01:36 <mfisch> hola
15:01:43 <mwhahaha> ok lets move on to the topics
15:01:56 <mwhahaha> #topic defaults for workers/threads
15:02:01 <mwhahaha> #link https://review.openstack.org/#/q/topic:os_workers-fact
15:02:24 <mwhahaha> so i created an os_workers fact to use for the defaults for workers in our modules
15:02:35 <mwhahaha> as part of the ocata work, i'd like to update the modules to leverage this
15:02:49 <EmilienM> hello
15:02:49 <iurygregory> nice =) i can help o/
15:02:54 <mwhahaha> it puts a cap on the maximum number of workers that we'll configure by default
15:03:10 <mwhahaha> anyone have questions/concerns?
15:03:13 <EmilienM> it's a good idea
15:03:30 <EmilienM> did we get feedback from operators? mfisch etc
15:03:33 <mfisch> yes we have way too many with our current defaults
15:03:53 <mwhahaha> I'll also be sending out a note to the mailing lists to notify people of this change
15:03:56 <mwhahaha> so they'll be aware
15:04:04 <EmilienM> mwhahaha: can you add operators ML too?
15:04:06 <_ody> Are their any modules left that need the wsgi treament so that can be leveraged consistently?
15:04:12 <mwhahaha> EmilienM: yea
15:04:19 <EmilienM> _ody: yes I think
15:04:26 <EmilienM> glance is WIP iirc
15:04:41 <_ody> I'll do a quick review today.
15:04:49 <_ody> I remember Murano needing it too.
15:05:31 <mwhahaha> #action mwhahaha to send ML notes about os_workers
15:05:36 <mwhahaha> ok moving on
15:05:44 <mwhahaha> #topic rspec-puppet-facts and puppet-openstack_spec_helper
15:05:48 <mwhahaha> #link https://review.openstack.org/#/q/topic:rspec-puppet-facts-organization
15:06:05 <mwhahaha> I also started some organization work around the rspec-puppet-facts stuff
15:06:25 <EmilienM> nice, more consistency and less code :)
15:06:51 <mwhahaha> yea so if we need to update stuff the goal is to have it all in one place again.
15:07:02 <mwhahaha> So this is another thing I'd like to work on during Ocata
15:07:24 <mwhahaha> also continuing to update the modules to use rspec-puppet-facts. We've got a good start but we have some places that still need updating
15:08:10 <iurygregory> maybe we should have an etherpad with the modules that need update
15:08:36 <mfisch> we almost need a spreadsheet
15:08:37 <EmilienM> etherpad or launchpad
15:08:51 <mfisch> feature in rows and modules in columns
15:08:52 <iurygregory> yeah!
15:08:58 <EmilienM> mfisch: what an good idea
15:09:06 <EmilienM> a good idea even
15:09:07 <mfisch> owner names go in the columns or a check mark
15:09:17 <iurygregory> mfisch, +1
15:09:19 <mwhahaha> sure we can do that
15:09:25 <mwhahaha> i'll create one for next week
15:09:52 <mwhahaha> #action mwhahaha to create a google spreadsheet to track test updates
15:10:14 <mwhahaha> moving on
15:10:15 <mwhahaha> #topic glance api v1 is deprecated
15:10:20 <mwhahaha> #link https://bugs.launchpad.net/puppet-glance/+bug/1627824
15:10:21 <openstack> Launchpad bug 1627824 in puppet-glance "glance_image provider uses v1 of the api" [Medium,Confirmed]
15:10:33 <mwhahaha> i was reviewing some code and noticed that the glance v1 api is depreacated as part of newton
15:10:45 <EmilienM> afik nova switched to use glance v2 in newton
15:10:55 <mwhahaha> so we're using v1 in our glance_image provider so we'll need to make an effort to update it in Ocata
15:11:16 <EmilienM> sounds like a feature we might want to backport (?)
15:11:21 <mwhahaha> I've created the bug so if anyone wants to take a stab at it i think it's mostly trivial except the upload via url
15:11:42 <EmilienM> (i consider it more a bug than a feature actually)
15:11:54 <mwhahaha> yea it might be a possible backport
15:12:06 <dmsimard> Slightly off topic but I want to better keep track of deprecations in general so we can address them .. I think the best way would be a logstash filter ?
15:12:10 <EmilienM> upload via url doesn't work in v2?
15:12:22 <mwhahaha> EmilienM: no they removed it i believe in v2
15:12:31 <dfisher> correct.  it's annoying as hell.
15:12:41 <EmilienM> mhh ok
15:13:03 <mwhahaha> so we'll need to download to a tmp space and upload if from a url
15:13:24 <mwhahaha> that's primarily why we still use v1 :D
15:13:34 <iurygregory> v1 >>> v2 lol
15:13:41 <EmilienM> yeah, it's not a big deal I would say
15:14:05 <EmilienM> let's see if someone picks this task during the next weeks
15:14:08 <iurygregory> it's simple i think i'll try to take a look =)
15:14:09 <mwhahaha> dmsimard: it would be nice if they announce deprecations in a better way, i found out cause I saw a review removing it in another project
15:14:29 <dmsimard> mwhahaha: it's probably in the release notes :P
15:14:32 <mwhahaha> especially something like deprecating an entire version of an api
15:14:36 <EmilienM> dmsimard: ++ for logstash filters
15:14:44 <mwhahaha> yea but it should have been a ML message
15:14:56 <EmilienM> #action EmilienM to investigate how to find OpenStack deprecations in Puppet CI with logstash queries
15:15:01 <mwhahaha> since it has a dev impact on people who integrate
15:15:16 <mwhahaha> aaanyway moving on
15:15:18 <mwhahaha> #topic Open Discussion, Bugs, Reviews, etc.
15:15:18 <dmsimard> We've already gone through this already.. we tried to brew up a storm when Nova make the api db mandatory but we were told to read the release notes :(
15:15:21 <EmilienM> or release notes
15:15:33 <mfisch> I have 1 thing
15:15:57 <mfisch> I spent some time last week cleaning up bugs, marking stuff as FR, Incomplete, Invalid etc
15:16:15 <mfisch> if I wrote to you and said "is this still an issue" and there's no response after awhile those will be closed out
15:16:28 <mfisch> its difficult to validate bugs in code from 2 years ago
15:16:37 <mwhahaha> cool thanks mfisch
15:17:00 <mfisch> what I'd like to do is have 1 screen to see all bugs in all projects
15:17:05 <mfisch> but I've not figured out yet if thats possible
15:17:15 <EmilienM> mfisch: awesome, way to go
15:17:28 <dmsimard> mfisch: maybe a good idea to check if storyboard has a feature like that (and if not, provide feedback)
15:17:59 <mwhahaha> Just an FYI, we're going to be creating stable/newton branches today hopefully.
15:18:00 <mwhahaha> #link https://review.openstack.org/#/c/377696/
15:18:08 <iurygregory> yay
15:18:10 <mfisch> dmsimard: would love to know if it does
15:18:14 <EmilienM> mwhahaha: thanks for working on the release
15:18:34 <dmsimard> mfisch: the developers in #storyboard are very receptive to feedback and helpful :)
15:19:19 <mwhahaha> ok does anyone have anything else they would like to talk about?
15:20:11 <mwhahaha> so i'll take that as a no.
15:20:22 <mwhahaha> thanks everyone, time to get back to work.
15:20:24 <mwhahaha> #endmeeting