15:00:36 <EmilienM> #startmeeting puppet-openstack
15:00:36 <openstack> Meeting started Tue May 31 15:00:36 2016 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:39 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:43 <EmilienM> #link agenda https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20160531
15:00:44 <_ody> o/
15:00:46 <iurygregory> o/
15:00:47 <EmilienM> o/
15:00:51 <mwhahaha> hi2u
15:01:07 <bkero> o/
15:01:14 <degorenko> o/
15:01:21 <iberezovskiy> hi
15:01:24 <vinsh> Hello.
15:01:29 <EmilienM> #topic Review past actions items
15:01:40 <EmilienM> * team to review https://review.openstack.org/#/c/319519/ (need to be postponed, waiting for bkero review)
15:01:52 <EmilienM> * review https://review.openstack.org/#/c/312280/ -> DONE & MERGED
15:01:53 <bkero> I'm back from holiday today, taking care of that this morning.
15:02:05 <EmilienM> bkero: cool thx
15:02:07 <EmilienM> * xarses to help degorenko on making puppet-ceph working on Ubuntu Xenial
15:02:18 <EmilienM> xarses, degorenko: did you guys made progress together?
15:02:33 <degorenko> unfortunately no :(
15:02:36 <xarses> I wasn't able to be as helpful as I had hoped
15:02:36 <EmilienM> mhh
15:02:43 <EmilienM> can we hope some progress by next week?
15:02:45 <degorenko> may be this week
15:02:55 <degorenko> i hope too :)
15:03:11 <xarses> yes
15:03:14 <EmilienM> #action xarses and degorenko to make puppet-ceph working on Ubuntu Xenial
15:03:48 <EmilienM> I'll skip announcements, since I don't think we have some
15:03:57 <EmilienM> #topic doc status
15:04:11 <EmilienM> bkero, iurygregory: anything else in progress except the big refactoring?
15:04:24 <iurygregory> EmilienM, only the update for this meeting =)
15:04:33 <bkero> Nothing to report
15:04:41 <EmilienM> ok
15:04:43 <EmilienM> #topic CI status
15:04:50 <EmilienM> ok I have a few notes :
15:05:00 <EmilienM> I did a lot of changes in our CI over the last days
15:05:29 <EmilienM> our current master (newton or jewel) does not run trusty jobs anymore, only xenial (voting)
15:05:37 <EmilienM> our stable/* jobs run trusty though
15:06:00 <EmilienM> puppet4 jobs are now in check queue of puppet-openstack-integration CI (non-voting now)
15:06:24 <EmilienM> current puppet4 jobs are currently broken on systemd platforms
15:06:24 <bkero> Will newton not be tested against trusty?
15:06:30 <EmilienM> _ody is AFIK working on it
15:06:34 <EmilienM> bkero: no
15:06:45 <_ody> https://tickets.puppetlabs.com/browse/PUP-6370
15:06:47 <EmilienM> bkero: Canonical does not and won't support Newton on Trusty
15:06:48 <bkero> Huh, I feel that might be a thorn in some user's side
15:06:53 <_ody> And I'll see about a work around today.
15:06:57 <EmilienM> #link ttps://tickets.puppetlabs.com/browse/PUP-6370
15:07:02 <EmilienM> #undo
15:07:03 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x7f2dd3922710>
15:07:07 <EmilienM> #link https://tickets.puppetlabs.com/browse/PUP-6370
15:07:13 <EmilienM> _ody: thx
15:07:26 <EmilienM> bkero: I agree, but there is nothing we can do
15:07:32 <EmilienM> we follow upstream
15:08:20 <EmilienM> regarding unit tests jobs, the matrix changed a bit, our current master CI is testing: 3.6, 3.8, 4.5 (voting) and latest (non-voting)
15:08:31 <EmilienM> while stable/* test what we had before
15:09:02 <EmilienM> another useful information: puppet-openstack-integration jobs (on centos7, 3 scenarios), now run in check pipeline of Tempest CI !
15:09:05 <EmilienM> (non-voting)
15:09:14 <degorenko> wow
15:09:18 <degorenko> that's really good
15:09:20 <iurygregory> aewsome =D
15:09:22 <EmilienM> so hopefully tempest folks will look at them when failing
15:09:38 <degorenko> or just they can will ask us
15:09:42 <iberezovskiy> cool
15:09:55 <EmilienM> regarding CI status today, it's quite unstable, I'm trying to investigate what is failing but mostly random
15:10:19 <EmilienM> I need people to review https://review.openstack.org/#/c/323374/
15:10:43 <EmilienM> I'm working on the liberty branch too: https://review.openstack.org/#/c/323379/
15:10:50 <EmilienM> it will save some failures in stable branches
15:11:07 <EmilienM> I also noticed scenario003 is failing on Xenial quite often, http://logs.openstack.org/20/323320/1/check/gate-puppet-openstack-integration-3-scenario003-tempest-ubuntu-xenial/cb423b0/console.html#_2016-05-31_12_30_04_678
15:11:21 <EmilienM> feel free to help at investigating why trove fail
15:11:27 <EmilienM> otherwise I'll disable trove on ubuntu
15:11:49 <EmilienM> questions?
15:12:25 <xarses> nope, looking good
15:12:26 <EmilienM> oh, and I'm also working on switching beaker jobs from trusty to xenial for master
15:12:42 <xarses> what's blocking there?
15:12:47 <_ody> indeed looking good, great work.
15:12:57 <EmilienM> xarses: https://review.openstack.org/322965
15:13:32 <_ody> EmilienM: I thought you said that didn't work in #puppet-openstack?
15:13:47 <EmilienM> it works
15:13:50 <xarses> thats merged =)
15:13:55 <EmilienM> maybe I was confused
15:13:58 <_ody> Ok.
15:14:14 <EmilienM> xarses: yeah but infra needs to rebuild image and reupload it to clouds
15:14:21 <xarses> ok
15:14:29 <EmilienM> anyway, beaker jobs was second priority
15:14:42 <EmilienM> #topic ubuntu xenial support status
15:14:48 <EmilienM> #link https://etherpad.openstack.org/p/puppet-openstack-xenial
15:15:03 <EmilienM> so we still have no progress on ceph and SSL issues
15:15:11 <EmilienM> also horizon is disabled now
15:15:17 <iurygregory> wow O.o
15:15:22 <EmilienM> do we have volunteers to actually help?
15:15:46 <iurygregory> now i have finish my tests i have time to try to help
15:15:58 <xarses> as noted prior, I will help with ceph
15:15:59 <EmilienM> iurygregory: please sync with degorenko, he's leading this work
15:16:06 <iurygregory> EmilienM, sure
15:16:30 <EmilienM> degorenko: anything you want to mention here about xenial?
15:16:30 <degorenko> that sounds hopeful :)
15:16:32 <iberezovskiy> I'll try to take a look on horizon
15:16:55 <degorenko> EmilienM, no, just we need to cooperate on ceph/ssl/dashboards issues
15:17:07 <EmilienM> cool
15:17:12 <EmilienM> (and trove now :-P)
15:17:18 <degorenko> + trove
15:17:19 <degorenko> :)
15:17:25 <EmilienM> I'll add it to etherpad
15:18:16 <EmilienM> done
15:18:21 <EmilienM> #topic release status
15:18:27 <EmilienM> so we released 7.1.0
15:18:47 <EmilienM> tag is done, and you can download tarballs on https://tarballs.openstack.org/
15:19:15 <EmilienM> once release team merges https://review.openstack.org/321873 - we'll have 8.1.0 (mitaka)
15:19:28 <EmilienM> this week I'm working on a newton-alpha release
15:19:41 <EmilienM> we have a problem with the version number
15:20:10 <EmilienM> they want me to push 9.0.0.0-a1
15:20:17 <iurygregory> O.o
15:20:21 <EmilienM> but it does not work in puppet
15:20:36 <iurygregory> why not 9.0.0-a1?
15:20:45 <EmilienM> they respect PEP440
15:20:49 <EmilienM> for python projects
15:20:56 <iurygregory> wow .-.
15:21:09 <EmilienM> and if we push our tag that works, their scripts won't do our release
15:21:20 <EmilienM> because their regex won't detect the right tag
15:21:23 <EmilienM> anyway, it's a mess
15:21:26 <EmilienM> so we have multiple options
15:21:29 <iurygregory> yeah =(
15:21:38 <EmilienM> 1) find another tag 9.0.1 maybe?
15:21:40 <degorenko> how then works our primary releases?
15:21:54 <EmilienM> 2) work with release team to add support for more tags
15:22:03 <EmilienM> degorenko: I don't know yet
15:22:12 <degorenko> EmilienM, 1) option looks like hardcode :)
15:22:27 <EmilienM> maybe we can produce alphas 9.0.1, 9.0.2, etc, and produce a stable release like 9.1.0
15:22:36 <EmilienM> ttx, dhellmann: thoughts? ^
15:22:38 <iurygregory> option two looks good but the question is, they are open to support more tags?
15:23:21 <EmilienM> maybe we can postpone this topic on mailing-list or later on IRC with interested folks
15:23:47 <degorenko> EmilienM, well, i don't like option to have major release started from 9.1.0 for example, we have every time major release N.0.0
15:23:58 <EmilienM> once we have a tag, I'll prepare this release, this week probably, stay tuned!
15:24:05 <EmilienM> degorenko: right
15:24:12 <EmilienM> we might need to find something else
15:24:17 <EmilienM> I'll talk with release folks today
15:24:24 <iurygregory> ok
15:24:31 <degorenko> probably 2) option is good, but we need to discuss it with release team
15:24:48 <EmilienM> any question / remark about release management?
15:25:03 <bkero> As a user, I imagine 9.0.1 would be "9.0 has been stabilized/released, and 9.0.1 is a minor bugfix"
15:25:20 <iurygregory> bkero, ++
15:25:32 <EmilienM> yeah
15:25:35 <EmilienM> we'll figure that
15:25:43 <EmilienM> #topic Open Discussion, Bug and Review triage
15:25:56 <EmilienM> if you have outstanding bugs / reviews or just questions, go ahead it's time
15:26:02 <iberezovskiy> #link https://review.openstack.org/#/c/317939/
15:26:11 <iberezovskiy> actually full discussion is in comments. team, please take a look
15:26:12 <iberezovskiy> here I want to clarify one moment: if sqlite directory isn't default (not /var/lib/<...>), should we manage it in puppet?
15:26:12 <ttx> EmilienM: that would fit a intermediary-release numbering scheme alright
15:26:22 <ttx> Not very smevery though
15:26:32 <ttx> semver-y
15:26:51 <EmilienM> ttx: right, we used to hav X.0.0 as our first stable release
15:27:46 <ttx> EmilienM: what's the issue with PEP440-like versions ? Puppet doesn't like them ?
15:27:59 <EmilienM> ttx: right
15:28:04 <EmilienM> it complains
15:28:15 <EmilienM> it's not like we can ignore it
15:28:15 <ttx> ok, so they have a meaning on your side too
15:28:22 <EmilienM> we can't, puppet fails to build tarball
15:28:42 <ttx> I think the 'right' solution is to support non-PEP440 release tags for projects that need them
15:28:45 <EmilienM> _ody, Hunner: any thoughts on that? ^
15:29:01 <mwhahaha> probably just pep440 and semver?
15:29:14 <EmilienM> that would be great yeah
15:29:17 <mwhahaha> limiting the options, pick two :D
15:29:48 <EmilienM> ttx: should I just submit a patch in zuul/layout to update the regex?
15:30:35 <ttx> EmilienM: it's slightly trickier than that. I think you'd need a separate pipeline so that Python projects still can't create releases from badly-formed tags
15:31:01 <ttx> I said 'right' option, not ' fast' option :)
15:31:14 <ttx> likely to need some discussion with infra too
15:31:17 <EmilienM> ttx: s/badly/not-PEP440/ ?
15:31:26 <ttx> yes
15:31:30 <EmilienM> ok i'll follow up on ML
15:31:38 <EmilienM> in the meantime we need to find a tag :(
15:31:57 <EmilienM> #action EmilienM to follow-up release tagging on ML
15:32:04 <ttx> EmilienM: why is it a new problem ?
15:32:23 <EmilienM> ttx: because it's the first time we manage releases with you
15:32:40 <EmilienM> (we did it for liberty subrelease and mitaka subrelease but it was not alphas
15:32:51 <EmilienM> it was 7.1.0 and 8.1.0)
15:32:59 <ttx> oh, you mean, it's first time you do pre-releases ?
15:33:06 <EmilienM> with you, yes
15:33:18 <EmilienM> we did it in Mitaka, but I did the tag myself
15:33:30 <ttx> so it did not trigger a release, right ?
15:33:36 <EmilienM> and we used a semver compliant tag
15:33:40 <EmilienM> ttx: right
15:33:49 <EmilienM> ttx: our project was not integrated in release management yet
15:33:54 <EmilienM> ttx: we did it very recently
15:34:04 <EmilienM> ttx: so did kolla, ansible, etc
15:34:14 <ttx> hmm, maybe in this case the best workaround is to let you continue to do it old-style
15:34:34 <ttx> while you look into the 'right' fix ?
15:34:36 <EmilienM> ttx: just the tag then
15:34:54 <ttx> yeah, missing tarball and all but not worse than past
15:35:10 <EmilienM> mhh we need to think about it.
15:35:20 <EmilienM> what's the point of releasing if we don't produce tarballs
15:35:22 <ttx> I'm fine pushing the tag directly for you so that we don't need ACL switch just for that
15:35:35 <ttx> EmilienM: but you didn't do tarballs in the past either right
15:35:42 <EmilienM> right
15:35:55 <EmilienM> but we wanted to change all of this
15:35:58 <EmilienM> and do like other projects
15:36:03 <ttx> I'm not saying it's a long-term solution, just something that lets you push your tag now and fix it in the coming weeks
15:36:09 <EmilienM> so for once, I want to build a solution that works for everyone
15:36:13 <EmilienM> ok
15:36:29 <EmilienM> we'll do that probably
15:36:31 <ttx> if your tag can wait until the 'right' fix is operational, that's the alternate solution
15:37:08 <EmilienM> #action EmilienM to produce release manually for newton-alpha-1 and work with infra/release folks to support more tags during newton-2
15:37:33 <EmilienM> ttx: sounds like a plan, thx for your time.
15:38:04 <mwhahaha> anyway back to the sqlite question :D
15:38:24 <EmilienM> who is using sqlite nowadays?
15:38:26 <EmilienM> :)
15:38:31 <mwhahaha> people evidently
15:38:36 <iurygregory> lolk
15:38:38 <iurygregory> lol*
15:38:58 <EmilienM> so we want to manage directory in puppet-oslo
15:39:03 <EmilienM> ?
15:39:09 <degorenko> it's rally
15:39:19 <degorenko> ah, got it now
15:39:25 <iberezovskiy> degorenko, the question is: manage it for all components or not?
15:39:47 <mwhahaha> well we can just ensure directory via ensure_resource
15:39:48 <degorenko> iberezovskiy, not sure that we need it
15:39:50 <EmilienM> honestly, just do it for rally now
15:40:02 <degorenko> in most cases for other projects we need specify only file
15:40:05 <mwhahaha> seems like a minor thing
15:40:13 <EmilienM> yeah
15:40:13 <iberezovskiy> I am unsure too
15:40:22 <EmilienM> do we have anything else for today?
15:40:26 <degorenko> yes
15:40:27 <degorenko> :)
15:40:34 <iberezovskiy> let's merge this https://review.openstack.org/#/c/322310/ :)
15:40:34 <EmilienM> shoot
15:40:38 <degorenko> i have question regarding nova v3 :)
15:40:43 <degorenko> EmilienM, we merged your patch
15:40:46 <degorenko> for master
15:40:55 <degorenko> but anyway, v3 is experimental api :)
15:41:05 <EmilienM> v3 is 2.1
15:41:16 <EmilienM> use 2.1 everywhere
15:41:25 <degorenko> yes i know
15:41:26 <degorenko> in master
15:41:31 <degorenko> in mitaka? :)
15:41:37 <degorenko> we have v3 as required endpoint
15:41:40 <EmilienM> we need to backport it then
15:41:43 <degorenko> in some cases we don' need
15:42:00 <degorenko> EmilienM, so, you are ok with backporting to mitaka your patch?
15:42:38 <EmilienM> degorenko: ok I'll try to cherry-pick it and see if it's backward compatible
15:42:47 <degorenko> or i can just upload additional patch, with parameter enable_v3 = true by default?
15:42:47 <EmilienM> we need to test it, in Fuel & TripleO
15:42:51 <EmilienM> to make sure we don't break the world
15:43:00 <degorenko> fuel won't use it
15:43:01 <EmilienM> enable_v3 is noop AFIK
15:43:09 <EmilienM> in nova
15:43:33 <degorenko> well, confugigure_v3_endpoint :D
15:43:45 <EmilienM> ok, let's take it oustide meeting
15:43:50 <degorenko> ok
15:43:56 <EmilienM> #action EmilienM & degorenko to work on nova v3 backport to mitaka
15:44:00 <EmilienM> anything else?
15:44:21 <EmilienM> ok
15:44:41 <EmilienM> have a nice week and keep working hard! lol
15:44:43 <EmilienM> #endmeeting