15:00:02 <EmilienM> #startmeeting puppet-openstack
15:00:03 <openstack> Meeting started Tue May 17 15:00:02 2016 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:06 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:09 <EmilienM> #link agenda https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20160517
15:00:11 <EmilienM> o/
15:00:16 <bkero> o/
15:00:20 <degorenko> hey o/
15:00:21 <_ody> o/
15:00:21 <vinsh> o/
15:00:50 <mwhahaha> hi
15:01:04 <EmilienM> #topic Review past actions items
15:01:30 <EmilienM> postpone config-deprecation-for-inifile-provider to newton : done -> http://specs.openstack.org/openstack/puppet-openstack-specs/specs/newton/config-deprecation-for-inifile-provider.html
15:01:43 <mattymo> hi
15:01:44 <EmilienM> vinsh to work on puppet-swift for xenial support and degorenko to start looking at Xenial support -> they are making good progress
15:01:53 <EmilienM> EmilienM create launchpad for normalize_ip_for_uri function : need to be postponed
15:01:57 <EmilienM> #action EmilienM create launchpad for normalize_ip_for_uri function
15:02:02 <vinsh> Both changes have merged for xenial and puppet-swift.
15:02:11 <EmilienM> I don't think we have announcements this week
15:02:22 <EmilienM> #topic CI status
15:02:24 <degorenko> yep, also fixed same issue as for swift (with upstart provider) for mongodb
15:02:47 <EmilienM> ok let me summarize a bit the CI status this week :
15:03:23 <EmilienM> 1) we have a working group on Xenial support: degorenko, vinsh and myself for now https://etherpad.openstack.org/p/puppet-openstack-xenial
15:03:49 <EmilienM> we're still waiting for a release of puppetlabs-mysql and puppetlabs-mongodb AFIK
15:03:56 <EmilienM> Hunner, _ody ^ FYI
15:04:09 <EmilienM> until then, we'll pin the right commit in Puppetfile.
15:04:47 <EmilienM> 2) I'm working on updating our CI to test latest Newton
15:05:06 <EmilienM> our major blocker here is that we need RDO to update paramiko >= 2.0
15:05:28 <EmilienM> if you have CI failures on centos7 and in the logs you see 3 tempests tests that fail because of nova, it's mostly this bug
15:05:40 <EmilienM> before recheck or ask on IRC, please check that
15:06:02 <bkero> Which RDO packages are missing for newton testing?
15:06:20 <EmilienM> 3) colonwq is working on bumping puppet-ceph to Jewel release in our CI
15:06:30 <EmilienM> bkero: nothing is missing, we need to update common deps
15:06:39 <EmilienM> bkero: right now, we're using same deps as Mitaka
15:06:47 <bkero> Ah, ok.
15:06:55 * bkero makes a note of that
15:07:00 <EmilienM> anyway, we should have this fix very very soon, I'm pushing on it
15:07:22 <EmilienM> bkero: it's in the code btw https://github.com/openstack/puppet-openstack-integration/blob/master/manifests/repos.pp#L30
15:08:07 <EmilienM> and 4) I'm working with pabelanger to use OpenStack Infra centos7 mirror in our stable jobs
15:08:19 <EmilienM> so hopefully we'll have less repo timeouts in stable jobs
15:08:28 <mfisch> here
15:08:35 <EmilienM> for master, we can't use mirror atm because everything is bleeding edge
15:08:47 <EmilienM> any question about CI? any useful update?
15:09:06 <EmilienM> next topic: xenial
15:09:11 <EmilienM> #topic xenial testing status
15:09:23 <EmilienM> degorenko, vinsh: do you guys have an update? any blocker?
15:09:33 <EmilienM> #link xenial testing status: https://etherpad.openstack.org/p/puppet-openstack-xenial
15:10:03 <vinsh> No update from me... swift working.
15:10:10 <degorenko> i dont have any blocker, trying to test scenario1 locally on my vm with all uploaded/merged patches
15:10:26 <EmilienM> excellent, thanks for your help guys
15:10:41 <EmilienM> I contacted UCA folks yesterday and they are not ready for Newton packaging yet
15:10:48 <degorenko> :(
15:10:53 <EmilienM> I think we have ~2 weeks before having working packaging (at minimum).
15:11:15 <EmilienM> so let's focus on getting Xenial jobs working with Mitaka code
15:11:19 <degorenko> agree
15:11:36 <EmilienM> any question / comment about Xenial testing?
15:11:54 <EmilienM> #topic release management status
15:12:03 <EmilienM> so we'll produce our first Newton release in 2 weeks
15:12:37 <EmilienM> I'll prepare release notes & metadata.json by next week or so. Now we have reno in place and we're going to use OpenStack release management, releases will be simpler
15:12:52 <EmilienM> please keep -1 when release notes are missing (and help people to make it)
15:13:06 <EmilienM> I think everyone got used to it, it's super cool
15:13:22 <EmilienM> any questions about release?
15:13:45 <EmilienM> we don't have new blueprint
15:13:51 <EmilienM> so i'll skip blueprint status
15:13:58 <EmilienM> #topic bug triage status
15:14:11 <EmilienM> #link https://etherpad.openstack.org/p/newton-puppet-bug-triage
15:14:21 <EmilienM> I made some progress on bug triage last week, but not finished yet
15:14:33 <EmilienM> if anyone volunteer to help please let me know.
15:14:35 <_ody> I'll do some today.
15:14:40 <EmilienM> good
15:14:46 <EmilienM> anything that is merged needs to be "Fix released"
15:15:01 <chem`> I've been lost in translation, so I didn't do much on this last week.  We do better this week.
15:15:08 <bkero> I'd like to help out with that as well
15:15:21 <chem`> s/we/I/
15:15:35 <EmilienM> bkero: cool, we'll sync after meeting
15:15:50 <EmilienM> any outstanding bug today that we need to discuss?
15:16:14 <EmilienM> #topic doc status
15:16:21 <EmilienM> #link https://etherpad.openstack.org/p/newton-puppet-docs
15:16:25 <EmilienM> bkero, iurygregory: o/
15:16:26 <vanditboy> hello
15:16:30 <bkero> \o
15:16:44 <EmilienM> do we have blockers or do you need reviews or are we done?
15:16:51 <bkero> I believe all the docs have either open reviews or have been merged. They could use some touching up and general improvements though.
15:17:09 <EmilienM> what are we doing with our current pages in Wiki?
15:17:17 <EmilienM> maybe I already asked the question 10 times sorry
15:17:29 <bkero> Nothing, although we should lock them, strike them through and post a link to the new docs, or delete them
15:18:05 <EmilienM> bkero: can we lock them?
15:18:09 <bkero> I'm in favor of posting a strike-through, then at the top saying that they are deprecated, with a link to the new docs. They're still readable, but readers know they are out of date.
15:18:12 <EmilienM> I'm not sure if this features does exist
15:18:20 <EmilienM> ++ excellent idea
15:18:28 <EmilienM> any objection?
15:18:55 <degorenko> +1
15:19:13 <EmilienM> bkero: can you take care of it?
15:19:16 <bkero> sure
15:19:20 <EmilienM> thx a lot
15:19:32 <EmilienM> #action bkero to strike-through old wiki pages and add a link to new doc somewhere
15:19:40 <EmilienM> any question / comment about doc?
15:20:10 <EmilienM> #topic Open Discussion, Bug and Review triage (submit modules to triage here)
15:20:19 <EmilienM> vanditboy: hey, are you Michal?
15:21:09 <vanditboy> hi, I am fine :)
15:21:45 <EmilienM> vanditboy: please go ahead
15:21:49 <EmilienM> if you have anything to ask
15:22:26 <vanditboy> Hi, from my site few things which are inside the etherpad
15:23:00 <vanditboy> we need to take care of lbaasv2 for magnum
15:23:04 <EmilienM> vanditboy: are you going to work on it?
15:23:26 <vanditboy> I can do the puppet module stuff and report it magnum devs
15:23:47 <EmilienM> cool
15:24:06 <vanditboy> that we need lbaasv2 support and magnum, correct me here, is dead for mitaka and further
15:24:11 <EmilienM> so there is https://bugs.launchpad.net/neutron/+bug/1581876 - https://bugs.launchpad.net/puppet-magnum/+bug/1581372 and you'll need to create a new bug for https://bugs.launchpad.net/magnum/+bug/1575524
15:24:15 <openstack> Launchpad bug 1581876 in neutron "neutron lbaas v2: update of default "device_driver" inside lbaas_agent.ini" [Low,New]
15:24:16 <openstack> Launchpad bug 1581372 in Magnum "Use trustee_domain, trustee_domain_admin name instead of trustee_domain_admin_id and trustee_domain_id for trust configuration" [High,Triaged]
15:24:17 <openstack> Launchpad bug 1575524 in Magnum " ERROR oslo_messaging.rpc.dispatcher TrusteeCreateFailed: Failed to create trustee 720d0137-3dc6-4c12-a323-bcfc924466a1 in domain 61a6f2b431c8475dbcc40e756cf3d8d6" [Undecided,New]
15:24:35 <EmilienM> vanditboy: I'm not sure about deprecations
15:25:13 <EmilienM> you'll need to check with neutron folks
15:25:18 <vanditboy> yep
15:25:20 <EmilienM> do we have anything else for today?
15:25:21 <vanditboy> I will
15:25:22 <vanditboy> !
15:25:25 <EmilienM> I'll close the meeting in 3às
15:25:27 <EmilienM> 30s*
15:25:34 <vanditboy> ok
15:26:03 <EmilienM> ok have fun folks and use an umbrella if it's raining! cheers
15:26:05 <EmilienM> #endmeeting