#openstack-meeting-4: puppet-openstack

Meeting started by EmilienM at 15:00:08 UTC (full logs).

Meeting summary

    1. agenda: https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20150714 (EmilienM, 15:00:14)

  1. Review past action items (EmilienM, 15:01:51)
  2. Announcements (EmilienM, 15:02:29)
    1. stable/kilo 6.0.0 released (EmilienM, 15:02:49)
    2. zuul-cloner works for all of our modules now, we can use Depends-On feature (EmilienM, 15:02:56)
    3. oslo/messaging/heartbeat is now disabled by default (EmilienM, 15:03:16)
    4. wiki page to create new modules: https://wiki.openstack.org/wiki/Puppet/New_module (EmilienM, 15:03:48)
    5. master branch policy is documented: http://specs.openstack.org/openstack/puppet-openstack-specs/specs/kilo/master-policy.html (EmilienM, 15:04:16)

  3. Montreal Sprint - September 2 to 4 (EmilienM, 15:05:11)
    1. Liberty Puppet sprint: https://etherpad.openstack.org/p/puppet-liberty-mid-cycle (EmilienM, 15:05:38)
    2. ACTION: EmilienM to inform the ML Puppet sprint will be virtual (EmilienM, 15:21:51)

  4. Default parameter policy (EmilienM, 15:22:51)
  5. CI status (EmilienM, 15:38:43)
    1. ACTION: pabelanger & EmilienM to work on openstack integration CI (EmilienM, 15:46:59)

  6. Open Discussion, Bug and Review triage (EmilienM, 15:49:34)
    1. https://bugs.launchpad.net/puppet-glance/+bug/1471364 (mfisch, 15:50:25)
    2. https://github.com/openstack/puppet-glance/blob/master/spec/acceptance/basic_glance_spec.rb#L77-L83 (EmilienM, 15:52:13)
    3. https://github.com/openstack/glance/blob/master/glance/api/v1/images.py#L433-L447 (EmilienM, 15:54:21)
    4. https://github.com/openstack/glance/blob/master/etc/glance-api.conf#L522-L523 (EmilienM, 15:55:29)


Meeting ended at 16:00:17 UTC (full logs).

Action items

  1. EmilienM to inform the ML Puppet sprint will be virtual
  2. pabelanger & EmilienM to work on openstack integration CI


Action items, by person

  1. EmilienM
    1. EmilienM to inform the ML Puppet sprint will be virtual
    2. pabelanger & EmilienM to work on openstack integration CI
  2. openstack
    1. pabelanger & EmilienM to work on openstack integration CI
  3. pabelanger
    1. pabelanger & EmilienM to work on openstack integration CI


People present (lines said)

  1. EmilienM (114)
  2. mfisch (39)
  3. mdorman (23)
  4. pabelanger (21)
  5. crinkle (21)
  6. spredzy (19)
  7. clayton (18)
  8. _ody (10)
  9. xarses (10)
  10. richm (5)
  11. openstack (5)
  12. dfisher (3)
  13. iurygregory (3)
  14. Vinsh (2)
  15. santosh (1)
  16. Hunner (1)


Generated by MeetBot 0.1.4.