15:00:39 <EmilienM> #startmeeting puppet-openstack
15:00:39 <openstack> Meeting started Tue Jun 16 15:00:39 2015 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:42 <openstack> The meeting name has been set to 'puppet_openstack'
15:00:45 <mdorman> hola
15:00:51 <EmilienM> who is here today?
15:01:04 <Guest25676> hey
15:01:07 <Guest25676> dang it
15:01:09 <RichardRaseley> I am here for the first 10 mins or so.
15:01:46 <xarses> hi
15:01:48 <crinkle> o/
15:02:17 <sbadia> hi
15:02:30 <Hunner> o/
15:02:46 <EmilienM> #topic review past actions
15:03:01 <EmilienM> spredzy,claryton create a POC and send an email to the ML about parameter default policy
15:03:14 <chem> hi
15:03:24 <EmilienM> I have no clue about this one ^
15:03:28 <EmilienM> but I guess it's WIP
15:03:29 <clayton> Same status as last week :(
15:03:40 <EmilienM> cody to finish neutron patch -> still WIP, need reviews though
15:04:00 <EmilienM> #link https://review.openstack.org/#/c/184646/
15:04:00 <RichardRaseley> I don't see _ody here this morning.
15:04:08 <EmilienM> #link https://review.openstack.org/#/c/189873/
15:04:15 <EmilienM> need review *and* rebase
15:04:28 <EmilienM> sbadia to patch swift module for puppet4 - MERGED
15:04:39 <sbadia> \o/
15:04:52 <EmilienM> crinkle to close this ML thread and explain our decision
15:05:00 <EmilienM> crinkle: what was it about again?
15:05:06 <EmilienM> #link https://etherpad.openstack.org/p/puppet-openstack-weekly-meeting-20150616
15:05:15 <crinkle> i think that was about the change abandonment policy
15:05:22 <EmilienM> ah yeah, nice
15:05:25 <EmilienM> so it's DONE
15:05:27 <mgagne> o/
15:05:39 <EmilienM> spredzy Send a patch as an implementation reference (dbsync exec) -> I think it's not done yet
15:06:21 <EmilienM> same for the thread
15:06:29 <EmilienM> spredzy|afk is out anyway
15:06:35 <EmilienM> #topic CI status
15:06:52 <EmilienM> beaker is almost voting: https://review.openstack.org/#/c/190778 \o/
15:07:11 <EmilienM> the only thing I noticed until now is an issue with puppet-sahara
15:07:14 <EmilienM> on trusty
15:07:23 <EmilienM> I'll figure that out today or so
15:07:54 <EmilienM> puppet4: we're still waiting for cody's patches to land and we can enable voting for puppet4 jobs
15:08:03 <EmilienM> anything else about CI ?
15:08:32 <EmilienM> ok seems no
15:08:33 <crinkle> i'm working on a poc to use zuul-cloner so we can test dependent patches, hopefully have something today
15:08:45 <crinkle> in beaker
15:08:52 <EmilienM> oh, that is awesome
15:09:43 <EmilienM> crinkle: any blocker on it now?
15:09:51 <crinkle> EmilienM: nope
15:09:55 <EmilienM> crinkle: ok, thx
15:09:57 <EmilienM> #topic migration status
15:10:00 <EmilienM> crinkle: o/
15:10:10 <EmilienM> thanks for having worked on that with infra team
15:10:49 <EmilienM> I had to *exceptionally* +2 +A some patches to have CI back to work
15:11:24 <EmilienM> it seems Havana and Grizzly CIs are broken for some modules, we figured that during the migration
15:11:31 <sbadia> because of lack of review ?
15:11:32 <mgagne> yha, no need to wait for 2x +2 to +A such changes
15:11:37 <sbadia> ah yes a question related
15:11:54 <sbadia> about patchs for .gitreview on havana branchs (what we do?)
15:11:55 <EmilienM> sbadia: yes, crinkle sent patches on Friday night but nobody reviewed them yesterday
15:12:03 <EmilienM> sbadia: so I landed them myself
15:12:13 <sbadia> spec tests are failing on theses branchs
15:12:23 <EmilienM> yeah... Not sure we should spend time on it
15:12:24 <sbadia> EmilienM: ok, sorry and thanks!
15:12:28 <sbadia> ok ok
15:12:32 <mfisch> why do we care if Grizzly is broken?
15:12:34 <clayton> I don't see much point in fixing them personally
15:12:59 <EmilienM> mfisch: well, if people are still using it and want to backport something, they can figure how to fix the CI
15:13:09 <mfisch> +1
15:13:10 <mgagne> mfisch: I think we did not officially stopped the support for it yet
15:13:12 <xarses> well, they likely won't figure it out
15:13:13 <EmilienM> but I don't think anyone here cares about havana/grizzly, and only for some modules.
15:13:24 <xarses> so we will likely have to help
15:13:24 <EmilienM> mgagne: maybe a good action to take
15:13:29 <clayton> wfm.  I don't think those releases (or icehouse) are still supported by any vendors
15:13:50 <EmilienM> #action Emilien to run a thread on ML about some stable branches deprecations (grizzly+havana)
15:13:54 <xarses> we are still supporting icehouse
15:14:00 <xarses> but that's our own issue
15:14:11 <mgagne> yea, we have still to move from icehouse here
15:14:19 <EmilienM> crinkle: anything else to notice about migration? Do we have any blockers?
15:14:43 <crinkle> EmilienM: i think we're all set
15:15:07 <EmilienM> cool, and thanks again for that.
15:15:08 <RichardRaseley> Unfortunately, I have to run. I will review the remainder of the meeting when I get back to my computer (more specifically on any actions from Zaqar or proposed ML change).
15:15:15 <EmilienM> #topic Zaqar module
15:15:19 <_ody> o/
15:15:22 <EmilienM> RichardRaseley: o/
15:16:11 <EmilienM> ok, we will postpone this one, RichardRaseley|A had to go
15:16:23 <EmilienM> #action postpone this topic when RichardRaseley is around
15:16:45 <EmilienM> we have a topic but I don't know who wrote this
15:16:50 <EmilienM> #topic How to deal with distributions merging multiple services in one package (RHEL)
15:17:13 <EmilienM> mgagne: maybe ?
15:17:29 <clayton> EmilienM: likely have similar issues with virtualenvs or docker support
15:17:35 <mgagne> we just have to figure out once and for all a good pattern
15:17:53 <mgagne> which might require refactoring, I just waited to raise the point
15:18:03 <mdorman> agreed.  what’s there now is kinda a mess
15:18:46 <mdorman> mgagne:   the only negative reaction i have to the $nova_title approach is how do users external to the module know what the title of the package will be.  but that speaks to having a consistent pattern across all
15:18:50 <EmilienM> mgagne: maybe we could define services managed by a package in an array?
15:19:12 <clayton> why not tag the resource and users that want to depend on it can use a collector?
15:19:24 <clayton> the collector will fail if the package isn't included in the manifest
15:19:35 <mgagne> I don't have any clear solution in my head, I'm open to all suggestions as long as it helps fixing the resource title issue
15:19:52 <EmilienM> mgagne: do you have a LP # ?
15:19:57 <mgagne> EmilienM: no
15:20:02 <mdorman> clayton:  so just use some tag, rather than changing the title?
15:20:26 <EmilienM> it would be great to submit a but explaining the issue and with some examples.
15:20:34 <EmilienM> s/but/bug/
15:20:39 <mgagne> I don't think tag were meant for that purpose
15:20:59 <EmilienM> clayton: this sounds tricky
15:21:04 <mgagne> we are suggesting not following conventions already in place
15:21:22 <mdorman> EmilienM:   here’s the bug from yesterday that explains this problem for one specific case (nova): https://bugs.launchpad.net/puppet-nova/+bug/1465433
15:21:23 <openstack> Launchpad bug 1465433 in puppet-nova "generic_service declares package incorrectly" [Undecided,In progress] - Assigned to Mike Dorman (mdorman-m)
15:21:39 <mgagne> it's not just about "getting the job done", it's about making it the most "puppet" way
15:21:48 <mgagne> which usually do not involve tag and such
15:22:22 <clayton> not sure how puppet tags are non puppet-like.
15:22:38 <mgagne> it's not something I see in other modules
15:23:25 <_ody> generally tags frighten me because everything in a catalog is implicitly tagged with something.  If you pick that somethting as your explicit tag, you get all the implicit ones too.
15:23:34 <mgagne> ^
15:23:58 <EmilienM> I think tags are not the right option here
15:24:24 <mgagne> I don't think we will come up with a solution in this meeting, just wanted to raise my concerns
15:24:34 <mdorman> i am not really up to speed with tags, so don’t have a strong opinion.  but i like the idea of a collector
15:24:51 <EmilienM> it seems like mdorman and mgagne have a great consensus on https://review.openstack.org/#/c/192009
15:24:53 <mdorman> mgagne / EmilienM   how about i iterate some more on https://review.openstack.org/192009 and we can go from there, discuss more next week?
15:24:55 <mgagne> collector tends to fail silently if you make a typo too
15:25:01 <EmilienM> mdorman: +1
15:25:01 <mdorman> true
15:25:36 <mdorman> #action mdorman to work more on https://review.openstack.org/192009, discuss more next meeting.
15:25:49 <EmilienM> perfect
15:26:18 <EmilienM> the agenda is done for today
15:26:25 <EmilienM> #topic open discussion
15:26:36 <EmilienM> you can rise your patches/bugs that need specific attention
15:26:55 <mgagne> I see reviews are on going for the keystone auto refactor. I'm happy about it
15:27:01 <EmilienM> I made a list for patches we need to land before a kilo release
15:27:20 <mgagne> and I also see people are ok with puppet openstack usage questions to go on openstack-operators so I'm happy to hear it too
15:27:28 <crinkle> https://review.openstack.org/191326 and https://review.openstack.org/191328 still needed to fix ci after the project renames
15:27:59 <_ody> EmilienM: Where is this list?
15:28:14 <EmilienM> _ody: a sec
15:29:01 <sbadia> crinkle: done
15:29:06 <sbadia> thx!
15:29:41 <crinkle> sbadia: ty
15:29:48 <EmilienM> #link http://paste.openstack.org/show/295543/
15:29:55 <EmilienM> please review that ^ for kilo
15:30:31 <EmilienM> also for Juno, I have some backports
15:30:42 <EmilienM> crinkle: did you have all your backports merged/reviewed?
15:30:53 <crinkle> EmilienM: look like it
15:31:11 <EmilienM> I'm still miising 2
15:31:12 <EmilienM> https://review.openstack.org/#/c/190634/
15:31:19 <EmilienM> and https://review.openstack.org/#/c/190464/
15:31:41 <_ody> crinkle: the beaker failure on trusty for https://review.openstack.org/#/c/191328/ looks almost legit.
15:32:16 <EmilienM> mgagne: are your patches on Introduce public_url, internal_url and admin_url a requirement for a kilo release?
15:32:25 <crinkle> _ody: hrm, thanks
15:33:07 <EmilienM> _ody: you'll need to rebase https://review.openstack.org/#/c/184646/
15:33:27 <crinkle> _ody: oh emilien commented on it
15:33:35 <EmilienM> does anyone wanted to raise another topic/patch/bug here? otherwise I can close the meeting in 1 minute
15:33:47 <sbadia> _ody: I've posted an inline question for 184646
15:34:18 <sbadia> EmilienM: seems ok for me :)
15:34:38 <EmilienM> ok. Thanks everyone and have a great day/evening!
15:34:44 <crinkle> o/
15:34:46 <EmilienM> #endmeeting