14:03:51 <crinkle> #startmeeting puppet-openstack
14:03:52 <openstack> Meeting started Mon Dec 15 14:03:51 2014 UTC and is due to finish in 60 minutes.  The chair is crinkle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:55 <openstack> The meeting name has been set to 'puppet_openstack'
14:04:16 <crinkle> #topic Aviator and keystone v3 update
14:04:33 <crinkle> #link https://review.openstack.org/#/c/139942/
14:04:41 <crinkle> #link https://review.openstack.org/#/c/116754/
14:05:34 <EmilienM> crinkle: ready for review?
14:05:50 <crinkle> I've refactored the base provider in openstacklib to be easier to test, not have any keystone-specific stuff, and to be a lot easier to use
14:05:56 <crinkle> yes please review
14:06:54 <crinkle> the keystone review has been updated to use the newer better base provider in openstacklib
14:06:59 <crinkle> unfortunately I just realized this will mean that keystone 5.1.0 will depend on openstacklib >=5.1.0 but since it's an internal library I think that is okay
14:07:45 <EmilienM> crinkle: it's fair I think
14:07:51 <crinkle> okay
14:08:04 <EmilienM> crinkle: I'll review it today & tomorrow
14:08:12 <crinkle> EmilienM: thanks
14:08:24 <crinkle> #info openstacklib base provider refactored and keystone_tenant updated
14:08:29 <crinkle> #info no v3 support yet
14:08:35 <sbadia> I'll take a look too
14:09:12 <crinkle> awesome
14:09:16 <crinkle> that was my update
14:09:35 <EmilienM> bogdando: any chance to have a status on the Pacemaker bits?
14:09:53 <EmilienM> crinkle: if bogdando is around, we can switch the topic
14:09:59 <bogdando> EmilienM, hi. Nothing to update, patches are on review
14:10:02 <EmilienM> ok
14:10:07 <crinkle> #topic open discussion
14:10:28 <EmilienM> #action EmilienM to review Pacemaker patches
14:11:48 <crinkle> I will look too
14:12:30 <crinkle> any other pet patches that need review?
14:13:19 <sbadia> :-D a lot of patchs need review in our review-queue
14:13:32 <sbadia> but specific one, I don't know
14:13:51 * crinkle will try to catch up again
14:14:03 <EmilienM> sbadia: crinkle: yes, that would be great people would do some triage also
14:14:29 <sbadia> EmilienM: yup, I will do this week, and also on bug
14:14:37 <EmilienM> sbadia: cool
14:15:09 <crinkle> #action everyone please help review and triage
14:15:24 <crinkle> anything else?
14:15:40 <sbadia> seems ok for me
14:16:01 <crinkle> oh I noticed the beaker-rspec changes weren't really working, made a patch to project-config to fix
14:16:43 <crinkle> #link https://review.openstack.org/#/c/141728/
14:17:16 <crinkle> o/
14:17:19 <crinkle> #endmeeting