14:01:09 <seanhandley> #startmeeting publiccloud-wg
14:01:09 <openstack> Meeting started Wed Jul  5 14:01:09 2017 UTC and is due to finish in 60 minutes.  The chair is seanhandley. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:12 <openstack> The meeting name has been set to 'publiccloud_wg'
14:01:23 <seanhandley> Anyone else here for the public cloud WG meeting?
14:01:31 <seanhandley> #link https://etherpad.openstack.org/p/publiccloud-wg
14:01:37 <seanhandley> Please add your name to the etherpad :)
14:01:42 <Labedz> o/
14:01:47 <seanhandley> hi Labedz o/
14:01:54 <Labedz> hi
14:02:38 <seanhandley> We'll wait a couple more minutes for latecomers then get started
14:02:53 <zhipeng> o/
14:03:00 <seanhandley> hi zhipeng :)
14:03:14 <zhipeng> Hi Sean
14:05:22 <seanhandley> Ok let's get started
14:05:35 <seanhandley> First item, last weeks's APs
14:05:43 <seanhandley> #topic Last meeting's action points
14:06:18 <seanhandley> So it was assigned to me to discuss the idea of the OpenStack Public Cloud Passport with Flanders from the OpenStack Foundation
14:06:54 <seanhandley> Basically, he wants this working group to take ownership of the design for how such a scheme would work technically
14:07:18 <seanhandley> so it's up to us how it should work
14:07:31 <seanhandley> if we need infrastructure to support it then the Foundation will provide it
14:07:41 <yankcrime> what is it?
14:08:21 <seanhandley> The Public Cloud Passport will be a scheme where users are effectively given some free credit that is valid on all participating OpenStack public clouds
14:08:52 <zhipeng> i think the foundation mkt team could help design the form of the passport
14:09:05 <seanhandley> there'll be some Foundation-specific branding and likely some centralised token validation authority that each cloud dials into when a user supplies their unique code
14:09:23 <seanhandley> basically it's down to us to figure out a working technical solution
14:09:38 <seanhandley> and they'll help us build/maintain it
14:10:18 <zhipeng> i think promo schemes should left the public cloud providers
14:10:27 <zhipeng> should avoid a grand centralised design
14:10:38 <zhipeng> that will cost much more time
14:10:50 <tobberydberg> o/
14:10:56 <seanhandley> hey tobberydberg
14:10:59 <tobberydberg> Taking passive role today....
14:11:10 <yankcrime> i would assume that the foundation's reach is > any individual public cloud providers, at least the ones interested in participating
14:11:17 <tobberydberg> Will read up later =)
14:11:26 <seanhandley> zhipeng: There'll have to be some single source of truth for valid tokens though
14:11:45 <seanhandley> and it makes sense for it to belong to the Foundation because they'll be the ones handing out the Passports
14:11:56 <Labedz> do you consider any 'implementation' meeting about passport?
14:12:14 <seanhandley> Yes, I think it's worth considered discussion around a whiteboard Labedz
14:12:15 <Labedz> like how to take care about legal stuff?
14:12:26 <Labedz> k
14:12:35 <zhipeng> the passport is a mkt campaign that will help promote the notion of OpenStack public cloud
14:13:01 <seanhandley> We're planning to run a couple of Public Cloud Working Group meetups before the Sydney Summit
14:13:09 <seanhandley> One in London at OpenStack Days London in September
14:13:18 <seanhandley> and another in Copenhagen for OpenStack Days Nordic in October
14:13:32 <seanhandley> Labedz: Can you make it to either of those?
14:14:04 <Labedz> hard to say now :}
14:14:04 <zhipeng> seanhandley shall we start meetup groups for that ?
14:14:15 <Labedz> for sure will try
14:14:21 <seanhandley> (I know Howard, myself, Nick and Tobias will be there)
14:14:29 <seanhandley> Would be great to have OVH at the table Labedz :)
14:14:40 <seanhandley> zhipeng: That's a great idea
14:14:41 <Labedz> we will be for sure in FR ;)
14:14:43 <zhipeng> we also need to write some material for the meetup series, so that Sydney Summit the foundation keynote could help promote
14:14:59 <seanhandley> #action Howard to create Meetup groups for the Public Cloud WG Meetups at OpenStack Days UK and Nordic
14:15:15 <yankcrime> Labedz: is this something you think OVH would participate in?
14:15:30 <Labedz> yankcrime: I think so
14:15:35 <yankcrime> cool :)
14:15:56 <seanhandley> zhipeng: Do you want to take on the task of writing that material?
14:16:17 <zhipeng> seanhandley I don't think I could handle that only by myself :P
14:16:33 <zhipeng> but we could do it around two weeks before Sydney
14:16:42 <zhipeng> to summarize the meetups so far
14:16:46 <seanhandley> Ok - would you write down some rough thoughts you have about it in a google doc and I'll collaborate with you on it?
14:16:53 <zhipeng> sure
14:17:33 <seanhandley> #action Howard and Sean to begin writing up some public cloud WG material ahead of the Sydney Summit
14:18:07 <seanhandley> Cool. Any more thoughts before we move onto our next topic?
14:18:52 <seanhandley> Ok! Onto the goals for the Sydney Summit
14:19:01 <seanhandley> #topic Decide on goals for the Sydney Summit
14:19:12 <seanhandley> #link https://etherpad.openstack.org/p/SYDNEY_GOALS_publiccloud-wg
14:19:23 <seanhandley> See the Etherpad above for what we came up with previously
14:19:48 <seanhandley> Flanders' advice is that we pick a single achievable goal and give it the majority of our focus
14:20:27 <seanhandley> The EU meetups are piggybacking off existing conferences so they're effectively organised already
14:20:39 <zhipeng> yep :)
14:21:26 <seanhandley> Rather than do a vote, I want each of us to say which item in that goals list should be focussed on
14:21:40 <seanhandley> (because I'm too lazy to curate them all into voting form)
14:22:29 <seanhandley> anyone want to start?
14:22:33 <zhipeng> i think the feature list and eu meetup series
14:22:35 <seanhandley> or should I pick on someone :P
14:22:41 <zhipeng> are two goals that we could achieve
14:23:03 <zhipeng> passport is a little bit depending on each company
14:23:11 <yankcrime> collaborating on missing features is a no-brainer
14:23:48 <seanhandley> thoughts tobberydberg Labedz ?
14:26:09 <seanhandley> Ok, none :D
14:26:15 <tobberydberg> Agree, but think that we should have passport as a goal as well
14:26:28 <seanhandley> I agree tobberydberg
14:26:31 <tobberydberg> if fail, we have a head start for next summit
14:26:39 <seanhandley> "Work on missing features" is vague
14:26:54 <seanhandley> and it takes a cycle or two to get work into an OpenStack project
14:27:10 <seanhandley> I'd hope we keep working on the missing features as a background task
14:27:17 <seanhandley> and I'd like to see them drawn up as specs
14:27:30 <seanhandley> but it's unlikely we can deliver any changes before the Sydney summit
14:27:44 <zhipeng> yes, but at the mean time, the missing feature itself should be a work product
14:27:59 <zhipeng> taht our working group could share with the community each cycle
14:28:04 <zhipeng> that~~
14:28:30 <yankcrime> i think it needs a step back from that, it needs a process agreeing that participating public cloud operators can discuss and vote for missing features, and then volunteer to write blueprints and fund development
14:28:39 <yankcrime> so the focus should be getting that process agreed and formalised
14:28:55 <yankcrime> then it becomes a background task
14:29:11 <yankcrime> afaik there's nothing analogous within the openstack community to that already
14:29:15 <yankcrime> i could be wrong though
14:29:19 <seanhandley> That's sort of already happening Nick: https://docs.google.com/spreadsheets/d/1Mf8OAyTzZxCKzYHMgBl-QK_2-XSycSkOjqCyMTIedkA/edit#gid=0
14:29:30 <yankcrime> that's just a spreadsheet seanhandley
14:29:30 <zhipeng> the list should be reviewed each cycle
14:29:58 <zhipeng> agree with yankcrime that we need a process to consensus on the missing features
14:29:59 <seanhandley> Yes, but people are referencing specs from it, marking their interest, and stating if it's currently being worked on
14:30:11 <yankcrime> what's the process for adding stuff to it?  do i just edit it?  when does it get reviewed?
14:30:22 <Labedz> Do we know if any of us (from this WG) are working on any specific subject from our feature list by himself?
14:30:28 <zhipeng> but i think it is doable for us to deliver the first version of the feature document before Sydney
14:30:41 <seanhandley> I agree it's not ideal and it needs moving into the correct parts of the OpenStack process
14:31:13 <zhipeng> yankcrime anyone should be able to add it, but we do need a process to pick the important features
14:31:20 <zhipeng> that most of us agreed upon
14:31:21 <yankcrime> it at least needs a wiki page linking off the public cloud wg calling attention to it
14:31:43 <zhipeng> wiki page sounds like a great idea :)
14:31:45 <seanhandley> How do other WGs accomplish their tasks?
14:32:00 <zhipeng> they find volunteers mostly
14:32:08 <seanhandley> Yes but how in terms of backlog management
14:32:20 <seanhandley> their ideas have to exist somewhere
14:32:28 <seanhandley> specs/blueprints? wikis?
14:32:46 <seanhandley> and I agree a spreadsheet isn't great long term
14:32:51 <seanhandley> it lacks visibility for one
14:33:20 <zhipeng> wiki would be a good choice
14:33:43 <yankcrime> the scientific wg have 'activity areas'
14:33:49 <yankcrime> "Every OpenStack development cycle, four activity areas are selected to focus on, and working group members gather data on problems and solutions in areas that affect them."
14:33:58 <yankcrime> there's wiki pages off the scientific wg for each of those
14:34:03 <seanhandley> ok
14:34:08 <seanhandley> so wiki is the answer then :)
14:34:35 <seanhandley> So is it a reasonable summit goal to have moved our features list onto the wiki and have it prioritised somehow?
14:35:22 <zhipeng> i think so
14:35:45 <seanhandley> Ok
14:35:50 <seanhandley> Perhaps a poll needs sending out
14:36:01 <seanhandley> We list all the features and have public cloud reps number them in order
14:36:07 <seanhandley> 1 being highest priority etc
14:36:09 <yankcrime> yup, and also wrapped up in a bit of documentation somewhere that says stuff like here's where you can suggest new ideas and vote for existing ones, here's when you can discuss them, here's what happens when there's sufficent votes, and options for collaboration
14:36:32 <seanhandley> Sounds good yankcrime
14:36:39 <zhipeng> sounds very good :)
14:36:44 <seanhandley> Any volunteers to make a start on that process?
14:37:38 <yankcrime> tumbleweed.gif
14:37:40 <yankcrime> ;)
14:37:50 <yankcrime> i'll do it
14:37:57 <seanhandley> nice one Nick
14:38:35 <seanhandley> #action Nick to update our wg wiki with information about how to get involved, and also moving features onto the wiki for better community visibility
14:39:15 <seanhandley> So that's achievable by the Sydney Summit in November
14:39:31 <seanhandley> I also think the Public Cloud Passport stuff is achievable by the Summit
14:39:41 <seanhandley> and I think it's worth pouring some time and effort in
14:39:57 <seanhandley> once there's a framework for it, public clouds can integrate against it at their leisure
14:40:03 <seanhandley> and ultimately it's a very simple service
14:40:19 <seanhandley> the authority creates unique tokens and then they're given to users
14:40:36 <Labedz> do we have a blueprint already?
14:40:44 <seanhandley> when a user supplies that token to a public cloud they check it against the OpenStack authority and it gets validated
14:40:54 <seanhandley> and then it gets marked as "used"
14:41:06 <seanhandley> and they honour the commitment to the amount of credit associated
14:41:09 <seanhandley> no Labedz
14:41:31 <seanhandley> But I'm sure I could build a POC fairly quickly and then write it up as a blueprint
14:41:36 <zhipeng> seanhandley sso like ?
14:41:38 <Labedz> great
14:41:42 <seanhandley> yeah zhipeng
14:42:05 <seanhandley> I'll discuss it with Flanders more before the next meeting and come up with a rough working model to share with the group
14:42:17 <zhipeng> plz also cc me and tobias
14:42:31 <seanhandley> #action Sean to discuss Public Cloud Passport with Flanders more before the next meeting and come up with a rough working model to share with the group
14:42:35 <seanhandley> Will do zhipeng
14:42:53 <seanhandley> I think it'd be neat to have this done by Sydney - would make for a great point in the keynotes
14:43:17 <zhipeng> yes it would be a plus for us :)
14:43:42 <seanhandley> Cool. I'll update the etherpad
14:44:08 <zhipeng> so does it mean we could officially propose our wg to the UC ?
14:44:20 <zhipeng> to have us formally recognized ?
14:44:32 <zhipeng> with our goals pretty much agreed today
14:44:56 <seanhandley> I'm not sure zhipeng
14:45:06 <seanhandley> Hopefully - who do we talk to?
14:45:46 <seanhandley> tobberydberg: Maybe that's a good AP for you this next two weeks?
14:46:18 <seanhandley> Guess he's busy. He won't mind :D
14:46:40 <seanhandley> #action Tobias to get the wg officially proposed to the UC using the goals we've agreed for the Sydney Summit
14:46:58 <seanhandley> Ok, next topic...
14:47:32 <seanhandley> #topic Submit OpenStack Summit Forum session(s) before July 14th
14:47:54 <seanhandley> Does anyone have any thoughts on Forum Sessions we should be running in Sydney?
14:48:24 <seanhandley> I guess this is tricky because it needs us to have conference attendance confirmed...
14:48:46 <zhipeng> yes ...
14:49:05 <zhipeng> missing feature discussion will continue to be a hit I guess :)
14:49:13 <seanhandley> Definitely zhipeng
14:49:15 <zhipeng> not sure about more possible session topics
14:49:27 <seanhandley> that's good enough at this stage tbh
14:49:43 <seanhandley> Are you definitely attending?
14:50:11 <zhipeng> i'm not sure as well ...
14:50:40 <seanhandley> I know Tobias hasn't had his attendance confirmed yet - and nobody from DataCentred either
14:50:42 <seanhandley> Labedz ?
14:50:53 <Labedz> probably somebody from OVH will be ther
14:50:55 <Labedz> *there
14:51:11 <seanhandley> Right
14:51:16 <seanhandley> In that case
14:51:32 <seanhandley> zhipeng: Would you submit a proposal via https://www.openstack.org/summit/sydney-2017/call-for-presentations/ ?
14:51:43 <seanhandley> and if necessary we'll change who's chairing it
14:52:14 <seanhandley> Or I can do it also
14:52:36 <Labedz> you mean Forum Session for Public Cloud WG?
14:52:37 <seanhandley> The main thing is to be on the timetable - chairing the fishbowl shouldn't be too demanding
14:52:41 <seanhandley> Yeah Labedz
14:52:43 <Labedz> ok
14:52:48 <seanhandley> we did a couple at the Boston Summit
14:53:15 <zhipeng> seanhandley is there a limit on Forum topic as well ?
14:53:26 <seanhandley> I'm not actually sure...
14:53:28 <zhipeng> there is a three topic per person limitation on the general session
14:53:37 <seanhandley> But the deadline will have elapsed before our next WG meeting
14:53:54 <seanhandley> ahh have you already got proposals submitted?
14:54:56 <zhipeng> no, not yet
14:55:16 <seanhandley> Thing is, I know for certain I'm not going to be there
14:55:36 <seanhandley> I'm happy to submit the proposal but it won't be me chairing it
14:55:54 <seanhandley> We're almost out of time
14:55:58 <zhipeng> seanhandley I think that could be managed
14:56:45 <seanhandley> I tell you what zhipeng - let's figure it out after this meeting over in the #openstack-publiccloud channel?
14:56:57 <seanhandley> the main thing is someone makes sure a proposal is put forward
14:56:58 <zhipeng> cool
14:57:03 <zhipeng> yes
14:57:03 <seanhandley> so I'll make sure that happens, somehow
14:57:21 <seanhandley> #action Sean to make sure we get a Forum session proposal in for a missing features fishbowl at Sydney
14:57:41 <seanhandley> and we're done with 3 minutes to spare :D
14:57:48 <seanhandley> #topic Any other business?
14:58:50 <seanhandley> Labedz: I see you added "Do we have track of current OpenStack infras issues in-house 'work in progress' ?" to the Etherpad
14:59:06 <Labedz> yeap - as far as I see we are talking about missing features
14:59:19 <Labedz> but for sure any of us are working on something daily
14:59:35 <Labedz> maybe we are fixing the same issues :)
14:59:43 <seanhandley> Yes - that's true
14:59:51 <Labedz> Is it good idea to have some kind of track of that?
14:59:58 <seanhandley> Definitely.
15:00:09 <seanhandley> zhipeng: Does the spreadsheet have a column for that?
15:00:22 <seanhandley> (and when it gets put on the wiki we'll have some info about it)
15:00:53 <zhipeng> i think so
15:01:02 <seanhandley> Is it the "Status" column?
15:01:19 <zhipeng> yes
15:01:27 <seanhandley> Perhaps a "Who's working on this?" column too - not a perfect solution, but it'd help
15:01:39 <prometheanfire> hi
15:01:58 <Labedz> seanhandley: good begining, we could improve later if needed
15:02:05 <seanhandley> ok :)
15:02:26 <seanhandley> Time to finish up then guys - thanks for coming - lots of stuff to talk about next time!
15:02:30 <seanhandley> #endmeeting