14:02:33 <tobberydberg> #startmeeting publiccloud-wg
14:02:33 <openstack> Meeting started Wed Jun 21 14:02:33 2017 UTC and is due to finish in 60 minutes.  The chair is tobberydberg. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:36 <pilgrimstack> o/
14:02:37 <openstack> The meeting name has been set to 'publiccloud_wg'
14:02:44 <tobberydberg> Ah, now it worked
14:02:49 <tobberydberg> Hi
14:02:53 <zhipeng> o/
14:03:13 <tobberydberg> #link https://etherpad.openstack.org/p/publiccloud-wg
14:03:22 <tobberydberg> Please put your name in there
14:04:06 <tobberydberg> Nice to see that we are a few here today!
14:04:31 <tobberydberg> #topic Review last meetings APs
14:04:38 <tobberydberg> Not that many APs
14:04:51 <tobberydberg> zhipeng: "Definitions to the missing features document"
14:05:12 <zhipeng> #link https://docs.google.com/spreadsheets/d/1Mf8OAyTzZxCKzYHMgBl-QK_2-XSycSkOjqCyMTIedkA/edit?usp=sharing)
14:05:17 <zhipeng> so from my side
14:05:28 <zhipeng> I added a tab named legend
14:05:41 <zhipeng> to provide the definitions
14:06:08 <zhipeng> and I've also added couple more features gaps that identified by our team
14:06:38 <zhipeng> from row 21 to row 24
14:06:42 <tobberydberg> Cool!
14:07:12 <zhipeng> also another tab for the Interop Guideline work that related to public cloud
14:07:25 <adriant> it's so weird, for some reason that spreadsheet doesn't render for me in Chrome... but it works in firefox
14:08:03 <tobberydberg> render well for me in chrome
14:08:03 <zhipeng> adriant works fine on my chrome
14:08:13 <tobberydberg> good job zhipeng
14:08:55 <zhipeng> no problem
14:10:20 <tobberydberg> So, to use the time we have well here...to all of you...just feel free to update the document whenever, comment etc etc
14:10:55 <tobberydberg> questions to zhipeng on this, or can we move on to next topic?
14:11:30 <seanhandley> I have a related matter to raise tobberydberg
14:11:38 <seanhandley> Regarding the missing features list
14:11:42 <tobberydberg> shoot
14:12:18 <seanhandley> I've been pursuing a potential way for several public clouds to pool their resources and pay for upstream development work.
14:12:33 <seanhandley> I'm happy to work on upstream dev as part of my job
14:12:52 <seanhandley> but it was expressed in Boston that companies could each pay a % of a full time upstream dev's salary
14:13:21 <seanhandley> A company here in Manchester with a good history of working with OpenStack is proposing to put forward a developer
14:13:55 <yamamoto> oops, sorry for leaving the taas meeting open.
14:14:06 <seanhandley> Right now I'm just seeing who's potentially prepared to get involved in this and then we'll get them to create a full costed proposal
14:15:05 <seanhandley> So if anyone here likes this then please tell other people and also tell me :-)
14:15:15 <seanhandley> And I'll make connections happen etc
14:16:11 <tobberydberg> As you know, I like the idea and we are willing to participate in this initiative
14:16:25 <seanhandley> Any thoughts/questions zhipeng adriant pilgrimstack
14:16:26 <seanhandley> ?
14:16:42 <adriant> we likely will as well, and we already have devs working in upstream as much as we can between internal work :)
14:17:07 <seanhandley> That's great adriant - who's the best person in Catalyst to CC on the relevant emails?
14:17:15 <seanhandley> yourself?
14:17:28 <zhipeng> i think we already have upstream devs in place
14:17:34 <adriant> Myself, but probably Bruno for anything directly business related
14:17:45 <adriant> I can pass on his details to you
14:18:12 <seanhandley> Thanks adriant
14:18:29 <tobberydberg> Did you put this to the Goals-doc?
14:18:35 <tobberydberg> yes
14:18:36 <seanhandley> Yes tobberydberg
14:18:38 <tobberydberg> I see it now
14:18:43 <seanhandley> it'd be good to have some agreements in place by Sydney
14:19:01 <seanhandley> and aim to deliver 6 and 12 months after Sydney
14:19:18 <tobberydberg> Exactly, thats probably a good time frame fot that
14:19:38 <seanhandley> it gives scope for full specs/blueprints and engagement with the community
14:19:42 <pilgrimstack> For us, we are hiring. So for now it's mostly best effort as we did until now. I hope this can change with new ressources.
14:20:09 <seanhandley> and then the ongoing expectation is that members of the Public Cloud WG will help maintain the features with fixes/reviews etc as an ongoing responsibility
14:20:28 <seanhandley> that way the up-front costs are predictable and have a definite end
14:20:39 <tobberydberg> yes
14:20:53 <seanhandley> It'd be cool to have OVH involved if possible pilgrimstack :-)
14:21:01 <seanhandley> Anyway, more info to come soon
14:21:13 <tobberydberg> Thanks for that seanhandley!
14:21:23 <tobberydberg> Next topic
14:21:34 <tobberydberg> #topic Decide on goals for Sydney Summit
14:21:44 <tobberydberg> #link https://etherpad.openstack.org/p/SYDNEY_GOALS_publiccloud-wg
14:22:24 <tobberydberg> I did remind all readers to go in and vote/put comments etc in the summary email from last meeting
14:22:38 <tobberydberg> Not sure how many that has been there =)
14:23:21 <tobberydberg> So, we don't have that many votes to base a decision on =)
14:24:02 <seanhandley> Keep it simple and achievable I guess
14:24:13 <seanhandley> the major feature changes to existing projects is a bit of a long game
14:24:23 <tobberydberg> I believe that it's pretty important that we decide up on a few reasonable goals, update our wiki, and announce the group
14:24:28 <seanhandley> I think focus on the coupons idea that Flanders had
14:24:56 <adriant> I'll most likely be doing a small presentation about Adjutant at a local OpenStack meetup fairly soon, and the plan is to record that, and use it also as basis for a potential further talk at the summit in Sydney.
14:25:00 <tobberydberg> I like that idea as well
14:25:09 <adriant> So that kind of covers/falls under that first 'technical' aspect
14:25:16 <seanhandley> That's great adriant
14:25:24 <seanhandley> Adjutant ticks a lot of boxes for missing features
14:25:40 <seanhandley> I'd like to spend some time using it/contributing over the next 6 months for sure
14:25:44 <adriant> Plus document a lot of what actually is happening there as well, so the features/plans are aware
14:26:11 <adriant> It needs work! But there is potential there
14:26:17 <seanhandley> it'd be awesome to have some examples in the doc of third party integrations
14:26:28 <zhipengh[m]> Sorry home network went down ...
14:26:45 <seanhandley> then public cloud providers have an idea of what they need to do in order to integrate with their payment gateways, for instance
14:26:52 <seanhandley> that's going to be a really popular type of task
14:27:26 <pilgrimstack> it sounds great, I'll cj-heck it with my team
14:27:32 <tobberydberg> yes that is great
14:28:41 <tobberydberg> We have the "PublicCloud Meetup" that I think that we should do as well
14:28:51 <pilgrimstack> can you describe one or two use cases?
14:29:22 <zhipengh[m]> We should set that as one of our goals :)
14:29:46 <zhipengh[m]> I think since there are many opportunities, we could do the meetup as a serie
14:30:05 <adriant> pilgrimstack: use cases for adjutant?
14:30:20 <zhipengh[m]> So if any of us could attend one of the OpenStack Day in EU country
14:30:26 <pilgrimstack> yep, real use case on your side
14:30:51 <zhipengh[m]> We should try to arrange a public cloud wg meetup, nothing fancy, maybe just one or two talks
14:31:04 <tobberydberg> I added headline "Decided goals" to the document, think that is the simplest way to make that clear to just copy them in there
14:31:19 <adriant> pilgrimstack: automatic sign-up was the original use case I started building it for, but also user management and invitation via emails, password resets, and other multi-system admin tasks that don't fit into keystone.
14:31:29 <seanhandley> We're talking two parallel threads here guys - let's finish talking about Adjutant
14:31:34 <seanhandley> and then move on to talking about the meetup
14:31:38 <tobberydberg> I think that can be the first decided goal (based on votes)
14:31:50 <tobberydberg> sure =)
14:32:12 <pilgrimstack> adriant: ok, nice, thx
14:32:23 <adriant> pilgrimstack: I
14:32:37 <adriant> l'll try and find the email I sent out talking about it
14:32:49 <adriant> it covers it better than I can quickly in irc :)
14:32:58 <adriant> but yes, I do need a recorded video demo
14:33:38 <seanhandley> Let me know if I can help with anything you're working on with Adjutant adriant
14:33:41 <tobberydberg> would be great =)
14:33:47 <adriant> pilgrimstack: for later reading: http://lists.openstack.org/pipermail/openstack-dev/2017-May/117603.html
14:33:59 <seanhandley> Shall we move onto discussing the WG meetup(s) ?
14:34:07 <adriant> yep :)
14:34:46 <tobberydberg> Cool =)
14:35:10 <tobberydberg> As I said, based on voting I believe we can decide that that is one of the goals
14:35:19 <tobberydberg> #link https://etherpad.openstack.org/p/SYDNEY_GOALS_publiccloud-wg
14:35:57 <tobberydberg> location doesn't need to be decided now, but could be if you think we should
14:36:14 <zhipengh[m]> Shall we specify as EU meetup ?
14:36:26 <zhipengh[m]> NA meetup could be the next goal
14:36:43 <tobberydberg> Looking in the etherpad, both UK and Copenhagen are potential candidates where we will have a room
14:37:00 <tobberydberg> sure
14:37:48 <zhipengh[m]> Nice !
14:37:55 <tobberydberg> Cupons/Passport ?
14:39:01 <zhipengh[m]> Could be in the goals as well
14:39:08 <zhipengh[m]> Worth doing :)
14:39:11 <tobberydberg> Keep "Missing features list" up 2 date?
14:39:14 <seanhandley> pilgrimstack: Is anyone from OVH attending OpenStack Days Nordic or OpenStack Days UK?
14:39:30 <pilgrimstack> I dont think so
14:40:12 <zhipengh[m]> Agree tobberydberg (IRC)
14:40:52 <tobberydberg> Thought? Suggestion of prioritised goals?
14:41:41 <pilgrimstack> Goals for the EU meetup ?
14:42:03 <tobberydberg> No, for this cycle until the Sydney Summit
14:42:42 <pilgrimstack> Ok, I was here mainly because I heard about global cupons :)
14:42:54 <pilgrimstack> can you tell me more about it ?
14:43:00 <tobberydberg> yes
14:44:27 <adriant> I'm assuming like a partnership between multiple openstack public cloud providers to give new users shared starting credit across all partner clouds?
14:44:47 <seanhandley> Basically yes adriant
14:45:01 <seanhandley> David Flanders (flanders@openstack.org) is driving this afaik
14:45:06 <adriant> ^ Interests me because I'm in the middle of a refactor/redo of our own credit/trial processes
14:45:09 <tobberydberg> yes, that is the suggestion of the coupon thing
14:45:21 <pilgrimstack> so it's juste about dealing vouchers from one central point?
14:45:25 <seanhandley> He's considering it as an "OpenStack Passport"
14:45:32 <seanhandley> so yes, the Foundation would deal out vouchers
14:45:47 <seanhandley> and then those would be valid on all participating public clouds
14:46:04 <seanhandley> no proposed technical solutions yet afaik
14:46:32 <pilgrimstack> ok, the cenrtal point should manage the "already consumed" state, right?
14:46:50 <tobberydberg> I guess that will be the harder part, if we can't do different for each cloud
14:46:57 <seanhandley> How about I set an action item to check in with Flanders about this and get more information of how the Foundation is thinking this will work?
14:47:05 <seanhandley> Otherwise we're only guessing
14:47:06 <pilgrimstack> it's $100 on each public cloud or $100 on one of the public cloud?
14:47:13 <adriant> It's also a hard one to unify since most providers tend to handle their credit/trial a little differently, and the user would still need accounts in each cloud, since multi-cloud federation would be weird.
14:47:22 <zhipeng> i think each cloud could have different offering
14:47:30 <zhipeng> the foundation just design the coupon format
14:48:01 <tobberydberg> sounds good seanhandley
14:48:07 <zhipeng> i would suggest we let each cloud provider keep their own way of offering
14:48:38 <tobberydberg> I guess we can put it as a goal anyway if we think it is a good thing in general
14:49:00 <tobberydberg> the details could be set later
14:49:10 <seanhandley> Definitely - it has great appeal for clouds, the foundation, and users
14:49:14 <zhipeng> yes agree
14:49:18 <seanhandley> it's just answering how it would work technically
14:49:24 <tobberydberg> ok, but it up there
14:49:31 <seanhandley> I'll check in with Flanders - it may be that he puts the question back to us :)
14:49:35 <tobberydberg> cool
14:49:35 <seanhandley> so feel free to give it some thought
14:49:38 <pilgrimstack> we all agree I think :)
14:49:54 <tobberydberg> #action seanhandley to check with flanders about passport
14:50:31 <tobberydberg> more?
14:50:33 <tobberydberg> Äny tech?
14:50:41 <tobberydberg> Any
14:51:13 <tobberydberg> I really think: Pooling of resources to fund upstream feature development
14:51:37 <tobberydberg> That can be a really good thing
14:51:40 <pilgrimstack> I think from the communication point of view, it should be something like: you want to try OpenStack? Let the foundation offer you $100 usable on any Public Cloud provider based on OpenStack"
14:51:57 <zhipeng> i think funding would be one aspect
14:52:13 <zhipeng> another direction is to utilize the upstream devs that are already there
14:52:40 <seanhandley> that's true zhipeng
14:52:57 <zhipeng> we could keep both option open
14:53:11 <zhipeng> WG could be the source to drive both directions
14:53:14 <seanhandley> absolutely - can you see what your upstream devs are working on?
14:53:25 <seanhandley> maybe try to steer towards some public cloud features in future?
14:53:26 <tobberydberg> of course ... could we get them to prio our list of missing features? ;-)
14:53:39 <adriant> I know at Catalyst we try and do everything we can upstream first, and I think having a goal like that for most providers helps.
14:54:07 <adriant> Trying to promote people to do less in house and more as a community if possible :)
14:54:21 <zhipeng> i think Matt who is the Nova PTL already left comments at the gap doc
14:54:27 <zhipeng> we could start there :)
14:54:28 <tobberydberg> A really good approach, really like that
14:55:25 <seanhandley> Agree tobberydberg adriant
14:55:29 <seanhandley> for us it's a skill shortage
14:55:34 <seanhandley> we're not Python devs
14:55:41 <seanhandley> though we're willing to learn :D
14:55:56 <zhipeng> tobberydberg do you think we have enough information from today's meeting that we could kickoff the official establishment of WG in UC ?
14:55:57 <tobberydberg> we are not either,,,,but would like to do more...
14:56:00 <adriant> seanhandley, yeah that doesn't help, and sometimes the openstack code bases are hard to get into
14:56:42 <tobberydberg> would like that we all review the list of decided and move more up to decided if we think that we should
14:57:04 <tobberydberg> we have 3 minutes =)
14:57:46 <seanhandley> Decided Goals tobberydberg ?
14:58:03 <tobberydberg> yes
14:58:37 <seanhandley> We need to commit to a location for the Public Cloud WG EU Meetup
14:59:00 <seanhandley> There's OpenStack Days London in September and OpenStack Days Nordic (Copenhagen)
14:59:25 <seanhandley> I propose we do something for both, and see who shows up. Even if that means repeating the sessions.
14:59:29 <tobberydberg> lets put votes in the docs and discuss in #openstack-publiccloud
14:59:44 <zhipeng> i agree with sean
15:00:09 <tobberydberg> time is up....always feel like to little time....
15:00:24 <seanhandley> We already have people in the WG organising both OpenStack Days :)
15:00:27 <tobberydberg> Thank you all for today...please check in to the goals document
15:00:43 <seanhandley> Cheers guys o/
15:00:47 <tobberydberg> #endmeeting